General Stock Firmware Collection for OnePlus 11

Search This thread


Mar 18, 2017
Xiaomi Mi 11 Ultra
OnePlus 11
I'm on mac and was running India A.10 firmware (cph2447_11_a.10)
I tried rooting but followed an incorrect guide and flashed boot.img instead of init_boot.img
The phone was soft-bricked

Then I downloaded the firmware for global A.09 rom (decided to go to global at the same time).
There was not good guide on flashing, so I had to come up with my own instructions. I tried to flash all the partitions from payload.bin extracted with dumper, but the system couldn't find system, vendor, odm and some other partitions for some reason???
As such, I couldn't flash them and the phone continues to be soft-bricked.

All the tools listed here are for windows.
Can someone just drop the necessary fastboot commands to flash the global CPH2449 rom to my device?

When I try to flash using bootloader:

Writing 'vendor_a' FAILED (remote: 'Partition not found')

When I try to flash using fastbootd
usb_write failed with status e00002ed

Trying to change active slot with
fastboot: error: Device does not support slots

What?? I don't have any ideas on how I managed to repartition the device by flashing the global firmware using fastboot only. How can I start from scratch, repartition and reflash the stock OOS?

UPD: OK if you reflash the bootloader partitions using this guide starts to work, but fastbootd mode still spits the e00002ed error
Last edited:


Senior Member
Jan 31, 2012


Senior Member
Nov 9, 2012
I have Oneplus 11 I used to have root on OxygenOS 13 A.09
*I uninstalled Magisk by restoring img from Magisk to update to OxygenOS 13 A.10 after the update completed
*I rebooted to fast boot and did fastboot boot init_boot_patched.img instead of flashing with the write command "" fastboot flash init_boot init_boot_patched.img ""

** I got the error " FAILED (remote: 'Failed to load/authenticate boot image: Bad Buffer S " and the phone stuck on fastboot —-
I did fastboot set_active a and the phone booted, i rebooted back to fastboot and flashed with the wrong command again 😢
"" fastboot flash boot init_boot_patched.img ""

I did flash the init-boot, to both boot A and B
I know my mistake, i flashed a patched init_boot over the boot image , right now i am on oxOS A10
following this
I flashed boot_b.img and the device booted to Black screen and rebooted no OS

there are 2 flies boot_b.img and boot_a.img is there a way to flash these separately or what does that mean

also if please share the boot img CPH2451 OxygenOS 13 A.10 full Boot.img maybe flashing this will fix it

please any help is much appreciated


Senior Member
Nov 9, 2012
Flashing the images over fastboot/fasbootd
It is possible to use ofp/edl package with Qualcomm Flashing apps if you have cracked or unlocked firehose loader file which is not available for OnePlus 11. Also you can download OFP/edl package, extract and flash the partitions using fastboot and fastbootd manually.
i am not sure if you lose all data

Top Liked Posts