Stuck/bricked in EDL mode?! That's the solution!

Search This thread


Senior Member
Nov 6, 2013
This is 2 days long story..
A friend gave me his Poco M3 for changing rom.
Searched an alternative working way to bypass the 7 days wait to unlock bootloader.
After some tries the phone goes in permanent EDL stuck.
Lost 2 nights searching and tried EVERYTHING: Qfire, Miflash (bypassing login but error for "not associated to this account"), enegeering rom, test points, etc..
After the successfully flashed, the phone was yet in EDL mode.
No way to exit.
but, finally, found a solution.

Heres what you need:

- Qualcomm Drivers
- Fastboot ROM
- MiFlash
- Patched Firehose (for bypass login to MiFlash)

- Install the Qualcomm drivers
- extract the downloaded fastboot rom
- go into rom folder, then images folder, and overwright the Firehose with the patched one
- now disconnect the fingerprint sensor cable from mainboard
- open Miflash, select the folder and flash it
- after complete the flash, disconnect cable from pc, disconnect the battery, reconnect the fingerprint sensor cable and reconnect the battery

and, magically, NOW WORKS.

Follow the procedure exactly otherwise will not work and will be stuck in EDL.

Hope to save time and money to someone have my same problem.


New member
Oct 5, 2022
Nope mine is stuck at flashing state... I hate this phone, I tried almost everything :)

But thanks anyway


Recognized Contributor / Inactive Recognized Dev
I'm constantly amazed how crappy all this software is.
First, there is this fixation with Com ports. That's so 1990's.
The USB interface is just a plain ol' bulk interface. Why not use that instead of some bogus virtual Com port driver?
Everything should have timeouts, there is no reason that a program should hang.

I'd almost suggest that you try my EDL client but I don't know if this flash_all is using sparse files or calculated sizes which are not things that I've implemented.


Senior Member
Nov 26, 2009
OnePlus One
Xiaomi Poco F3
For my daughter's M3 the trick worked, but only one time.
When I switched off the phone, it returned to EDL mode.
Works only if I don't switch off the phone.
There must be a hardware fault/bug, probably triggered by the latest MIUI 12.5 update. I think that this problem will not have a definitive working solution.