• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Stuttering/frame skip while scrolling [Oxygen Os 10 BUG on all OnePlus 7T/7TPRO/7PRO]

Search This thread

Tyrigi

Senior Member
Apr 27, 2010
574
30
It's incredible that one plus still didn't fix it hope Android 11 will come with a fi...
 

FireflyNord

New member
Dec 4, 2020
1
0
I've got the same problem on my 1+ Nord. There's lag and stuttering on scrolling in all apps. It's really quite obvious and not a fussy thing that only some would notice. It's in your face, which makes me all the more annoyed by the way most reviewers didn't mention it. Even MKBHD gave the Nord a runner-up mention in his latest "Best Phones 2020" piece. I don't understand. Very Disappointed. The recent 10.5.5 did not help. Hopefully android 11 will help... when we get it... someday.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    BUG:
    There is always a stuttering/frame skip while scrolling on every Oneplus 7T/7TPRO/7PRO with Android 10, on every app and every time you scroll.
    1) This is the complete video and here the stuttering is so visible, moreover you can see how to reproduce it (watch it on pc at full quality 1080p60 and full screen): https://www.youtube.com/watch?v=1RUf5DP3-qU
    2) If you watch this slowmotion video you can see how the written "Batteria" (when it appears stutter in red) does a sort of jump because of frame skip (I also added a frame count so you can be sure that the video is original): https://www.youtube.com/watch?v=OGbqj29EXhI
    3) I did other test on my 7T with "Profile Rendering HWUI" and as you can see from the screenshots, If you do little scrolls there are serious frames drop (see the spikes):
    View attachment 4913573
    4) Here you can support the feedback I sent: https://forums.oneplus.com/threads/...le-scrolling-oxygen-10-bug-on-all-7t.1171252/

    HOW TO REPRODUCE:
    -90hz (more visible) or 60hz
    -Light theme (also with dark but it's easier too see on light)
    -Animation 0.5 or 1 (it's the same)
    -Open settings and do little scroll with the finger (don't leave the finger on display)
    -Look at the written texts ("Battery" fro example): they don't do a fluid transition up or down, they don't flow on the screen, but they "appear-disappear", it seems that they jump some pixels. Infact there is multiple frame skip every time that you scroll.

    TEST:
    Tests I did on both 60hz and 90hz and light theme (easier to see than dark mode) on settings app:
    1- Oneplus 7T frosted silver OOS 10.0.6/10.0.7: stuttering is PRESENT
    2- Oneplus 7T frosted silver OOS 10.0.1: stuttering is PRESENT
    3- Oneplus 7T glacier blu OOS 10.0.1: stuttering is PRESENT
    4- Oneplus 7T glacier blu OOS 10.0.1: stuttering is PRESENT
    5- Oneplus 7T PRO OOS 10: stuttering is PRESENT
    6- Oneplus 7 PRO OOS 10.0.2: stuttering is PRESENT
    7/8- Oneplus 7 PRO OOS 9 and Oneplus 6T with OOS 9: stuttering is NOT PRESENT

    RESULTS:
    I'm pretty sure that this bug is due to Oxygen Os on Android 10 (on 7 Pro with Pie is not present) and it is present on all 7T/7TPRO/7PRO.
    Clear system cache, factory reset, block 90hz etc.. are all useless solutions (I tried).
    OnePlus still didn't fix the issue, in these condictions the 90hz are pretty useless.




    Open the spoiler to see the old post:

    LINK video(it's better to download for quality and watch it on bigger screen, open with chrome): https://gofile.io/?c=dGaFtF

    Recently I shared this post on Oneplus forum:

    "Hi all, on my op 7t (hd1903) I notice a slight stutter when flick scrolling.
    It happens both at 60hz/90hz light/dark theme (atm with OOS 10.0.6).
    When I scroll I notice that some lines of words on display don't do a fluid transiction, but they "disappears-appears". You can notice that issue when you do a scroll with finger (and you don't keep the finger on display), or a slow scroll (just touch the display and scroll down) in settings app.
    There isn't a delay of the speed of written transiction, but a really bad flow of written text on display, it's not fluid at all, a sort of "glitch".
    It happens with settings, Chrome, instagram (harder to see with images) etc.. it s not an app related problem.
    I don't know if it is an issue of 10.0.6, because I don't remember if it happened with the previous oos version (I got this phone about 1 week ago).
    I did factory reset and a new installation 2 times but no success. I want to understand if the problem is software or hardware, thank you all"

    How to reproduce:
    -90hz or 60hz
    -Light theme (also with dark but it's easier too see on light)
    -Animation 0.5 or 1 (it's the same)
    -Open settings and do little slow scroll with the finger (don't leave the finger on display)
    -Look at the texts written at the same time (center area): they don't do e fluid transiction up or down, they don't flow on the screen, but they "appear-disappear" in a fraction of second, like if they jump some pixels.

    After I noticed this problem, I decided to go to a shop and I did some tests with the following six devices (eu versions) on both 60hz and 90hz and light theme (easier to see than dark mode) on settings app:

    - Oneplus 7T frosted silver OOS 10.0.6: glitchy transictions of written lines is PRESENT

    - Oneplus 7T frosted silver OOS 10.0.1: glitchy transictions of written lines is PRESENT

    - Oneplus 7T glacier blu OOS 10.0.1: glitchy transictions of written lines is PRESENT

    - Oneplus 7T PRO OOS 10: glitchy transictions of written lines is PRESENT (but harder to see because of a strange acceleration on scrolling)

    - Oneplus 7 PRO OOS 9 and Oneplus 6T with OOS 9: this issue is NOT PRESENT

    At this point in my opinion this issue is present on all 7T (and probably 7TPro).
    Now, 7TPro and 7 Pro should have the same display, but I tested them with different oos versions (9 on 7Pro and 10 7TPro).
    So I think that this is a software issue with Android 10, and I hope in a fast fix for this situation.
    It's not possible to have "smooth" as a claim with a stuttering scrolling. Clear system cache, factory reset, block 90hz etc.. are all useless solutions (I tried).
    I opened a bug report on feedback section, because 90hz or 60hz are useless in these conditions.
    Sorry for english but it was difficult to explain in a written format this issue.

    So, what do you think ? Let me know if you did a test or if you see this issue, thanks!
    4
    Solution maybe, it works for me. Source: Self Tweaking.

    Open "chrome://flags/#ignore-gpu-blacklist" and enable Override software rendering list.


    This helped me!
    -HP


    Screenshot-20200703-132353.jpg






    Upvote if this helps. :fingers-crossed:
    3
    I was having this problem. I don't think there is a way to completely get rid of it. However, I recently switched my T-Mobile variant to the Global Open Beta 2 and flashed Arter97 r54 kernel and scrolling is much smoother. The device in general is just overall much better with this ROM/Kernel. Arter97's kernel gets rid of most of OnePlus' code and uses Qualcomm's code as a base. It also uses a 300Hz base frequency which reduces jitter. I highly recommend this kernel!
    3
    UPDATE: I tried another 7Pro with android 10 (not 9 as the last time) and...it has stuttering/frame skip while scrolling.

    Also I did two video of the issue with a better camera and quality, now the stuttering is visible:
    1) This is the complete video and here the stuttering is so visible, moreover you can see how to reproduce it (watch it on pc with full quality 1080p60 and full screen): https://www.youtube.com/watch?v=1RUf5DP3-qU
    2) If you watch this slowmotion video you can see how the written "Batteria" (when it appears stutter in red) does a sort of jump because of frame skip (I also added a frame count so you can be sure that the video is original): https://www.youtube.com/watch?v=OGbqj29EXhI

    So yes, it is a oxygen os 10 bug and OnePlus has to resolve it as soon as possible.
    Moreover, oneplus staff contacted me again three days ago on oneplus forum for asking me other info/log about the issue.
    2
    Is it same issue?
    Opened a community app and tried to scroll
    I see similar lags in many apps with rich content
    I noticed that too but I think that community app has just some troubles with video preview.
    You have to try on settings app or chrome,Twitter etc..

    Inviato dal mio HD1903 utilizzando Tapatalk