Successfully installed TWRP but phone won't turn on?

Search This thread
Dec 9, 2021
5
0
please need help very urgently. i was trying to install a custom rom in my phone today. unlocking bootloader was successful, installing twrp was successful too and i was very happy. when i tried to boot into the recovery it turned off and never booted. tried restarting (volume up+power button), pressing the power button but nothing happens. it's still in the "off" state. please don't think it is a bootloop. the phone doesn't turn on and i can't see the logo. seems like it is permanently turned off
 

Danish on XDA

Member
Jan 21, 2022
23
2
POCO M3
please need help very urgently. i was trying to install a custom rom in my phone today. unlocking bootloader was successful, installing twrp was successful too and i was very happy. when i tried to boot into the recovery it turned off and never booted. tried restarting (volume up+power button), pressing the power button but nothing happens. it's still in the "off" state. please don't think it is a bootloop. the phone doesn't turn on and i can't see the logo. seems like it is permanently turned off
Idk but charge ur phone for a min..then unplug ur battery reconnect it then volume down+power
 

SubwayChamp

Senior Member
Aug 6, 2016
3,735
4
1,539
please need help very urgently. i was trying to install a custom rom in my phone today. unlocking bootloader was successful, installing twrp was successful too and i was very happy. when i tried to boot into the recovery it turned off and never booted. tried restarting (volume up+power button), pressing the power button but nothing happens. it's still in the "off" state. please don't think it is a bootloop. the phone doesn't turn on and i can't see the logo. seems like it is permanently turned off
Sometimes it is that the screen is blank but TWRP is there though, when you are presumably in TWRP, connect your device to the PC and try with ADB commands to see what happens, let us know.
 
Dec 9, 2021
5
0
Sometimes it is that the screen is blank but TWRP is there though, when you are presumably in TWRP, connect your device to the PC and try with ADB commands to see what happens, let us know.
okay, so tried and when typing "adb devices" laptop don't detect my phone, says nothing is connected. same with "fastboot device" command nothing is being shown. although twrp is still there installed but it doesn't turn on neither other devices can dtect my phone now
 

SubwayChamp

Senior Member
Aug 6, 2016
3,735
4
1,539
okay, so tried and when typing "adb devices" laptop don't detect my phone, says nothing is connected. same with "fastboot device" command nothing is being shown. although twrp is still there installed but it doesn't turn on neither other devices can dtect my phone now
Not this way, press the buttons to supposedly enter to TWRP, do all of them blindly. Start with pressing the three buttons simultaneously for about 12 seconds (this will power off your device) then immediately press the volume up + PWR button for about 7 seconds (to enter to TWRP), then type the commands.

Pay attention if something is displayed in your screen and if you hear some sound when connecting to PC.