[SUPPORT] Update failures

Chainfire

Moderator Emeritus / Senior Recognized Developer -
Oct 2, 2007
11,440
87,679
263
www.chainfire.eu
With all major changes to SuperSU, there are updates to both the GUI and binary. The GUI is the part you see on screen, the binary is what allows other apps to actually acquire root access. The first time you open SuperSU after such an update, it will attempt to update the binary to the latest version.

There are a lot of components to the binary and it needs to be set up just right for everything to work. This is a complex operation, and sometimes it fails. SuperSU is used by dozens of millions of users across hundreds of different devices, running even more different firmware revisions - any change always has the potential to break something somewhere.

SuperSU offers multiple ways of installation: in-app 'normal', in-app TWRP/CWM, and ZIP via TWRP/CWM. These all have their own strengths and weaknesses, so if one doesn't work, try the others if available.

If you are reporting an update failure, you should include at least the following information. Some information requires some skill with adb to retrieve.

- Exact device model
This includes the brand, the model, and the carrier variant (if applicable: mostly USA, Korea, China)

- Exact firmware version
Which exact firmware are you using? If you are using a custom firmware, please include a link to the download for this firmware. If on top of that, you are also using a custom kernel, please include a link to the download for that as well.

- Exact Android version
Android x.y

- Exact SuperSU version
Which version were you running, and to which version are you updating? If using Pro, do you have OTA survival mode enabled?

- Interfering apps
There are some apps that can interfere with SuperSU installation, primarily:
- other Superusery apps
- Xposed
- BusyBox (symlinked or non-symlinked)
Include in your report if you have one or more of these installed.

- Update methods tried
In-app 'normal', in-app via recovery, and ZIP via recovery. If you used one of the recovery options, please include exactly which version of which recovery you are using, and if it's not an official build (so a TWRP not from the TeamWin website, a CWM not from CWM's site, etc) a link to where you got it from.

Note that if you let TWRP or CWM "fix" root for you, or let them disable the firmware from flashing a new recovery (sometimes you are asked this), you have broken root, and the only way to recover it is flashing the full ZIP through recovery.

- What kind of root are you left with?
After a failed binary update, multiple outcomes are possible:
- Root is lost. Apps cannot get root anymore, you cannot get root using "su" from an adb shell, etc
- Root seems to mostly still work. Most apps still work, and/or "su" still works from an adb shell
- Nothing seems to have changed at all, even the GUI still shows the old version number
Report what state your device is in now. Note that you can get the version of the main "su" binary by running "su -v" from a terminal emulator or adb shell.

- Logs from TWRP, when updating the binary using the TWRP/CWM button inside the SuperSU app
After pressing the TWRP/CWM button, the device should reboot into TWRP, do it's thing for a few seconds, then reboot into Android. If SuperSU still complains about the binary, please retrieve the TWRP log file. You can retrieve it via adb pull /cache/recovery/last_log, which should produce the last_log file in your current directory. You still need at least partial root from booted Android to retrieve this log. Sadly it is wiped and replaced with a new file when you boot into recovery a second time, so you cannot retrieve it that way. Note that this log will always contain a number of errors, as the installer tries several things in several ways, that work differently on different firmwares. Attach this log file.

- Logs from TWRP, when updating SuperSU completely via ZIP
If after you boot back into Android, SuperSU is not working right or still asks for updated binaries, reboot back into TWRP, install the ZIP again. After the ZIP is installed, you can retrieve the log file via adb pull /tmp/recovery.log, which should produce the recovery.log file in your current directory. Attach this log file.

- Logs from SuperSU (very important)
If SuperSU keeps asking you to update the binaries after trying any which way and failing, please post the detection log. After updating has failed, don't reboot, but produce detection information via adb logcat -d | find /i "installer" > logcat.txt (Windows, use 'grep -i' instead of 'find /i' on Linux or OSX), which should produce a logcat.txt file in your current directory with several lines mentioning SuperSU. Attach this log file.

- Various logs (very important)
Some additional handy information can be gotten by via some adb shell calls. If you that working, copy/pasting the following commands should produce a nice sulog.txt file in your current directory, which you should attach to your post:
(as always with copy/pasting, make sure you press enter a few times afterwards to make sure the last line was flushed)

Code:
adb shell getprop > sulog.txt
adb shell set >> sulog.txt
adb shell toolbox id >> sulog.txt
adb shell busybox >> sulog.txt
adb shell su -v >> sulog.txt
adb shell su -V >> sulog.txt
adb shell su -h >> sulog.txt
adb shell su --self-test >> sulog.txt
adb shell ls -l /system/xbin/*su* >> sulog.txt
adb shell ls -lZ /system/xbin/*su* >> sulog.txt
adb shell ls -lZ /system/bin/toolbox >> sulog.txt
adb shell ls -l /system/bin >> sulog.txt
adb shell ls -l /system/xbin >> sulog.txt
adb shell ls -laR /su >> sulog.txt
adb shell ps >> sulog.txt
In closing
All this information will help diagnose the problem, and potentially help fix the issue if there is something wrong with SuperSU itself (which is not unheard of). The more information you provide, the better you can be helped. Still, be aware that often it takes a while to get a problem sorted. Even when a lot of people are having the same problem (and many problems may look the same but deep down are separate issues), it is rare to find a user who actively wants to help fix the issue. Most users will only complain but then don't really assist in solving the issue. If you can be someone who can actively help, and by that I mean being responsive to questions, being available for a live debugging session, etc, you are a rare gem indeed, and your assistance will be greatly appreciated.

If you are writing multiple posts, it is always helpful if you keep linking back to your original post with the report. Saves me time.

Sorry for the inconvenience!
 
Last edited:

Emmie0702

Senior Member
Jun 20, 2008
87
3
0
Roanoke, VA
Update has make my Galaxy S5 is unusable...

After update I am unable to open any Google based apps, Gmail, maps, YouTube, etc. I get an error that says "Unfortunately, [app] has stopped.". Im also getting the "Unfortunately, the process com.google.process.gapps has stopped" error. What do I need to do? I did a factory reset hoping thats would fix the problem but it hasn't. It seems as thought it's not reading my SD card as well. It's showing I don't have pic or that one is even installed. I can make calls but that's about it. No Internet, no connections, no apps. Can't even sign onto my gmail to be able to download any app from the play store. I am out of town & without a computer until later tonight. Would re rooting fix my problem? I do not have recovery flashed onto my phone. It wasn't available when I rooted & I never got around to doing it. Pleasant Help! I have a titanium back up of my 0hone but can't download the application to try that avenue.
 

Chainfire

Moderator Emeritus / Senior Recognized Developer -
Oct 2, 2007
11,440
87,679
263
www.chainfire.eu
SGH-T999
4.3
2.06 can update to 2.14 but binary update never takes
BusyBox but dont know what kind
In-app 'normal', in-app via recovery, and ZIP via recovery after that binary update still fails normal and via TWRP v2.8.0.1
Still have root
As stated on IRC, I'm going to need the logs described above.
 

Chainfire

Moderator Emeritus / Senior Recognized Developer -
Oct 2, 2007
11,440
87,679
263
www.chainfire.eu
After update I am unable to open any Google based apps, Gmail, maps, YouTube, etc. I get an error that says "Unfortunately, [app] has stopped.". Im also getting the "Unfortunately, the process com.google.process.gapps has stopped" error. What do I need to do? I did a factory reset hoping thats would fix the problem but it hasn't. It seems as thought it's not reading my SD card as well. It's showing I don't have pic or that one is even installed. I can make calls but that's about it. No Internet, no connections, no apps. Can't even sign onto my gmail to be able to download any app from the play store. I am out of town & without a computer until later tonight. Would re rooting fix my problem? I do not have recovery flashed onto my phone. It wasn't available when I rooted & I never got around to doing it. Pleasant Help! I have a titanium back up of my 0hone but can't download the application to try that avenue.
Sounds unlikely to be due to SuperSU. Either way, there's nothing you can really do about it now. Situations like these I advise a factory reset and a data restore.
 

Chainfire

Moderator Emeritus / Senior Recognized Developer -
Oct 2, 2007
11,440
87,679
263
www.chainfire.eu
I've done a factory reset & stoll have the same problem. How would I restore data?
You would restore the data from a backup you've made before resetting ?

In SuperSU you can try 'full unroot' from Settings (twice if necessary) and unroot, see if that resolves the slowness/crashing.
 

Emmie0702

Senior Member
Jun 20, 2008
87
3
0
Roanoke, VA
The only backup I have is a titanium backup. I can't get anything to download from the play store. I never flashes recovery because it wasn't available when I rooted. I never went back to add it (which I could kick myself for right now). Would re rooting help? Supersu isn't on my phone anymore either. I'm not sure what happened to that.

Edit: could the platform.xml under /etc/permissions/platform.x ml have anything to do with it?
 
Last edited:

bizantium

Member
Jul 4, 2014
6
2
0
23
Bekasi
Knox

After update I am unable to open any Google based apps, Gmail, maps, YouTube, etc. I get an error that says "Unfortunately, [app] has stopped.". Im also getting the "Unfortunately, the process com.google.process.gapps has stopped" error. What do I need to do? I did a factory reset hoping thats would fix the problem but it hasn't. It seems as thought it's not reading my SD card as well. It's showing I don't have pic or that one is even installed. I can make calls but that's about it. No Internet, no connections, no apps. Can't even sign onto my gmail to be able to download any app from the play store. I am out of town & without a computer until later tonight. Would re rooting fix my problem? I do not have recovery flashed onto my phone. It wasn't available when I rooted & I never got around to doing it. Pleasant Help! I have a titanium back up of my 0hone but can't download the application to try that avenue.

@Emmie0702 I think it's a weird Knox Action -i mean, It MAY happen 'coz Knox
 
  • Like
Reactions: hamid1355usus

p220fhf

Member
Nov 8, 2010
16
9
23
Hong Kong
Samsung N7100 Hong Kong (rom is UK)
N7100XXUFND3
4.4.2
2.14 pro

Don't have OTA survival mode enabled.

Before updating the SU, I can use the SU as usual. But after updating the SU binary via normal, it says I didn't install the execute file ( something like that, since I'm using Chinese), which means i haven't root.

So, do i need to re-root, then update the SU binary?
 
Last edited:
  • Like
Reactions: MACATELY

Chainfire

Moderator Emeritus / Senior Recognized Developer -
Oct 2, 2007
11,440
87,679
263
www.chainfire.eu
Samsung N7100 Hong Kong (rom is UK)
N7100XXUFND3
4.4.2
2.14 pro

Don't have OTA survival mode enabled.

Before updating the SU, I can use the SU as usual. But after updating the SU binary via normal, it says I didn't install the execute file ( something like that, since I'm using Chinese), which means i haven't root.

So, do i need to re-root, then update the SU binary?
You can give it a shot, rerooting via the ZIP ( http://download.chainfire.eu/supersu ) with TWRP. See if that helps, and let us know. If it doesn't fix the issue, I will find this firmware and flash it on my own N7100 (if possible) and see if I can replicate the issue.
 
  • Like
Reactions: AntnLizAndrade

Skretax

Member
Oct 21, 2014
6
0
0
SuperSU Problem!

I've rooted my device (GT-1335 - Android 4.4) with Windershare Rooting Toolkit, After rooting I've installed Root checker basic from the market and run it. It says your device is rooted. But when i wanted to go to root using FX explorer, it says you need permission from Advance user. When i click SuperSU after that it says that "There is no Su binary installed, and SuperSu cannot install it. This is a problem!", After that i checked whether my device is rooted or not with Root checker basic, but now its says that my device isn't rooted!
Please Help, and replay soon!

Note: My device isn't original samsung model!
 

ycon

Senior Member
Apr 2, 2013
238
8
0
I had problems with using Stock 4.4.4 on my i9305.

Was freezing/not opening, then when it did it wouldn't update.

So I went to the SuperSu site and downloaded the latest to instal via CWM.

Now working fine. Hope this helps someone.
 

p220fhf

Member
Nov 8, 2010
16
9
23
Hong Kong
You can give it a shot, rerooting via the ZIP with TWRP. See if that helps, and let us know. If it doesn't fix the issue, I will find this firmware and flash it on my own N7100 (if possible) and see if I can replicate the issue.
I tried to reroot on my s4, but nothing changes, when updating the SU to 2.14.

So, I think, maybe, the main problem is SU 2.14 on 4.4.2 and 4.3.
My s4 was 4.3 rooted, before the SU update, everything was fine. But after updating, the SU app said I didn't root. Then I updated my FW to 4.4.2(I9505ZHUFNB3), and used CF-root to root. Still ok, but when the SU updated to 2.14, thing happened again. (Now my s4 is temp unroot for playing game :p, but can't root again as it says "You didn't root")

Sorry for my bad English.
 
  • Like
Reactions: santirulo

BIG-MOEP

New member
Oct 22, 2014
2
2
0
SuperSU 2.14 not working on s4 4.3

After update super su in playstore my s4 octacore in app tab on supersu still loading but nothing happened...
same problem here on my S4-quad-16G with samsung 4.3-stock, which was rooted mothns ago via AutoROOT+twrp2.7.01

I tried to reroot on my s4, but nothing changes, when updating the SU to 2.14.

So, I think, maybe, the main problem is SU 2.14 on 4.4.2 and 4.3.
My s4 was 4.3 rooted, before the SU update, everything was fine. But after updating, the SU app said I didn't root. Then I updated my FW to 4.4.2(I9505ZHUFNB3), and used CF-root to root. Still ok, but when the SU updated to 2.14, thing happened again. (Now my s4 is temp unroot for playing game :p, but can't root again as it says "You didn't root")

Sorry for my bad English.
same here update 2.14 from PlayStore f.cked-up the SuperSU app (i have waiting-donut on APPS and LOGS-tabs...)
Device stays rooted, and root-requests from other apps seems to work too, because there is a typical SuperSU-reuqest popup there....

So please fix the APP for Samsung 4.3 4.4 firmwares...
Versions 2.01+2.06 worked flawlessly.

what i have already tryed:
1) On the [Settings]-TAB: => UNINSTALL APP: Effect 'uninstalling...'-popup stays 4ever w/o effect
2) On the [Settings]-TAB: => UNINSTALL APP for a NEW SuperUserApp: Effect 'uninstalling...'-popup stays 4ever w/o effect
3) Booted into TWRP => INSTALL the SuperSU-2.14.ZIP, rebooting phone -> in SuperSU (the same waiting donuts on APPS/LOGS...) :(

Phone: i9505-OpenEUROPE quad-core/16G Samsung-stock-FW 4.3
 
Last edited:
  • Like
Reactions: AntnLizAndrade

SirVss

Senior Member
Dec 8, 2010
132
10
0
Arad
www.webinvent.ro
Device I9505
Android Version: Stock 4.3 MKF
BusyBox v1.22.1
Wanam Xposed installed
Stock Recovery
Kingo Root
Google Play Update

Issue: After update from 2.13 to the latest 2.14 when supersu try to reinstall it stuck more than 5 minutes, I reboot my phone, reopen supersu but now in my "APPS" and "LOGS" I have some kind of neverending loop load, I can't manage to see my rooted apps there, and in my SETTINGS if I try to make some changes it stuck and need phone reboot, otherwise all my rooted apps work fine!
 
Last edited:
  • Like
Reactions: whaaevaa

p220fhf

Member
Nov 8, 2010
16
9
23
Hong Kong
You can give it a shot, rerooting via the ZIP with TWRP. See if that helps, and let us know. If it doesn't fix the issue, I will find this firmware and flash it on my own N7100 (if possible) and see if I can replicate the issue.
I think i figure out the problem, is the SU bin update. My note 2 is rooted and is using SU 2.14 pro, but i don't update the bin. It works fine, but when opening the su app, it asks you to update the bin.