System partition is too small to install Google GSI system

Search This thread

SteQu

Senior Member
Oct 31, 2013
122
23
24
Poznań
Google Pixel XL
Hi There!

I come to you with a request for help. Well, I wanted to install the GSI system straight from the Google website, but during the installation it turns out that my system partition is definitely too small.
Is there any way to properly install the IMG image straight from the Google site? Probably should enlarge the system partition, just HOW? I need the help of experts, and I know that at the XDA Forum I will find them.

Below you will need information:
- My device is Google Pixel XL (marlin),
- My phone supports Treble A and B updates,
- The system I wanted to install was the beta GSI Android 11 straight from the Google website,
- The recovery I used when trying to install the system: twrp-3.4.0-0-marlin.img from TWRP site,
- I also tried to install the system using CMD with ADB and fastboot,
- I have fastboot unlocked on my device,
- Information about too small partition also occurs when trying to install GSI Android 10,
- My device does not support fastbootd,
- LineageOS ZIP packages work normally and install without any errors,
- Updates from ADB sideload also load smoothly,
- Here is the link from where I got GSI Android 11 and 10: https://developer.android.com/topic/generic-system-image/releases#android-gsi-11,
 

Papote3

Senior Member
Dec 10, 2010
343
133
I'm trying this also, credited the error to the system partition on marlin being 2gb and the system img on Google GSI being 2.1gb.

I know there's also an AOSP GSI which i downloaded from the same Google website and the image is 1.3gb if I'm not mistaken. I was able to flash this but phone wont boot. It will just bootloop on the Google with white background image and that's it.

I also tried downgrading to Android 8.1 factory image since I heard that another user got GSI Android 11 working coming from 8.1 but after trying this way I got the same bootloop error.
 

Top Liked Posts