• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

T-Mobile 7T Pro 5G McLaren bootloader unlock without SIM unlock/OnePlus unlock token!

Search This thread
Nov 23, 2015
49
14
I used this to unlock my McLaren's bootloader yesterday so I could flash a custom rom (AOSIP) and ditch OOS. It worked perfectly. I was on 10.0.37 beforehand, and backed up my persist.img before unlocking.
 
  • Like
Reactions: Neverforgotten45

noobiedev83

Senior Member
May 12, 2015
232
72
Just a thought your bootloader is unlocked there are fastboot ROMs available for stock firmware that's my suggestion. I'm shocked msm isn't doing it for you it's like a cure all
The issue I'm having is that after my bootloader is unlock the phone won't boot to the os but if I flash the phone with the not modified tool it works fine, do you know where I can get this stock fastboot ROMs?
 

Joe199799

Senior Member
Sep 7, 2014
827
283
The issue I'm having is that after my bootloader is unlock the phone won't boot to the os but if I flash the phone with the not modified tool it works fine, do you know where I can get this stock fastboot ROMs?

I'm not sure where I saw them but I definitely remember seeing them, unless I'm mixing up this phone with my old 6T which is possible.
 

Jessietigres

New member
Aug 31, 2020
1
0
Hi

Hey there, I have an issue where it does not get out of fastboot mode.

I tried loading different ROMs and it wouldn't work.
Also tried getting oxygen OS through a recovery.img it does not help. Just gets me into recovery mode and T mobile infinite logo

Any help with this?
 

noobiedev83

Senior Member
May 12, 2015
232
72
Hey there, I have an issue where it does not get out of fastboot mode.

I tried loading different ROMs and it wouldn't work.
Also tried getting oxygen OS through a recovery.img it does not help. Just gets me into recovery mode and T mobile infinite logo

Any help with this?
This is already been reported,just use the none modified tool and flash the stock rom.
 

Hypnotic818

Member
Jan 7, 2015
16
2
I'm not sure if I'm doing something wrong but every time I click start it says "Sahara Communication Failed, Please try again"

I've installed the drivers for the phone(I think I used the all in one tool) I've installed Qualcomm Drivers 64 bit. So I'm not sure if I'm missing something

Edit: I used a USB in the back of my pc and it finally worked! :D
 
Last edited:

Gamesoul Master

Senior Member
Aug 26, 2010
682
177
Found an issue. When unlocking the bootloader this way, it renders my phone unable to boot. I also can't install a custom ROM. The issue is apparently that the odm partition is missing. That's what stops any custom ROM from installing ('Partition not found'). I started out on 10.0.36, so no issues there. Upon this happening the first time, I used the 10.0.36 unpatched tool to go back to stock, no issues. Booted to home, enabled OEM bootloader unlock in the developer settings again, and then tried again. Same exact issue.
 
Last edited:

Superboy58

Senior Member
Jun 3, 2010
140
70
Clermont-Ferrand
The main purpose is to unlock the bootloader of the phone.
It would be nice indeed but we (the people who helped creating and testing the tool and me) didn't get why it's not booting right after the flash.
 

Gamesoul Master

Senior Member
Aug 26, 2010
682
177
@Gamesoul Master you might have to re flash you boot and recovery partitions after running the tool. This has been reported in the past.
Sorry, I forgot to mention that I did try flashing those two partitions back as suggested earlier in the thread. But it didn't help at all, my odm partition was still apparently missing. Apparently the odm partition is part of super.img, if that helps you at all. I thought about trying to flash that, but since it contains so many partitions, I figured that might not be a good idea, since it may also contain whatever you're using to make this unlock work.

The main reason I thought to report this is because while it seems to have come up before, nobody else had reported more specifically what the issue was. Which is apparently the missing odm partition. It's also possible that there's more missing than that, but I can't tell because installs always fail at that point.
 

Gamesoul Master

Senior Member
Aug 26, 2010
682
177
Alright, let's tackle this from a different angle. So far, we know for sure that using this tool is somehow causing one or more partitions to disappear (at least for some of us). Assuming we're all using an HD1925 on the 10.0.36 update, are there any other differences between our devices that could cause this to happen? And what partitions does this modified tool *actually* need to flash for the bootloader to be unlocked? Assuming it's a small list, is there any way we could further address this on our end? Is there a way to replace just the partitions needed for this exploit in the backup we all presumably made before trying to unlock this, and then restoring that?
 

Gamesoul Master

Senior Member
Aug 26, 2010
682
177
Has anyone successfully unlocked it according to this post?
Well, there's only been one testimonial of it actually working thus far. Unless the OP used it, then that would be two. Otherwise, the rest of us have had issues. Presumably due to the modded tool not flashing all the partitions properly. I haven't figured out a way to fix that yet, nor has anybody been willing to work with me on figuring that out.

If you don't mind that your user data will be wiped in the attempt, give it a shot. If it fails, you can easily use the stock MSMTool to get your phone up and running again. Worst case scenario, you have to reinstall your apps and restore your data. Which isn't horrible if you've had the phone for a while, to be honest.

---------- Post added at 06:12 AM ---------- Previous post was at 05:41 AM ----------

I used this to unlock my McLaren's bootloader yesterday so I could flash a custom rom (AOSIP) and ditch OOS. It worked perfectly. I was on 10.0.37 beforehand, and backed up my persist.img before unlocking.
Were you SIM unlocked already before trying this? And did you enable the "OEM Unlocking" option beforehand? Did you do anything unique or out of the ordinary besides what exactly is listed in the OP?
 
Nov 23, 2015
49
14
[/COLOR]
Were you SIM unlocked already before trying this? And did you enable the "OEM Unlocking" option beforehand? Did you do anything unique or out of the ordinary besides what exactly is listed in the OP?

Nope, and you can't toggle "OEM Unlock" while SIM locked. I just followed the guide (after backing up persist.img ofc) then I flashed my ROM of choice, which is AOSIP.

Note: you have to do fastboot reboot fastboot when flashing a rom, otherwise you get the 'partition not found' error, which doesn't seem to work when using Windows command prompt. I think the powershell works, haven't tried it as I can reboot into that using macOS/Linux. Yes, fastboot reboot fastboot, not bootloader.
 
Last edited:

Top Liked Posts