• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

T-Mobile OnePlus 7 Pro bricked

Search This thread

daybeers

Member
Mar 7, 2019
7
0
Hi there!

I have experience with unlocking bootloaders and rooting, but I am really really stuck here. I tried following these instructions with this MSM tool to convert it to an Unlocked version. My OP7P is stuck in an endless boot cycle and says "Upgrade download failed! Please check your download flow is right!" I don't like to leave it on the charger for very long because it just reboots endlessly and I don't think that's good for the phone, but otherwise it won't charge. My Windows computer doesn't recognize the device when checking for adb or fastboot in CMD. I can get it to be recognized in the MSM tool by holding the volume buttons and then plugging it in, and the process starts correctly, but fails after 10-15 seconds.

I have uninstalled and deleted and reinstalled drivers countless times. I've tried to follow these directions and these as well with the same results.

This is replacing a broken LG G6 with a non-functioning speaker mode, abysmal battery life, terrible camera quality, and slow performance. My purchase of the OP7P was supposed to solve all of that with a premium smartphone and right now it's just an expensive paperweight sitting on my desk.

What can I do? Thanks so much in advance!
 

amaroney55

Senior Member
Ya do what he said do. But if using the msm tool open up device manager and plug in it phone and adb reboot edl whatever that command is. Then go to ports on the device manager and check and see if I have the qcom driver installed. I forget exactly what it supposed to say but it has 9008 in it. I am just gonna tell you I have 2 oneplus 7 pro both tmo brand. I converted them. But idk what it is tho. Each time I change phones to flash rom or whatever I do sometimes the way I do it changes. I am firm believer idc what so and so says it may work one way or another. These phones are crazy weird. The processes change like when I flash using the tool he is talking bout sometimes I lose my network sometimes I don't. Some ppl say when u flash twrp using magisk u gotta flash the the twrp zip once in twrp. Sometimes I don't have to. But when I do it says I lose root but I don't. Just check ur drivers and make sure ur using the right msm tool either global or the T-Mobile