• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

T-Mobile OP8 5G Netowrk Issues

Search This thread

stompysan

Senior Member
Feb 1, 2011
400
78
Hey everyone. I am hoping someone can give me a bit of advice with my device. I have a T-Mobile OP8 5G, and up until the past month or so it has been solid. However, I am now having issues with mobile networking. Randomly, the data connection will completely break. This happens primarily when connected to 5G, but has happened with standard LTE as well. At first I thought it may have been location, as it primarily happened when I was at work. However, it is now happening at both my home and my parents' home as well. I don't think it is signal-related, as there is a mid-band 5G tower less than a block away from my parents' house. I am starting to think it may be related to it transitioning to a different network type. I have done about all I can think of software-wise. The problem is persistent with the T-Mobile firmware, global firmware, and custom ROMs. I also tried flashing a different modem, but this does not change anything. Using an LTE-only device does not exhibit this behavior, but it is still happening with NR turned off entirely. It is much less prevalent, happening maybe once a day, but it's still there. I think it may be hardware-related at this point, but am a bit unsure where to go from here. I currently have the device on contract, so I can visit a store and try my luck there. I figured I would reach out on here first, just in case there is something else someone has to try. Pulling logs is a bit difficult, as I usually don't notice until quite a bit after it happens, but I can try if that may help.