[T710/T715] LineageOS 15.1 (Experimental stuff)

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    These are my experimental builds. They are not pretend to be stable and have a lot of issues. Flash it if you know how to restore your tablet from brick. This stuff is not for daily usage. Just for testing and helping me to find bugs.
    Feel free to write your feedback about builds.
    I will upload roms for t710 and t715 only. Don't ask about t81x roms here please.

    if you don't know how to flash recovery or flash rom, this topic is not for you.

    compatible twrp:
    T710: https://drive.google.com/open?id=1F-RA6OEXpWSJx2LgxsRKum2KoROGrIhd
    T715: https://drive.google.com/open?id=1Icux5fPJqxDveYAjvMWASnfUpfWzO4xj

    rom:
    t710 only: https://drive.google.com/open?id=1-abtJDh5CbnC2ijCoAL8AdVHzP47hfCe

    I'm trying to make compatibility with phh gsi builds., but for now I have error with composer. To run his builds is dirty hack: replace /system/lib/libsurcafeflinger*.so two libs from my working build.


    sources:
    http://github.com/bonuzzz
    2
    one more build for today
    https://drive.google.com/open?id=1cIV5WN-VZUngamcNCQCNZfHS_BDIMO_W
    this universal build for both models (t710 and t715)
    modem stuff doesn't work here. I haven't included in config yet, but all sensors should work.
    2
    Hello, thanks for those builds! I've been trying your lineage 15.1 ROM and I think everything is working there already. So I'll start testing these ones now... Is there something in particular you want me to logcat?

    Sent from my Aquaris M5 using Tapatalk

    if you want something to test, there is new build https://drive.google.com/open?id=1Mu-XjXbskSXzft11onGL3mrY_I1llVKX
    1
    no. it replaces some parameters in build.prop
    will check later

    ok, so you are writing into the /system/build.prop my device atributes (model, device name, stuff ...). I guess you do that there in order to have same build for both t710 and t715, am i right?

    ---------- Post added at 01:10 PM ---------- Previous post was at 12:51 PM ----------

    no. it replaces some parameters in build.prop
    will check later

    So in this line:

    sed -i 's/.*ro.build.fingerprint.*/ro.build.fingerprint=samsung/gts28wifixx/gts28wifi:7.0/NRD90M/T710XXU2DRB1:user/release-keys/' /system/build.prop

    I suppose you're trying to replace the "ro.build.fingerprint=samsung/lineage ... " with "ro.build.fingerprint=samsung/gts28wifixx/gts28wifi:7.0/NRD90M/T710XXU2DRB1:user/release-keys" but I think sed can not understand that ... don't you have to scape the "/" stuff on your string there?

    ---------- Post added at 01:21 PM ---------- Previous post was at 01:10 PM ----------

    in any case the '/' in the substituting expression crashes, I just tested it :)

    Sent from my Aquaris M5 using Tapatalk

    ---------- Post added at 01:41 PM ---------- Previous post was at 01:21 PM ----------

    ok, so you are writing into the /system/build.prop my device atributes (model, device name, stuff ...). I guess you do that there in order to have same build for both t710 and t715, am i right?

    ---------- Post added at 01:10 PM ---------- Previous post was at 12:51 PM ----------



    So in this line:

    sed -i 's/.*ro.build.fingerprint.*/ro.build.fingerprint=samsung/gts28wifixx/gts28wifi:7.0/NRD90M/T710XXU2DRB1:user/release-keys/' /system/build.prop

    I suppose you're trying to replace the "ro.build.fingerprint=samsung/lineage ... " with "ro.build.fingerprint=samsung/gts28wifixx/gts28wifi:7.0/NRD90M/T710XXU2DRB1:user/release-keys" but I think sed can not understand that ... don't you have to scape the "/" stuff on your string there?

    ---------- Post added at 01:21 PM ---------- Previous post was at 01:10 PM ----------

    in any case the '/' in the substituting expression crashes, I just tested it :)

    Sent from my Aquaris M5 using Tapatalk

    So this works:
    sed -i 's/.*ro.build.fingerprint.*/ro.build.fingerprint=samsung\/gts28wifixx\/gts28wifi:7.0\/NRD90M\/T710XXU2DRB1:user\/release-keys/' /system/build.prop
    sed -i 's/.*ro.vendor.build.fingerprint.*/ro.build.fingerprint=samsung\/gts28wifixx\/gts28wifi:7.0\/NRD90M\/T710XXU2DRB1:user\/release-keys/' /system/vendor/build.prop
    1
    I haven't checked this script on t710 yet. Working mostly on t715 tablet. Thanks for fix.

    You're welcome, that's what this thread is about ... :good: