• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[TB-8504X] No WiFi or Sim card after restoring stock rom with Lenovo Rescue and Smart Assistant

Search This thread

subinpt

Member
Jul 31, 2021
6
0
Hello There,

I was trying out LineageOS 17.1 on Lenovo Tab4 8, 8504X, 8MP Rear camera model. Everything was fine except the very low volume during audio playback. I was trying to follow the volume fix guides and while in adb shell, device kept crashing. So I tried restoring the factory image using Lenovo Rescue and Smart Assistant. It downloaded and flashed the firmware image, but I saw afterwards, wifi was not working. After a few more attempts, the SIM card also stopped working. Now the device has no connectivity.

I did an oem lock after flashing the stock firmware, now I am not able to use fastboot to flash images. QFIL tool works. The stock firmware version flashed by the tool is TB_8504X_USR_S001024_1909061423_Q12000_ROW_SVC. I am not sure if this is the correct one. Does anyone have the same device with stock ROM? Or can someone please point me to the stock ROM image where things work? The region is India.

Thanks in advance,
 

subinpt

Member
Jul 31, 2021
6
0
Checking further, the baseband version is shown as unknown. Is there an image file that can be flashed to fix this ?

EDIT: Now I understand the QCN needs a restore :( Does anyone have a copy ?
 
Last edited:

subinpt

Member
Jul 31, 2021
6
0
I wanted to update on the thread on how I managed to fix this. I tried the whole thing again, so that I can make sure.

Using the same QFIL tool, I flashed TB_8504X_USR_S001024_1909061423_Q12000_ROW_SVC firmware. This helped booting back to the system. This also enabled diag mode and adb by default on the tablet. That was a big relief. I noticed that wifi is not working and not turning on during the initial setup. I completed the setup and did

Code:
adb reboot bootloader

Once in fastboot mode, I did

Code:
fastboot flash persist persist.img

I used the persist.img from the same firmware folder. Once I turned on the device, WiFi and Bluetooth were working. Since diag port was already on, I used the backup and restore QCN option in QFIL to flash TB-8504X[MPSS.JO.2.0.c1-00151-8937_GENNS_PACK-1].qcn.

I tried may QCN rebuilder tools, but this QCN file seems to be not conforming to the format they expect and they kept gaving error. So I flashed the QCN as it is, rebooted the device and then used a tool named "WriteDualIMEI-W-G-eMMC" to program the IMEI number. This worked perfectly and I have network back.

When I was trying to do this again, for some reason, Sahara errors kept popping up and none of the tools were able to access the device. I found that was because of the driver I used. It wasn't the same ones I used first time. But I used the QDL tool from Linaro in linux and flashed the images with it. It worked perfectly.

I wasn't able to restore the tablet serial number though. Couldn't find a way to do that.