TCL 2022 Google TVs (P635/P735/C635/C735/C835/C935)

Search This thread

daviddave1

New member
Nov 26, 2022
2
0
New TCL T615T03 Google TV Update available in V473.
MT9615 Platform ....C735 & C835/C935.......(C728 & C825)
V8-T615T03-LF1V473.000411

V473 OTA

LINK

build date= Nov 02 2022
build= 1667398451
security_patch= 2022-06-05
gmsversion= Android_11_GTV
product.build.fingerprint= TCL/G05_4K_GB/G05:11/AR2101/AR19:user/release-keys
revision= 000411
OTA size= 1.734 GB
Ty. I just upgraded the firmware to this one.
I just bought and installed the tcl 55c735 144hz 4k tv. bought it mainly so I can game on it from my 12900K 3080 TI PC that supports 2.1 HDMI unfortunately the max hz I can choose is 120Hz in the NVIDIA control panel and I cant enable the Game Master Mode. I can enter the Game Bar though with my remote.

Do I miss out inputlagwise?

I tried different 2.1 HDMI cables.
The tv is in PC mode.
In the attached file a screenshot of some more settings i have enabled.
Gonna call the tcl helpdesk monday but maybe someone here also knows the answer. Any help is welcome.
 

Attachments

  • 20221126_202346.jpg
    20221126_202346.jpg
    985 KB · Views: 121

Giulio199

New member
May 10, 2015
2
0
Hello everybody,
I bought a TCL 55c835 a few days ago, and it arrived with fw V8-T615T03-LF1V438.000296

I encountered a problem with the 5ghz wifi: I have divided networks with different SSIDs and the 5ghz band set by the modem in auto (20/40/80 mhz). Unfortunately my 55c835 does not detect the 5ghz network, indeed it does not detect ANY 5ghz network (not even the hotspots of other smartphones).
Is this a known problem or a bug on mine?
 

stasiof

Senior Member
Oct 9, 2013
2,820
1,113
Hello everybody,
I bought a TCL 55c835 a few days ago, and it arrived with fw V8-T615T03-LF1V438.000296

I encountered a problem with the 5ghz wifi: I have divided networks with different SSIDs and the 5ghz band set by the modem in auto (20/40/80 mhz). Unfortunately my 55c835 does not detect the 5ghz network, indeed it does not detect ANY 5ghz network (not even the hotspots of other smartphones).
Is this a known problem or a bug on mine?
Set in your wifi router 5ghz band to a different lower channel, for example 48 instead of auto mode.
 

dfinikis

Member
Jul 24, 2011
18
7
Set in your wifi router 5ghz band to a different lower channel, for example 48 instead of auto mode.

Exactly...for example channel 36 is ok for me...I have seen the same issue in a Mecool KM6 android box, so I manually have set the 5Gz channel in my modem. And my 55C835 works smoothly with channel 36! :)

//dfinikis
 

Giulio199

New member
May 10, 2015
2
0
Set in your wifi router 5ghz band to a different lower channel, for example 48 instead of auto mode.

Exactly...for example channel 36 is ok for me...I have seen the same issue in a Mecool KM6 android box, so I manually have set the 5Gz channel in my modem. And my 55C835 works smoothly with channel 36! :)

//dfinikis

Ok, I set channel 36 and now the 5ghz network appears correctly.
How does this happen? what channels are supported?
 

shizu11

New member
Oct 2, 2022
2
0
i installed V473 OTA and now i cant find the VRR settings anywhere when playing PS5. did they removed it?
Anybody knows where they moved it?

Update: Always cut your tv from electricity after update and hidden menu reset. After restart VRR worked again.
 
Last edited:

Wensum

Member
Nov 29, 2022
7
1
Hi there.

I have just bought a tcl 43c635. I renamed one of the hdmi inputs. I now have the original plus the custom named input. However I cannot find a way of deleting the custom named input.

Hope someone can help. Thanks in advance.
 

leroy1980

Member
Feb 12, 2008
14
0
Hi everyone. A few days ago I purchased a 50P735 and I have the following issue.
When I turn off the TV sometimes the stand by led switches off and then there is no way to turn the TV on again from the remote or TV's physical button. I always have to unplug it in order to turn on. I have switched off any energy savings and and I have enabled fast turn on. I have already made a factory reset but nothing changed. Is is a faulty TV or is there anything else I can do.

Have been updated to V477 automatically when first switched on.
 

stasiof

Senior Member
Oct 9, 2013
2,820
1,113
Hi everyone. A few days ago I purchased a 50P735 and I have the following issue.
When I turn off the TV sometimes the stand by led switches off and then there is no way to turn the TV on again from the remote or TV's physical button. I always have to unplug it in order to turn on. I have switched off any energy savings and and I have enabled fast turn on. I have already made a factory reset but nothing changed. Is is a faulty TV or is there anything else I can do.

Have been updated to V477 automatically when first switched on.
I don't know why you are messing with power...:rolleyes:
Once you plug TV in socket, On and Off can be done with remote control.
When TV is ON...
short press on remote...stand by
long press on remote....TV Off
Why you switched off any energy savings ?
 

leroy1980

Member
Feb 12, 2008
14
0
I don't know why you are messing with power...:rolleyes:
Once you plug TV in socket, On and Off can be done with remote control.
When TV is ON...
short press on remote...stand by
long press on remote....TV Off
Why you switched off any energy savings ?
Yes, I have switched off energy savings.
I always use the remote, I just checked the button to turn it on only when the remote could not do the job. But not even TV button can turn it on once the stand by led switches off.
This is really frustrating....
I still have to option to return it back (it will take 2days to return to the shop) but I was just wondering if that is a bug from the update that TV automatically installed.
 
Dec 30, 2010
5
0
Hi, folks.

I've been using Chromecast for years and some weeks ago I bought the latest Chromecast (HD, not 4K). The thing is that a some days ago, I bought also the TCL 55C635, that comes with Google TV. What should I do? Do I return the Chromecast? I bought it JUST for the TV that I just stopped using today and that I'm gonna sell soon. I don't want it to carry it with me if I go to a hotel or things like that.

The BIG difference that I've seen is that Google Chromecast uses Android TV 12 and the C635 uses Android TV 11. :/ And also, the TCL comes full of bloatware...

Thanks for your advice!

BTW, my firmware is V8-R51MT05-LF1V477.020694
 
Last edited:

leroy1980

Member
Feb 12, 2008
14
0
Yes, I have switched off energy savings.
I always use the remote, I just checked the button to turn it on only when the remote could not do the job. But not even TV button can turn it on once the stand by led switches off.
This is really frustrating....
I still have to option to return it back (it will take 2days to return to the shop) but I was just wondering if that is a bug from the update that TV automatically installed.
So I have more info. If I turn off TV and after 3-4 minutes turn it on again, it turns on quick to home screen. If I turn it on about 30 minutes later, it turns on like booting starting with the TCL logo and then access home screen. If after that boot, I press turn of after 2-3 minutes, both the TV and stand by led turn off and the TV does not turn on again untill I unplug it first........ really weird.
 

monguly

New member
Oct 6, 2010
3
0
我的電視是TCL 75C935

我想通過電視的 Earc 將藍光電影和 TrueHD 信號發送到 SoundBar。
這個時候有一些問題
一個。我用PC的PowerDVD直接連接SondBar,TuneHD的信號可以流暢傳輸(聲音22M/s)
b. 使用PC -> 75C935 -> EARC to Soundbar的EARC --> 此時只能開啟DD5.1,TuneHD無法啟動。
C。我把Soundbar拆下來直接在PC上播放-> 75C935電視內解碼-->同樣只能傳DD 5.1信號給電視。
d. 用KODI播放,75C935 -> EARC -> Soundbar的EARC 明明在播放,但是Soundbar只能接收到PCM信號,聽上去像是雙聲道切換出來的。。。完全不是TrueHD。

想請問一下,如果你買了這台電視,能不能測試一下,看能不能順利解碼TrueHD?
我現在感覺這種高碼率信號傳到電視上是不對的

I saw C735 / C835 had same porblem in this discuss series.
 
Last edited:

Wensum

Member
Nov 29, 2022
7
1
VPN connection problems

Hi there.

I have a tcl 43c635 and I have a VPN connection problem.

My VPN (Proton) connects perfectly. However, if I exit any app, the VPN connection drops out. It would appear that the TV allows only one connection.

I have tried all the usual problem resolving routines: reinstalling the app, clearing the cache, increased background processi to max, installed different protocols (openvpn and wireguard apps) but I get the same results.

I have also tried at least 5 other VPN providers and get the same problem.

(I have a firestick and the sames VPNs stay connected for days.)

Hope someone can help. Thanks in advance.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    New TCL R51MT05 Google TV Update available in V508.
    R51MT05 Platform P638 & P735 & C635.........(P725 & C725).
    V8-R51MT05-LF1V508.020773

    V508 OTA

    LINK

    build date= Oct 19 2022
    build.date.utc= 1666183594
    security_patch=2022-06-05
    gmsversion= Android_11_GTVs
    build.fingerprint= TCL/G03_4K_GB/BeyondTV4:11/RP1A.200622.001/AR05:user/release-keys
    revision= 020773
    OTA size= 1.6GB
    3
    OTA network auto update and OTA on telegram, no difference.
    100% same file.
    People posting without any clue.
    2
    Hello there,
    Are these TV good?
    I'm thinking on buying a new tv and these seem to be good on price / quality IMO.
    If you read this thread you will know if yes or not, but to be honest I have mixed feelings. These TVs have good VA panels. Very clean and great picture quality, colour, contrast, and even black level, but it is still LCD not OLED. These TVs have also everything you need and want, but not everything of these works well or at least not for everyone. It always depend of bought piece and firmware instalations stuff. Android devices have always problems, small or big problems, but always they actually have and you need to accept the reality of those devices. TCL is typical china stuff with medium quality assurance in production stage and as on the all china devices with android - even if that device has good stuff inner I mean cpu, ram, good quality mobo elements, screen and etc.. - but the always problems are with firmware/software. I think sometimes that they never have enough time to write good firmware and the most problems are because of fails in firmware and it works like sh*t sometimes and always you need to find any workarouds to work with these device. The best example is that Dolby Vision. Ehh.. to be honest don't know what to say.. I wouldnt buy the TCL TVs once again or at least for a few years, maybe in few years TCL will learn and be better brand, because for now it is like a first older sh*tty xiaomis or ztes mobile phones, where the hardware was nice, but firmware omg... I think don't wanna say anything more, but nevertheless also don't know what will be better and give you the same soo much in the same good TCLs prices.
    2
    The flashing of the screen stopped, however, still without the 144hz. I don't know what else to do to get my Nvidia control panel to offer this option.
    Hi, at the launch of the tv there was a problem with the nvidia cards to activate the 144hz, in tests that i saw online it was ok with AMD but not NVIDIA. On the other hand i don't know if it is with all nvidia cards or not. I have an AMD card but I haven't tested 144hz yet, just 120.
    You also have to change to 8bits colors for 4k 144hz, in 10bits you can only have 4k 120hz.
    2
    Not so, sir. The concept of quality in production has changed a lot in the recent period, and there are many international companies that have given concessions to factories in Asian and African countries to implement some models of devices with modest quality. Giant and well-known companies are now seeing devices made in their name with major manufacturing errors and problems with the quality of the materials and parts used, and yet they pay a high amount of money for the brand name only. Well-known brands focus only on high-end devices. That is why Chinese companies have appeared strongly in the recent period... For example, TCL used to buy QLED screens from Samsung factories before 2019. Then TCL bought the factory from Samsung and became the one to supply screens for some Samsung models!!! The same is the case with many well-known international companies that have come to rely on Chinese factories to supply all their needs of ready-made parts and raw materials, and send them to their factories in Asia and Africa for assembly and branding on them.......
    Yea.. and everything still mean that the problem is always in sh!ity-atittude in china products producents and at the end of this story - the client himself. Samsung also sh!t. LG it depends on models. Panasonic don't know, haven't seen any product since 10 years. Sharp maybe, but honestly nothing special. Toshiba.. yeaa where is Toshiba. Myself don't know what to buy instead of TCL to be honest and this is the worst thing, but even if you wanna buy something better now what will be complete-device, f!ck don't know what, because even higher models of reputable brands have bugs and it doesn't work well sometimes, but I think this is the new world problem in technology - mediocrity in everything and lack of refinement (i feel sometimes the everything is left as it is and the client is left alone with it (mediocrity) later, with possible problems and has to think for himself how to fix and workaround them, if possible, of course) in the most important things that should be flawless and shine bright like a diamond.
    The example from these thread - dolby vision, I can't understand how they let to produce the TV with problem like this (I think the firmware is problem, but this firmware isn't repaired afaik yet even in v501, don't know about v508, but I don't think it is - If someone got info about that - let us to know..). Can't understand. The main function - watching - and doesn't work.. really?! It's freakin' annoying. TCLs TVs aren't the cheapest in 50+ inches to be honest, so.. of course this is budget shelf, but.. not the cheapest. Can't understand once again and again..
  • 4
    New TCL R51MT05 Google TV Update available in V508.
    R51MT05 Platform P638 & P735 & C635.........(P725 & C725).
    V8-R51MT05-LF1V508.020773

    V508 OTA

    LINK

    build date= Oct 19 2022
    build.date.utc= 1666183594
    security_patch=2022-06-05
    gmsversion= Android_11_GTVs
    build.fingerprint= TCL/G03_4K_GB/BeyondTV4:11/RP1A.200622.001/AR05:user/release-keys
    revision= 020773
    OTA size= 1.6GB
    4
    New TCL T615T03 Google TV Update available in V474.
    MT9615 Platform ....C735 & C835/C935.......(C728 & C825)
    V8-T615T03-LF1V474.000418

    V474 OTA

    LINK

    build date= Nov 23 2022
    build= 1669174746
    security_patch= 2022-06-05
    gmsversion= Android_11_GTV
    product.build.fingerprint= TCL/G05_4K_GB/G05:11/AR2101/AR19:user/release-keys
    revision= 000418
    OTA size= 1.734 GB
    3
    New TCL T615T03 Google TV Update available in V473.
    MT9615 Platform ....C735 & C835/C935.......(C728 & C825)
    V8-T615T03-LF1V473.000411

    V473 OTA

    LINK

    build date= Nov 02 2022
    build= 1667398451
    security_patch= 2022-06-05
    gmsversion= Android_11_GTV
    product.build.fingerprint= TCL/G05_4K_GB/G05:11/AR2101/AR19:user/release-keys
    revision= 000411
    OTA size= 1.734 GB
    3
    I have 50c735 europe_pl (bought and use here) first set up update firmware to v477, but that's it, no more updates to do, it says - nothing to update. I know that there are few next updates so I decided to do update by myself, but to be sure and safe, just for know I just update with v496 OTA, of course reset shop, reset all and after that full factory reset and configuration of all Google TV once again with all apps etc.. Hmm.. I don't know if this update give something new, may be some functions or naming of it, may be little smooth feeling, but rather little not many. Hmm, but what I noticed, after update the screen is more more red.. and maybe pink moreover in some movies/ apps so I have to change white balance in expert mode 2 points and red boost set to -16 and blue -2, now is very good, but.. hmm someone also noticed it?? Some said here that the Dolby Vision is repaired now, but don't know what, maybe is more smooth, maybe - ok, but still the problem about @OnyOnaki said above actually exist. I can't say that is brightness lag, its like a delay in led backlight software saying about reaction. Hmm Im good with that to be honest, it doesn't annoying me, but some in my family said that is really not cool. Hm.. in my opinion this is a dynamic hdr so..., but yeahh.. it could be faster... To avoid big jumps of brightness I set bright preset and gamma -1, everythings OFF and dynamic mapping on OFF [but to be honest this option is really good to have ON, because of details that he helps you to see in very white scene, but.. also makes more work to brightness regulators]...

    I think about v501 flash via IMG and make completly fresh instalation, but.. don't know if it make sense. I think the main problem is CPU and everything we say its about him. TCL make not good move with making money on us who don't need big-bigg screens and they implement ****ty realtek CPU inner <50 inchs. Really sad, because these TV to be honest isn't the cheapest we can buy, but maybe some updates helps us.

    Maybe someone has calibration settings for these C735 SERIES to 50 inches etc.. screens, I mean of course calibrated with sensor, not on eye, because on eye I also did that, I've got good eye hehe, but if someone has settings made by pro, it will be be nice to share with us.

    Someone test v501 on c735? I saw there isn't at v501 OTA so.. I don't know if it is safe.. and if it is worth to update.


    EDIT: UPDATE ABOUT FOR ALL OF US WHO HAVE DOLBY VISION BRIGHTNESS PROBLEM, THERE IS A WORKAROUND SOLUTION AND SOMETHING LIKE A GOOD NEWS.

    I found these instruction here on xda in other thread with beyond TVs:
    1. Activate Quick Start (EVEN if you have this option ON, just do TURN OFF AND TURN ON THIS OPTION once AGAIN)
    2. Turn off (hold power button on remote control 5 seconds and say YES/ OK to turn off question and unplug the TV and of course after 10-15 sec, plug in powercord to TV again)
    3. Turn on the TV
    4. Let it load all the GTV UI
    5. Turn off the TV with the remote control button (but not completly, just one short click - to quick start standby mode)
    6. Turn the TV back ON with the button on the remote
    7. Put the movie or series with Dolby Vision
    8. Enjoy, finally, the movie or series without brightness changes in the scenes

    And if you always use stand-by quick start turn off turn on method od remote control, these will be work. If you unplug TV or you lost power on TV powercord you will need to do that ALWAYS ONCE AGAIN AND AGAIN [DON'T SKIP ANY STEP, JUST DO THAT ALWAYS THE SAME WAY]. Don't test it how it will be working after few days and making a mess with apps etc.

    And these is that good news - its only firmware problem, not a hardware, but the question is if the TCL knows about that and has a will to repair that in next updates. Some say here that the V501 repair that. Don't know, im on v496 now after manual OTA update with V477 stock firmware, but on these two version, it was the same problem. Maybe I will try to V501 IMG full firmware flash with reset all and reset shop before, and factory reset after flash this IMG and I will also report if that helps or not, but to be honest I think TCL don't know how to repair that. I know one TV from my country which is on the market warranty Service and 7 days after still we don't know what will be done in this case. I also forward these news and instruction how to workaround these problem and maybe service will contact with TCL SUPPORT and MAYBE THEY forward this information on the next steps, but to be honest in these budget - the only we can do now is to have hope that they will still work on these platform, it's 2022y model so maybe... Don't know, will see.
    3
    OTA network auto update and OTA on telegram, no difference.
    100% same file.
    People posting without any clue.