• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

TCL Android TV model 55p8m / Android Recovery TCL/BeyondTV/BeyondTV

Search This thread

fatjoez

Senior Member
Feb 25, 2011
644
144
can someone link the android 11 update?
I have:

model #50c715
software #V8-R851T02-LF1V606.017688
 

fatjoez

Senior Member
Feb 25, 2011
644
144
@stasiof
Thanks I found it just before you reply me :)
I am currently on 606 and have LOTS of problem tv is SLOWWWWW lag.
Is any improvement on 650 / 653 for the lag/slow???
 

stasiof

Senior Member
Oct 9, 2013
1,707
652
Yes, is many improvements.
If you don't have many addittional apps, best way is to update with IMG file,
which will wipe all your system.
Or just flash OTA file and do factory restore (if need).
 

elison_nc

Member
Jun 20, 2021
18
5
@stasiof
Thanks I found it just before you reply me :)
I am currently on 606 and have LOTS of problem tv is SLOWWWWW lag.
Is any improvement on 650 / 653 for the lag/slow???


Check your remote batteries, when you click and something doesn't happen, or you need to click two times, it's because the controller is low on battery, when is like that the TV looks very slow, but is actually the remote, telling you to put new batteries.
 
  • Like
Reactions: titovski

fatjoez

Senior Member
Feb 25, 2011
644
144
Check your remote batteries, when you click and something doesn't happen, or you need to click two times, it's because the controller is low on battery, when is like that the TV looks very slow, but is actually the remote, telling you to put new batteries.
Thanks but the lag on 55 C715 is real lag.
Sometimes press button arrows multiple times in some media app & after like 10-20 seconds it will respond and suddenly move multiple times (responding to those previous presses of key)
So it's a real lag.

I have NVIDIA shield on another tv and can see the performance higher on shield.
very sad!!
 

stasiof

Senior Member
Oct 9, 2013
1,707
652
Thanks but the lag on 55 C715 is real lag.
Sometimes press button arrows multiple times in some media app & after like 10-20 seconds it will respond and suddenly move multiple times (responding to those previous presses of key)
So it's a real lag.

I have NVIDIA shield on another tv and can see the performance higher on shield.
very sad!!
10-15 min need to update firmware.....
 

fatjoez

Senior Member
Feb 25, 2011
644
144
10-15 min need to update firmware.....
Yep I did the update to v653.
Some minor improvement to speed definitely yes.

Some apps still lag though. I think it's also a problem some apps are too slow.

I guess this is the best possible on TCL tv.

I tried the android 11 upgrade now.
but when i uploaded the zip file to the USB and power on it tell me no update package available

what am i doing wrong?
i didnt unzip the file (it's an OTA update from the post 2359)


EDIT: Found the problem. you MUST NOT RENAME the ota update filename.
The TV search for the update zip by filename
(V8-R851T02-LF1V900)

It's looking for V8-R851T02- *******
I had changed the filename to: TCL_TV_50C715_firmware_V8-R851T02-LF1V900

Now the firmware is updating
 

stasiof

Senior Member
Oct 9, 2013
1,707
652
Now the firmware is updating
You will have problem to flash back,as Android 11 (R007) firmware is very buggy.
V8-R851T02-LF1V900 is just name of zip file and not firmware.
On the end you will end up with flashing IMG file, which will wipe all your apps....then you will have speedy system..haha
 
  • Like
Reactions: fatjoez

MadMungo

Senior Member
Nov 30, 2013
71
27
Sydney
I tried the V900 firmware on my C715 tv a couple of days ago.
The difference in responsiveness between V900 and V653 is night and day.
The ONLY reason I went back to V653 is because Dolby Vision and HDR10/+ was super dark and un-watchable.
No amount of tweaking could fix it for me.
Now on V653 I have similar lag in programmes as @fatjoez, but I have been experiencing that since V620 so not a big deal.
 
  • Like
Reactions: fatjoez and jabes01

MadMungo

Senior Member
Nov 30, 2013
71
27
Sydney
I was able to flash back using the V653 OTA file. Had to do a factory reset as I got an error when booting saying something along the lines of "there was a problem starting android" - Try restarting again / Perform Factory Reset. After that was back on V653, re-setup tv, and back to how it always has been.
 
  • Like
Reactions: fatjoez

fatjoez

Senior Member
Feb 25, 2011
644
144
I'm on Android 11 beta now (the latest one posted about 5 days ago in the telegram group).
Honestly it's so far OK. I don't know maybe you guys used it more than me.

So far I tested the apps:
PLEX, SmartYoutube, general browsing user interface.


My opinion it's not slower or faster. It's still painful slow as all previous versions lol.
I might get an Nvidia Shield and stop wasting time on this tv.

Also I argued with TCL about this tv & they accepted to return the TV for refund $ because of the slowness.
So I will probably do that.

I wanted to replace it with a C825 (2021 miniled TCL) but I read that they used a MediaTek CPU and it sucks performance.

Really sad what is happening with technology. Suppliers are using rubbish CPU which 90% of customer don't understand the performance is bad but the 10% like us can see it's obviously bad.
 
  • Like
Reactions: cbm80

twerg

Senior Member
Oct 11, 2009
881
142
Hobart
Apps & Games
i think its more a ram issue, 2 gb shared with video is nothing. once u trim down the system mit AdbAppControl it will become way more responsive.

edit: here's my preset in case anyone wants to try
Thanks for reminding me of this App, Stasiof first mentioned this to me. I have now gone through and disabled/deleted various apps, restarted TV system (reboot) and have 654MB free RAM. Not sure how much difference it'll make, there may be other apps can disable, not sure yet.. Not all that you offered in your .txt was on my TV.

Handy little tool.. Cheers
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I downloaded and tested latest beta version of android 11.

    My personal opinion, i dont see any difference, from v660 android 9 in terms of menu, etc.. except a new android logo when tv is turning on.
    Compared to previous beta version, everything is working ok, but when changing from 4k, to 4k with HDR enabled, it lags, and takes a few seconds to show image again using HDMI, in my case, PS5 console.

    In terms of image quality, equal or slightly better than v660.
    I am not an expert, i am a normal user, that likes to test new things.

    In netflix, youtube, hbo, works absolutly great.
    KODI, i dont use it anymore, i cant give my opinion for some users.

    i use wifi connection, but usind ethernet port is a huge diference and can take full advantage of 4k content streams, etc...

    I enabled the DEV MODE on settings, and disabled all animations options, and that takes a diference using the normal menu, etc..

    Has a daily FW, i will keep it on Android 11, since i can use the TV as i used with v660.

    For "hardcore users" probably can test and give more detailed info than me, but i just decided to give my feedback.

    Any questions, or recomendations regarding some tweeks i could do on android DEV settings i would be apreciated.

    Regards everyone!
    3
    I know its quite some time now. Can you provide any newer versions for MS 6586?
    No new V versions, only some R custom version.

    Edit:
    Found one new....V467

    3
    New TCL R851T02 Android TV Update available in V677 IMG file

    ANDROID 11

    V8-R851T02-LF1V677.000023
    (Beta test version)

    V677 IMG File:

    build date= Dec 02 2021
    build=
    security_patch= 2021-09-05
    gmsversion= Android_11_R
    IMG size= 3.00 GB

    2.jpg


    1.jpg



    Edit:
    So far positive response.....

    https://t.me/tclupdates_discussion

    3.jpg


    2022-01-17-001955.png
    2
    Hi all,

    I've been experimenting and troubleshooting with my 50C715 in trying to get the lowest input lag for gaming. I mostly use it for retro gaming. So far I feel that the display lag is quite good, and the majority of issues with pixel trails have been resolved, but there is still an issue with sound lag. I use the TV's internal speakers for sound output for now.

    V653 had a very noticable delay in sound I've recently installed V660 after using V653 for a while and hoped that it would improve the sound delay, but if it has it appears to be only marginal. I've run sound tests by connecting a pair of amplified desktop speakers to the headphones jack and running a video/audio synchronicity test, and have the same sound delay issue. However, when I connect the speakers directly to the gaming console there is a noticable improvement. It becomes very obvious when I use the desktop speakers connected to the gaming console as well as output from the TV, as you can hear the desktop speakers first before the TV's speakers.

    I've tried adjusting all the settings that I can think of but none make a difference to the sound delay. I've also tried adjusting the settings in the service menu.

    Does anyone else have the same experience? I've seen reports of soundbar delays which could be related. Beyond that, does any one have any recommendations to resolve it? My next best option would probably be buying an AV unit to connect all my consoles to and output the sound from there before it's sent to the TV.
    2
    v660 is working great, at least for me, so I would not be bummed if this was the last update for C715

    I have the V653 upstairs. I use it with satisfaction.
  • 17

    UPDATE VERSION: V643​


    Date of publication/uploaded : 16.06.2021
    Check URL file size : 1.385 Gb
    Compilation date : 11/06/2021

    [Download link]
    :

    [Change log] :
    1. enhance stability
    2. optimised experience
    3. fixed some audio formats crash
    4. security package update (gDLL)
    5. optimisation
    DVB-S2 for SAT (lib.sat.so) card
    11
    V645


    build date= Jun 19 2021
    build= 1624032310
    security_patch= 2021-01-05
    gmsversion= Android_9_Pie
    software.version_name=AP08
    file size= 1.38GB
    10
    Another Argentinian here.
    As I got tired of waiting for the OTA to appear, with my adb logcat running, and it never did ...
    I thought: "why don't I edit the ota v213 url to see if it works?", and it did. :p

    V8-R851T02-LF1V321.014450.zip
    9

    UPDATE VERSION: V649​

    Date of publication/uploaded : 28.07.2021
    URL file size : 1.37732Gb
    Android 9.0
    BTL compiled 16/07


    - Ground channel optimization
    - Fix that occurred while reading some audio formats
    - (opt) BT remote controls & pairing
    - Other minor optimizations and fixes

    Observation: My sounbar now works correctly.
    9
    V640


    build date= Jun 02 2021
    build= 1622639309
    security_patch= 2021-01-05
    gmsversion= Android_9_Pie
    software.version_name=AP08
    file size= 1.40GB