TCL Android TV model 55p8m / Android Recovery TCL/BeyondTV/BeyondTV

Search This thread

stasiof

Senior Member
Oct 9, 2013
2,717
1,061

stasiof

Senior Member
Oct 9, 2013
2,717
1,061
Hello all,

I have a TCL 65S434, Android 9, Software version - V8-R51MT02-LF1V104.018670

My question is, can I find an update on here that I can use for a local update? When I use the built-in updater, it just tells me my software is up to date, but my security patch level is from way back in november of 2020! I see a lot of versions being brought up in this thread, but I certainly don't want to use the wrong software. Can anyone direct me to the correct firmware update? Any help is appreciated.

*edit* I forgot to mention that I originally wanted an update because this TV seems to freeze up and is often laggy... but I'm stuck with it for now.
What is your location ?
S434 is for N.America region.
 

tmcstn

Member
Dec 1, 2021
8
0
Hello everyone, I noticed horizontal light bands on my TCL C715. It may be there since the beginning and I did not realize it and it may also be quite normal but I ask the question out of curiosity. This is especially visible on the output screens or when I really lower the brightness of the TV. It doesn't bother the viewing in itself but I find it curious :unsure:.
 

twerg

Senior Member
Oct 11, 2009
906
160
Hobart
Apps & Games
Hello everyone, I noticed horizontal light bands on my TCL C715. It may be there since the beginning and I did not realize it and it may also be quite normal but I ask the question out of curiosity. This is especially visible on the output screens or when I really lower the brightness of the TV. It doesn't bother the viewing in itself but I find it curious :unsure:.
I don't get that on my 50C715, not from what I've seen.. post a picture of it maybe?
 

tmcstn

Member
Dec 1, 2021
8
0
I don't get that on my 50C715, not from what I've seen.. post a picture of it maybe?

Not obvious to take a picture of it, even a video... I tried with the exit screen. It can also be seen on classic content when you lower the brightness thoroughly. It doesn't show more than that but I feel like it adds a feeling of "dirty" screen

 

twerg

Senior Member
Oct 11, 2009
906
160
Hobart
Apps & Games
Not obvious to take a picture of it, even a video... I tried with the exit screen. It can also be seen on classic content when you lower the brightness thoroughly. It doesn't show more than that but I feel like it adds a feeling of "dirty" screen

View attachment 5503231
Yeah, that's not normal. Have you reset the TV and tested? Have you tried turning all picture enhancement settings off and checking again?

Is there some other device nearby that might be causing some interface with the TV?

The only setting I have used that makes screen flicker, and not quite like that, is the motion/black frame insertion mode
 

tmcstn

Member
Dec 1, 2021
8
0
Yeah, that's not normal. Have you reset the TV and tested? Have you tried turning all picture enhancement settings off and checking again?

Is there some other device nearby that might be causing some interface with the TV?

The only setting I have used that makes screen flicker, and not quite like that, is the motion/black frame insertion mode

Yes I tried it, it doesn't change anything, and i have all the image enhancement settings disabled. There is a PS4 connected to the other HDMI and the internet box next to it . Yes I see what it does, I don't use motion / black frame insertion.

With normal use it is impossible to detect and I do not have the impression that it deteriorates the quality of the image but it is still strange ...
 

g0w

Member
Jul 26, 2014
24
3

davidbz

Senior Member
Sep 16, 2020
56
16
yes V660 is latest but when i try to search it on brazil website it says that c715 has different models and need specify serial number but if tv is not built in brazil it won’t search, is it safe and correct install brazil version update in europe model tcl C715?
 

stasiof

Senior Member
Oct 9, 2013
2,717
1,061
yes V660 is latest but when i try to search it on brazil website it says that c715 has different models and need specify serial number but if tv is not built in brazil it won’t search, is it safe and correct install brazil version update in europe model tcl C715?
Brazil, Malaysia or Kenya link, all is same, as firmware is global.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Hello I'm new here and need help please, I'm sorry if someone asked before. This is my TCL TV and I need the update please 🙏
    Thank you in advance
    As posted in other threat...
    You have V645 .....ATV 9.
    Latest is V715 OTA or V718 IMG....ATV 11.
    Latest is V660 OTA or V662 IMG....ATV 9.

    All versions you can found here in this threat....

    Usefull thread.....
    2
    Just Downloaded .. Installing it now as i type this msg... will update with my findings soon... :)
    Sadly the "HDMI-CEC Power On" bug still remains on v718 ... It's worse now getting a "Black Screen" flickering when turning "On/Off" the Sony Soundbar (HDMI1-ARC) while watching Amazon Prime on my Shield (HDMI2).. Which didn't happen when on v662 .. :-(
    2
    Hello,
    I've just installed and configured the latest version V718 on my 50C715. I previously used V645. I have a couple of points to raise regarding this release:

    - This is the first version I was able to hear DTS audio from my Sonos Beam, but only via internal player (streaming from Jellyfin server). There's even a logo displayed shortly on the screen. Unfortunately it crashes a lot, so no good movie experience there.
    - My BT remote RC802V is unable to pair (no response after pushing HOME+OK) - it worked in V645 just fine. When used as a IR remote it repeats clicks like crazy.
    - Internal video player crashes the system. It really depends on the used source. Not sure if anyone has similar issues with this release. I saw rebooting twice during my 1h testing session.
    - This is not specific to this version, but any 3rd party player like VLC, Exo, Nova etc. can't pass-through audio stream. On this version it's basically downmixing everything to stereo regardless of what audio format is used (DD+5.1 arrives at Sonos, but this is really ****ty stereo downmix).

    If you have any idea how to solve any of the above issues let me/us know. :)
    Cheers!
    2
    If I understand the guide correctly, since the move is from A9 to A11 that I should do the IMG install instead of OTA, right? Also, if IMG is a clean install, should I still do reset all/shop? I also read somewhere here that you use v715, are you still using that or are you on R815.
    ATV9 => ATV11 can do with OTA also.....V715
    Opposite,must use ATV9 IMG file......V662
    I am on R815 (latest by date), but is IMG file.
    2
    Thanks for your reply. Unfortunately, "Dolby Digital +" only works on wider band HDMI ARC. Toslink works, of course, but limited to plain vanilla "Dolby Digital".

    I've found this thread, which describe exactly my problem. Unfortunately it shows no solution without breaking completely HDMI-CEC (and as consequence HDMI-ARC).

    I have the same issue with my setup (TCL C815, Sony HG700) when using A11 (v701, v715, R815) .. So i reverted back to A9 v662 and i have no issues with Auto-On .. now I can switch on the Surround when I want to :) ..
  • 17

    UPDATE VERSION: V643​


    Date of publication/uploaded : 16.06.2021
    Check URL file size : 1.385 Gb
    Compilation date : 11/06/2021

    [Download link]
    :

    [Change log] :
    1. enhance stability
    2. optimised experience
    3. fixed some audio formats crash
    4. security package update (gDLL)
    5. optimisation
    DVB-S2 for SAT (lib.sat.so) card
    11
    V645


    build date= Jun 19 2021
    build= 1624032310
    security_patch= 2021-01-05
    gmsversion= Android_9_Pie
    software.version_name=AP08
    file size= 1.38GB
    10
    I have a 75c815k (uk) and have just updated to V715 android 11 software, I was previously on V645 the current official TCL European software and had spent many many hours tweaking the settings to get what I consider the best picture quality to suit my taste and eye. My son has an LG 77" c1 oled which cost him roughly 4 times more than my TCL and whilst my picture is not quite up to his with my settings I think it comes very close and thought I would share them if anyone wants to try them. I like quite a vibrant picture so have used the standard mode with the following settings for SDR ( in movie mode the same settings give a slightly softer look)
    Brightness/backlight 45,
    Contrast 90,
    Black level 40,
    Dynamic contrast off, black stretch off, brightness+ on, local dimming low, gamma 0
    Colour 48, tint 50, dynamic colour on, colour temp -1
    Sharpness 50, digital noise and noise reduction off
    Gradation clear (not on V645) low
    Motion clarity on, led motion clear off, judder reduction off
    Expert calibration settings untouched apart from colour space set to auto.

    My Hdr settings are similar although brightness and contrast left at 100 and colour pulled back to around 46
    Dolby Vision left alone.

    These settings were originally set on V645 but seem ok with V715

    As with most things picture quality is subjective but these settings I believe would give a much better baseline to the out of box settings which are way overblown in my opinion.
    10
    Another Argentinian here.
    As I got tired of waiting for the OTA to appear, with my adb logcat running, and it never did ...
    I thought: "why don't I edit the ota v213 url to see if it works?", and it did. :p

    V8-R851T02-LF1V321.014450.zip
    9
    V640


    build date= Jun 02 2021
    build= 1622639309
    security_patch= 2021-01-05
    gmsversion= Android_9_Pie
    software.version_name=AP08
    file size= 1.40GB