TCL Android TV model 55p8m / Android Recovery TCL/BeyondTV/BeyondTV

Search This thread

DizXDA83

Senior Member
Mar 12, 2012
185
16
Portugal
yes i read it... checked on telegram for it.... is Android 11 version stable enough?? for Android 9 (Pie) this is latest correct?
V8-R851T02-LF1V662 662 version?
 

CaptainFlakes

Member
Oct 28, 2014
35
5
OK, its the OTA we have all been waiting for. Big thumbs up from me so far, I upgraded from 701, did a reset, updated Play Store and then did all the updates. 701 seemed to get sluggish for me after having it installed for a while so I will report back after a week if I can, but its very smooth and fixed a few issues I was having.
For me HDMI sound paththrough is broken, same as with 701. Worked flawlessly with latest android 9 build.
 

twerg

Senior Member
Oct 11, 2009
897
151
Hobart
Apps & Games
For me HDMI sound paththrough is broken, same as with 701. Worked flawlessly with latest android 9 build.
How is HDMI Passthrough broken for you? On both v701 and now v715, it works fine for me with no issue that I see, though I only use up to 5.1 over this.

Provide some examples how it's broken, what equipment you are using, what troubleshooting you have done etc. This all helps to understand and to help people with a response
 
Last edited:
  • Like
Reactions: Bogdans29

lcdsantos

New member
Dec 16, 2011
4
0
Sao Paulo, Brazil
How is HDMI Passthrough broken for you? On both v701 and now v715, it works fine for me with no issue that I see, though I only use up to 5.1 over this.

Provide some examples how it's broken, what equipment you are using, what troubleshooting you have done etc. This all helps to understand and to help people with a response
I'm not the author, but I will tell about my experience.

I'm using v715, upgraded from v701. And I have tested several other v6xx (Android 9) versions before.

Today, my HDMI passthrough (setting digital audio output on bypass) works nicely using the internal default video player.

I'm using a common small video file, from Dolby, with channel check sound. It's a DD+ file, and DD+ is correctly detected by Denon receiver, with a HDMI ARC cable. And with 7.1 channels.

Netflix also works, sending DD+ to the receiver, but only with 5.1. As far I know, there's no 7.1 audio content on Netflix.

But video player apps, like MX Player Pro or VLC doesn't work, despite all attempts. I successfully installed DD+ external audio decoder for MX Player.

Audio stream always reach receiver in 2.0 with bypass on TV.

My TV is a local brazilian TCL, R851T02 chassis, of course.
 
Last edited:

CaptainFlakes

Member
Oct 28, 2014
35
5
How is HDMI Passthrough broken for you? On both v701 and now v715, it works fine for me with no issue that I see, though I only use up to 5.1 over this.

Provide some examples how it's broken, what equipment you are using, what troubleshooting you have done etc. This all helps to understand and to help people with a response
Pretty much all the apps like netflix, amazon prime or disney+ do not stream 5.1 sound when paththrough is activated. As soon as a video starts the receiver has no signal anymore. Going back to the menus, the signal returns. I have a yamaha receiver and paththrough worked fine with android 9.

I have installed 701 over the air and also starting from scratch with img. I have resetted everything multiple times. 715 also installed as image. Returning to android 9 fixes the problem immediately.

May be a specific problem with yamaha idk.
 

amer.abdo

Member
Mar 17, 2021
9
0
Pretty much all the apps like netflix, amazon prime or disney+ do not stream 5.1 sound when paththrough is activated. As soon as a video starts the receiver has no signal anymore. Going back to the menus, the signal returns. I have a yamaha receiver and paththrough worked fine with android 9.

I have installed 701 over the air and also starting from scratch with img. I have resetted everything multiple times. 715 also installed as image. Returning to android 9 fixes the problem immediately.

May be a specific problem with yamaha idk.
You are not alone, for me it is pretty much the same, I have a Yamaha AVR and ARC did not work for me on any android 11 version on my C815 including the latest V715 no matter what I do to pass through settings, on the other hand all Android 9 ones worked without any issue.
 

lcdsantos

New member
Dec 16, 2011
4
0
Sao Paulo, Brazil
You are not alone, for me it is pretty much the same, I have a Yamaha AVR and ARC did not work for me on any android 11 version on my C815 including the latest V715 no matter what I do to pass through settings, on the other hand all Android 9 ones worked without any issue.
With bypass/passthrough TV option, and on my old Denon receiver (AVR-2311CI), all mainstream VOD apps (Netflix, Amazon Prime, HBOMax, Apple TV) works nicely, with DD+ sound over HDMI ARC. Sometimes Denon only receives DD, others DD+, but always mch sound.

Using a common demo/check DD+ file, from Dolby, mch audio stream also works nicely using internal/built-in video/media player.

I can't manage to work although any video app with DD/mch sound. Only stereo 2.0 always. I tried MX Player Pro, VLC, Nova Player, Kodi and so on. All free apps I have tested. Finally I give a chance for a paid one, Vimu. It has the most complete array of decoding/audio passthrough options. But, unfortunately, it also didn't work.

On my TV built-in video player has terrible subtitles. So I prefer to drop the mch over a nice readable subtitle.
 

simonarturo

Senior Member
Jun 19, 2014
292
97
hey everyone! I'm trying to go from version 701 to 715 via the OTA file, but for some reason when trying to perform the local update, it gives an error before even starting saying: "the validation of update package failed and system update stopped!".

I have tried with different USB sticks, formatting and re-formatting them, but I still get the same error, which I have not gotten in the past when updating via USB...Anyone knows what it could be?

It seems I will have to try with the IMG file, but I have been avoiding that option since I don't want to setup everything again...

EDIT: re-downloaded the file from another source and managed to flash it, so I must have downloaded an incomplete or corrupted file. Cheers!
 
Last edited:
  • Like
Reactions: hd9500

uvramana1

Member
Apr 28, 2016
12
1
I am trying to upgrade my 43S434 model to V8-R851T02-LF1V715.zip from the telegram channel, it says package verification failed. I am on older version v631, do I need to go to latest v6xx series before I can upgrade to 7xx?
 

Bailey56

Member
Jun 28, 2022
20
15
I have a 75c815k (UK) currently running V645 could someone point me in the right direction for downloading V653 as none of the links on previous posts seem to work anymore. I am not really fussed about Android 11 just want the best possible image quality, I would stick with 645 but have a few odd bugs like not holding picture settings when quick start is disabled? Thanks in advance for any help :)
 

stasiof

Senior Member
Oct 9, 2013
2,368
902
I have a 75c815k (UK) currently running V645 could someone point me in the right direction for downloading V653 as none of the links on previous posts seem to work anymore. I am not really fussed about Android 11 just want the best possible image quality, I would stick with 645 but have a few odd bugs like not holding picture settings when quick start is disabled? Thanks in advance for any help :)
Why V653 ?..... (post #2250)

Latest is V662 IMG and V660 OTA ,under Android 9.
I still recommend V715.

Edit:
V645 has major HLG bug.
 
Last edited:

Bailey56

Member
Jun 28, 2022
20
15
Why V653 ?..... (post #2250)

Latest is V662 IMG and V660 OTA ,under Android 9.
I still recommend V715.

Edit:
V645 has major HLG bug.
Thanks for the response...to be honest I read so many pages I probably got confused as thought V653 was most recent stable OTA , I see you are a major contributor on this thread so will bow to your greater knowledge where can I find a link to V715 as 645 is still latest on TCL Uk website? Thanks
 

stasiof

Senior Member
Oct 9, 2013
2,368
902
Just out of interest what improvements will V715 bring over 645 (i don't seem to have HLG problem?)
V715...post #3512

Not all HLG clip (from YouTube) has problem, but let say 40%.
Attached some pic from V645 and YouTube clips.....fixed from V649 and above.
 

Attachments

  • TCast1619273626224.png
    TCast1619273626224.png
    2.7 MB · Views: 67
  • TCast1625388577505.png
    TCast1625388577505.png
    1.3 MB · Views: 68
  • Like
Reactions: Bailey56

Mohenjo Daro

Member
Nov 29, 2012
11
2
V715 OTA update is not working on C715. I believe a number of required files are missing from it, at least when compared to V701 OTA package. The system can't start the update since it can't find relevant files.

Is there an alternative OTA pack for V715 perhaps, or an alternative way to deploy OTA update?
 

stasiof

Senior Member
Oct 9, 2013
2,368
902
V715 OTA update is not working on C715. I believe a number of required files are missing from it, at least when compared to V701 OTA package. The system can't start the update since it can't find relevant files.

Is there an alternative OTA pack for V715 perhaps, or an alternative way to deploy OTA update?
V715 OTA file working without any problem.
Describe how you try to update.....
Sometime other USB help.
 

Top Liked Posts