TCL Android TV model 55p8m / Android Recovery TCL/BeyondTV/BeyondTV

Search This thread

stasiof

Senior Member
  • Oct 9, 2013
    865
    305
    I am having a TCL P815, which has a "Google Home" integrated. Means the Mic is in the TV itself.
    Unfortunatly if I press the power button on my TV, I am unable to say "Okay Google" anymore.
    Is there any way, how I could use the integrated Okay Google event when the TV itself is in sleep?

    I mean we can also cast to the TV while it is in sleep. So its strange that this is not working.
    I am not aware of this...sorry.

    I quote you to ask, why I can't go in t.me/tclupdatesr851t and t.me/tclupdatesr51m anymore...since 2-3 days ago?
    Before no problem.
     

    cbm80

    Member
    Oct 3, 2008
    6
    0
    I am having a TCL P815, which has a "Google Home" integrated. Means the Mic is in the TV itself.
    Unfortunatly if I press the power button on my TV, I am unable to say "Okay Google" anymore.
    Is there any way, how I could use the integrated Okay Google event when the TV itself is in sleep?

    I mean we can also cast to the TV while it is in sleep. So its strange that this is not working.
    What language?
    Are you sure you have 'OK Google' reaction set in settings?
    Try to change language to any language then back to English.
     

    FaserF

    Senior Member
    Oct 23, 2014
    1,306
    2,152
    Munich
    www.youtube.com
    I quote you to ask, why I can't go in t.me/tclupdatesr851t and t.me/tclupdatesr51m anymore...since 2-3 days ago?
    Before no problem.
    I have merged the two channels into the following:
    https://t.me/tclupdates

    As it makes no sense to maintain multiple channels and groups

    What language?
    Are you sure you have 'OK Google' reaction set in settings?
    Try to change language to any language then back to English.

    I am using german. But thanks for the tip, I will try it with english.
    And yes OK Google reaction is set, as it works great while the TV is turned on.

    EDIT: Even with english its not better.
    It looks like its working some times, but only some times, not often and not good :/
     
    Last edited:
    • Like
    Reactions: stasiof

    jostken

    Member
    Mar 9, 2021
    6
    2
    Hi Guys.

    I have just attempted to change project ID on my 55C715 from 562 to 281. The results is vertical bars on the screen. I have tried to restart but to no avail. Any ideas on how to fix it.
    Any help will be greatly appreciated.

    It was originally
    Project ID: 562
    Client Type: TCL-ME-RT2851-S1
    PQ Version: EU_ID151_V1.7_2020228
     

    Attachments

    • 5d657707-9c89-4955-a407-cba9c8101b52.jpg
      5d657707-9c89-4955-a407-cba9c8101b52.jpg
      215.8 KB · Views: 33
    • 34b390ac-466f-4ae8-aab2-e1b688f97348.jpg
      34b390ac-466f-4ae8-aab2-e1b688f97348.jpg
      223 KB · Views: 33

    jostken

    Member
    Mar 9, 2021
    6
    2
    Hi Guys.

    I have just attempted to change project ID on my 55C715 from 562 to 281. The results is vertical bars on the screen. I have tried to restart but to no avail. Any ideas on how to fix it.
    Any help will be greatly appreciated.

    It was originally
    Project ID: 562
    Client Type: TCL-ME-RT2851-S1
    PQ Version: EU_ID151_V1.7_2020228

    Hi

    I used the short code 062598(Menu)281 to attempt to change the "Project ID". I hope this puts it in perspective.

    Thanks
     

    stasiof

    Senior Member
  • Oct 9, 2013
    865
    305
    Hi

    I used the short code 062598(Menu)281 to attempt to change the "Project ID". I hope this puts it in perspective.

    Thanks
    Problem is that 562 is not on the list. Seems that list is already outdated.
    I have very latest Project ID list_RT51 and...
    560....65C815K
    561....75C815K

    But no 562 and you should ask here before changing.
    Where/when you bought your TV (Middle East ?) , software version, product info pic..etc..?
    Also is very important to know "Panel Model".
    Btw,
    according to your PQ Version: EU_ID151_V1.7_2020228 ,
    I found 55C715 from Poland , but Project ID 607 (I have a pic).....

    Project ID: 607
    Client Type: TCL-EU-RT2851-S1
    PQ Version: EU_ID151_V1.7_2020228
     

    Attachments

    • Project ID list_RT51.rar
      16.8 KB · Views: 30
    Last edited:
    • Like
    Reactions: jostken

    jostken

    Member
    Mar 9, 2021
    6
    2
    Problem is that 562 is not on the list. Seems that list is already outdated.
    I have very latest Project ID list_RT51 and...
    560....65C815K
    561....75C815K

    But no 562 and you should ask here before changing.
    Where/when you bought your TV (Middle East ?) , software version, product info pic..etc..?
    Also is very important to know "Panel Model".
    Btw,
    according to your PQ Version: EU_ID151_V1.7_2020228 ,
    I found 55C715 from Poland , but Project ID 607 (I have a pic).....

    Project ID: 607
    Client Type: TCL-EU-RT2851-S1
    PQ Version: EU_ID151_V1.7_2020228

    Hi Stasiof,

    Thanks for your input and advice. The device came with TCL Apps that seem to be tailored for the Middle East with Arabic content. I wanted to change to regular English content based apps. I will try to use ADB App Control to manage the apps.

    I had seen someone say that they managed to change project ID in this thread, I decided to try.

    Thanks though
     

    EJ_the_DJ

    Member
    Nov 11, 2008
    12
    1
    New version V112.....for P815/816/818

    Hi,
    I have the following issue with this update (65P815):

    - did the Update manually with ZIP via USB (downloaded from official website)
    - update was obviously successful, TV rebooted, I checked version -> update successful
    - then I decided (like I always do with my devices after update) to do a reboot (Android-System-Settings)
    - TV tried to power down ... and stucked...

    The screen is slightly illuminated but black.

    I tried everything like powerless for a long time, every cable out e.g. ... always the same result: After power on no logo, nothing, just slightly dimming.

    So I tried to boot with the update.zip. When I plug the TV in it direct starts to dim a bit. I can't get it into deep stand-by. So I just can get in stand-by by pressing the button on the back. Then plug in the USB-Stick, press and hold power-button on the back till it's blinking. So far, so good. LED is blinking for maybe two minutes, nothing to see on the screen (still dimming), then the TV power off (complete black) and boot again to dimmed screen.

    Anyone an idea how I can force the reset/new installation to get the TV working again?

    Thanks!
    EJ
     
    Last edited:

    stasiof

    Senior Member
  • Oct 9, 2013
    865
    305
    Hi Stasiof,

    Thanks for your input and advice. The device came with TCL Apps that seem to be tailored for the Middle East with Arabic content. I wanted to change to regular English content based apps. I will try to use ADB App Control to manage the apps.

    I had seen someone say that they managed to change project ID in this thread, I decided to try.

    Thanks though
    Yup, with ADB you can disable or delete those unwanted apps.
    Yes,somebody managed to change Project ID ,but with ID which is on TCL list.
    Yours 562 is not.
    Carry on with "recovered" TV now.... :)
     
    • Like
    Reactions: jostken

    stasiof

    Senior Member
  • Oct 9, 2013
    865
    305
    Hi,
    I have the following issue with this update (65P815):

    - did the Update manually with ZIP via USB (downloaded from official website)
    - update was obviously successful, TV rebooted, I checked version -> update successful
    - then I decided (like I always do with my devices after update) to do a reboot (Android-System-Settings)
    - TV tried to power down ... and stucked...

    The screen is slightly illuminated but black.

    I tried everything like powerless for a long time, every cable out e.g. ... always the same result: After power on no logo, nothing, just slightly dimming.

    So I tried to boot with the update.zip. When I plug the TV in it direct starts to dim a bit. I can't get it into deep stand-by. So I just can get in stand-by by pressing the button on the back. Then plug in the USB-Stick, press and hold power-button on the back till it's blinking. So far, so good. LED is blinking for maybe two minutes, nothing to see on the screen (still dimming), then the TV power off (complete black) and boot again to dimmed screen.

    Anyone an idea how I can force the reset/new installation to get the TV working again?

    Thanks!
    EJ
    Try this...
    If you use a full package (IMG), then you have to copy the .img file to the USB drive, plug into the TV,
    turn it off (full off, by long pressing the power button) and turn it power back on by holding the TV's power button.
    Hold it until the bottom light starts to blink.

    1) Hold the power button on the remote control, until the power off menu shows up.
    2) Select Yes to turn off the TV.
    3) When the power LED turns off, press and hold the TV's power button.
    4) When the power LED begins to blink, release the power button.

    Btw,
    did you manage to access Service Menu?

    And V112 OTA is on official TCL web page...


    Edit:
    So , you trying update IMG file from pdf file attached bellow:
     

    Attachments

    • Software update procedure R51M-ASPV.pdf
      544.7 KB · Views: 28
    Last edited:

    EJ_the_DJ

    Member
    Nov 11, 2008
    12
    1
    Try this...
    Unfortunately I have no access to anything because the screen stays black. No TCL either Android-Logo after boot. Just slightly illuminated...
    I recognize that the TV is working, because it accesses the USB-device, but nothing more. So I don't have the option doing something with the RC. I tried the steps with the RC at black panel, but when I select "ok" I only hear a loud "bing....".
     

    stasiof

    Senior Member
  • Oct 9, 2013
    865
    305
    Unfortunately I have no access to anything because the screen stays black. No TCL either Android-Logo after boot. Just slightly illuminated...
    I recognize that the TV is working, because it accesses the USB-device, but nothing more. So I don't have the option doing something with the RC. I tried the steps with the RC at black panel, but when I select "ok" I only hear a loud "bing....".
    Power Off...unplug TV from power. When is unpluged, press and hold power button for 15-20 sec. and release.
    Place USB with IMG file (try both USB input), again hold power button and then plug back TV power....

    Edit:
    Which steps with the RC you perform and which reboot you perform after OTA update (Factory Reset or Restart in "About" section?

    Btw,
    seems got some problem with this [email protected]enisey_ru also noted on page 63.
     
    Last edited:

    EJ_the_DJ

    Member
    Nov 11, 2008
    12
    1
    Power Off...unplug TV from power. When is unpluged, press and hold power button for 15-20 sec. and release.
    Place USB with IMG file (try both USB input), again hold power button and then plug back TV power....

    Edit:
    Which steps with the RC you perform ?

    Ok, I'll have a try later.

    1st: I did the OTA-Update via USB with official TCL-Update, after update finished the tv rebooted itself (everithing worked), the I did a reboot in "About"-section: during shutdown it stucked in blackscreen

    after blackscreen:

    2nd: I tried to boot with the image you posted

    Steps RC: When TV is on I tried to get in deep standby by pressing OFF long and then OK. After OK the loud sound plays...
     
    Last edited:

    stasiof

    Senior Member
  • Oct 9, 2013
    865
    305
    I putting my TV in standby by pressing short time Off/On button on remote.
    Same about On Tv....short press. No OK button.
    As I disable "Quick Start" need to boot (restart) arround 30-35 sec to come alive.
    So every time "Up Time" in Status starting from 0 (rebooted).
     

    EJ_the_DJ

    Member
    Nov 11, 2008
    12
    1
    I putting my TV in standby by pressing short time Off/On button on remote.
    ...

    I mean this part of instruction:

    Software update method – ASPV-R51M
    Do the complete standby:
    Press and Hold the power button of the remote control (Long press for 3 seconds).
    Now TV will show the pop up menu for Power off.
    Select OK to confirm.
    Once the TV has been completely turned off, please start the below process.

    At mine Quick start is/was enabled...
     

    EJ_the_DJ

    Member
    Nov 11, 2008
    12
    1
    Power Off...unplug TV from power. When is unpluged, press and hold power button for 15-20 sec. and release.
    Place USB with IMG file (try both USB input), again hold power button and then plug back TV power....

    I tried it, same result. LED blinks, TV tries to start, but in first step no reaction (except that panel is slightly illuminated - no logo, nothing else) ... then USB gets active (have an USB with busylight) ... after a couple of minutes LED gets off, panel gets dark (like reboot) and then panel gets slightly illuminated, nothing more happens. 😫
    If I now press the "OK"-button at RC a loud "bing" sounds ... that's it.

    I think I have to wait for TCL-support...
     
    Last edited:

    VonnHansenn

    Member
    Dec 13, 2020
    30
    12
    I don't know if it makes sense to use img, because "img" and "id" have nothing in common. Or at least I don't know how img can change or fix the "id".

    This strong beep will come from the installation menu that you will see after using "img", but you do not see it.

    This way you could use the remote control and enter the code to change the ID blindly. But now that you've restored the whole TV, I don't think it will work. You will see what more experienced users will write to you :)

    Good Luck !
     
    Last edited:

    Top Liked Posts

    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone