Tesla Style Headunits

Search This thread

l33boy

Senior Member
Jul 16, 2013
199
53
Bluetooth antenna

Hi all, been a while...
I'm looking to extend the range of the BT so it picks up BT TPMS at the rear of the car, my phone picks them up but the head unit doesn't see them.
Does anyone know if the BT antenna is separate or is it using the wifi antenna.. seeing as they transmit at the same frequency.. ?
Cheers
I have the android 7.1 head unit and there is only one antenna on the back
 
Last edited:

ramathorn1982

Senior Member
Apr 21, 2015
398
53
Hi all, been a while...
I'm looking to extend the range of the BT so it picks up BT TPMS at the rear of the car, my phone picks them up but the head unit doesn't see them.
Does anyone know if the BT antenna is separate or is it using the wifi antenna.. seeing as they transmit at the same frequency.. ?
Cheers
I have the android 7.1 head unit and there is only one antenna on the back
It's separate. Here is an image of the antenna outlined in red. You can probably just solder a longer one on. InkedIMAG0226_LI.jpg

Sent from my HTC U11 using Tapatalk
 

hamkan101

New member
Oct 4, 2020
1
0
Hi Guys,

Just got a rkpx3 and need some help with how to root it and update to the latest firmware.

Its a 16 inch unit, I'm pretty noob with android so looking for some help.

Also reading about Car launcher, any one has it on this type of unit? Would like to explore that as well.

Below are the details of the unit.

MCUver - 860B_CHHWY_F142 -TD FTSP V372-2
FrameworkVer - rkpx3-eng 6.0.4 KTU84Q
OSVer - 3.0.36+
APPVer - 20191203A-Ver 1.1.0.chwy_1080_EN
Android Ver - 6.0.4

Can anyone please point in the right direction with latest android version and firmware, appreciate it.
 
Last edited:

l33boy

Senior Member
Jul 16, 2013
199
53
Hi Guys,

Just got a rkpx3 and need some help with how to root it and update to the latest firmware.

Its a 16 inch unit, I'm pretty noob with android so looking for some help.

Also reading about Car launcher, any one has it on this type of unit? Would like to explore that as well.

Below are the details of the unit.

MCUver - 860B_CHHWY_F142 -TD FTSP V372-2
FrameworkVer - rkpx3-eng 6.0.4 KTU84Q
OSVer - 3.0.36+
APPVer - 20191203A-Ver 1.1.0.chwy_1080_EN
Android Ver - 6.0.4

Can anyone please point in the right direction with latest android version and firmware, appreciate it.

Take a look here
If you can find the right resolution etc...
 

NaviPR

Senior Member
Feb 20, 2015
87
10
Hey, got a problem with a Tesla unit for a Mitsubishi Outlander. None of the installed apps show up in "Downloaded Apps", also in settings where you choose which app should be the one for navigation, the list is empty. What should I do with this?

8SfG3r4.jpg
 

mrsilently

New member
Nov 5, 2020
2
1
Help with my Ford Edge head unit

Hello, I recently purchased and installed my tesla style head unit in my 2016 Ford Edge. I was having a few issues so I did a factory reset and now the screen is black except for the top navigation icons and the bottom a/c display.

The apps are still working in the background but the black screen prevents any touch controls. I can select an app from the top menu but when it opens in the main display area I can't see or change anything. It seems like an overlay that is set to always be on top. What can I do to get my unit working again. I've contacted the seller for several days for the latest firmware with no success.

Here are the specifications that were posted by the seller:

OS: Android 9.0
Software: Rockchip PX6 (RK3399)
CPU: 1.5GHz Cortex A53 octa-core
RAM: 4GB
Flash: 32GB, support 64GB

MCUVer: RL78c_NCHHWY_F044PB
FrameworkVer: px6-userdebug 9 PQ2A.190305.002 eng.work2.20191127.155441 test-keys
OSVer: 9 Wed Nov 27 15:31:02 CST 2019
APPVer: 20191128-1920X1080-960C-Ver1.0.0.chwy-edp
Nandflash: 21.93G/32.00G
RAM: 2G/4G
BTVer: SD_carplay_I2S_191031_sdk1.3
Barcode: ZF-1803X02019114970
 

konstantinos_north

New member
Nov 9, 2020
3
0
PX6 4G internet connection issue -AOTSR Tesla Style Android 8 PX6 Car Player

Need help with internet connectivity.
AOTSR Tesla Style Android 8 PX6 Car Player For Land Rover Freelander 2 2007 - 2015
MCUver RL7A_CHUANGT9M_F038PB-SX2_DAC_IV8.6

Everything went well with installation apart from internet connection with 4G LTE. The unit has sim card slot and connects to 4g network in Europe such as Vodafone . When starting the unit I get internet connectivity for a minute or so and then it stops. All settings including APN are fine and the unit seems to be connected to network, however when launching play store or web browser there is no internet. The strange thing is that I get connection for a few seconds and then it stops. 4G signal is always ON so cell is connected.
Also all work fine through wifi connection.

So far:
1. Have tried different network sim card
2. Switched off all WiFi and other networking in case they interupt 4G connection.
3. disabled carplay connectivity - unistalled zlink for the same reason
4. Done factory reset
5. Changed 4G Module type in hidden menu (DATANG,COMMON etc)
6. Manufacture support claimed that it should work with european mobile carriers no problem.

May provide more information if needed. I have looked in forum for similar cases and have tried already a few things but without result. Any help, even where might look for possible solution is appreciated.
 

NaviPR

Senior Member
Feb 20, 2015
87
10
Hey, got a problem with a Tesla unit for a Mitsubishi Outlander. None of the installed apps show up in "Downloaded Apps", also in settings where you choose which app should be the one for navigation, the list is empty. What should I do with this?

8SfG3r4.jpg

Still need help with this.
 

CruzeRSLT

Member
Nov 12, 2020
19
0
Somewhere In USA
Hi,

How do you set KM to MPH and Celsius to Farenheight on original launcher? I have a 9213b Tesla Style for a '11-'15 Chevy Cruze. My other Cruze has settings in Perimeter CANBUS settings but this one does not. It does sound ALOT better with the 7850 amp capacitor. Gonna change that out in my other radio with the awful 7388.

I've seen videos that show you need to tap on Radio Info settings. Any help would be much appreciated!
 

raduxcata

New member
Dec 24, 2020
3
0
Hello guys. I bought 2 weeks ago this unit and installed it in my Range Rover Sport 2010. After i changed the settings i saved and reboot the system and now, none of the applications works anyone. I have the top menu, i can scroll between apps but when i touch on nothing happens. Please take a look here.

I contacted the seller and he wrote to me only after I opened a dispute...he sent me this PX6 file shorturl.at/ajFI2 and he also told me to unzip the file and put all on a usb drive.

I unzipped the files and copied them on a usb drive formatted fat32 and nothing happens (not even after reset). I also tried to put the zip file on the usb drive with various names like "update.zip" "pX6.zip" "px6_format.zip" ... none of them worked :( maybe even the zip file received from the seller is not ok.

Anyone had this problem before? any idea what i could try?

This problem ruined my Christmas...

thanks
 

Dibanoff

New member
Aug 12, 2008
4
0
Correct name of the firmware file for Android 9:
- easy update - px6-9.0.zip
- update with data cleaning (installation via reboot) - px6-9.0_format.zip

When updating with data cleaning, it is necessary to restore the Zlink, TXZ and EasyConnection applications.
 
Last edited:

raduxcata

New member
Dec 24, 2020
3
0
Everything that you do is at your own peril and risk!
I think it will be enough just to update the system.
For firmware use the file name px6-9.0.zip

Thanks for the reply!

I changed the file name to px6-9.0.zip and I connected to USB but again nothing happens. I tried to reboot it but the same. The unit has two usb cables, I tried both.

Is it necessary to do something else for the unit to boot ? do i have to press anything else?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Looking to root mine for more themes mine was only shipped with 2. Not sure which firmware to go with? I want to be on the latest firmware I can get on. Any help much appreciated

    Here's my unit info:

    You have already the most fresh firmware (april 2019). You can google about using ADB wifi to get root for your device. But You need to know theme numbers to add to customer.xml for selection. Or You can download Phoenix Radio stock firmware with unlocked themes. Also You can buy custom firmware with unlocked themes and more features.
    Make your choice :)
    3
    I've been working on my 7.1.1 HU to get it to look and work how I like it but without using 3rd party software.
    This keeps it as fast and slick as possible... boots instantly from sleep with radio or music playing before I've started the engine.
    It uses a page of the top bar for 'what's playing' and GPS speed even when using maps or whatever. You can still scroll left<>right to bring up the shortcut icons as normal.
    Also changed the Radio to show the station name in large rather than frequency (which is now in the top bar)
    Big thanks to ShIvADeSt for the help on the top bar programming :good::good:
    3
    For completeness, I'll show you the images ive changed on my unit, and list the mods done so far.

    1) Changed the stereos 'boot screen' to the attached BootScreen.jpg
    2) Changed the stereos 'home screen logo' to the attached ZXWLOGO.png
    3) Modified EventCenter.apk to fix multiple typos and spelling/grammar mistakes
    4) Modified MusicPlayer.apk to remove 'Lyrics', make a single colour, fix some spelling/grammar mistakes, enlarge font sizes, change font colours, change player control buttons and their positions
    5) Currently trying to work on editing the TPMS app, but having issues when trying to install/update it after the mods.


    PS: If you want to have a go at the modded MusicPlayer, you can checkout the git repo I setup, and build it using apktool

    https://bitbucket.org/wishie/musicplayer-tesla-style-android-car-stereo/src/master/
    3
    where is this option?

    There is no such option. Need root and manually change some files.
    2
    There are some small updates.

    First: Rooting via Kingroot is possible.

    Second: I've managed to get the SystemApps and found the Bundle ID's com.choiceway for the launcher and com.szchoiceway for other apps like radio. But google it, did not bring any results :mad:
    Further I was able to decompile the settings APK and extract all factory Pin codes. For now, I won't post it public, to keep the risk that the manufacturer maybe changes them, as low as possible. But if you are interested in them, you can PM me anytime. If interest is increasing, I will post them here of course.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone