Search This thread

bally12345

Member
May 1, 2018
8
6
Hey all! Just wanted to add my experience so far! Orderd in September and was delivered on time and and well packed. Got the CC3 with rear cam, dvr, canbus, obd2 and surround fasica for a 2019 Mercedes Vito.

Have to say the install was super quick and easy and everything seems to just work. There are a few small niggles eg obd doesn't always connect and can't find easy way to change boot logo as option is greyed out.

Steering controls worked out the box with no tweaking needed! Pretty much plug and play for me. Removed yandex apps, don't like the voice controls but 4 weeks in and it all pretty much works.

Got Netflix for apk site and in UK Sky Go even works which is added bonus.
 

spoonzz666

Member
Oct 24, 2022
18
3
Just got my teyes cc3 for my 2016 RAV4 gxl. Very easy install and my steering wheel wasn't working but turns out I was using the wrong can bus settings but I'm not sure if I'm using the right one still! I have rcz(l) selected. Can anyone let me know what the rcz(m) variant is?

I have two issues (only number 2 is a real issue).

1. I miss is the beep my car makes when I lock/unlock my car. That seems to be no more :(. I'm unable to find it in the vehicle settings as well. I have to settle for indicator lights as feedback.

2. Internet does not work via Bluetooth even though I have it enabled on my phone (google pixel 6 pro). It looks like I need to buy a sim for my teyes head unit or exclusively use android auto as internet through that works.

anyone else own a RAV4 2016-2018 and have the same Bluetooth issue?
 

spoonzz666

Member
Oct 24, 2022
18
3
Thanks. I may just do that. I guess I'll figure out the problems myself.

Only left is that steering wheel buttons work fine, I just can't remap them.
 

jaydubbs

Senior Member
Mar 25, 2011
692
330
Newton
Just got my teyes cc3 for my 2016 RAV4 gxl. Very easy install and my steering wheel wasn't working but turns out I was using the wrong can bus settings but I'm not sure if I'm using the right one still! I have rcz(l) selected. Can anyone let me know what the rcz(m) variant is?

I have two issues (only number 2 is a real issue).

1. I miss is the beep my car makes when I lock/unlock my car. That seems to be no more :(. I'm unable to find it in the vehicle settings as well. I have to settle for indicator lights as feedback.

2. Internet does not work via Bluetooth even though I have it enabled on my phone (google pixel 6 pro). It looks like I need to buy a sim for my teyes head unit or exclusively use android auto as internet through that works.

anyone else own a RAV4 2016-2018 and have the same Bluetooth issue?
For #2 I'm using this app from the Play store, https://play.google.com/store/apps/details?id=de.christian_heinisch.hotspot.enablehotspot, that kicks on your phones hotspot when it's connected to the units Bluetooth. Hasn't let me down yet.
 
  • Like
Reactions: spoonzz666

Rookie23

Member
Sep 20, 2021
23
1
I have a CC3 purchased around June 2021 which is running firmware from late April 21.
I am considering upgrading the firmware to the latest October release hoping it may be a bit better but I also do not want to create a headache for myself either. I assume anything already not Teyes installed and working will not be touched.

Any thoughts on whether upgrading CC3 firmware is likely to be a good idea or not?
 

spoonzz666

Member
Oct 24, 2022
18
3
Unfortunately not available on the Australian Play Store
I had to get the APK from apkpure and you should be good to go.

I have a CC3 purchased around June 2021 which is running firmware from late April 21.
I am considering upgrading the firmware to the latest October release hoping it may be a bit better but I also do not want to create a headache for myself either. I assume anything already not Teyes installed and working will not be touched.

Any thoughts on whether upgrading CC3 firmware is likely to be a good idea or not?

If everything is fine I wouldn't bother upgrading. I had the issue of the 3d model of the car not rendering in the 360 panorama app so I thought I'd update but I still have the same issue. It works when in reverse though.
 
  • Like
Reactions: Rookie23

Rookie23

Member
Sep 20, 2021
23
1
Works beautifully. Thanks 😃😃
Thanks got this installed and working by manually starting the app after I have turned on the ignition and phone has a BT connection to CC3, I do the same after ignition off and BT to CC3 has disconnected. Its definitely an improvement :)

Should this be working automatically or is there a way to automate it so i don't have to remember to do it each time? The BT disconnect is maybe more important than the BT connect and I would like my Hotspot off and Wifi on after leaving the vehicle.
 

spoonzz666

Member
Oct 24, 2022
18
3
Thanks got this installed and working by manually starting the app after I have turned on the ignition and phone has a BT connection to CC3, I do the same after ignition off and BT to CC3 has disconnected. Its definitely an improvement :)

Should this be working automatically or is there a way to automate it so i don't have to remember to do it each time? The BT disconnect is maybe more important than the BT connect and I would like my Hotspot off and Wifi on after leaving the vehicle.
Do you have the "Hotspot Automatic" option enabled in the app? I have that and also the notification bar setting enabled as well.
 

Aussie Dave

Member
Mar 7, 2014
20
1
@TEYESAustralia

When i do the FOTA it said I'm up to date with my software, but on the website it say's "Latest version time:20.10.2022"

My CC3 say's Version date :15.01.2022, am i reading it right?

Thank you
 

Attachments

  • 20221117_125936.jpg
    20221117_125936.jpg
    2.4 MB · Views: 19

FlowersByIrene

New member
Sep 25, 2022
2
0
Anyone else got issue with Google maps not switching to dark mode automatically at night?
Yes I've been having this issue too. Trying to find out if there's a setting in Google Maps for day/night mode, thought there was one. Just tonight I was using maps, and when I switched my headlights on, the map didn't change to dark mode. I had to make a stop and shut my car off for a few minutes, then when I got back and started up it was in dark mode, so I was thinking maybe it was based on sunrise/sunset times changing automatically rather than using my illumination signal from the headlights being on. I'll try to remember to report back if I find out any more.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Ok, so I just solved a massive headache with my teyes CC3 audio. And I will explain how and what. It concerns not working rear speakers. The worst part is that Teyes has no instructions AT ALL for the A3/A4 and I had to either figure this out on my own or with the help of people here on the forum or a bit of help of the teyes technical support which cost me about a week. However I want to enable people to have a smooth install with their A3 as the headunit itsself is fantastic and seriously worth the money.

    To start first the (overall very few) issues I had with it and how to solve them (also link to a video I made about all but #1 at the end):

    1. The frame of the A3 being to small

    The actual frame fits exactly into the gap that the OEM radio you take out leaves behind. The issue is the tabs that are supposed to hold it in place. They are too widely moldel. What I mean is that they are molded in such a way that they are wider than is needed to make them fit. As such it is a PAIN to get them in.

    A big tip I can give is the 3 first then 1 method. Get the bottom 2 in by pressing on them and then 1 of the 2 top ones. Or one side in and then pry the other 2 in. But the last one will be VERY hard to press in and I highly reccomend a interior trim removal kit tool to press it with to the inside. It will help give you leverage.

    3 will click into place and the last one will be ehhhh kind of in there but if you press it in it should sit flush. I can say from experience you can expect that 1 of the 2 top tabs will slightly break away from the main mold but it should hold.

    now big thing. DO NOT SCREW THE CC3 INTO THE FRAME. You can but removing it will be extremely hard as the frame will sit 100% flush with the dash and even getting a prying tool into 1 of the corners is next to impossible.
    Ideally, get the frame in first, THEN do the wiring. and press the unit in afterwards. One thing that helps remove it is if you attach a sort of tab with tape or glue that will stick out (tape maybe is the easiest?) so you can use it as a pull cord and pull the unit out that way.

    2. The unit not powering on at all (also explained in the video).

    So this is one is a headbreaker and I almost thought I needed to ship the unit back.
    I installed the unit and connected all the wires as they should be (based on other videos) but nothing after I powered on the car. Optical out on the back however did light up for a bit and then went blank.

    The issue was as following. On the main cable harnass you get there are 2 boxes that lead to a. the CANBUS box connector and b. The main power/connector that goes into the G slot on the diagram.

    The harnass for the A3 8p has 2!!!! boxes where it begins. A " quadlock" that will fit on the 8p" and a different one that will NOT fit.

    Now it seems that from factor they connect the ACCESORY wire, which in my case was orange (look up the diagram supplied with the unit to see which cable it should be), to the connection box that will NOT FIT. So you have an empty box like connector that has many wires on of which was orange with a 2 pin connector. There is an IDENTICAL but loose wire with 2 pins on the quadlock connector. You need to UNPLUG the accesory cable from that wrong harnass and connect it to the wire that runs to the quadlock connector. That will make the unit turn on and work.

    3. NON WORKING REAR SPEAKERS (NON BOSE)

    So this has been posted many many times on many forums but there has been no consise solution explained so I will attempt my best.

    If you get the CC3 unit and connect all the wires you need to choose 1 of 2 extra cables included. One has the mic connector, sim card tray, AMP-C wire and the AUX L and R connectors. the other is Some fo those but mostly RCA cables. But for both it works the same.

    First of all, and this is NOT EXPLAINED AT ALL ANYWHERE, you need to take the AMP cable (blue and white) that comes off the quadlock AND ISO connector (they are joined together in the factory AND HAVE A SEETHROUGH BLUE CAP ON THE END) and connect it to the AMP-C cable (solid blue) coming off the second set of wires you plug in.

    The issue is that you need to strip the isolation of both ends and then twist the exposed leads together to get the front amplifier to work at all...... then once that is done you use electrical tape to secure and insulate it. Now the front amp will work. The front speakers will with either the cables connected or not.

    Now onto the rear speakers. Teyes has only now after I and other mailed them started selling an extra harness that you need to make the rear ones and sub work. The A3 and A4 are half amplified cars. This means that the headunit is supposed to also provide power and a turn on signal to the rear amp that is built into the speakers.

    However, the unit does not have enough power to do that on its own. Its impedance is too low. You need the following harness it will not work without : https://teyes.eu/products/special-p...t?shpxid=020fa858-1cb9-4173-964f-bcd43d2a8198

    61vwriFZ6aL._AC_SL1500_1024x1024@2x.jpg



    This harness goes in between the original quadlock of the car and the quadlock connector of the CC3 unit. it changes the impedance of the speakers and makes it so the unit has enough power to power the rear amp and speakers.

    This harness is also sold by XTRONS under a different name. Look around and you will find it.

    A tip I can give is that you may need to adjust the amount of impedance by using a small flathead screwdriver to turn the 4 knobs in the transparent cases (see pic below). You need to have it all plugged in and working to hear (you need to listen to the audio) but if they are set too much to 1 of the 2 sides (I think clockwise?) The harness wont work and the amps are silent. Completely the other way and the amps work and the sound is of good loudness.



    View attachment 5821291

    I hope this helps at least 1 person and saves them from the heart attacks and stress this caused me.

    Here is a link to my video explaining this post:
    2
    The green square problem is a bug in the new firmware.
    Not sure about the red square problem. I thought there was a setting in older firmware for this. (edit) Old firmware set in general - back-light control.
    Problem is you cannot roll back to previous software so any bugs like this, we as users get stuck with. Just another bad decision by Teyes to lock down their firmware and not give a stuff about their users.
    In settings, the button backlight on my unit had reverted to "time based" instead of linked to headlight control. Changed this and that issue was fixed. Had not noticed this at first.
    2
    cryptyk said:
    Do you have an ETA on the CC3 360 firmware?

    see here CC3 2K firmware

    We know you you will do anything to advertise your products but at least answer the question asked.
    2
    Hmm very interesting. I have not. And how would I know which wire this is? and where does it connect to? This might indeed be the issue.
    This has been posted about so many times.

    Sellers sell with poor quality control and buyers self install, get into trouble then quick to post.

    If unable to make basic checks, suggest consulting reputable local installer.
    1
    @TEYESAustralia

    Updated to the Version date :06.01.2023
    But now the side buttons don't light up (Red Square) and also how do i add apps the the Application section (Green Square).
    Thanks for your help.


    View attachment 5809159
    The green square problem is a bug in the new firmware.
    Not sure about the red square problem. I thought there was a setting in older firmware for this. (edit) Old firmware set in general - back-light control.
  • 9
    The OP had a discussion with us and it was decided that he will not be permitted to sell here but offer technical support only. So anything connected to prices, comparisons with other units/manufacturers etc will be outside the understanding.

    Guys, why don't we take him at face value and see whether he is offering support or not? I agree that the reputation of resellers has taken a beating but why don't we give him a chance? Even if he is able to resolve some issues of atleast some users, his being on XDA would be justified.

    I hope you all understand that it was in the interest of the users that it was decided to permit him to operate here.

    Moderator Announcement

    This is a thread regarding technical support or solving of technical problems ONLY! No references to sales, prices, comparisons, orders, consumer rights etc. are accepted and off-topic in this thread. The thread has been cleaned in this respect.

    @TEYESAustralia Even if users raise questions on those issues, I'd appreciate if YOU tell them that no such information will be provided in the thread.

    Regards
    Oswald Boelcke
    Senior Moderator
    Moderator Announcement

    This thread has been cleaned already multiple times - and I just did it again! The scope of this thread has been clearly defined and announced. If somebody doesn't like these left and right arcs or the thread, please just move on without posting. I've also removed (hopefully) all links and references to a specific Russian phone related website (not affiliated with XDA at all), other social media and commercial websites. XDA is not just another social media; it's a privately owned website that runs based on its own Forum Rules implemented by the site owners. If someone is unhappy with the rules, please contact the site owner or administrators. If you're unable to accept a thread's existence, please just report the thread or contact any moderator privately but don't post your disagreement in a thread.

    I've now subscribed to this thread and will monitor it closely. I reserve the right to temporarily or permanently revoke write permissions in this thread from any poster whose post is not in line with the forum rules and the above quoted guidance.

    Regards
    Oswald Boelcke
    Senior Moderator

    I have not had a problem with google login, please contact me in PM to discuss

    The market has moved towards completely buttonless, looks alot better too. In regards to you subaru, contact me in PM to discuss.
    thank you

    Hello, please send me a DM with a picture of your dash and confirm model year.

    Thank you

    Can you send some links to my inbox to these reviews for the issues you state for the Honda accord euro 8?

    gremlin190 and ejacobs, in regards to this issue, please provide your whatsapp numbers in PM

    Thank you

    Hello we need to speak to engineer regarding this issue, I believe we spoke on another mode. If your having trouble getting in contact pass me your whatsapp number in private.

    sorry for the late response


    Hello sorry this is not monitored, best way is by email and phone. Sometimes we get to busy and myself have been unwell for weeks but now recovering.
    Email me so I have your contact
    It is found on our website, there is one other dealing with similar issue to yours. thank you

    You may need a forced firmware reset
    contact
    @TEYESAustralia Please provide your support here in the thread and refrain from attempts to drag members to whatever private means. Only public support helps all XDA members. A thread that doesn't provide this public support is eventually going to be closed.
    I've removed every link I found to your commercial website. Please don't use it in this thread.
    7
    Can we have an admin corroborate if this is true? We don't need the details of what was talked about, just whether the above is true. Also, I found a picture of the Teyes engineering team discussing all mentioned software issues.
    View attachment 5246243
    The OP had a discussion with us and it was decided that he will not be permitted to sell here but offer technical support only. So anything connected to prices, comparisons with other units/manufacturers etc will be outside the understanding.

    Guys, why don't we take him at face value and see whether he is offering support or not? I agree that the reputation of resellers has taken a beating but why don't we give him a chance? Even if he is able to resolve some issues of atleast some users, his being on XDA would be justified.

    I hope you all understand that it was in the interest of the users that it was decided to permit him to operate here.
    6
    Hello all, TEYES Australia is now online. The audience is not just Australia but a more western audience.

    XDA members are thorough in their questions and suggestions. Any value adding advice for the site would be greatly appreciated.

    Trolls, attacks and off topic commentary will be removed to keep this thread precise and on point for those looking for information.

    This thread is not for urgent enquiries that need fast responses. If you have an order number you can contact us directly, if not we will reply in time in here when our schedule permits

    Thank you all!
    5
    MOD ACTION:

    Thread cleaned.

    I have said this before and I will say it again.

    This thread is allowed for tech support of the products. Any post not relevant to that is off topic and will be removed.

    Next time it happens, there may be harsher reactions because we can't be simply cleaning threads of off topic posts.

    And once anyone reports a post as violative of the Rules, please stop responding to that post in the thread. If you do not, it becomes difficult to identify the offender and initiate action.

    Please cooperate so that all the users have a pleasant experience here.

    Thank you.
    4
    {Mod edit: Quoted post has been deleted}

    I'm an Australian buyer who has just purchased and received a CC3 through Teyes Australia. I sent Dan from Teyes Australia numerous emails with questions and he always answered within hours. I never expected that he would stock in Australia the thousands of possible wiring and facia kits. His contact details and phone number are all over the Teyes Aus website.

    One of the main concerns I had was the facia for my 2017 Kia Soul. There are two available and the one for the Australian spec Soul showed two extra cutouts that I didn't need. He was straight onto the supplier/warehouse in China to check the stock and had a photo of my facia back that very evening. It was perfect.

    There are two possible radios in the series 2 Soul and two possible wiring plugs. The kit was delivered with both possible plugs which made basic install really easy.

    I am going to chase Dan up with a couple of improvement requests. I hope that with his contacts back in China that he might be able to get a result.
    - the ability to export video files from the dashcam DVR to the hard drive or a USB stick
    - how do I get Australian radio icons added to the radio unit. It appears to be based on gps coordinates. Do I specify Sydney NSW, or my specific outer suburb location. ?

    My overall impression of Dan from Teyes is 5 out of 5. The local logistics company they use only gets a 2 out of 5. It sat in limbo in Australia for nearly 2 weeks before being delivered. Their website said they attempted delivery once but I was home all day and they didn't. When it finally turned up it was in a small sedan hatch packed to the roof with boxes. Not at all professional.

    My thoughts on the CC3 ? It is excellent. It looks fantastic in my Soul and a vast improvement. Everything works well. I modified the wiring to use my existing 6 volt rear view camera but the resolution looks pretty [email protected] on the high res screen. My next project might be to retrofit the new camera to the existing moulding in the rear hatch.