Question Teyes cc3 360 on prado 150 no steering wheel buttons working

Search This thread

nenethern

New member
Dec 9, 2022
4
0
Hi installed with most of the functions working. But i have no button working on steering wheel.

The harness, called configuration A, here , doesn't have a connector for canbus box. I don't know if canbus box is a must for the buttons to work.
IMG-20221125-WA0002.jpg

My previous head unit the cc3 replaces had a canbus box on it and the buttons worked on that unit.

I don't know if that is a design flaw? or cc3 doesn't support the buttons on prado 150? or what? I can't find any information on the internet. @TEYESAustralia ? or someone has experience? Help please.
 
Hai diinstal dengan sebagian besar fungsi berfungsi. Tapi saya tidak punya tombol yang berfungsi di setir.

Harness, yang disebut konfigurasi A, di sini , tidak memiliki konektor untuk kotak canbus. Saya tidak tahu apakah kotak canbus adalah suatu keharusan agar tombol berfungsi.
View attachment 5780885
Unit kepala saya sebelumnya yang diganti dengan cc3 memiliki kotak canbus di atasnya dan tombol-tombolnya berfungsi di unit itu.

Saya tidak tahu apakah itu cacat desain? atau cc3 tidak mendukung tombol di prado 150? atau apa? Saya tidak dapat menemukan informasi apa pun di internet. @TEYESAustralia ? atau ada yang punya pengalaman? Tolonglah.
ssetting manually .. enter the control menu then follow the steps
 

nethernbing

New member
Sep 2, 2014
2
1
Ok I finally fixed it! Here is what I did in case someone had same issue. It is partially my stupid-ness. For 2010 prado 150 gxl, there is no need of a canbus decoder box.

1. There is one flat plug, one of the two as shown in the photo above, I did not plug. Apparently it is important for the key information
2. in the "canbus setting" menu where you configure the make and model of you canbus. Needs to set to "NULL". I was fiddle with it before.
3. in the "Steering wheel button learning" in system menu, configure the button as instructed by the teyes instruction video. When entering this menu, if the previous two steps were done, numbers of 255 on top of each button config, would flicks, like changes to 254 for a blink of eyes then back to 255. Then you know the buttons are responsive now and the button learning will work.
 
  • Like
Reactions: TEYESAustralia

TEYESAustralia

Senior Member
Feb 28, 2021
118
28
Australia
www.teyes.com.au
Hi installed with most of the functions working. But i have no button working on steering wheel.

The harness, called configuration A, here , doesn't have a connector for canbus box. I don't know if canbus box is a must for the buttons to work.
View attachment 5780885
My previous head unit the cc3 replaces had a canbus box on it and the buttons worked on that unit.

I don't know if that is a design flaw? or cc3 doesn't support the buttons on prado 150? or what? I can't find any information on the internet. @TEYESAustralia ? or someone has experience? Help please.
Good job - you mentioned the Video 19 as a guide for setup Analogue Controls Mapping
 
Last edited:

marchnz

Senior Member
Nov 26, 2012
5,362
1,170
NZ
Ok I finally fixed it! Here is what I did in case someone had same issue. It is partially my stupid-ness. For 2010 prado 150 gxl, there is no need of a canbus decoder box.

1. There is one flat plug, one of the two as shown in the photo above, I did not plug. Apparently it is important for the key information
2. in the "canbus setting" menu where you configure the make and model of you canbus. Needs to set to "NULL". I was fiddle with it before.

The key and missing information from the first post. Seems all too common people leave out key information, which results in multiple posts of guessing - as can be seen here

3. in the "Steering wheel button learning" in system menu, configure the button as instructed by the teyes instruction video. When entering this menu, if the previous two steps were done, numbers of 255 on top of each button config, would flicks, like changes to 254 for a blink of eyes then back to 255. Then you know the buttons are responsive now and the button learning will work.

So the standard, non-canbus installation.

The short of this thread is - find an experienced installer to assist if unsure how to install or inexperienced.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Ok I finally fixed it! Here is what I did in case someone had same issue. It is partially my stupid-ness. For 2010 prado 150 gxl, there is no need of a canbus decoder box.

    1. There is one flat plug, one of the two as shown in the photo above, I did not plug. Apparently it is important for the key information
    2. in the "canbus setting" menu where you configure the make and model of you canbus. Needs to set to "NULL". I was fiddle with it before.
    3. in the "Steering wheel button learning" in system menu, configure the button as instructed by the teyes instruction video. When entering this menu, if the previous two steps were done, numbers of 255 on top of each button config, would flicks, like changes to 254 for a blink of eyes then back to 255. Then you know the buttons are responsive now and the button learning will work.
    1
    S All Toyota cars use a remote steering system using impedance which can be adjusted manually.