Hardware Development TEYES CC3

Search This thread

Gunde

Senior Member
Jul 12, 2007
284
92
I just installed the CC3 360 (from teyes.com.au) and I'm having a few issues. Most of them I can fix, I think, but the worst one I can't live without, so I could use some help. I've tried searching through this thread and Google but haven't found anything concrete.

It's regarding steering wheel buttons not working at all. Weird thing is that everything else CAN related works fine; climate control, door status, 360 camera activation, wheel posistion, etc. But steering wheel buttons are dead. I really want at least volume up/down to work.

So what's the recommendation? Try a firmware upgrade (eg. Gordgelin), buy a bunch of different CANBUS decoders? Anything else?

Currently the unit is on 03.10.2022 firmware.

Thanks.
Oh my God. There's a whole separate harness that plugs into the steering wheel plug with one wire going back to the CANbus decoder. I completely overlooked that. Doh!

All works perfectly now.
 

L22EEW

Senior Member
Mar 13, 2008
1,139
250
Wales
www.facebook.com
Any clue why the parking sensor sonar won't appear on my CC3?
When I put the car in reverse I get a black image with the grid to park like it wants to start up the camera (which I don't have), but no sonar. In the bottom right.

Did you manage to sort this? If so, can you please share which sub menu is the option hidden in? As I have looked but don't immediately see the option.

Many thanks.
 

aussie2802

Member
Oct 16, 2010
7
3
I can only get wireless carplay to work. Wired carplay Carlink 2.0 refuses to recognize my devices. Ive tried two different iphones, several cables. USB will charge, but Carlink refuses to see it. USB port and connection to CC3 are fine as I can put in a USB stick and update firmware and use file manager to transfer files to the unit. Any idea why wired carplay isnt working?
Hi there have you solved the issue with carplay? I got hung up on that but all you need to do is tether your mobile phone to CC3. Easy 5 second job and you get full direct functionality with Apple just like you do on your phone. It's much better then carplay. Try that.
 
Last edited:

aussie2802

Member
Oct 16, 2010
7
3
I have some problem with the RCA sound to my amplifilter. When I not playing anything I can here some poppinng sound, like it´s some kind of interference. Then I remove the rca connection to my amp it disapear. Has the CC3 bad ground maybe?
Old thread but for others ground your CC3 and your Amp at the same place. It's not a CC3 thing but a general audio thing that occurs occasionally. This should fix it.
 

Gunde

Senior Member
Jul 12, 2007
284
92
Also available now at www.teyes.com.

Now that I have it installed and all issues are solved, I'm very happy with the unit. It's a quality product.
Therefore I'm hesitant to update ... what will it break? :)
 

alfiabraham

Senior Member
Apr 17, 2012
92
50
Chennai
4BAEC910-E056-4BFD-9D56-36B5D4B0C50C.jpeg
I did a factory reset of my Teyes CC3 (32GB + 3GB) yesterday and after there is no space to download any file in the system. Looks like the 32GB internal storage isn't mounted. Please HELP!

Also how to see device storage option.
 

ahmed123

Senior Member
Jan 14, 2006
66
3
I'm hoping someone can advise. I have a Teyes CC3 head unit installed and originally it was working very well. Then all of a sudden one of the days it completely got messed up where it just kept rebooting while i'm using it every few minutes. It made the unit completely unusable. So I spoke to Teyes and they told me to upgrade to new system update 18 July 2022 which apparently solved automatic reboots due to voltage fluctuations. I restored it and updated from USB and then for a good few days worked very well and I drove for over 6 hours on two different days and it worked well. Then all of a sudden i went to start the car one day after parking it few hours before. Usually it's supposed to just wake-up from sleep but i noticed it's rebooting. So I just ignored it as I thought that's odd because a restart should only happen if teyes has been sleeping for few days. The next day the problem of the unit restarting every few minutes returned and was really annoying.

That night I thought of something that was in common about the two times. The last time this problem happened, the day before I had been watching the Teyes Vision App and the following day was when the problems started. This time was same, I watched the Teyes Vision app the day before and problem returned the next day. So I thought i'd remove the teyes vision app from the home screen and i also remembered that I had a USB key plugged in that had some APK's. So I unplugged the USB too. And in factory settings I noticed a USB Error Detection which was on, so i turned that off too. And since then the following day until now the problem has not returned.

So I am a little baffled as the exactly what is wrong with this kit.

Can anyone help or offer any advice please?

Also, worth mentioning I have deelife TPMS app running with the deelife tpms internal sensors. They seem to run fine. In hindsight I should have got the Teyes internal tpms but I already had deelife on my wheels from my previous head unit so changing the internal tpms wasn't really an option. Might consider it when my tyres need changing

Thank you
 
Last edited:

Gunde

Senior Member
Jul 12, 2007
284
92
Can it really be true, that there's no true system-wide dark mode on this unit? Yes, display dims a bit at night, but apps that switch to dark mode automatically with the system, remain white and Google Maps don't even have a dark mode ...
 

rooy

Member
Dec 20, 2012
21
0
Hello im new and i want to buy teyes cc3 ..
anyone know how many Volt preout have the cc3?
THANKS!
 

lunacies

Member
Jul 14, 2016
34
9
I purchased one of these units but have been having issues getting it installed and up and running and waiting on a new harness to come in from Teyes thinking that is the issue.

I was curious though, as I have no experience with Android Auto, is I guess what apps work with this unit? If I am using Android Auto but use Youtube sometimes to play a podcast, but lock the screen and leave the phone in my seat, will that still play through on android auto or does it disable apps like Youtube from working? Would the results be any different using "Youtube Vanced" rather than the official app?

Alternatively, can I install Youtube directly on the head unit and use it while driving (outside of android auto)? Obviously I am not talking about actually watching videos while driving but some podcasts I listen to I typically have always pulled up through youtube in the past.

Also, I also see people posting their home screens on this and I always see spotify featured as the music app. Is Spotify strictly the only app that can be used or put right on the head unit and widgets etc. or if I use something like Deezer, can I replace spotify with that?
 

rooy

Member
Dec 20, 2012
21
0
Anyone here have an oscilloscope to test what volume the sub preout clips at on the CC3? Have one ordered and on the way soon. Not sure I want to order one for a single install, so hoping someone here has one and could test or has already tested?
hello did u test it ? can u share results ?
noone here will answer :/
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Ok, so I just solved a massive headache with my teyes CC3 audio. And I will explain how and what. It concerns not working rear speakers. The worst part is that Teyes has no instructions AT ALL for the A3/A4 and I had to either figure this out on my own or with the help of people here on the forum or a bit of help of the teyes technical support which cost me about a week. However I want to enable people to have a smooth install with their A3 as the headunit itsself is fantastic and seriously worth the money.

    To start first the (overall very few) issues I had with it and how to solve them (also link to a video I made about all but #1 at the end):

    1. The frame of the A3 being to small

    The actual frame fits exactly into the gap that the OEM radio you take out leaves behind. The issue is the tabs that are supposed to hold it in place. They are too widely moldel. What I mean is that they are molded in such a way that they are wider than is needed to make them fit. As such it is a PAIN to get them in.

    A big tip I can give is the 3 first then 1 method. Get the bottom 2 in by pressing on them and then 1 of the 2 top ones. Or one side in and then pry the other 2 in. But the last one will be VERY hard to press in and I highly reccomend a interior trim removal kit tool to press it with to the inside. It will help give you leverage.

    3 will click into place and the last one will be ehhhh kind of in there but if you press it in it should sit flush. I can say from experience you can expect that 1 of the 2 top tabs will slightly break away from the main mold but it should hold.

    now big thing. DO NOT SCREW THE CC3 INTO THE FRAME. You can but removing it will be extremely hard as the frame will sit 100% flush with the dash and even getting a prying tool into 1 of the corners is next to impossible.
    Ideally, get the frame in first, THEN do the wiring. and press the unit in afterwards. One thing that helps remove it is if you attach a sort of tab with tape or glue that will stick out (tape maybe is the easiest?) so you can use it as a pull cord and pull the unit out that way.

    2. The unit not powering on at all (also explained in the video).

    So this is one is a headbreaker and I almost thought I needed to ship the unit back.
    I installed the unit and connected all the wires as they should be (based on other videos) but nothing after I powered on the car. Optical out on the back however did light up for a bit and then went blank.

    The issue was as following. On the main cable harnass you get there are 2 boxes that lead to a. the CANBUS box connector and b. The main power/connector that goes into the G slot on the diagram.

    The harnass for the A3 8p has 2!!!! boxes where it begins. A " quadlock" that will fit on the 8p" and a different one that will NOT fit.

    Now it seems that from factor they connect the ACCESORY wire, which in my case was orange (look up the diagram supplied with the unit to see which cable it should be), to the connection box that will NOT FIT. So you have an empty box like connector that has many wires on of which was orange with a 2 pin connector. There is an IDENTICAL but loose wire with 2 pins on the quadlock connector. You need to UNPLUG the accesory cable from that wrong harnass and connect it to the wire that runs to the quadlock connector. That will make the unit turn on and work.

    3. NON WORKING REAR SPEAKERS (NON BOSE)

    So this has been posted many many times on many forums but there has been no consise solution explained so I will attempt my best.

    If you get the CC3 unit and connect all the wires you need to choose 1 of 2 extra cables included. One has the mic connector, sim card tray, AMP-C wire and the AUX L and R connectors. the other is Some fo those but mostly RCA cables. But for both it works the same.

    First of all, and this is NOT EXPLAINED AT ALL ANYWHERE, you need to take the AMP cable (blue and white) that comes off the quadlock AND ISO connector (they are joined together in the factory AND HAVE A SEETHROUGH BLUE CAP ON THE END) and connect it to the AMP-C cable (solid blue) coming off the second set of wires you plug in.

    The issue is that you need to strip the isolation of both ends and then twist the exposed leads together to get the front amplifier to work at all...... then once that is done you use electrical tape to secure and insulate it. Now the front amp will work. The front speakers will with either the cables connected or not.

    Now onto the rear speakers. Teyes has only now after I and other mailed them started selling an extra harness that you need to make the rear ones and sub work. The A3 and A4 are half amplified cars. This means that the headunit is supposed to also provide power and a turn on signal to the rear amp that is built into the speakers.

    However, the unit does not have enough power to do that on its own. Its impedance is too low. You need the following harness it will not work without : https://teyes.eu/products/special-p...t?shpxid=020fa858-1cb9-4173-964f-bcd43d2a8198

    61vwriFZ6aL._AC_SL1500_1024x1024@2x.jpg



    This harness goes in between the original quadlock of the car and the quadlock connector of the CC3 unit. it changes the impedance of the speakers and makes it so the unit has enough power to power the rear amp and speakers.

    This harness is also sold by XTRONS under a different name. Look around and you will find it.

    A tip I can give is that you may need to adjust the amount of impedance by using a small flathead screwdriver to turn the 4 knobs in the transparent cases (see pic below). You need to have it all plugged in and working to hear (you need to listen to the audio) but if they are set too much to 1 of the 2 sides (I think clockwise?) The harness wont work and the amps are silent. Completely the other way and the amps work and the sound is of good loudness.



    1674850219583.png


    I hope this helps at least 1 person and saves them from the heart attacks and stress this caused me.

    Here is a link to my video explaining this post:
    2
    It's there. It's called Power Conditioning.
    The sound adjustment parameters are found in these three tables
    1
    i dont even know how i can get it to stick somewhere outside of the car. When you mean outside you actually mean outside in the air?
    Yes, placed on the roof, or elsewhere, possibly with adhesive temporarily, passing the cable through a window, static, or a short trip (only test recess)
    1
    Hello Guys!

    I recently bought CC3 and have a few problems, hope You guys can help.

    1. Different bugs with Navigation apps
    Every Navigation app I set on my home screen is broken

    Waze let me search but only generates routes for my saved addresses, when I select the one I searched for it does nothing
    Google Maps gives top view without directions, speedometer etc.
    HERE WeGo when opened the smaller windows is on top of the full screen view of app

    This is a bug with the home screen launcher window.

    Waze (or any other navi app) will work perfectly if you do not set it as the launcher app.
    1
    There is no difference between firmware downloaded from RU and downloaded from EN?
    I am asking because the file being downloaded has either EN or RU in its name, depending on which region is selected on the website.
    Yesterday I made the upgrade with the RU file, but all text in the setup was in English, the Unit stayed on english, my keyboard stayed English (also kept my native language). :)
  • 7
    Teyes announced another CC3 update for April 2021, here is the translated changelog.



    The following important updates are expected to be released for the CC3 software at the end of April.
    The new version will add the following features:

    1.Added Cam REC software. With this application, you can record from a rear view camera. The recording files are saved to a flash card.

    2.Added TEYES YAHU, the world's first 3D music player for the automotive industry (due to technical complexity, work may not be completed in April).

    3.In the device settings, a function has been added to change the screen brightness depending on the time of sunrise and sunset.

    4.The system version has been updated. Fixed the issue of crashing the Google Play app in some areas.

    5.Added setting for the sensitivity level of voice commands. If you feel that certain keywords easily trigger voice commands, you can lower the sensitivity level. In addition to Russian and English, a voice control function has been added for 7 countries.

    6.Added CAR LINK software which supports Android Auto via wired connection and Car Play via wired and wireless connection. Please note that CARPLAY only supports this feature on CC3 devices released in 2021. Android Auto has no limits. For CARPLAY wired connection, you must use the original iPhone USB cable. When using CARPLAY wirelessly, make sure the mobile phone is connected via Bluetooth.

    7.Updated EQ software and added a phase switch. The volume and sound effects of the subwoofer change according to the volume of the head unit.

    8.Added a new layout for the main screen, as well as automatic switching between day and night modes. From the home screen, you can directly speed dial, view driving data, compass and GPS information. The 4 main music players can be switched with one key. Redesigned and increased image size when viewed in picture-in-picture mode.

    9Optimized software for making Bluetooth phone calls. Added a choice of avatars in favorite contacts. Opened data synchronization with the main interface.

    10.Added TEYES RADIO and private internet station. Musical compositions can be downloaded and shared through the site mp3.teyes.ru

    11.Steering Wheel Key Customization Tutorial has been added for multiple languages.

    12.Added automatic OTA update function. In the future, we will provide 2 update methods: manual download update and automatic update.

    13.Added multi-finger touch control function. To find out how to use this feature, please see the personal settings section.

    14.Added the ability to slide the application menu to the right side of the screen. Swiping from below returns to the previous level. The function is supported no matter which interface you are in!
    6
    Hi. earlier you said taht you dont't recommend buying Teyes for people outside Russia and now, that Teyes focuses on European region. What about other countries from Europe other than Russia? I'm from Poland and I own Ford Focus mk 3 (2011-1015)
    I am in France, and my CC3 gives me complete satisfaction on my Ford Focus 2. I do not see what the restrictions would be due to the development by the Russians
    5
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )
    OBD2.jpg


    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    5
    Upcomming CC3 update screenshots:

    cc3_may2021_1.jpg


    cc3_may2021_2.jpg
    4
    I want wipe dalvik cache.but I dont know how
    unpack this to usb stick and plug into HU usb port, just like usual firmware update. it will clear cache