Hardware Development TEYES CC3

Search This thread

Cryzzgrantham

Member
Aug 3, 2022
13
1
Hi guys I've had my unit for a while now and just have s few niggles...

Have a cc3 and the touch buttons on the left briefly light up upon boot, I cannot seem to get them to stay on.

I havent worked out how to connect the canbus box to my vehicle, its a transit custom and I understand how its connected head unit side but I'm completely lost with what happens on the other end.

Any help is greatly appreciated thanks
 

leo06

Senior Member
Dec 28, 2008
349
91
Patras
Hi guys I've had my unit for a while now and just have s few niggles...

Have a cc3 and the touch buttons on the left briefly light up upon boot, I cannot seem to get them to stay on.

I havent worked out how to connect the canbus box to my vehicle, its a transit custom and I understand how its connected head unit side but I'm completely lost with what happens on the other end.

Any help is greatly appreciated thanks
The buttons lights up when you turn on your headlights and also the screen will dim. For that to work you must connect the canbus box.
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
The buttons lights up when you turn on your headlights and also the screen will dim. For that to work you must connect the canbus box.
Ah so it roots back to the second problem, I have no clue what connects on the other side. Is there some cable that should be existing in the vehicle or something? I searched everywhere and can't see it.
 

leo06

Senior Member
Dec 28, 2008
349
91
Patras
Ah so it roots back to the second problem, I have no clue what connects on the other side. Is there some cable that should be existing in the vehicle or something? I searched everywhere and can't see it.
Canbus box has only one 16pin connection, that is connecting to the same cable that powers the headunit. After that you have to choose the correct canbus box and your specific car model in the factory settings on your headunit
 

Scumi

New member
May 31, 2016
2
0
Hello everybody. I have had the cc3 for a few months and I always find the problem with the FM radio, the signal is very weak compared to the standard car radio, plus AF and LOC do not work perfectly in the sense that if you feel badly a frequency is not there. changes immediately or does not change it at all, has someone had the same problem as me and solved it? Thank you
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
Yeah I've done all that dude. Is it connecting wirelessly to then vehicle then? I see there is an option to update canbus but to only do it if youre having issues, If it connects wirelessly and I'm not missing a connection on the vehicle side I'll try the update? Honestly I'm clueless, no instructions at all so I'm amazed I've even made it this far.
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
Canbus box has only one 16pin connection, that is connecting to the same cable that powers the headunit. After that you have to choose the correct canbus box and your specific car model in the factory settings on your headunit
Yeah I've done all that dude. Is it connecting wirelessly to then vehicle then? I see there is an option to update canbus but to only do it if youre having issues, If it connects wirelessly and I'm not missing a connection on the vehicle side I'll try the update? Honestly I'm clueless, no instructions at all so I'm amazed I've even made it this far
 

leo06

Senior Member
Dec 28, 2008
349
91
Patras
Yeah I've done all that dude. Is it connecting wirelessly to then vehicle then? I see there is an option to update canbus but to only do it if youre having issues, If it connects wirelessly and I'm not missing a connection on the vehicle side I'll try the update? Honestly I'm clueless, no instructions at all so I'm amazed I've even made it this far
No, doesn’t connect wireless, if you already connected to 16pin it’s connected to the headunit and to car. Did you choose the right box and car model in the headunit settings? Do you have steering wheel buttons? Do steering wheel buttons working?
Do you have any photo with the box and the wiring?
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
No, doesn’t connect wireless, if you already connected to 16pin it’s connected to the headunit and to car. Did you choose the right box and car model in the headunit settings? Do you have steering wheel buttons? Do steering wheel buttons working?
Do you have any photo with the box and the wiring?
Oh I see that makes so much more sense haha. I saw the connector on the other side and assumed it needed a connection head unit side and also vehicle side, completely ignoring head unit side is fed from the vehicle already haha.

Yeah I have the correct one I think, I selected transit custom when I ordered anyway, can only assume this box is correct.

I dont have steering wheel buttons bud, would that be the variable that's missing here?
 

Attachments

  • Screenshot_20220927-154253_Photos.jpg
    Screenshot_20220927-154253_Photos.jpg
    1.4 MB · Views: 27

leo06

Senior Member
Dec 28, 2008
349
91
Patras
Oh I see that makes so much more sense haha. I saw the connector on the other side and assumed it needed a connection head unit side and also vehicle side, completely ignoring head unit side is fed from the vehicle already haha.

Yeah I have the correct one I think, I selected transit custom when I ordered anyway, can only assume this box is correct.

I dont have steering wheel buttons bud, would that be the variable that's missing here?
Did you go to factory settings and choose the right box? Yours it’s a raise box, you have to choose that and after car manufactor and car model
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
Did you go to factory settings and choose the right box? Yours it’s a raise box, you have to choose that and after car manufactor and car model
What's raise labeled as bud? I recieved literally a piece of paper for the instructions and all it said was to select these options in the photo.
 

Attachments

  • 20220927_155745.jpg
    20220927_155745.jpg
    2.5 MB · Views: 46

mastrv

Senior Member
Jul 1, 2010
277
87
None of the can bus features are working mate. Just says no vehicle information on car info
Please take a picture and post it. If it's the Car Info I'm thinking about, that is for OBDII. If you want to see Car Info with more/any info, you may need an OBDII module...but that's a whole other can of worms.

Canbus is a module used to communicate with various systems in the car. The Canbus module only interacts with systems that are available on your car. If the head unit doesn't need any of the items or your car doesn't provide them, then you won't see them. Is anything not working on your head unit? Typical things that the Canbus module might provide are:

- steering wheel buttons
- rear view camera
- backup camera tracking - lines that turn/bend based on steering wheel angle
- air conditioning/heater controls
- door open/close indicators
- audio/amplifier controls

Also, even if your vehicle has some of these features, they may or may not go through the Canbus. Some, none or all of the features may need the Canbus.

What year is your car? There are usually more features going through Canbus for newer cars. Mine is a Kia Sorento 2012 and while I was provided with a Canbus module, only the sound for the amplifier was going through the Canbus. Unfortunately the Canbus software still didn't work with it and I had to get another module. In any case, even if some of the above features goes through the Canbus, it doesn't mean it will work.

So, is there anything specific you're looking for?
 

Cryzzgrantham

Member
Aug 3, 2022
13
1
Please take a picture and post it. If it's the Car Info I'm thinking about, that is for OBDII. If you want to see Car Info with more/any info, you may need an OBDII module...but that's a whole other can of worms.

Canbus is a module used to communicate with various systems in the car. The Canbus module only interacts with systems that are available on your car. If the head unit doesn't need any of the items or your car doesn't provide them, then you won't see them. Is anything not working on your head unit? Typical things that the Canbus module might provide are:

- steering wheel buttons
- rear view camera
- backup camera tracking - lines that turn/bend based on steering wheel angle
- air conditioning/heater controls
- door open/close indicators
- audio/amplifier controls

Also, even if your vehicle has some of these features, they may or may not go through the Canbus. Some, none or all of the features may need the Canbus.

What year is your car? There are usually more features going through Canbus for newer cars. Mine is a Kia Sorento 2012 and while I was provided with a Canbus module, only the sound for the amplifier was going through the Canbus. Unfortunately the Canbus software still didn't work with it and I had to get another module. In any case, even if some of the above features goes through the Canbus, it doesn't mean it will work.

So, is there anything specific you're looking for?
I've attached the screen it shows bud.

I did actually get mine with OBDII, are you saying that I will need to use that in conjunction with this somehow?

Yeah my head unit isn't working with any systems, camera works but only because I've installed that using the instructions provided with the kit. And tapped in to ACC for power.

I have a 2016 transit custom bud.

Well my main peeve was that the LED on the panel buttons don't work, another guy mentioned they are connected via canbus and when the headlights are on..

But mainly its the reverse lines, it's great having the read camera but I had a reverse camera when it was stock and having the tram lines makes all the difference..

In your case you needed an alternate module, is there anyway I could search for something like that on my vehicle bud?
 

deadeye920

Senior Member
Apr 30, 2022
100
20
I've attached the screen it shows bud.

I did actually get mine with OBDII, are you saying that I will need to use that in conjunction with this somehow?

Yeah my head unit isn't working with any systems, camera works but only because I've installed that using the instructions provided with the kit. And tapped in to ACC for power.

I have a 2016 transit custom bud.

Well my main peeve was that the LED on the panel buttons don't work, another guy mentioned they are connected via canbus and when the headlights are on..

But mainly its the reverse lines, it's great having the read camera but I had a reverse camera when it was stock and having the tram lines makes all the difference..

In your case you needed an alternate module, is there anyway I could search for something like that on my vehicle bud?
Do you have a factory reverse camera? The button lights will only turn when the screen dims. The screen dims by two options. Either a time setting which will turn them on at a certain time and off at another certain time or via the headlight switch. Most opt for the headlight switch. This dims the screen and turns on the button leds.

What area are you in?
 

Elmer123456

Member
Feb 1, 2022
17
5
Zürich
I've attached the screen it shows bud.

I did actually get mine with OBDII, are you saying that I will need to use that in conjunction with this somehow?

Yeah my head unit isn't working with any systems, camera works but only because I've installed that using the instructions provided with the kit. And tapped in to ACC for power.

I have a 2016 transit custom bud.

Well my main peeve was that the LED on the panel buttons don't work, another guy mentioned they are connected via canbus and when the headlights are on..

But mainly its the reverse lines, it's great having the read camera but I had a reverse camera when it was stock and having the tram lines makes all the difference..

In your case you needed an alternate module, is there anyway I could search for something like that on my vehicle bud?
I come back to your question about the lighting of the symbols on the left. This has little to do with Canbus, it's a setting....
go to Settings - General - Backlight Control -off
and now the backlight works when you turn on the light.
or
Settings - General - Backlight Control - on
now you can adjust the backlight according to the clock, e.g. 1900h - 0600h
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Ok, so I just solved a massive headache with my teyes CC3 audio. And I will explain how and what. It concerns not working rear speakers. The worst part is that Teyes has no instructions AT ALL for the A3/A4 and I had to either figure this out on my own or with the help of people here on the forum or a bit of help of the teyes technical support which cost me about a week. However I want to enable people to have a smooth install with their A3 as the headunit itsself is fantastic and seriously worth the money.

    To start first the (overall very few) issues I had with it and how to solve them (also link to a video I made about all but #1 at the end):

    1. The frame of the A3 being to small

    The actual frame fits exactly into the gap that the OEM radio you take out leaves behind. The issue is the tabs that are supposed to hold it in place. They are too widely moldel. What I mean is that they are molded in such a way that they are wider than is needed to make them fit. As such it is a PAIN to get them in.

    A big tip I can give is the 3 first then 1 method. Get the bottom 2 in by pressing on them and then 1 of the 2 top ones. Or one side in and then pry the other 2 in. But the last one will be VERY hard to press in and I highly reccomend a interior trim removal kit tool to press it with to the inside. It will help give you leverage.

    3 will click into place and the last one will be ehhhh kind of in there but if you press it in it should sit flush. I can say from experience you can expect that 1 of the 2 top tabs will slightly break away from the main mold but it should hold.

    now big thing. DO NOT SCREW THE CC3 INTO THE FRAME. You can but removing it will be extremely hard as the frame will sit 100% flush with the dash and even getting a prying tool into 1 of the corners is next to impossible.
    Ideally, get the frame in first, THEN do the wiring. and press the unit in afterwards. One thing that helps remove it is if you attach a sort of tab with tape or glue that will stick out (tape maybe is the easiest?) so you can use it as a pull cord and pull the unit out that way.

    2. The unit not powering on at all (also explained in the video).

    So this is one is a headbreaker and I almost thought I needed to ship the unit back.
    I installed the unit and connected all the wires as they should be (based on other videos) but nothing after I powered on the car. Optical out on the back however did light up for a bit and then went blank.

    The issue was as following. On the main cable harnass you get there are 2 boxes that lead to a. the CANBUS box connector and b. The main power/connector that goes into the G slot on the diagram.

    The harnass for the A3 8p has 2!!!! boxes where it begins. A " quadlock" that will fit on the 8p" and a different one that will NOT fit.

    Now it seems that from factor they connect the ACCESORY wire, which in my case was orange (look up the diagram supplied with the unit to see which cable it should be), to the connection box that will NOT FIT. So you have an empty box like connector that has many wires on of which was orange with a 2 pin connector. There is an IDENTICAL but loose wire with 2 pins on the quadlock connector. You need to UNPLUG the accesory cable from that wrong harnass and connect it to the wire that runs to the quadlock connector. That will make the unit turn on and work.

    3. NON WORKING REAR SPEAKERS (NON BOSE)

    So this has been posted many many times on many forums but there has been no consise solution explained so I will attempt my best.

    If you get the CC3 unit and connect all the wires you need to choose 1 of 2 extra cables included. One has the mic connector, sim card tray, AMP-C wire and the AUX L and R connectors. the other is Some fo those but mostly RCA cables. But for both it works the same.

    First of all, and this is NOT EXPLAINED AT ALL ANYWHERE, you need to take the AMP cable (blue and white) that comes off the quadlock AND ISO connector (they are joined together in the factory AND HAVE A SEETHROUGH BLUE CAP ON THE END) and connect it to the AMP-C cable (solid blue) coming off the second set of wires you plug in.

    The issue is that you need to strip the isolation of both ends and then twist the exposed leads together to get the front amplifier to work at all...... then once that is done you use electrical tape to secure and insulate it. Now the front amp will work. The front speakers will with either the cables connected or not.

    Now onto the rear speakers. Teyes has only now after I and other mailed them started selling an extra harness that you need to make the rear ones and sub work. The A3 and A4 are half amplified cars. This means that the headunit is supposed to also provide power and a turn on signal to the rear amp that is built into the speakers.

    However, the unit does not have enough power to do that on its own. Its impedance is too low. You need the following harness it will not work without : https://teyes.eu/products/special-p...t?shpxid=020fa858-1cb9-4173-964f-bcd43d2a8198

    61vwriFZ6aL._AC_SL1500_1024x1024@2x.jpg



    This harness goes in between the original quadlock of the car and the quadlock connector of the CC3 unit. it changes the impedance of the speakers and makes it so the unit has enough power to power the rear amp and speakers.

    This harness is also sold by XTRONS under a different name. Look around and you will find it.

    A tip I can give is that you may need to adjust the amount of impedance by using a small flathead screwdriver to turn the 4 knobs in the transparent cases (see pic below). You need to have it all plugged in and working to hear (you need to listen to the audio) but if they are set too much to 1 of the 2 sides (I think clockwise?) The harness wont work and the amps are silent. Completely the other way and the amps work and the sound is of good loudness.



    1674850219583.png


    I hope this helps at least 1 person and saves them from the heart attacks and stress this caused me.

    Here is a link to my video explaining this post:
    2
    It's there. It's called Power Conditioning.
    The sound adjustment parameters are found in these three tables
    1
    There are 143 pages of this thread and nothing in those has worked for me, but thanks for taking the time to reply.
    1
    Hello Guys!

    I recently bought CC3 and have a few problems, hope You guys can help.

    1. Different bugs with Navigation apps
    Every Navigation app I set on my home screen is broken

    Waze let me search but only generates routes for my saved addresses, when I select the one I searched for it does nothing
    Google Maps gives top view without directions, speedometer etc.
    HERE WeGo when opened the smaller windows is on top of the full screen view of app

    This is a bug with the home screen launcher window.

    Waze (or any other navi app) will work perfectly if you do not set it as the launcher app.
    1
    There is no difference between firmware downloaded from RU and downloaded from EN?
    I am asking because the file being downloaded has either EN or RU in its name, depending on which region is selected on the website.
    Yesterday I made the upgrade with the RU file, but all text in the setup was in English, the Unit stayed on english, my keyboard stayed English (also kept my native language). :)
  • 7
    Teyes announced another CC3 update for April 2021, here is the translated changelog.



    The following important updates are expected to be released for the CC3 software at the end of April.
    The new version will add the following features:

    1.Added Cam REC software. With this application, you can record from a rear view camera. The recording files are saved to a flash card.

    2.Added TEYES YAHU, the world's first 3D music player for the automotive industry (due to technical complexity, work may not be completed in April).

    3.In the device settings, a function has been added to change the screen brightness depending on the time of sunrise and sunset.

    4.The system version has been updated. Fixed the issue of crashing the Google Play app in some areas.

    5.Added setting for the sensitivity level of voice commands. If you feel that certain keywords easily trigger voice commands, you can lower the sensitivity level. In addition to Russian and English, a voice control function has been added for 7 countries.

    6.Added CAR LINK software which supports Android Auto via wired connection and Car Play via wired and wireless connection. Please note that CARPLAY only supports this feature on CC3 devices released in 2021. Android Auto has no limits. For CARPLAY wired connection, you must use the original iPhone USB cable. When using CARPLAY wirelessly, make sure the mobile phone is connected via Bluetooth.

    7.Updated EQ software and added a phase switch. The volume and sound effects of the subwoofer change according to the volume of the head unit.

    8.Added a new layout for the main screen, as well as automatic switching between day and night modes. From the home screen, you can directly speed dial, view driving data, compass and GPS information. The 4 main music players can be switched with one key. Redesigned and increased image size when viewed in picture-in-picture mode.

    9Optimized software for making Bluetooth phone calls. Added a choice of avatars in favorite contacts. Opened data synchronization with the main interface.

    10.Added TEYES RADIO and private internet station. Musical compositions can be downloaded and shared through the site mp3.teyes.ru

    11.Steering Wheel Key Customization Tutorial has been added for multiple languages.

    12.Added automatic OTA update function. In the future, we will provide 2 update methods: manual download update and automatic update.

    13.Added multi-finger touch control function. To find out how to use this feature, please see the personal settings section.

    14.Added the ability to slide the application menu to the right side of the screen. Swiping from below returns to the previous level. The function is supported no matter which interface you are in!
    6
    Hi. earlier you said taht you dont't recommend buying Teyes for people outside Russia and now, that Teyes focuses on European region. What about other countries from Europe other than Russia? I'm from Poland and I own Ford Focus mk 3 (2011-1015)
    I am in France, and my CC3 gives me complete satisfaction on my Ford Focus 2. I do not see what the restrictions would be due to the development by the Russians
    5
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )
    OBD2.jpg


    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    5
    Upcomming CC3 update screenshots:

    cc3_may2021_1.jpg


    cc3_may2021_2.jpg
    4
    I want wipe dalvik cache.but I dont know how
    unpack this to usb stick and plug into HU usb port, just like usual firmware update. it will clear cache