Hardware Development TEYES CC3

Search This thread

chatocean

Member
Jan 18, 2010
7
1
Hi all,

I got CC3 from last week, I have an issue with subwoofer volume. When I volume up/down the subwoofer is not effect. So when I volume down to 1 the subwoofer volume is too large. Does anyone get this issue, and do we have any solution to resolve it?

Thank you
 

chatocean

Member
Jan 18, 2010
7
1
I resolved this problem, just update Equalizer app and on phase.
eq.png
 
  • Like
Reactions: Flemischguy

pawex

Member
May 23, 2018
23
2
Hi. No. If you use the original player then WidgetUpdater is not needed. It is only for those who use third party players via MusicProxy.
Sorry i think you dont understand my question , i mean can i still use the original player ? Since installing the Widget updater when i try tu turn on the original music player it starts straight away spotify
 

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
I thought he replaced the Teyes boot animation, which appears on startup, with an own animation.
I was not able to find the folder for this without rooting.
You can do it without rooting. If you unpack everything in the firmware (brotli, sdat2img, mount (system) img), you can see where the bootanimation resides. Then you make/take your own boot animation and zip it, and flash it with your your own flash script and the lsec6315update binary.
I did it for my sc9853i, but it works exactly the same for the uis7862.

The bootanimation should be copied to /system/media/bootanimation.zip and then do a
Code:
chmod 0644 /system/media/bootanimation.zip
 

KёniG

Member
Mar 28, 2020
25
11
when i try tu turn on the original music player it starts straight away spotify
MusicProxy completely replaces the original player. So if you press the launcher music button or the launcher music widget or the steering wheel music button or call "Start music" TeyesVoice command, the third party player (Spotify in your case) will start. It is the main feature) There is no way to start Teyes player without uninstalling MusicProxy.
Even if you uninstall MusicProxy, WidgetUpdater will conflict with Teyes player so they are use the same widget updating mechanism.
Do not hestitate write me to private messages if you need further help.
 

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
You can do it without rooting. If you unpack everything in the firmware (brotli, sdat2img, mount (system) img), you can see where the bootanimation resides. Then you make/take your own boot animation and zip it, and flash it with your your own flash script and the lsec6315update binary.
I did it for my sc9853i, but it works exactly the same for the uis7862.

The bootanimation should be copied to /system/media/bootanimation.zip and then do a
Code:
chmod 0644 /system/media/bootanimation.zip
Answering on my own reply ;)

Please find attached a zip with a script with my bootanimation.zip. (I have a Skoda and took 2 boot animations and used gimp to modify/merge it into a new bootanimation. This is for the uis7862 (I have the same for my own sc9853i where this one is simply converted from)
Unzip that flash_bootanimation.zip to a clean usb-stick. Make sure you keep the structure:
Code:
lsec6315update (file)
lsec_updatesh/7862lsec.sh
lsec_updatesh/bootanimation.zip

And replace my bootanimation.zip with your own bootanimation.
Upon flashing it might say "setting system back to factory defaults", but that is definitely not happening
 

Attachments

  • flash_bootanimation.zip
    17 MB · Views: 121
  • Like
Reactions: pcmicro

beichtvater

Member
Mar 17, 2021
12
10
Answering on my own reply ;)

Please find attached a zip with a script with my bootanimation.zip. (I have a Skoda and took 2 boot animations and used gimp to modify/merge it into a new bootanimation. This is for the uis7862 (I have the same for my own sc9853i where this one is simply converted from)
Unzip that flash_bootanimation.zip to a clean usb-stick. Make sure you keep the structure:
Code:
lsec6315update (file)
lsec_updatesh/7862lsec.sh
lsec_updatesh/bootanimation.zip

And replace my bootanimation.zip with your own bootanimation.
Upon flashing it might say "setting system back to factory defaults", but that is definitely not happening
Wait, you just did the whole work for me and i just have to add my own boot animation to the unzipped fat32 stick, plug it into my cc3 and flash it?

Nothing else?
 

beichtvater

Member
Mar 17, 2021
12
10
Yes. (the whole work? It took me 5 minutes once you know what to do.)
... So does the graphics guy, after charging me 1500€ after one day of work for a few banners or the plumber, charging me 250€ after 20 minutes.

Thank you a lot, i had no clue how to do this. Does this replace the Teyes boot animation after the car logo?

And what about the:
1024 600 20
p 1 0 part0
p 0 0 part1

I took some Jeep boot animations from here, they have different values in the first line, 1024 600 is the resolution but the 20 is a different value in some animations. Is it the "refresh rate"?

Thanks again, you helped me a lot.
 

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
... So does the graphics guy, after charging me 1500€ after one day of work for a few banners or the plumber, charging me 250€ after 20 minutes.

Thank you a lot, i had no clue how to do this. Does this replace the Teyes boot animation after the car logo?
Yes.
And what about the:
1024 600 20
p 1 0 part0
p 0 0 part1

I took some Jeep boot animations from here, they have different values in the first line, 1024 600 is the resolution but the 20 is a different value in some animations. Is it the "refresh rate"?

Thanks again, you helped me a lot.
Please google on how to create bootanimations. There is even a good article on the XDA forums. (I even wrote one somewhere in 2009~2011 for Archos tablets)
The 20 is indeed the refresh rate in frames per second. The current PX5/PX6/sc9853i/uis7862 can accomodate higher frame rates. You can simply increase the value until your unit starts stuttering on the anmation, but 20 is a nice "fluent" frame rate.
The 1024x600 is indeed the resolution. That's why most bootanimations have transparent backgrounds. If you use it on 1280x720 it will be centered on your screen with black borders around it. With a transparent bootanimation you do not see those borders.
 

beichtvater

Member
Mar 17, 2021
12
10
Yes.

Please google on how to create bootanimations. There is even a good article on the XDA forums. (I even wrote one somewhere in 2009~2011 for Archos tablets)
The 20 is indeed the refresh rate in frames per second. The current PX5/PX6/sc9853i/uis7862 can accomodate higher frame rates. You can simply increase the value until your unit starts stuttering on the anmation, but 20 is a nice "fluent" frame rate.
The 1024x600 is indeed the resolution. That's why most bootanimations have transparent backgrounds. If you use it on 1280x720 it will be centered on your screen with black borders around it. With a transparent bootanimation you do not see those borders.

Something went wrong, do you have any advice?
 

Attachments

  • 20210324_103920.jpg
    20210324_103920.jpg
    2.1 MB · Views: 85

JMM44700

Senior Member
Jun 17, 2018
112
29
Orvault
They answer me in a day. Strange you don't get an answer
I also tried communicating with them, by Whatsapp: +60 12-3761466, but is it another reseller? (FSK).

And here is their response:

We are from the official from the Southeast Asia region.
Due to different countries, the rights of consumers may be limited. There may also be differentiation in terms of software or hardware.
For products purchased in another region, you can contact your original seller for service and support. Thank you.



So I found the T'eyes number +8613684964012, and I reiterated my request to integrate the "IGO" GPS navigator into the CC3 home page. And since then no response from them
 

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
Something went wrong, do you have any advice?
The read-write mounting of /system did not work. Nothing has been done to your system as it could not do anything.

I used the command
Code:
mount -o remount,rw /system
In my previous JET apk I used several commands for the several android versions.

Please open the uis7862.sh script and change
Code:
mount -o remount,rw /system
to
Code:
mount -o rw,remount /system

Believe me: this is absolutely stupid in the unix/linux world, but somehow FYT made the mount command that picky. :rolleyes:
It seems it has been changed again going from Android 8.1 to Android 10.

Or use attached modified zip and replace the bootanimation.zip again.
 

Attachments

  • flash_bootanimation.zip
    17 MB · Views: 40

beichtvater

Member
Mar 17, 2021
12
10
The read-write mounting of /system did not work. Nothing has been done to your system as it could not do anything.

I used the command
Code:
mount -o remount,rw /system
In my previous JET apk I used several commands for the several android versions.

Please open the uis7862.sh script and change
Code:
mount -o remount,rw /system
to
Code:
mount -o rw,remount /system

Believe me: this is absolutely stupid in the unix/linux world, but somehow FYT made the mount command that picky. :rolleyes:
It seems it has been changed again going from Android 8.1 to Android 10.

Or use attached modified zip and replace the bootanimation.zip again.
Exactly the same again with this zip file.
I attached the Isec file i got from the last update on the 02.04.2020 and the update worked, i just renamed it to .txt so i can upload it here. Maybe you could take a look.
Here is a link, where all of the firmwares and updates are located, i just switch it on the top (Google website translator) to German because i unfortunately dont speak russian and everything is there.

 

Attachments

  • lsec6315update.txt
    2 MB · Views: 28
Last edited:

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
Exactly the same again with this zip file.
I attached the Isec file i got from the last update on the 02.04.2020 and the update worked, i just renamed it to .txt so i can upload it here. Maybe you could take a look.
Here is a link, where all of the firmwares and updates are located, i just switch it on the top (Google website translator) to German because i unfortunately dont speak russian and everything is there.

I think I made it much too difficult. The uis7862 firmware comes with the bootanimation in the root folder of the usb-stick.
I think that if you simply copy the lsec6315update and your bootanimation.zip in the root of a clean usb-stick, it will flash that bootanimation. No folders, no scripts. Simple as that.
 
  • Like
Reactions: beichtvater

sgtm7

Member
Oct 22, 2015
7
2
Received my CC3 today. Installed it right away. Didn't take long(about 15 minutes), because I was only replacing a similar unit. First thing I had to do was determine which CANBUS Box to select, because my steering wheel controls weren't working with the one they had selected. My vehicle brand wasn't in their list where the CANBUS setting instructions were located. Luckily, I knew which one to select from my last head unit. This is my third head unit I have had in this car, and it had the same issue as my last one: I can't remap the steering wheel buttons. I am stuck with the default ones. My very first head unit was a Wondefoo, and it allowed me to remap the buttons. I really like reassigning the mode/music button to be a play/pause button. It isn't too often I actually change my music source, but I play or pause quite often. I guess if it was really important, I could reinstall the olde Wondefoo unit, just to see which CANBUS settings it used.

Once I got the right CANBUS settings, I immediately installed Car Launcher Pro. Everyone has their preference, but I like it better than any of the vendor supplied launchers. I have it installed on all my cars' head units.

The head unit is very responsive. With the amount of RAM and ROM(6 and 128GB), I don't forsee that changing when I install more apps.

Data connection with my SIM installed in the head unit works great also. I didn't have to input any APN settings either. Everything just worked right away.

This unit appears to have a higher output than my previous head unit, and I am going to need to reset the gains on my amplifiers tomorrow.

Overall, I am happy with my purchase.
 

beichtvater

Member
Mar 17, 2021
12
10
I think I made it much too difficult. The uis7862 firmware comes with the bootanimation in the root folder of the usb-stick.
I think that if you simply copy the lsec6315update and your bootanimation.zip in the root of a clean usb-stick, it will flash that bootanimation. No folders, no scripts. Simple as that.
You know what, i was thinking the same when i took a look at the original firmware update folder but i didnt want to mess around.

I did it now but i have a black screen instead of the Teyes boot animation, it was because i changed the frame rate from 10 to 20. With the framerate 10 everything is working with this boot animation, the boot animation just ends too fast in the middle of the full boot animation, i have to figure it out, how to get the full boot animation. I will test the 720 resolution too because of the black frame.
The device is working normal after boot.

For anybody looking how to change your boot animation:

Just put the lsec6315update file and the bootanimation.zip file of your choice into the root folder of your fat32 formatted usb stick and let it update your boot animation. It will change only the boot animation, nothing else.

Credits to surfer63 for explaining how to do it.
 

Attachments

  • 20210325_113517.jpg
    20210325_113517.jpg
    1.5 MB · Views: 90
  • 20210325_113623.jpg
    20210325_113623.jpg
    4.4 MB · Views: 95
Last edited:
  • Like
Reactions: checksum123

surfer63

Senior Member
May 4, 2010
4,652
2,202
Zwolle
github.com
I did it now but i have a black screen instead of the Teyes boot animation, it was because i changed the frame rate from 10 to 20. With the framerate 10 everything is working with this boot animation, the boot animation just ends too fast in the middle of the full boot animation, i have to figure it out, how to get the full boot animation. I will test the 720 resolution too because of the black frame.
The device is working normal after boot.
What is the size of your bootanimation in MBytes?
My total bootanimation is 17 MB at 1024x600, with 39 images in part0 and 77 image in part1 running at 20 frames per second.
Your uis7862 should be 60% faster than my sc9853i, so 20 fps or even 30fps should not be a problem, unless your bootanimation is massive.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Ok, so I just solved a massive headache with my teyes CC3 audio. And I will explain how and what. It concerns not working rear speakers. The worst part is that Teyes has no instructions AT ALL for the A3/A4 and I had to either figure this out on my own or with the help of people here on the forum or a bit of help of the teyes technical support which cost me about a week. However I want to enable people to have a smooth install with their A3 as the headunit itsself is fantastic and seriously worth the money.

    To start first the (overall very few) issues I had with it and how to solve them (also link to a video I made about all but #1 at the end):

    1. The frame of the A3 being to small

    The actual frame fits exactly into the gap that the OEM radio you take out leaves behind. The issue is the tabs that are supposed to hold it in place. They are too widely moldel. What I mean is that they are molded in such a way that they are wider than is needed to make them fit. As such it is a PAIN to get them in.

    A big tip I can give is the 3 first then 1 method. Get the bottom 2 in by pressing on them and then 1 of the 2 top ones. Or one side in and then pry the other 2 in. But the last one will be VERY hard to press in and I highly reccomend a interior trim removal kit tool to press it with to the inside. It will help give you leverage.

    3 will click into place and the last one will be ehhhh kind of in there but if you press it in it should sit flush. I can say from experience you can expect that 1 of the 2 top tabs will slightly break away from the main mold but it should hold.

    now big thing. DO NOT SCREW THE CC3 INTO THE FRAME. You can but removing it will be extremely hard as the frame will sit 100% flush with the dash and even getting a prying tool into 1 of the corners is next to impossible.
    Ideally, get the frame in first, THEN do the wiring. and press the unit in afterwards. One thing that helps remove it is if you attach a sort of tab with tape or glue that will stick out (tape maybe is the easiest?) so you can use it as a pull cord and pull the unit out that way.

    2. The unit not powering on at all (also explained in the video).

    So this is one is a headbreaker and I almost thought I needed to ship the unit back.
    I installed the unit and connected all the wires as they should be (based on other videos) but nothing after I powered on the car. Optical out on the back however did light up for a bit and then went blank.

    The issue was as following. On the main cable harnass you get there are 2 boxes that lead to a. the CANBUS box connector and b. The main power/connector that goes into the G slot on the diagram.

    The harnass for the A3 8p has 2!!!! boxes where it begins. A " quadlock" that will fit on the 8p" and a different one that will NOT fit.

    Now it seems that from factor they connect the ACCESORY wire, which in my case was orange (look up the diagram supplied with the unit to see which cable it should be), to the connection box that will NOT FIT. So you have an empty box like connector that has many wires on of which was orange with a 2 pin connector. There is an IDENTICAL but loose wire with 2 pins on the quadlock connector. You need to UNPLUG the accesory cable from that wrong harnass and connect it to the wire that runs to the quadlock connector. That will make the unit turn on and work.

    3. NON WORKING REAR SPEAKERS (NON BOSE)

    So this has been posted many many times on many forums but there has been no consise solution explained so I will attempt my best.

    If you get the CC3 unit and connect all the wires you need to choose 1 of 2 extra cables included. One has the mic connector, sim card tray, AMP-C wire and the AUX L and R connectors. the other is Some fo those but mostly RCA cables. But for both it works the same.

    First of all, and this is NOT EXPLAINED AT ALL ANYWHERE, you need to take the AMP cable (blue and white) that comes off the quadlock AND ISO connector (they are joined together in the factory AND HAVE A SEETHROUGH BLUE CAP ON THE END) and connect it to the AMP-C cable (solid blue) coming off the second set of wires you plug in.

    The issue is that you need to strip the isolation of both ends and then twist the exposed leads together to get the front amplifier to work at all...... then once that is done you use electrical tape to secure and insulate it. Now the front amp will work. The front speakers will with either the cables connected or not.

    Now onto the rear speakers. Teyes has only now after I and other mailed them started selling an extra harness that you need to make the rear ones and sub work. The A3 and A4 are half amplified cars. This means that the headunit is supposed to also provide power and a turn on signal to the rear amp that is built into the speakers.

    However, the unit does not have enough power to do that on its own. Its impedance is too low. You need the following harness it will not work without : https://teyes.eu/products/special-p...t?shpxid=020fa858-1cb9-4173-964f-bcd43d2a8198

    61vwriFZ6aL._AC_SL1500_1024x1024@2x.jpg



    This harness goes in between the original quadlock of the car and the quadlock connector of the CC3 unit. it changes the impedance of the speakers and makes it so the unit has enough power to power the rear amp and speakers.

    This harness is also sold by XTRONS under a different name. Look around and you will find it.

    A tip I can give is that you may need to adjust the amount of impedance by using a small flathead screwdriver to turn the 4 knobs in the transparent cases (see pic below). You need to have it all plugged in and working to hear (you need to listen to the audio) but if they are set too much to 1 of the 2 sides (I think clockwise?) The harness wont work and the amps are silent. Completely the other way and the amps work and the sound is of good loudness.



    1674850219583.png


    I hope this helps at least 1 person and saves them from the heart attacks and stress this caused me.

    Here is a link to my video explaining this post:
    2
    It's there. It's called Power Conditioning.
    The sound adjustment parameters are found in these three tables
    1
    i dont even know how i can get it to stick somewhere outside of the car. When you mean outside you actually mean outside in the air?
    Yes, placed on the roof, or elsewhere, possibly with adhesive temporarily, passing the cable through a window, static, or a short trip (only test recess)
    1
    Hello Guys!

    I recently bought CC3 and have a few problems, hope You guys can help.

    1. Different bugs with Navigation apps
    Every Navigation app I set on my home screen is broken

    Waze let me search but only generates routes for my saved addresses, when I select the one I searched for it does nothing
    Google Maps gives top view without directions, speedometer etc.
    HERE WeGo when opened the smaller windows is on top of the full screen view of app

    This is a bug with the home screen launcher window.

    Waze (or any other navi app) will work perfectly if you do not set it as the launcher app.
    1
    There is no difference between firmware downloaded from RU and downloaded from EN?
    I am asking because the file being downloaded has either EN or RU in its name, depending on which region is selected on the website.
    Yesterday I made the upgrade with the RU file, but all text in the setup was in English, the Unit stayed on english, my keyboard stayed English (also kept my native language). :)
  • 7
    Teyes announced another CC3 update for April 2021, here is the translated changelog.



    The following important updates are expected to be released for the CC3 software at the end of April.
    The new version will add the following features:

    1.Added Cam REC software. With this application, you can record from a rear view camera. The recording files are saved to a flash card.

    2.Added TEYES YAHU, the world's first 3D music player for the automotive industry (due to technical complexity, work may not be completed in April).

    3.In the device settings, a function has been added to change the screen brightness depending on the time of sunrise and sunset.

    4.The system version has been updated. Fixed the issue of crashing the Google Play app in some areas.

    5.Added setting for the sensitivity level of voice commands. If you feel that certain keywords easily trigger voice commands, you can lower the sensitivity level. In addition to Russian and English, a voice control function has been added for 7 countries.

    6.Added CAR LINK software which supports Android Auto via wired connection and Car Play via wired and wireless connection. Please note that CARPLAY only supports this feature on CC3 devices released in 2021. Android Auto has no limits. For CARPLAY wired connection, you must use the original iPhone USB cable. When using CARPLAY wirelessly, make sure the mobile phone is connected via Bluetooth.

    7.Updated EQ software and added a phase switch. The volume and sound effects of the subwoofer change according to the volume of the head unit.

    8.Added a new layout for the main screen, as well as automatic switching between day and night modes. From the home screen, you can directly speed dial, view driving data, compass and GPS information. The 4 main music players can be switched with one key. Redesigned and increased image size when viewed in picture-in-picture mode.

    9Optimized software for making Bluetooth phone calls. Added a choice of avatars in favorite contacts. Opened data synchronization with the main interface.

    10.Added TEYES RADIO and private internet station. Musical compositions can be downloaded and shared through the site mp3.teyes.ru

    11.Steering Wheel Key Customization Tutorial has been added for multiple languages.

    12.Added automatic OTA update function. In the future, we will provide 2 update methods: manual download update and automatic update.

    13.Added multi-finger touch control function. To find out how to use this feature, please see the personal settings section.

    14.Added the ability to slide the application menu to the right side of the screen. Swiping from below returns to the previous level. The function is supported no matter which interface you are in!
    6
    Hi. earlier you said taht you dont't recommend buying Teyes for people outside Russia and now, that Teyes focuses on European region. What about other countries from Europe other than Russia? I'm from Poland and I own Ford Focus mk 3 (2011-1015)
    I am in France, and my CC3 gives me complete satisfaction on my Ford Focus 2. I do not see what the restrictions would be due to the development by the Russians
    5
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )
    OBD2.jpg


    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    5
    Upcomming CC3 update screenshots:

    cc3_may2021_1.jpg


    cc3_may2021_2.jpg
    4
    I want wipe dalvik cache.but I dont know how
    unpack this to usb stick and plug into HU usb port, just like usual firmware update. it will clear cache