Hardware Development TEYES CC3

Search This thread

ajnin_

Member
Jan 10, 2022
7
5
Hello, I recently purchased the Teyes cc3 + 360 cameras ( cc360 ) and also experienced the bug with my google contacts being deleted from my phone. Unfortunately, I can't update to the latest update from the official page " https://cc3.teyes.ru/en/update.html " because that page is only for the standard CC3, and that update removes the 360 functionality from my device. ( deletes the 360 app and the connected cameras don't show any picture given as a reverse camera ) There is a different page specifically for CC360 " https://cc3.teyes.ru/ru/360/update.html " but the latest update there is from 29.9.2021. But thanks to the user " geeksquad2 " a workaround to this issue is to disable the google contact sync on the CC3 device. After doing so I have not experienced the bug again.
 

Dadeepman

Member
Dec 11, 2021
7
0
Installed the cc3 in my mk3 focus …. Seemed ok.

I installed an aftermarket 12v rca output reverse cam (wired to 12v accessory) and used the canbus provided with the unit (raise) to tell the cc3 when the car was in reverse

At firstwhen i switched to reverse, the radio screen would switch to the reverse cam as expected and the volume would mute.

I contacted teyes support because my frame lights were constantly blinking

They sent me a canbus upd file which i loaded

It did not solve the problem

Now when i engage reverse nothing happens. The volume doesnt mute and the radio acts as though it has no idea i switched to reverse.

if i manually launch the camera, i can see an image and everything works. Indicates the cam is still working fine.

just wont do it using the reverse canbus signal.

I then did the canbus update from the teyes site for the 4 files (mcu update) which specifically has a file called canbus as well as system, ms, and us

it used to work fine.

i’ve tried resetting the unit and no change.

i tried reloading the firmware and besides losing all my radio station favourites and my learned steering wheel programming, nothing helped.

the screen still shows hvac when i change settings and also indicates when the doors are opened. So it appears the canbus is still sending signals

Not sure what to try next

yes i could run the reverse light wire to g5 and force the issue, but i shouldnt have to.

Something in that canbus file they sent me screwed everything up, but the files they had me load (apk from website) to reset everything were all .apk files

Originally the tech sent me an .upd file and i had to load it via canbus update menu item. The 4 .apk files were installed from the file manager.

Anyway to get the default canbus .upd file to go back to factory for the raise canbus unit? I tried googling but no luck yet.
 
Last edited:

ChrisJones243

New member
Jan 14, 2022
3
0
Hi all, I've only had my t'eyes CC3 recently, but I have a problem where it won't turn on unless I push and hold the 'rst' button, and then it either shows a dead android with 'no command' text, or it will boot up but the touch screen won't work. And if I release the 'rst' button it will turn off again.

Any thoughts?
 

marchnz

Senior Member
Nov 26, 2012
4,449
872
NZ
Hi all, I've only had my t'eyes CC3 recently, but I have a problem where it won't turn on unless I push and hold the 'rst' button, and then it either shows a dead android with 'no command' text, or it will boot up but the touch screen won't work. And if I release the 'rst' button it will turn off again.

Any thoughts?
What does reseller say
 

ChrisJones243

New member
Jan 14, 2022
3
0
What does reseller say
Hi, I've contacted t'eyes yesterday, since I bought it from them. But haven't had a response yet. I'm going to try and see if an update works.
It only stopped working when I tried to install a back camera, and connect it to the ACC cable. However even if I remove the back camera ACC cable again It still doesn't work.

**Update**
I've tried updating it but when it tries to update it only show about 75% on the installing update page and then tries to restart, which then again shows the no command message with a dead android.
 
Last edited:

alfiabraham

Senior Member
Apr 17, 2012
90
49
Chennai
Installed the cc3 in my mk3 focus …. Seemed ok.

I installed an aftermarket 12v rca output reverse cam (wired to 12v accessory) and used the canbus provided with the unit (raise) to tell the cc3 when the car was in reverse

At firstwhen i switched to reverse, the radio screen would switch to the reverse cam as expected and the volume would mute.

I contacted teyes support because my frame lights were constantly blinking

They sent me a canbus upd file which i loaded

It did not solve the problem

Now when i engage reverse nothing happens. The volume doesnt mute and the radio acts as though it has no idea i switched to reverse.

if i manually launch the camera, i can see an image and everything works. Indicates the cam is still working fine.

just wont do it using the reverse canbus signal.

I then did the canbus update from the teyes site for the 4 files (mcu update) which specifically has a file called canbus as well as system, ms, and us

it used to work fine.

i’ve tried resetting the unit and no change.

i tried reloading the firmware and besides losing all my radio station favourites and my learned steering wheel programming, nothing helped.

the screen still shows hvac when i change settings and also indicates when the doors are opened. So it appears the canbus is still sending signals

Not sure what to try next

yes i could run the reverse light wire to g5 and force the issue, but i shouldnt have to.

Something in that canbus file they sent me screwed everything up, but the files they had me load (apk from website) to reset everything were all .apk files

Originally the tech sent me an .upd file and i had to load it via canbus update menu item. The 4 .apk files were installed from the file manager.

Anyway to get the default canbus .upd file to go back to factory for the raise canbus unit? I tried googling but no luck yet.
Settings -> General -> Mute audio when reversing : ON ?

Mine too isn't working. I will check if I've given the wiring circuit as per Teyes and confirm here.
 
Last edited:

alfiabraham

Senior Member
Apr 17, 2012
90
49
Chennai
I'm unable to get reception on my Teyes CC3. The SIM operator, mobile number, APN settings are recognised but there is no signal reception. Can someone help? Jio is a LTE only network in India. Please refer attachments
 

Attachments

  • IMG-20220116-WA0010.jpg
    IMG-20220116-WA0010.jpg
    174.2 KB · Views: 32
  • IMG-20220116-WA0009.jpg
    IMG-20220116-WA0009.jpg
    104 KB · Views: 32

JMM44700

Senior Member
Jun 17, 2018
75
20
Orvault
Have you previously put the SIM card in the smartphone, and deactivated the PIN code (usually 0000). Otherwise the Teyes CC3 or any other brand/model will not connect
 

Bridgerock

Member
Dec 7, 2009
10
2
After the latest firmware update, I do observe the CC3 unit will auto restart itself when Waze and Spotify are being used at the same time. Had a number of times this occurred. Not too sure if it is a memory management issue. Hope there will be a fix in the next upcoming firmware.
 

andrew85ap2022

New member
Jan 17, 2022
2
0
Hello. I bought a teyes cc3 for my Volkswagen Beetle 2013. After first installation Everything works fine, but I have an audio issue. The audio system doesn’t work. My car have a stock Fender amplifier, maybe the problem lies with this amplifier that doesn't start? how do i make it work?
 

oldbarba

Member
Jan 16, 2022
9
2
u need to find remote wire from your amplifier and conect it to "Cont/AMP" wire (mostly blue one) on your unit or acc wire from your car
 

giallorosso84

New member
Jan 17, 2022
4
1
Hello everyone ! I don't know if this question has been asked before, I'll try my luck. I have owned a CC3 for 6 months and since then I have not been able to access 4G. The sim that I put is however recognized and functional in another teyes device but not in the CC3. Is there a particular manipulation (I'm in France)

thanks in advance
 

oldbarba

Member
Jan 16, 2022
9
2
Hello everyone ! I don't know if this question has been asked before, I'll try my luck. I have owned a CC3 for 6 months and since then I have not been able to access 4G. The sim that I put is however recognized and functional in another teyes device but not in the CC3. Is there a particular manipulation (I'm in France)

thanks in advance
if u have unlocked sim card and no problem with sim slot on your unit (sim card recognized) maybe u need to manualy input a APN settings on your unit for that sim card and your carrier and dont forget to reboot
 
Last edited:

oldbarba

Member
Jan 16, 2022
9
2
ok but the problem is i can't find the amplifier remote cable on my car a 2013 volkswagen beetle,can you help me?View attachment 5511109
i dont own that car,u have to look shematic diagram from your old unit or on internet with part numb and name of that conector or u have to search someone on youtube who allready done that conversion..i read litlle about your problerm and find that vw use digital turn on trough canbus so u probably need some adapter this headunit take look this video and questions&answers below
 
Last edited:

JMM44700

Senior Member
Jun 17, 2018
75
20
Orvault
Hello, on CC3 6/128GB with last update 01/12/2021, in FM radio mode, the GPS cuts the radio sound well, but does not emit any sound. Voice prompts are muteis .This problem known?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )
    OBD2.jpg


    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    3
    hi,

    it looks like your Wiring is mixed up, as the red should be constant 12V (battery) and yelllow should be ACC.

    try to reconnect them and check again. is should solve your problem.

    Eli.
    That's not necessarily the case. In the normal world, red is usually 12v constant from battery. However, in Chinese android head unit land, I've seen yellow be 12v constant.

    Best advice is to check schematics for your car and the schematics for the CC3. Not a bad idea to check source voltage with a multimeter as well.

    CC3 diagram can be found here:


    The G plug has B+ for 12v constant and ACC pins.
    3
    Be very careful about adjusting the backlight settings.

    I don't know if they've improved the UI experience from before, but if they haven't you can get yourself into a situation where you may need to do a factory reset or maybe that won't even help.

    On older models, I've read about people adjusting the settings so that the screen is unreadable and then, because the screen is unreadable, they can't revert the settings as they can't figure out where controls are.

    And, write down the settings that work before you change them so that you can set them back, if needed.
    3
    The yellow on my car is 12v continuous supply and it's the same on the cc3 schematics. The g3 on cc3 is red wire and says it should go to ACC and i have connected it that way itself. The yellow g2 says B+ and thats how it is connected.
    I will try to reverse the connection and see once
    I concur - I always thought red is BAT, yellow is ACC - makes sense just by the color -, but I've met at least five Chinese head units and cameras where BAT was yellow and RED was ACC, from the factory, labeling, cable thickness. They could also mix them up, so better test it.
    2
    Hello members, i have a cc3 360 and i just installed it in my car. The connections are perfect and the yellow goes to the battery positive while the red to the acc. However everytime i shut down the car and leave it for 5 or 10 min the unit hard restarts with teyes booting logo. No way it stays in sleep mode and unable to wake in quick seconds.

    What could be wrong with the settings, or is it a firmware issue.

    Edit : the sleep mode under factory >168> sleep mode is on. Its not off
    hi,

    it looks like your Wiring is mixed up, as the red should be constant 12V (battery) and yelllow should be ACC.

    try to reconnect them and check again. is should solve your problem.

    Eli.
  • 7
    Teyes announced another CC3 update for April 2021, here is the translated changelog.



    The following important updates are expected to be released for the CC3 software at the end of April.
    The new version will add the following features:

    1.Added Cam REC software. With this application, you can record from a rear view camera. The recording files are saved to a flash card.

    2.Added TEYES YAHU, the world's first 3D music player for the automotive industry (due to technical complexity, work may not be completed in April).

    3.In the device settings, a function has been added to change the screen brightness depending on the time of sunrise and sunset.

    4.The system version has been updated. Fixed the issue of crashing the Google Play app in some areas.

    5.Added setting for the sensitivity level of voice commands. If you feel that certain keywords easily trigger voice commands, you can lower the sensitivity level. In addition to Russian and English, a voice control function has been added for 7 countries.

    6.Added CAR LINK software which supports Android Auto via wired connection and Car Play via wired and wireless connection. Please note that CARPLAY only supports this feature on CC3 devices released in 2021. Android Auto has no limits. For CARPLAY wired connection, you must use the original iPhone USB cable. When using CARPLAY wirelessly, make sure the mobile phone is connected via Bluetooth.

    7.Updated EQ software and added a phase switch. The volume and sound effects of the subwoofer change according to the volume of the head unit.

    8.Added a new layout for the main screen, as well as automatic switching between day and night modes. From the home screen, you can directly speed dial, view driving data, compass and GPS information. The 4 main music players can be switched with one key. Redesigned and increased image size when viewed in picture-in-picture mode.

    9Optimized software for making Bluetooth phone calls. Added a choice of avatars in favorite contacts. Opened data synchronization with the main interface.

    10.Added TEYES RADIO and private internet station. Musical compositions can be downloaded and shared through the site mp3.teyes.ru

    11.Steering Wheel Key Customization Tutorial has been added for multiple languages.

    12.Added automatic OTA update function. In the future, we will provide 2 update methods: manual download update and automatic update.

    13.Added multi-finger touch control function. To find out how to use this feature, please see the personal settings section.

    14.Added the ability to slide the application menu to the right side of the screen. Swiping from below returns to the previous level. The function is supported no matter which interface you are in!
    5
    Hi. earlier you said taht you dont't recommend buying Teyes for people outside Russia and now, that Teyes focuses on European region. What about other countries from Europe other than Russia? I'm from Poland and I own Ford Focus mk 3 (2011-1015)
    I am in France, and my CC3 gives me complete satisfaction on my Ford Focus 2. I do not see what the restrictions would be due to the development by the Russians
    5
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )
    OBD2.jpg


    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    5
    Upcomming CC3 update screenshots:

    cc3_may2021_1.jpg


    cc3_may2021_2.jpg
    4
    I want wipe dalvik cache.but I dont know how
    unpack this to usb stick and plug into HU usb port, just like usual firmware update. it will clear cache