Hardware Development TEYES CC3

Search This thread


Jun 13, 2022
Alibaba confirmed that the CC3 doesn't use a canbus decoder for my car (2019 Toyota Tacoma) because it's not a "premium vehicle".

What am I missing out on without the Canbus decoder? They told me steering wheel controls still work. Will the head unit just not be able to tell when the door is open, etc?

Can I use the canbus decoder from my Joying unit on the CC3?
Don't even buy from teyes, I have the canbus and it still doesn't work, save yourself the headache.
I've got an issue with my CC3 that the seller doesn't seem to be able to give any guidance on, and it's a weird one. I installed a sub in my car right before this started happening, so it may be related. Every once in awhile, maybe every 5th time I start the car, only the sub has any audio, the rest is silent. After a lot of troubleshooting, I discovered that unplugging the canbus decoder and plugging it back in (while still running) was the only thing that would bring the music/sound back to the regular speakers. The sub is the only thing plugged into the harness, which has like 4 other RCA connections. My car only has 2, so it normally works with the other harness. I tried plugging in the 2 RCA cables for my car's factory amp to each of the 4 on the same harness as the sub, but I get no sound at all from any of them.
I also noticed that while my SWC and such work (canbus controlled), if I go to the car settings for canbus type, it appears to be reset. Has anyone run across this before ? The only solution I can think of so far is to wire a switch to the dash to toggle power to the canbus decoder when it goes quiet, since taking the stereo out every other day is bananas.
I know this is an old post, but did you ever figure out what was wrong? Same thing is happening to my cc3


Jul 19, 2019
I see some posts with the gordgelin firmware, but I wondered how exactly to get this, I have found a link to the website, but it is all in Russian, so it is not really clear to me, is this firmware even English?
And does it have any disadvantages or non working issues compared to the Teyes firmware?


Senior Member
May 4, 2010
I see some posts with the gordgelin firmware, but I wondered how exactly to get this, I have found a link to the website, but it is all in Russian, so it is not really clear to me, is this firmware even English?
And does it have any disadvantages or non working issues compared to the Teyes firmware?
Use a modern browser and right-click to translate.
The firmware is Chinese, like the original Chinese firmware and just like the current CC3 firmware you have.
It has tweaks. bugfixes, some extras and the old partition scheme, which gives the "advanced" user a lot of extra possibilities.


Senior Member
Jun 9, 2021
New firmware 6/5/22 for cc3 is in the wild. Gordgelin has it in his modified firmware. Not sure of changes though from previous release. Maybe bug fixes?


New member
May 31, 2016
Hi everyone, I'm about to buy a cc3 for my Toyota rav4 2014, I will definitely buy it on the official website since they have a good price. I wanted to ask you if anyone has had problems mounting this cc3 on a vehicle like mine.I also wanted to understand if the buttons on the steering wheel work and if I can use my rear camera without having to buy other components, I would also like to know if the microphone is also connected. it is installed as standard on my car, thanks


Jun 13, 2022
Hi, I've contacted t'eyes yesterday, since I bought it from them. But haven't had a response yet. I'm going to try and see if an update works.
It only stopped working when I tried to install a back camera, and connect it to the ACC cable. However even if I remove the back camera ACC cable again It still doesn't work.

I've tried updating it but when it tries to update it only show about 75% on the installing update page and then tries to restart, which then again shows the no command message with a dead android.
Did you figure out what the problem was? I have the same issue


New member
Nov 13, 2012
Sometimes I have this issue where the CC3 display doesn't turn on when I turn the car on. It seems like the CC3 itself does turn on because tapping on the (blank) screen does seem to hit buttons that do things. Either way, the only way I can get the screen to turn on is to turn off the car and turn it back on again.

Is this a common problem? What should I do? I bought my CC3 from Teyes Australia just under a year ago and am on the January firmware. The problem only started recently.


Jun 13, 2022
Hi all, I've only had my t'eyes CC3 recently, but I have problem where it won't turn on unless I push and hold the 'rst' button, and then it either shows a dead android with 'no command' text, or it will boot up but the touch screen won't work. And if I release the 'rst' button it will turn off again.

Any thoughts?
How did you resolve the RST button issue? I'm hiding the same problem, when I release the RST button the unit turns off.


New member
Jun 24, 2022
Hello, I want to update my CC3 on latest firmware, but due to internet disocnnections, I am unable to get that download, and now my attempts are ended. Can anybody help me get that?



Senior Member
Jun 9, 2021
Really you asked for a firmware link because you had trouble downloading and know what are the changes?
Last edited:


Senior Member
Oct 30, 2020
Hi everyone, I'm about to buy a cc3 for my Toyota rav4 2014, I will definitely buy it on the official website since they have a good price. I wanted to ask you if anyone has had problems mounting this cc3 on a vehicle like mine.I also wanted to understand if the buttons on the steering wheel work and if I can use my rear camera without having to buy other components, I would also like to know if the microphone is also connected. it is installed as standard on my car, thanks
What's the official website?


Senior Member
Jun 9, 2021
The 15/01 firmware is the latest official firmware for the CC3.
The CC3 360 has different firmware. The site I linked to is not a official site as the official firmware is via OTA and as you found out for reason only known to Teyes they lock you out after so many tries.
I am unsure of what you are looking for as you asked for help obtaining firmware for CC3 which I provided. Perhaps you need to be more clear in your requests for help from the forum.


Senior Member
May 14, 2021
I would like to load onto my HengCheng which is same mfg number as medke #116. I want the 32 eq app instead of 16 for my ROHM32107. My current eq app which is same as medke sucks and the "subwoof" setting hi and low crossover doesnt work. Sorry you are right should have been more clear and detailed.


Aug 7, 2017
I’m unable to install the OTA, anyone know what could be wrong?


  • 2845EEE4-CE41-4867-974C-C317740424CC.jpeg
    3.2 MB · Views: 54
  • E784895B-2244-4788-B599-C54267C5D5D7.jpeg
    2.6 MB · Views: 54

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Thanks for the response. Here's a couple more questions if you don't mind.
    • What can you tell me the screen quality? more specifically its brightness under (almost) direct sun light? I had another (rater crapy) android unit before, and regretted buying it, because the screen was so dim that I couldn't read it most of the time.
    • Is the software too buggy? Too many pay walls? From 1 to 10, how do you rate the software?
    • Did you try the external mic?
    Screen quality is very good however in my car I did have issues with glare in sunlight. I do have a panoramic roof. I bought an anti glare screen protector which seems to help. The brightness is good on the display and it is sharp and vivid. The software can have its moments but I’d say 9 out of 10 compared to other fyt machines I’ve used.
    Yes I do have the external mic connected. I’m completely disabled the internal one.
    Hi all.

    I have the cc2+. To which Ive had it since launch as at the time the cc3 only existed once I received my cc2+. What was annoying was that they wouldn't comfirm a new model was on the horizon and said I may as well just order.

    I have the 6gb 128gb version as I have bad memory's of the 1gb versions from 2016.

    Overall it's a great device however it's not hard to understand that this device has been forgotten by Teyes even though it's 95 percent the same as the cc3.

    Anyway I've played with a few of the cc3 ROMs however I reached out to @gordgelin over his Vincent Vega edition and installed it. It works amazingly.

    It allows for control of the fan, android auto just works wirelessly as it should and the additional features such as access to the original settings and the tweeks that have been made are great.

    If your on a cc2+ I really recommend this.
    Desoldering isn't necessary. There's instructions somewhere in this thread to tape the 2 mic pins on the ribbon cable. I just desoldered to be extra sure.

    I ended up finding how to access Engineer Mode via our Russian friends at 4pda.to. It involves opening the calculator app and entering a secret code (too afraid to link it since it's easy to permanently screw up you unit but if you search, you'll find it). Regardless, this was not helpful as there's no microphone level setting in there (also confirmed by people on 4pda.to). Maybe there's another secret settings menu I'm not aware of via Phone app?

    I just ordered a mic pre-amplifier https://www.amazon.com/gp/product/B08JHWSX2C/. It's cheaper on Aliexpress but didn't want to wait 2 weeks. It's not an ideal solution but I'm hoping it helps.

    Ooh, may try this. Any pointers for which files you changed and what settings you used?
    The information was in the main hardware post.


    Pop the above in a config file and reflash the firmware.
    A humbling experience this is.. marchnz is going to enjoy it.

    I found the fault. A loose pin in the supplied kia connector.
    When I used my flash multimeter I must have been push enough to make contact with the steering wheel circuit resistance.
    Plug it into the AHU, and it would go open circuit.

    I only found it because I managed to loosen the single USB pins for the factory USB.

    Giant Dummy
    This is a common problem in this type of pinout! Not exclusive to T'eyes
    I've grabbed everything I know so far and put it in here Teyes Radio App - missing icons, station information, and How to use
    Could you have a look and see what you think.
    images are 180x180, not 150x150. That might be part of the issue? As far as FMBD.txt, I cant tell from your but make sure there are no spaces after the commas. Other than that, it looks right. I have this fully working on my end so the only real discrepancy i see is your image sizes
  • 7
    Teyes announced another CC3 update for April 2021, here is the translated changelog.

    The following important updates are expected to be released for the CC3 software at the end of April.
    The new version will add the following features:

    1.Added Cam REC software. With this application, you can record from a rear view camera. The recording files are saved to a flash card.

    2.Added TEYES YAHU, the world's first 3D music player for the automotive industry (due to technical complexity, work may not be completed in April).

    3.In the device settings, a function has been added to change the screen brightness depending on the time of sunrise and sunset.

    4.The system version has been updated. Fixed the issue of crashing the Google Play app in some areas.

    5.Added setting for the sensitivity level of voice commands. If you feel that certain keywords easily trigger voice commands, you can lower the sensitivity level. In addition to Russian and English, a voice control function has been added for 7 countries.

    6.Added CAR LINK software which supports Android Auto via wired connection and Car Play via wired and wireless connection. Please note that CARPLAY only supports this feature on CC3 devices released in 2021. Android Auto has no limits. For CARPLAY wired connection, you must use the original iPhone USB cable. When using CARPLAY wirelessly, make sure the mobile phone is connected via Bluetooth.

    7.Updated EQ software and added a phase switch. The volume and sound effects of the subwoofer change according to the volume of the head unit.

    8.Added a new layout for the main screen, as well as automatic switching between day and night modes. From the home screen, you can directly speed dial, view driving data, compass and GPS information. The 4 main music players can be switched with one key. Redesigned and increased image size when viewed in picture-in-picture mode.

    9Optimized software for making Bluetooth phone calls. Added a choice of avatars in favorite contacts. Opened data synchronization with the main interface.

    10.Added TEYES RADIO and private internet station. Musical compositions can be downloaded and shared through the site mp3.teyes.ru

    11.Steering Wheel Key Customization Tutorial has been added for multiple languages.

    12.Added automatic OTA update function. In the future, we will provide 2 update methods: manual download update and automatic update.

    13.Added multi-finger touch control function. To find out how to use this feature, please see the personal settings section.

    14.Added the ability to slide the application menu to the right side of the screen. Swiping from below returns to the previous level. The function is supported no matter which interface you are in!
    Hi. earlier you said taht you dont't recommend buying Teyes for people outside Russia and now, that Teyes focuses on European region. What about other countries from Europe other than Russia? I'm from Poland and I own Ford Focus mk 3 (2011-1015)
    I am in France, and my CC3 gives me complete satisfaction on my Ford Focus 2. I do not see what the restrictions would be due to the development by the Russians
    Check if the OBD has good connection with the car socket. Pull it out and put it in again. Scan for Bluetooth devices and you must find it there. Also check the pins on the OBD adapter and the car socket, to see if there are any bent pins that don't connect properly. Also I think I heard somewhere that it's good to connect the OBD before you start the engine.
    Thank you for the advice. I did all of the above, but unfortunately with the same result as before.
    The CC3 sees the OBD2 adapter in the Bluetooth menu, but after some time attempting to connect I get a "Connected Unsuccessfully" message ( or at least that is what I believe it says, because the message is cut off )

    Also I would like to do a follow up regarding the new firmware. I can confirm that with it the device remains in sleep while the ignition of the car is off, even after 1h and 45min once the ignition was turned on the device woke up instantly. Where as before with the original firmware, after about 5min the device would do a clean / full boot.

    And for those looking to get Google assistant working a possible workaround would be to trigger the assistant via one of your steering wheel buttons.
    #1 go to Settings / General
    #2 Set the Google Assistant as the Navi App option
    #3 Go to Settings / Device / Steering Wheel Setting
    #4 Map one of your steering wheel buttons to launch the Navi app.

    Now just before anyone get way too excited, this is not a perfect solution.
    While I'm able to do things like opening apps ( YouTube, waze, 360 panorama app ) asking for direction via google maps, playing specific Playlist via Spotify. I discovered that it's not possible to make or receive phone calls via the assistant, and most likely there are other things that I did not test or discovered.
    Upcomming CC3 update screenshots:


    I want wipe dalvik cache.but I dont know how
    unpack this to usb stick and plug into HU usb port, just like usual firmware update. it will clear cache