Question That pesky visual voicemail problem with Google Phone

Search This thread

manjaroid

Senior Member
Jun 25, 2019
250
106
I suppose this could have been posted anywhere in XDA but since I just got a Pixel 6 I though I'd start here.

I'm using Mint Mobile and it's all good except visual voicemail in Google's Phone app won't activate. The My Visual Voicemail app activates and works fine. Calling voicemail works fine too.

The problem seems common for OnePlus users on T-Mobile's network but it's evident this is an old problem between lots of devices and carriers. And oddly, it seems to work or not under random conditions. When I sampled a Pixel 5a for a couple weeks using the same SIM, visual voicemail in the Phone app worked straight away and transcribed accurately.

So that nobody here wastes their time with suggestions, I've researched the problem and have probably already tried the most common suggestions short of factory reset. The only thing Mint Mobile can offer is resetting voicemail for a clean slate, which didn't help. Prior to that, network resets, clearing cache and data in both the Phone and My Visual Voicemail apps, rolling back the Phone app, many reboots and power downs... Whatever is tried I get the dreaded "Visual voicemail isn't working" error with or without My Visual Voicemail installed and activated.

I really like this feature in Google Phone when it works. I'm ok with moving on to an alternative like Google Voice for transcribed voicemail but I'm hard headed about getting something to work as designed. If anybody has figured this out I'd appreciate hearing from you.

Thanks!
 
  • Like
Reactions: jefffrom

opz187

Senior Member
Sep 30, 2012
1,458
480
I suppose this could have been posted anywhere in XDA but since I just got a Pixel 6 I though I'd start here.

I'm using Mint Mobile and it's all good except visual voicemail in Google's Phone app won't activate. The My Visual Voicemail app activates and works fine. Calling voicemail works fine too.

The problem seems common for OnePlus users on T-Mobile's network but it's evident this is an old problem between lots of devices and carriers. And oddly, it seems to work or not under random conditions. When I sampled a Pixel 5a for a couple weeks using the same SIM, visual voicemail in the Phone app worked straight away and transcribed accurately.

So that nobody here wastes their time with suggestions, I've researched the problem and have probably already tried the most common suggestions short of factory reset. The only thing Mint Mobile can offer is resetting voicemail for a clean slate, which didn't help. Prior to that, network resets, clearing cache and data in both the Phone and My Visual Voicemail apps, rolling back the Phone app, many reboots and power downs... Whatever is tried I get the dreaded "Visual voicemail isn't working" error with or without My Visual Voicemail installed and activated.

I really like this feature in Google Phone when it works. I'm ok with moving on to an alternative like Google Voice for transcribed voicemail but I'm hard headed about getting something to work as designed. If anybody has figured this out I'd appreciate hearing from you.

Thanks!
I'm on TMobile and had the same issue. You need to remove all visual voicemail apps and carrier visual voicemail apps. Just uninstall them. Then go into Google phone and set up visual voicemail through settings and whatnot.
 

manjaroid

Senior Member
Jun 25, 2019
250
106
You need to remove all visual voicemail apps and carrier visual voicemail apps
Thanks, but I tried that. Mint doesn't have their own vvm app like T-Mobile does and they recommend My Visual Voicemail which activates every time it's reinstalled. I'm talking myself into a factory reset but don't know if I should remove the SIM or leave it.
 

utnick

Senior Member
Nov 8, 2009
345
158
Texas
I'm on TMobile and had the same issue. You need to remove all visual voicemail apps and carrier visual voicemail apps. Just uninstall them. Then go into Google phone and set up visual voicemail through settings and whatnot.
Had you tried the t-mobile app first? I wanna know if the google version is better.
 

opz187

Senior Member
Sep 30, 2012
1,458
480
Thanks, but I tried that. Mint doesn't have their own vvm app like T-Mobile does and they recommend My Visual Voicemail which activates every time it's reinstalled. I'm talking myself into a factory reset but don't know if I should remove the SIM or leave it.
I'm confused. Are you saying you don't have any vvm apps installed already? If you do just humor me and try to remove all voicemail apps again and try Google dialer after. I had the same issue and for the life of me could not figure out how to use Google vvm, & it finally worked after all voicemail apps were uninstalled
 

jefffrom

Senior Member
Oct 19, 2016
362
124
Im on Tello mvo off t-mobile same thing T-mobiles app works but who want more 3rd party apps , googles never worked not on a pixel phone but its a common problem Ive flashed many roms currently on Arrow12 poco f-3 but it never worked on stock and all other roms ivied flashed so I just call VM its the best solution so far
 

manjaroid

Senior Member
Jun 25, 2019
250
106
Are you saying you don't have any vvm apps installed already? If you do just humor me and try to remove all voicemail apps
No third party vvm or vm apps separate from Google Phone are installed. Whenever a vvm app was installed it was temporary. I understand that no other voicemail apps should be installed while using Google Phone's vvm.

First I tried getting Google Phone's vvm to activate. It never did after lots of trouble shooting (cleared storage in Phone, reset networks, rolled back Phone etc.). I installed My Visual Voicemail just to make sure it would activate. It does activate and works as expected. Knowing Mint's voicemail works fine with this app and probably others, and that calling voicemail works, focus is on Google Phone and/or the phone network.

The part that really peeves me is that Google Phone's vvm worked great on a Pixel 5a recently with the same SIM.
 

EtherealRemnant

Senior Member
Sep 15, 2007
3,256
897
37
Denver, CO
Im on Tello mvo off t-mobile same thing T-mobiles app works but who want more 3rd party apps , googles never worked not on a pixel phone but its a common problem Ive flashed many roms currently on Arrow12 poco f-3 but it never worked on stock and all other roms ivied flashed so I just call VM its the best solution so far
VVM works fine on Tello on my 3 XL. I just had to turn off wifi before I enabled the VVM switch, it wouldn't provision with wifi.
 

mac796

Senior Member
Aug 20, 2014
1,357
472
Long Beach
Wasnt working for me either. I decided to uninstall TMobile vvm and try it again and now the Google one is working. Maybe January fixed it for me.
 
I have RedPocket on AT&T's network. When I had the OnePlus 7t I had the same VVM issues the OP described. They reset stuff on my account & SIM with no luck. It had worked fine on the Pixel 3 I had before and it's working fine on the Pixel 6 I have now. It's probably as much a OnePlus problem then anything.
 

manjaroid

Senior Member
Jun 25, 2019
250
106
I just had to turn off wifi before I enabled the VVM switch
I read about trying this but in my case it didn't help.

I notice Mint Mobile's store recently added the Pixel 5a to their offerings but not the 6, yet. This has me wondering if there's a provisioning issue on the carrier side.

However, Mint customers in recent reddit posts describe a mixed bag that show no pattern at all. For some Pixel 6 users Google's vvm works but not for others.

https://www.reddit.com/r/mintmobile/comments/s7xyvq
 

EtherealRemnant

Senior Member
Sep 15, 2007
3,256
897
37
Denver, CO
I read about trying this but in my case it didn't help.

I notice Mint Mobile's store recently added the Pixel 5a to their offerings but not the 6, yet. This has me wondering if there's a provisioning issue on the carrier side.

However, Mint customers in recent reddit posts describe a mixed bag that show no pattern at all. For some Pixel 6 users Google's vvm works but not for others.

https://www.reddit.com/r/mintmobile/comments/s7xyvq
Does the phone recognize your Mint SIM as being T-Mobile? I know that has caused problems before.

Honestly the MVNO situation with iPhone, Samsung, and Pixel can be really messy. My 12 Pro Max still doesn't get 5G on most T-Mobile MVNOs because T-Mobile moved them to new SIM cards that the T-Mobile bundle doesn't recognize (8901240 instead of T-Mobile's 8901260) and I've seen a wide range of complaints about MVNOs not working right on Pixels. I think it was Red Pocket that was being seen as "zipsim" or something on Pixels and broke a lot of features.

Buddy of mine got a 6 and he reported that Tello's VVM does not work so yeah, I guess I'll find out when I buy my 6 or 6 Pro in a few months.
 

finshan

Senior Member
Jan 17, 2018
106
21
I suppose this could have been posted anywhere in XDA but since I just got a Pixel 6 I though I'd start here.

I'm using Mint Mobile and it's all good except visual voicemail in Google's Phone app won't activate. The My Visual Voicemail app activates and works fine. Calling voicemail works fine too.

The problem seems common for OnePlus users on T-Mobile's network but it's evident this is an old problem between lots of devices and carriers. And oddly, it seems to work or not under random conditions. When I sampled a Pixel 5a for a couple weeks using the same SIM, visual voicemail in the Phone app worked straight away and transcribed accurately.

So that nobody here wastes their time with suggestions, I've researched the problem and have probably already tried the most common suggestions short of factory reset. The only thing Mint Mobile can offer is resetting voicemail for a clean slate, which didn't help. Prior to that, network resets, clearing cache and data in both the Phone and My Visual Voicemail apps, rolling back the Phone app, many reboots and power downs... Whatever is tried I get the dreaded "Visual voicemail isn't working" error with or without My Visual Voicemail installed and activated.

I really like this feature in Google Phone when it works. I'm ok with moving on to an alternative like Google Voice for transcribed voicemail but I'm hard headed about getting something to work as designed. If anybody has figured this out I'd appreciate hearing from you.

Thanks!
Have you tried activating it over mobile data?

I switch phones a lot and have had your issue several times, most recently on my pixel 6. Disabling wifi while I opened the voicemail got it working, and it has in the past as well. (Might want to force stop and clear data and etc, maybe a reboot, then try on mobile data only.)
 

manjaroid

Senior Member
Jun 25, 2019
250
106
Does the phone recognize your Mint SIM as being T-Mobile?
No, it's recognized as Mint in network settings plus the voicemail number that was setup is Mint's. The APN that's automatically configured is T-Mobile's but switching to Mint's wholesale APN makes no difference.

Doesn't mean you're not onto something. One difference between the Pixel 6 and 5a setups (again, Google's vvm worked on the 5a) is that Play Store installed a T-Mobile app on the Pixel 6 on its first day. I didn't think much of it until I saw a T-Mobile option under Default apps settings. Can't remember what that setting was but it didn't seem related to voicemail. When I uninstalled this app the setting under Default apps disappeard. Which was a relief because for a moment I broke out in a sweat thinking the T-Mobile model was shipped. I verified my phone is the unlocked model.

Over the weekend I may unlock the bootloader and root. Maybe wiping will make a difference.

Btw, Mint does in fact sell the Pixel 6, they're just out of stock.
 

manjaroid

Senior Member
Jun 25, 2019
250
106
Have you tried activating it over mobile data?
Yes, many times usually connected to 5G. Tried setting LTE as the preference too.

I'm resigning myself to an alternative like Google Voice or Youmail. A friend with a OnePlus 8T TMO variant has never gotten native vvm to work with T-Mobile's network. His unanswered calls go to Google Voice and the Phone app's vvm works well with it.
 
Last edited:

manjaroid

Senior Member
Jun 25, 2019
250
106
Same issue here! (Mint Mobile user)
Thanks for chiming in. Parts of that subreddit are informative while most of it repeats other articles I've seen. It's a mystery wrapped in a riddle but one thing is certain: if T-Mobile boffins can't figure it out no point in asking Mint about it unless we want the usual "Don't support it" or "Can't guarantee it" nonsense.

Interesting that there's a Mint voicemail number (18056377243) different than the one assigned by my Mint SIM (18056377456). We could try different numbers but the setting is greyed out in the Phone app. Changing the number would require removing the SIM to make the field editable but it'll probably revert back to the original number when the SIM reconnects.
 

EtherealRemnant

Senior Member
Sep 15, 2007
3,256
897
37
Denver, CO
Thanks for chiming in. Parts of that subreddit are informative while most of it repeats other articles I've seen. It's a mystery wrapped in a riddle but one thing is certain: if T-Mobile boffins can't figure it out no point in asking Mint about it unless we want the usual "Don't support it" or "Can't guarantee it" nonsense.

Interesting that there's a Mint voicemail number (18056377243) different than the one assigned by my Mint SIM (18056377456). We could try different numbers but the setting is greyed out in the Phone app. Changing the number would require removing the SIM to make the field editable but it'll probably revert back to the original number when the SIM reconnects.
Just FYI, the one Tello uses where my VVM works on my 3 XL is the same as Mint is using.

At this point it seems like an issue specific to 6/6 Pro because I have confirmation of VVM working on T-Mobile MVNOs with 3/4/5 and two people I know could not get it working on 6/6 Pro, both with Tello, who had it working on their last Pixel.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I suppose this could have been posted anywhere in XDA but since I just got a Pixel 6 I though I'd start here.

    I'm using Mint Mobile and it's all good except visual voicemail in Google's Phone app won't activate. The My Visual Voicemail app activates and works fine. Calling voicemail works fine too.

    The problem seems common for OnePlus users on T-Mobile's network but it's evident this is an old problem between lots of devices and carriers. And oddly, it seems to work or not under random conditions. When I sampled a Pixel 5a for a couple weeks using the same SIM, visual voicemail in the Phone app worked straight away and transcribed accurately.

    So that nobody here wastes their time with suggestions, I've researched the problem and have probably already tried the most common suggestions short of factory reset. The only thing Mint Mobile can offer is resetting voicemail for a clean slate, which didn't help. Prior to that, network resets, clearing cache and data in both the Phone and My Visual Voicemail apps, rolling back the Phone app, many reboots and power downs... Whatever is tried I get the dreaded "Visual voicemail isn't working" error with or without My Visual Voicemail installed and activated.

    I really like this feature in Google Phone when it works. I'm ok with moving on to an alternative like Google Voice for transcribed voicemail but I'm hard headed about getting something to work as designed. If anybody has figured this out I'd appreciate hearing from you.

    Thanks!
    1
    Same issue here! (Mint Mobile user)

    We are pulling our hair out on the Pixel subreddit:

    Pixel Subreddit Link
    1
    VVM works fine on Tello on my 3 XL. I just had to turn off wifi before I enabled the VVM switch, it wouldn't provision with wifi.
    This did the trick for me, tried most suggestions here. with tmobile's app uninstalled, and wifi off I was able to provision on the tmobile network.