• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

The Complete Noob Guide To Getting Read/Write Access On The Moto One 5G Ace XT2113 [Qualcomm Variant]

Search This thread
As @RETIEF stated, and I confirmed, that is exactly what he suggested. Came up with a solid plan. Taking a bit to get it executed and complete but I still have hopes. Following three guides in total to get the desired results is a quest to say the least. LOL
@RETIEF or anyone else that knows the whole root process on the N00B's guide... I posted the following over there but since I got some direction from this thread I figured I would ask here too as I am sitting in a holding pattern and don't know what to do!!!

Need Help Please...

So I am at step 33, the whole time following EVERY step exactly as directed. However, 33 states...
33. In Minimal ADB and Fastboot type "fastboot flash boot boot.img" and hit enter.

When I do that, this is what I get...
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash boot boot.img
target reported max download size of 805306368 bytes
sending 'boot_b' (98304 KB)...
OKAY [ 2.400s]
writing 'boot_b'...
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 2.490s

This is the second time going through all this thinking I missed something and now I am sitting in a holding pattern. Please someone assist! Thanks in advance.

*will be waiting with fastboot on screen*
If your phone is a AT&T or Verizon variant that error is letting you know it's not going to let you flash the phone. Again, I cannot guarantee those variants as they are usually tough cookies.

Also, what guide are you on, this one does not have a step 33.
 

Paul_Neocube

Member
Aug 7, 2021
28
6
Android Wear
Moto G 5G
If your phone is a AT&T or Verizon variant that error is letting you know it's not going to let you flash the phone. Again, I cannot guarantee those variants as they are usually tough cookies.

Also, what guide are you on, this one does not have a step 33.
I was on the first one out of the three mentioned earlier but it doesn't matter anymore. Apparently my phone has a defect where it will not give an unlock code to start the unlock procedure. Again, I am screwed. Usual.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Update: I used Version 2 with no problems. According to @munjeni there are BIG DANGEROUS ISSUES with Version and newer. Starting at V7 there are clone issues. I have tried Version 9 and had those issues.

    Using the V2 method you will be able to delete and remove files. The ability to resize the partitions has not been achieved, so you will be at the mercy of the space limitations in the partition.



    This tutorial is for people like me that after rooting the Moto One 5G Ace XT-2113 (MetroPCS Qualcomm Variant) running on stock Android 10 discovered that their root did not grant them Write Access to system files. Starting with Android 10, a new System As Root protocol prohibits users from access all of their files due to Dynamic Partitions and being formatted to EXT4_FEATURE_RO_COMPAT_SHARED_BLOCKS, effectively making root useless. You can read about that here:
    Rest not, a method has been made!

    Follow the following at your own risk! I am not responsible for any mishaps with your devices and neither is @munjeni. I also don't know if this will work on other variants, as I only have tried this method on the RETUS and RETEU stock firmware. Also, this will NOT obviously work for Verizon, AT&T, and Cricket phones or other mobile carriers that lock their bootloaders.

    I want to thank a couple of people for their big beautiful brains and hard work in figuring this out. First, all the love in the world goes out to @lebigmac. This beautiful soul and I have been back and forth a week trying to get something going on the Moto. I thank him for his patience, his genius, and his tenacity to hang in there with my device even after I threatened a bunch of times to go to Apple and be done with this new cumbersome lockdown AndroidOS. He gave the hope as his method has worked on Asus and Xiaomi variants. It has been an honor to be on his beta test team.

    Last, but not least, I want to thank @munjeni whose method finally broke on through to the other side. If it were not for his big beautiful brain I’d be ordering me an iPhone and calling it quits. It is due to his and @lebigmac’s hard work researching and testing that gives us the ability to finally have full root access. Thank you guys. I love you both!

    And please visit both of their threads and help them continue support and development on this project for ALL of your Android 10 phones (especially this one).
    @lebigmac Method: [SCRIPT][Android 10+] Universal Mount System read write R/W
    @munjeni Method: [TOOL][WIN,LIN,AND,DARW] Super image unpack-repack tools

    Introduction/Preparation
    First, go and prepare by READING EVERYTHING I’M WRITING IN THIS POST BEFORE YOU START. Very important. Don't even jump into this without reading this thread here all the way to the end. This isn’t exactly child’s play if you are not comfortable with the ADB Shell or Linux, and if you type the wrong commands you could do serious, irreparable damage to your device. It also doesn’t hurt to read the original thread for this all the way through, and you can find that here: Munjeni's Superpack Repack Tool

    Second, make sure your bootloader is unlocked and you have Magisk root on your device. You can check the forum for tutorials on how to do that. This method will ABSOLUTELY NOT WORK if you are not bootloader unlocked, and rooted with your boot.img patched by Magisk. If you can’t figure out that part of it then you definitely aren’t prepared for this.

    ***NOTES SO YOU DON'T FREAK OUT***
    1. While it hasn’t happened to me, there is the possibility that you can brick your phone doing this. As such, make sure you have your firmware already downloaded and available to flash should something go wrong. This is just a precaution, a break glass in case of emergency situation. It’s better to have the files already ready to go with the flashfile commands converted and not need it than need it and frustrated because you didn’t prepare.

    2. There is no custom recovery/TWRP for this variant yet (and trust me I’m trying very hard to work on that), so you will have to use ADB Shell to run the commands we need for this exercise. If you are not familiar with that, please do some research on ADB Shell so you’re comfortable and familiar. Google for once is a friend for that!

    Files
    Here is a list of things you will need going into it.

    1. Windows 7. I did it in Windows 7 and Kali Linux so I can’t speak on whether or not this will work smoothly in other versions. This method is exclusively for Windows 7. Go to the original thread on info on how to use it on other platforms.

    2. Get Tiny ADB and Fastboot (it's easier to use than Android SDK and smaller) or whatever fastboot you’re comfortable with.

    3. Make sure the drivers for your Moto One 5G Ace are already downloaded and installed on your computer.

    4. @munjeni’s Super Unpack Repack Tool. Can’t get anywhere with the method without it. You can download it here from the first post: https://forum.xda-developers.com/t/tool-win-lin-and-darw-super-image-unpack-repack-tools.4120963/

    5. Root Explorer (or whatever your favorite type of system explorer is). There’s no getting into the system files without it.

    6. Busybox. I used Busybox Pro 70 that I had from my MotoG7Power and that worked flawlessly. A newer version of Busybox did not install on my device because I didn’t have Write access going into it but that version I can attest works.

    7. Stock Firmware (Just in case, remember?) I used XT2113_KIEV_RETUS_10_QZK30.Q4-40-55_subsidy-DEFAULT_regulatory-DEFAULT_CFC_R1_CFC.xml which is the US Retail software and the XT2113-3_KIEV_RETEU_10_QZKS30.Q4-40-62-2_subsidy-DEFAULT_regulatory-XT2113-3-EU-SAR_CFC.xml instead of MetroPCS's firmware because I hate any branded US carrier bloatware and such and like that factory unlocked from the manufacturer feel. Both of my phones flashed fine with it and you can find it here: Moto One 5G Ace ALL Firmwares. It doesn't matter what your carrier is, they have them all there.

    8. The stock charging cable that comes with your phone.

    The Process
    1. Make sure the phone is at least halfway charged. Last thing you want is the phone to die in the middle of any of this and cause a system error that you might can’t get out of.

    2. Make sure your have installed your Root Explorer and Busybox beforehand.

    3. Extract @munjeni’s Super Unpack Repack Tool. Copy the file “superrepack.arm64_pie” to your phone.

    4. Rename “superrepack.arm64_pie” on your phone to “superrepack” (obviously without quotations).

    5. Move “superrepack” file on your phone to /data/local/tmp folder. If you have root and using a root explorer you can’t miss it (obviously without quotations).

    6. Connect your phone to your PC via the charging cable.

    7. Open TinyADB and Fastboot. Do not open it as an administrator or it will not function correctly getting root access on your device.

    8. Type: “adb shell” and press enter. This will change C:/TheNameOfYourDirectory to kiev:/ $

    9. Type: “su” and press enter. This will change the dollar sign “$” to a sharp symbol “#” and will look like kiev:/ # Make sure you allow permissions if Magisk asks for it or it will give you a permission denied message.

    10. Type: “ls -Alg /dev/block/by-name | grep "super"” and press enter since you need to know where your block device is. It should return a result that looks like “lrwxrwxrwx 1 root 16 1970-01-01 08:07 super -> /dev/block/NameOfYourBlock” (obviously without quotations except the quotations in "super" - keep those)

    11. Copy and paste somewhere “/dev/block/NameOfYourBlock” (obviously without quotations). You’re going to need that later.

    12. Close TinyADB and Fastboot. Now open a fresh instance of it in a new window.

    13. Type: “adb shell” (obviously without quotations) and press enter. This will change C:/TheNameOfYourDirectory to kiev:/ $

    14. Type: “su” (obviously without quotations) and press enter. This will change the dollar sign “$” to a sharp symbol “#” and will look like kiev:/ #

    15. Type: “chmod 755 /data/local/tmp/superrepack” (obviously without quotations) and press enter as the chmod command will give us root permissions to run the script. This is VERY IMPORTANT. Don’t worry if it goes to a blank next line that’s normal.

    16. Type: “setenforce 0” (obviously without quotations) and press enter as we need to disable selinux. Again, don’t worry if it goes to a blank next line as that’s normal.

    17. Type: “/data/local/tmp/superrepack /dev/block/NameOfYourBlock” (obviously without quotations) and press enter. Let the script run to the end.

    18. Reboot your phone. Close Tiny ADB and Fastboot.

    19. When your phone is rebooted go to Root Explorer (or your explorer).

    20. Mount the system in your file explorer! You should have R/W Access in ALL of your partitions.

    If Something Goes Wrong And You Have To Reflash Your Phone…
    Please refer to the guides in the forum on how to get your phone back to stock. There’s one for flashing, one for root, and a subsequent one for debloat.
    If you come up with an error, please go to the original thread https://forum.xda-developers.com/t/tool-win-lin-and-darw-super-image-unpack-repack-tools.4120963/ and let @munjeni know what the issue is so he can help.

    Hope this brings some love to the Moto One 5G Ace users. We definitely need a boost to lift development spirits.

    I will try and answer questions if I can or point you in the right direction.
    3
    https://forum.xda-developers.com/t/script-android-10-universal-mount-system-read-write-r-w.4247311/

    "moto g 5g" can use makeSystemRW v1.31.
    It must be used in conjunction with makesysrw_repair.
    makesysrw_repair requires linux.

    The size option will not work if it is too large or too small.
    You need to specify an appropriate size.
    Please adjust it by yourself.
    I got the right result with 20mb.

    adb shell
    su
    chmod +x /data/local/tmp/makesysrw_1.31/makesysrw.sh
    setenforce 0
    ./data/local/tmp/makesysrw_1.31/makesysrw.sh size=20
    2
    https://forum.xda-developers.com/t/...t-system-read-write-r-w.4247311/post-84914345

    Perhaps this will eliminate the need for makesysrw_repair.
    However, you will need an sd card.

    adb shell
    su
    chmod +x /data/local/tmp/makesysrw_1.31/makesysrw.sh
    setenforce 0
    cd /data/local/tmp/makesysrw_1.31
    ./makesysrw.sh size=20 out=/external_sd/super.img
    2
    You have it correct. Follow the guides exactly. I tried shortcuts and they all failed. As a result, I have none this process three times. Don't be me.
    1
    Alright yeah that makes me feel better.. Got stuck but going to try again later on as I have stuff to get done this morning. A lot to this guide lol