The Complete Noob Guide to Rooting MetroPCS XT1955-5 Qualcomm Variant

Search This thread
I'm fixing to get one of these G7 Power, (Swappa says it's "unlocked") - should I root it BEFORE taking it to Metro for the SIM (their SIM cards put stuff in the phone)

And (moderator, please forgive me) I find one vendor on ebay (Craiglist is useless), this is a FAR more complex process than last time I rooted a phone (like, 2016)... Security being a grave concern these days you'd think one could find folks providing this service. It's simply I've gotten OLDer and the process has gotten harder.

As it is, I'm without cell phone at all because of that demonic VoLTE thing, and I cannot afford to mess up (again) - hint: do not let a carrier talk you into accepting "Oh we give free phone to old PPL"... Very expensive error.

Unfortunately the method is getting complicated because they're locking down Android. And I wouldn't go with a G7 - it's not 5G and they are going to be booting people off the network next year that don't go over to 5G. Google it. Tmobile and ATT have already announced this earlier this year.
  • Like
Reactions: sd_shadow


Jun 24, 2020
I know this thread is from 2019, but you can install TWRP on a MetroPCS variant! It is as easy as putting twrp on a regular variant!

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    This tutorial is for people like me than ran into problems rooting the Moto G7 Power XT-1955-5 (MetroPCS Qualcomm Variant) running on stock Pie. I got two of these literally today brand new in the box after swapping out that mess Samsung Galaxy A20 crap.

    Follow the following at your own risk! I am not responsible for any mishaps with your devices. I also don't know if this will work on other variants, as I only have these for MetroPCS, and from my understanding this will NOT obviously work for Verizon, AT&T, and Cricket phones.

    I want to thank @diversenerd, and @jhjhjhjhjhjh for their hard work tinkering with the phone as I tried to figure it all out from their notes and instructions. And for the rest of the contributors that I took bits and pieces from that helped me figure out rooting this, as the information wasn't quite clear in some places and I got some bootloops.

    First, go and prepare by READING EVERYTHING IN THIS FORUM. Very important. Don't even jump into this without reading this thread here all the way to the last page: (this is so you know start to finish what worked for some might not work for this variant).

    Second, unlock the bootloader. The MetroPCS variant can be unlocked by Motorola; follow their instructions, it's easy peasy. If you do it in firefox it may not go to the third step page and hang on the page where you put the long code in (follow instructions on page to get the unlock code you'll see what I'm talking about). I did it in Firefox this go round and it sent the codes immediately . When you get it, follow Motorola's instructions for unlocking the bootloader in fastboot. It will show you that the bootloader is unlocked.

    1. Every time you power up the phone after you unlock the bootloader Moto will try and make you feel like crap with a bad key error in the middle of a nice message that your phone is not to be trusted. :laugh: This is normal. Give it a minute, you havent broke it.

    2. There is no custom recovery/TWRP for this variant, so read carefully so you don't delete something you might not be able to flash back later.

    3. OEM Unlocking toggle switch is interesting. On my first phone it was activated once the bootloader is unlocked and greyed out to where it couldn't be accessed anymore; On the significant other's phone it is still accessible and can be toggled even with the bootloader unlocked.

    There is confusion in some of the threads about leaving the Sim Card/SD Card in while flashing. Yes, pull it out and flash without it. Flashing with the sim card/SD card in can cause problems flashing. I did my first phone without it, but forgot to take it out with my second and had to start from scratch. Avoid that step.

    1. Get Minimal ADB and Fastboot (it's easier to use than Android SDK and smaller).
    2. Download the Motorola Drivers from their site (if you run into problems you will have to uninstall and reinstall them through their utility which is found on PC here: C:\Program Files\Common Files\Motorola Shared\Mobile Drivers
    3. Cpu-Z.apk (This is a good thing to have to know your hardware responsibly).
    4. Stock Firmware. I used XT1955-5_OCEAN_RETUS_9.0_PPO29.114-63-2_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml which is the US Retail software instead of MetroPCS's firmware because of the issues I was having with it straight out the box. Both of my phones flashed fine with it and you can find it here: I used the 2nd one with success - the first one doesn't play nice with Magisk.
    5. MagiskManager-v7.3.2 apk.
    6.The Boot .img separately extracted from the Firmware listed in Step 4.
    7. Root Checker.apk
    8. Patience (and a good movie keeping you going).

    1. Make sure the phone is fully charged.
    2. Make sure your sim card and SD card is REMOVED from the phone. Again, this is to prevent problems in the flashing.
    3. Make sure your wifi is OFF. Every time you wipe the phone or do anything messing with the boot image the phone resets itself to factory settings, and immediately pushes updates galore.
    4. Make sure you save Magisk and the Boot .img to your phone directly. Using the Download folder is a great place and easily accessible in Magisk. You will not be able to add files once in fastboot).
    5. Make sure your developer options are activated.
    6. Make sure your USB debugging is enabled AND you've given permissions for your computer to have administrative access with it enabled (more on this below).
    7. Make sure to check CPU-Z for your hardware specs and to make sure you're avoiding potential problems.
    8. Make sure you manually set USB to Transfer files (no other option will work and by default its set to Charge this Device). Once you flash, you have to constantly check USB to Transfer because it will not do it.
    9. Make sure you have the STOCK CABLE that comes with the phone. This model is funky about using other cables.
    10. Make sure you set your display to time out to ten minutes. If the phone screen goes to sleep mode, it may interfere with flashing.

    Here is the fun part. Please keep in mind you may get a bootloop. I did on both phones on the first try with two different methods. I was on the infamous March 1 2019 security update and still got a bootloop from the patching. The second phone I just flashed ahead of time to the new firmware and still got a bootloop until I flashed again. Expect it.

    1. Go into your developer options and DISABLE Automatic Updates. This is important for later on.
    2. With the phone on, install Magisk. Make sure you use the version 7.3.2 or update to it since it's the latest version at the time of this guide.
    3. Say yes when your phone asks whether or not you want to install things from unknown sources. It will grant access for this application only.
    4. Open Magisk Manager and turn on your Wifi. If you don't Magisk will hang at checking updates. If necessary, force close Magisk and open it up again with Wifi on. It should bring you to One Green Check Mark that Magisk Manager is Up To Date, and One Red Mark above it that says Magisk isn't installed.
    5. Click install on that tab ONLY (there is no need to click install by the Green Check Mark one). Magisk will then ask you "Do You Want To Install Magisk v19.3(193000) now? and click Install again.
    6. Under Select Method, navigate to the folder on the phone where you saved your boot.img file (or whatever you named it). Once you select it you will be taken to a screen where the letters are funky looking but spell FLASHING at the top. Once it patches your file, it will tell you when it's done. Should it hang or you get errors, you WILL HAVE TO REFLASH THE FIRMWARE AND START OVER.
    7. When the screen tells you it's all done, plug your phone up to the computer and drag the patched img file (it should by default say magisk_patched.img) and put it in the folder with Minimal ADB and Fastboot.
    8. Turn the phone completely OFF.
    9. Plug your phone via USB cable into the computer.
    10. Press Volume Down and Power to boot into fastboot mode.
    11. Open up Minimal ADB and Fastboot (Make sure you don't have it set to open this as an administrator, it messes with permissions) Make sure your boot image file is in the Minimal ADB directory or it won't work.
    12. Type "fastboot flash boot thenameofyourrecoveryfile.img" and hit enter.
    If all goes well it should flash to "a" partition, and you should see in the command prompt "image signed with key bad key" before it says done. If it doesn't take do not re-flash as it will flash to "b" partition which will definitely bootloop and ensure you have to reflash the firmware.
    13. When it is done, reboot phone by selecting START (keep pressing volume rockers until you see it, then press the power button).
    14. Wait for the bad key/device cannot be trusted screen to pass (may take a minute) and wait for the Hello Moto opening.
    15. Open Magisk Manager. The icons should be in green, letting you know you have root. Follow @diversenerd advice and Click Tap To Start SafetyNet Check. Make sure your Wifi is on for that check. This apparently tests to see if it can deceive Google checks and possibly install OTA (can't say I did all that, not a update junkie).
    16. Install Root Checker and confirm root.
    17. Disable Updates. I know this is hard for some people, but you dont know if a forced OTA update will take root away, and leave us with no option to get it back or roll back to an earlier version of Pie.


    1. Do NOT flash someone else's patched boot image. It WILL NOT WORK. Do the work, find your firmware, and patch the boot image yourself. I have no idea why it doesn't work device to device, but it doesn't. And while I thank @jhjhjhjhjhjh for giving up his original files, it was incompatible with my phone (even though we are on the same variant) and bootlooped me.

    2. You may have followed everything perfect and it still bootlooped. Save yourself the frustration and just flash it over. See the next section on the proper way to flash so you don't lose your baseband, IMEI, or any other important stuff.

    3. You will lose everything datawise flashing and playing with the boot.img. My phone reset itself tinkering with flashing, every time. Don't be alarmed if it takes you through a reset.

    4. I wasn't able to confirm by going into updates (couldn't find the system settings) and verifying that nothing said anything about Device Integrity Compromised. I just assumed it.

    5. Magisik is TEMPERAMENTAL. So if first you don't succeed, reflash the firmware and try again.

    6. You cannot just go into the Stock Rom file and extract the boot.img file, put it in the Minimal ADB file folder and flash it if it bootloops. YOU MUST REFLASH ALL THE FIRMWARE OVER.

    ****Notes on Flashing The Stock Firmware if you have to****
    In the event you bootloop and have to start from scratch, here's what you're going to have to do. And don't worry - it won't relock the bootloader.

    1. Make a duplicate folder of Minimal ADB & Fastboot that is clean (doesn't have any boot images or any added files in it).
    2. Extract the firmware to the folder where Minimal ADB & Fastboot are at on your computer.
    3. Turn the phone completely OFF and back ON if you haven't done so yet. Make sure there is no Sim Card of SD card in it.
    4. Press Volume Down and Power to boot into fastboot mode.
    5. Plug your phone via USB cable into the computer.
    6. Open up Minimal ADB and Fastboot (Make sure you don't have it set to open this as an administrator, it messes with permissions) Make sure all your firmware files have been extracted in the Minimal ADB directory or it won't work.
    7. Cut, Copy, and Paste in Fastboot All Together the following:
    fastboot oem fb_mode_set
    fastboot flash partition gpt.bin
    fastboot flash bootloader bootloader.img
    fastboot flash dsp adspso.bin
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash dtbo dtbo.img
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    fastboot flash system system.img_sparsechunk.4
    fastboot flash system system.img_sparsechunk.5
    fastboot flash system system.img_sparsechunk.6
    fastboot flash system system.img_sparsechunk.7
    fastboot flash system system.img_sparsechunk.8
    fastboot flash system system.img_sparsechunk.9
    fastboot flash system_b system_b.img_sparsechunk.0
    fastboot flash system_b system_b.img_sparsechunk.1
    fastboot flash system_b system_b.img_sparsechunk.2
    fastboot flash vendor vendor.img_sparsechunk.0
    fastboot flash vendor vendor.img_sparsechunk.1
    fastboot flash oem oem.img
    fastboot flash oem_b oem_other.img
    fastboot erase userdata
    fastboot erase DDR
    fastboot oem fb_mode_clear
    fastboot reboot
    8. When it is done it will stop on fastboot reboot. Hit enter and the phone will reboot.
    9. Repeat all steps in the Pre-Rooting and Rooting section to obtain root.

    Hope this helps my fellow MetroPCSers. I boot looped both of my phones this evening and brought them back with this method, and eventually achieved root on the 2nd tries, respectively. Old girl is working and I got Root Explorer and Titanium Backup going full stop. At least this root was easier than on my E4, lol.:cool::laugh:

    I will try and answer questions if I can or point you in the right direction.
    If you want to get rid of the bad key message at boot, you can flash the logo.bin file from the link below with fastboot. Just place the downloaded logo.bin in the minimal adb and fastboot folder, open a cmd window and type fastboot flash logo logo.bin and press enter. Next boot you should have a plain white screen with a large black moto symbol instead.
    Not saying you done it wrong but did you click oem unlock in developer options and can you post while output from where you get unlock data
    i got it all rooted but now it shows i have no imei and sim status not available any suggestions do i need to flash modem or radio
    fastboot flash modem NON-HLOS.bin 
    fastboot erase modemst1 
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    ...and how much is it to rewrite my lost original Imei
    Most IMEI=0 baseband not found errors can be fixed with
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    Or reflashing full stock firmware

    or unlock the device?
    Bootloader or sim lock?

    Sent from my mata using XDA Labs