• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question TitaniumBackup and files owned by media_rw

Search This thread

gone_bush

Member
Sep 4, 2014
46
0
I've got a couple of troubles with TitaniumBackup.

1) Some backup files are generated with the uid/gid of media_rw and not even root can access them! I rsync the TitaniumBackup directory to my server each day and the transfer of those files fails. This only started happening with Android 11.

In the dim dark past, you could overcome this by patching a file (forget which one) but that is no longer an option(?). Is there a way around this in Android 11?

2) In an effort to work around (1) I've tried to get a copy to Google Drive working but all I get is "titaniumbackup google drive sync skipped due to power/connectivity".

"Power modes" is set to any and "Connectivity modes" is set to WiFi. Both are true when the original backup runs. When I try a manual copy to Google Drive only a few files are transferred and there is no error message. Does it fail trying to transfer a file owned by media_rw?

I have attempted to contact the developers but have not had a reply in six weeks.
 

jwoegerbauer

Senior Member
Jul 11, 2009
7,049
21
1,642
European Union
I've got a couple of troubles with TitaniumBackup.

1) Some backup files are generated with the uid/gid of media_rw and not even root can access them! I rsync the TitaniumBackup directory to my server each day and the transfer of those files fails. This only started happening with Android 11.

In the dim dark past, you could overcome this by patching a file (forget which one) but that is no longer an option(?). Is there a way around this in Android 11?

2) In an effort to work around (1) I've tried to get a copy to Google Drive working but all I get is "titaniumbackup google drive sync skipped due to power/connectivity".

"Power modes" is set to any and "Connectivity modes" is set to WiFi. Both are true when the original backup runs. When I try a manual copy to Google Drive only a few files are transferred and there is no error message. Does it fail trying to transfer a file owned by media_rw?

I have attempted to contact the developers but have not had a reply in six weeks.

Here you go: