[Tool] Frija - Samsung firmware downloader/checker

SlackingVeteran

Senior Member
Mar 24, 2013
674
311
93
^ Tried it a bunch of times through Frija. Didn't work for me until I downloaded U1 from another site directly.
I haven't seen any decryption related issues with files for Android 10 or below. Haven't seen U1 Android 11 update show up on my end yet to test it out. I will keep an eye out for any issues related to this and if there is any will post an update here

UPDATE: Tested by trying to download Android 11 for SM-G975U and it seem to decrypt without any issues

1613162861554.png
 
Last edited:

Wiz

Senior Member
Nov 13, 2003
995
81
58
Amsterdam
www.t-systems.com
Frija has always been working fine for me. Until I switched to a Surface Pro X (Windows-on-Arm64) .. Frija still works (in x86 emulation) but Frija download speeds have dropped to an almost unbearable level ... (Yet in general download speeds over Wi-Fi and ethernet on my 1Gbit fiber connection remain stellar) .. Any clues as to what the reason could be for this?
 

fado5ster

Senior Member
Feb 27, 2013
63
5
28
Looks as though its an Android 11 issue?
I updated OTA last week and it has ruined my phone! All of the sensors are only working after a restart for anywhere between 20min to 8 hours and they all stop then.
Downloaded Frija (v1.4.3.0.) and downloaded my latest version for Model: SM-G9730 (Galaxy S10 Dual Sim), CSC: TGY which matches my OTA (was thinking maybe corrupt DL from OTA?)
But I now have a .zip.enc4 file that I can't rename to .zip, can't unzip and have no way to flash with Odin.
Frija seemed to decrypt the file fine but when it was complete all I had was the .zip.enc4 file.
Hopefully this is spotted soon.. before I launch my phone out of the window!

BTW thanks to devs!

*EDIT*
I have tried downloading again but when prompted to save I renamed from .zip.enc4 to just .zip then let it download as before.
This left me with a .zip file that I was able to unzip which left me with AP, BL, CP, CSC x2 files.
I added these to Odin and flashed.
Everything seemed to go ok, flash succeeded and phone rebooted.
The phone didn't wipe however. Not sure if it was supposed to or not as when I used to do this before I was usually going from a custom rom to stock, have never gone stock - stock, especially when even using the same firmware versions.
I guess time will tell as to whether it has fixed my problem but it may help others flash the .zip.enc4 file.

*EDIT 2*
Problem still exists, 9 hours later and have lost auto rotate, other sensors probably about to fail..
So not sure if this is a problem with the actual update or if the above method I used with frija didn't work. I guess my next step is to try downgrade to the previous version and try again
 
Last edited:

-BoneZ-

Senior Member
Oct 24, 2009
517
102
73
Indiana
I'm having trouble with the newly downloaded Frija Tool. I have the Note 20 Ultra SM-986U1 U.S. unlocked, and I've tried different CSC's and none seem to work: ATT, USC, XAA. Frija just says it can't find anything. What am I doing wrong?
 

SlackingVeteran

Senior Member
Mar 24, 2013
674
311
93
Looks as though its an Android 11 issue?
I updated OTA last week and it has ruined my phone! All of the sensors are only working after a restart for anywhere between 20min to 8 hours and they all stop then.
Downloaded Frija (v1.4.3.0.) and downloaded my latest version for Model: SM-G9730 (Galaxy S10 Dual Sim), CSC: TGY which matches my OTA (was thinking maybe corrupt DL from OTA?)
But I now have a .zip.enc4 file that I can't rename to .zip, can't unzip and have no way to flash with Odin.
Frija seemed to decrypt the file fine but when it was complete all I had was the .zip.enc4 file.
Hopefully this is spotted soon.. before I launch my phone out of the window!

BTW thanks to devs!

*EDIT*
I have tried downloading again but when prompted to save I renamed from .zip.enc4 to just .zip then let it download as before.
This left me with a .zip file that I was able to unzip which left me with AP, BL, CP, CSC x2 files.
I added these to Odin and flashed.
Everything seemed to go ok, flash succeeded and phone rebooted.
The phone didn't wipe however. Not sure if it was supposed to or not as when I used to do this before I was usually going from a custom rom to stock, have never gone stock - stock, especially when even using the same firmware versions.
I guess time will tell as to whether it has fixed my problem but it may help others flash the .zip.enc4 file.

*EDIT 2*
Problem still exists, 9 hours later and have lost auto rotate, other sensors probably about to fail..
So not sure if this is a problem with the actual update or if the above method I used with frija didn't work. I guess my next step is to try downgrade to the previous version and try again
It looks like its firmware issue from samsung themselves. I’d suggest to factory reset and see if the issue persists.
 

b4b4.4l1

Senior Member
Aug 27, 2012
134
20
48
Medan
Using this for Samsung Galaxy A10 SM-105G Indonesian model and it works, just a bit slow on searching the firmware but it works alright. Thank you.