[TOOL] Lx Multi Tool v1.3.2 [WIN/LIN/MAC][Unlock/Recovery/Stock/Kernel/More]

Search This thread


Senior Member
Dec 5, 2010
Unfortunately I never got the chance to test the MAC version, finally I have a tester :D

From what I can see at a first look is that this simple_curses.sh is some leftover from when I experimented with some UI tricks for bash to try to simulate the looks of the batch version..

Can you please check this temporary version from here -> 6PMultiTool.v0.2.1.zip

Sure I'd be happy to help.

Ok I checked that version out and it runs now however there still seems to be a few issues with it. Not sure if this is because there is not a phone hooked up or not but otherwise here's what I found.

Option 1: line 26: bootloader: command not found
'q' Command doesn't work either. Says command does not exist.

Most other options gave errors as saying fastboot-mac and adb-mac does not exist. I'm just assuming that's because I have no device plugged in. Let me know if you want those specifics as well.


Retired Recognized Developer
Aug 7, 2011
ASUS ZenFone 7/7 Pro
Sure I'd be happy to help.

Ok I checked that version out and it runs now however there still seems to be a few issues with it. Not sure if this is because there is not a phone hooked up or not but otherwise here's what I found.

Option 1: line 26: bootloader: command not found
'q' Command doesn't work either. Says command does not exist.

Most other options gave errors as saying fastboot-mac and adb-mac does not exist. I'm just assuming that's because I have no device plugged in. Let me know if you want those specifics as well.

Okay, checked everything in more detail, apparently there were lots of mistakes around the Linux and MAC scripts (due to not testing...).

Here is the new version -> 6PMultiTool.v0.2.2
  • Like
Reactions: mattnmag


Senior Member
May 4, 2009
Great seeing this already. Coming from an S4 to the 64GB 6P. Will it be possible to relock the bootloader after installing a custom recovery or is the stock recovery required for the lock?

Sent from my SPH-L720 using Tapatalk

Yes, you should be able to lock the bootloader after installing a custom recovery. The only times I have done it though is if I needed to send the device back to the manufacturer for service. And for that, I had to go to stock recovery as well. However, locking the bootloader is safer if you 1. have stock recovery and 2. have disabled USB debugging. And perhaps even that is not safe. The idea is that if someone wants to install a custom recovery or ROM, they will have to wipe the phone since unlocking the bootloader forces that. However, you have apps like BootUnlocker (https://play.google.com/store/apps/details?id=net.segv11.bootunlocker) which get around that as well if you are rooted. And I really can't see myself without USB Debugging, unrooted and not having TWRP. So I just try to practice safe downloads, pay attention to permissions and have Cerberus on my phone to lock/wipe after theft.


Senior Member
Jan 22, 2010
I'm going to wait with rooting until there is some more information from google regarding the whole Qfuse situation. From what i've read it disables your fingerprint scanner and some other key features regarding google pay.
Last edited:


Senior Member
Jul 17, 2010
Atlanta, GA
The real question everyone wants to know is that will unlocking your bootloader on the 6P cause Android Pay to stop working.

Top Liked Posts

  • There are no posts matching your filters.
  • 71


    It has LINUX/UNIX and MAC support!

    Because there is another tool for Android called Android Multi Tools, I renamed this one to Lx Multi Tool, future releases will go under this name.


    - Unlock/Lock Bootloader​
    - Flash Recovery Menu (you can choose and add recoveries) - TWRP Included
    - Flash any partition (Flashing submenu)​
    - Flash full Stock images (you can choose and add images)​
    - Erase partitions (you can choose which of the partitions)​
    - Reboot (you can choose again...)​
    - Sideload .zip files (you can choose and add .zip files) - SuperSU v2.56 (Systemless!) included
    - Backup (you can choose the name and place for your backup)​
    - Restore (you can choose your backup)​
    - Version (it just shows the version of your adb binaries) - platform-tools 23.0.1 included
    - Logs (DMESG and Logcat)​
    - Screenshots (you can directly take screenshots to your PC with no Root)​
    - Reboot (lots of choices)​
    - Refresh and delete files/folders from menus (Right-click or key F5 and Del)​
    - Open tool folders from the menus (to add your own kernel/stock image/recovery/sideload zip files)​
    - Tab key support for easier keyboard navigation​
    - Tool-tips for all buttons​
    - Check for updates​
    - Link to xda-thread (here)​
    Download links:

    Windows x86|x64 - Linux x64 - MAC x64​
    All released versions can be found here.​

    (The latest versions are always on the bottom.)​
    [ROOT] Use SuperSU 2.62 or higher from here systemless for 6.0.1 and above.​

    Known bugs/limitations:

    - For partition Flashing, it is recommended(mandatory?) to do a reboot-bootloader if you want to flash multiple partitions one after the other. (according to the Google flashing scripts) (Implemented in 1.2.1)​
    - For the return to stock, the tool will be stuck after your phone successfully boots, you need to reboot to fastboot again in order to flash the Radio and finish the full return to stock. (Fixed in 1.2.0)​


    Check the changelog for each release here.​

    Q: How do I get in bootloader/fastboot mode?
    Turn off the phone and turn it on by using Volume down + Power key.​
    Q: How do I check for updates on your tool?
    Follow the instructions on the screen below.​
    Q: Where can I find the device driver to install it for windows?
    Click here, download the driver, and run the setup.​
    Q: How do I root my stock phone?
    - Unlock bootloader.​
    - Flash recovery.​
    - Use SuperSU 2.62 systemless or higher from here.​
    (Usually the latest version upon tool release is included in the Sideload folder of the tool, you can either sideload it or copy it to recovery and flash it manually)​
    Q: I get an error "Cannot open file" on MAC, what should I do?
    Open the terminal, go to your application path and paste this command:​
    chmod +x LxMultiTool.app/contents/macos/*
    Q: What do I need to do in order to be in Fastboot or in ADB mode.
    Fastboot mode will be detected only while being in bootloader.​
    ADB mode will be detected from Recovery (custom) and actual ROM with USB debugging active.​
    Refresh button needs to be used in order to check for what mode you are in.​
    Q: Are there any other software that I need to install in order to run this tool?
    On Windows and MAC everything is bundled, so nothing needs to be installed, just run.​
    On Linux you need to install from your package manager libQt5Core, libQt5Widgets, libQt5Gui, libQt5Network.​
    If it's not enough, use ldd LxMultiTool in the terminal to find out what you're missing from your environment.​
    Q: I have a yellow/orange/red text screen during boot, what's that?
    When you unlock you usually get the Orange screen and it's normal, but if you really want to know what's this about, give a reading to this.​
    Q: Hey, my device is not detected, why?
    On windows, you need to manually install the USB drivers, they are not included and probably they won't be included in this tool.​
    Also, make sure you click the connection Refresh button after connecting the device to your PC.​
    Q: What do I need to do in order to install a custom ROM?
    1. Unlock Bootloader.​
    2. Flash a custom recovery of your choice.​
    3. Flash an insecure kernel (boot).​
    4. Flash custom ROM with no problems via recovery.​
    All those things are found and can be done via this tool.​
    Q: Hi, I just downloaded this tool, how do i use it?
    First, extract the folder somewhere.​
    After that, run LxMultiTool.exe on windows by double-clicking it, LxMultiTool on Linux, and the same on mac.​
    Q: Do I need android-sdk installed or something else?
    No! This tool uses its own supplied binaries for adb and fastboot, if you have android-sdk installed it will be ignored anyway.​
    This tool is fully portable and stand-alone.​
    Q: I get an error while trying to unlock the bootloader -> FAILED(remote: oem unlock is not allowed), what now?
    Starting with Android 5.0, you need to enable Bootloader Unlocking from the developer settings, in order to do that, follow these steps:​
    - Enable Developer options​
    - Enable USB Debugging​
    - Look for the ‘OEM Unlock’ Option and toggle it.​
    Q: How do I use the return to stock feature?
    First, download the latest package from here, then extract the contents (there is an archive in the archive) until you get to a folder like angler-mda89d
    that contains the images, that folder needs to be copied in the /Data/StockPackages folder in order to be visible.​
    Easier steps -> Get your device in bootloader -> Start the tool -> Hit refresh -> go to Stock -> hit open folder -> copy the extracted folder with the name angler-xxxxxx in there, hit F5 or Right-click + Refresh -> you should see the folder in there like in the following screenshot. Thanks @ursa08 for the screenie.​
    Q: How do I enable Developer options?
    - Launch the Settings​
    - Scroll Down and Tap on About Phone(or About Device)​
    - Locate the Build Number Section​
    - Tap on the Build Number Option 7 Times​
    - Go Back to the Main Settings Page​
    - Scroll Down and Tap on Developer Options​
    Q: Hi, I just bought a phone what should I do now?
    Well, you firstly need to unlock your bootloader...​
    Q: What is logcat?
    Well, you can pretty much use google for that answer, but to put it short, is that thingy that tells you what is happening behind the scenes of your phone.​
    It is usually used for debugging and entertainment(?).​
    When you report an error/bug to somebody, it will be a blessing to provide a logcat (log file)!​
    Q: What is a Custom Recovery and why do I need one?
    A custom recovery is that thingy that lets you flash .zip files, use your logic, and you will get it why you need one.​
    Q: There are other guides/tutorials out there. Should I check them instead of this?
    If you manage to get things done using this one, no, otherwise yes, note that some could be outdated...​
    Q: What is sideload and how do I use it?
    Sideload is a function from adb that let's you flash a zip file while in recovery directly from your PC.​
    Please note that you need to be in sideload mode on your recovery before doing this.​
    To enter sideload mode, in TWRP go to Advanced -> ADB Sideload -> Swipe to sideload


    The official and original repository can be found here.​

    Bug reports/feature requests:

    If you have any bug, or you consider a feature to be a must-have, please use the issue functionality on GitHub for more traceability here.​


    Please note that this tool is open source and released under the GPL v3 license, which can be read here.​
    Make sure you understand at least the short version of the license that's provided in the tool before using it or before contributing/forking and other related stuff.​

    Tech and stuff:

    Some additional marketing for stuff used in this tool​
    Qt - An awesome cross-platform IDE​
    Vmware - For letting me test this tool on all platforms (Linux and MAC).​
    Icons8 - A nice platform for good-looking FREE icons. (Big thanks!)​
    UnixUtils - For the sed utility for Windows.​
    AndroidFileHost - For the awesome file-management platform for developers.​


    Even though this tool is provided free of charge, fully open-source, donations are very welcome to support the future development of this tool and to buy me a beer while coding future improvements on it.​
    This section will also include the hall of fame for donors and on the github repository.​
    Special thanks for donations:​


    I will not be responsible for smashed screens, bricked phones, or any other things that you can accuse me of, I've done this tool to help people, use it at your own risk and consider giving a THANKS if you use it and like it.
    Please consider leaving some feedback, what to improve, what could be done better, what annoys you, it really helps me improve the tool.
    Also, to avoid useless threads on general, Q&A, or useless posts, please read the FAQ section upside, it's like a Mini-Guide!

    XDA:DevDB Information

    Lx Multi Tool, Tool/Utility for the Huawei Nexus 6P

    Source Code: https://github.com/lexmazter/LxMultiTool

    Version Information

    Created 2016-01-01
    Last Updated 2016-01-16
    can i flash 6.0.1 boot loader, radio & vendor with this tool?

    Right now you cannot flash partitions on their own, this feature will be added in the next release.

    If you have the knowledge you can modify a stock package so you flash only what you need, will look into that when I will reach home, basically there is an image_something.zip where you have different stuff.

    I will come back at this post after I investigate if this can be done easily and maybe I will change the stock image to flash it without the Data partition. (Note that the System and Boot partitions still need to be flashed for a successfull update).

    P.S. I have my Nexus since yesterday evening, development stuff can be done easier now. :D
    Okay, sorry for the long wait, as expected qwindows.dll was missing, tested on my girlfriend's laptop, it had the same problem and the .dll fixed it.
    The .zip file with the newly include .dll has been put instead of the old one in the main thread.

    I'm truly sorry for this issue and I really hope that it's fixed now, need to sleep in peace (4 AM here).
    Sorry to be thick about this, but I don't see and flashall.bat to click on. I tried minimal adb and fastboot, I also tried regular sdk and platform tools. I pasted the factory image into the platform tools folder. I see adb.exe, dmtracedump.exe, flashboot.exe, etc1tool.exe, etc, but no flashall.bat. I did try the "adb shell" command, and it said device 'null' not found. I get the sense it's not seeing my phone, and I have no idea where this "flashall.bat" command is on top of that. Again, apologize for my issues here, I don't get what's going on.

    I guess you haven't extracted the .tar and .tgz archives of the factory image, the flashall.bat is in the archive and in the last folder in the archive, that's what you need and there is where you need to put the fastboot.exe.

    If you don't know how to open or extract the archives, you can try by installing 7-zip.
    @Lexmazter Just a heads up, you need to update the unlock command to "fastboot flashing unlock" as this is the new command for the M devices - oem unlock no longer works.