[TOOL] One-Click bootloader unlock (no root required)

Search This thread


Senior Member
Nov 10, 2014
hi if anyone have problem with this tools can try in this way

0-move the files in tools folder (in ZF2_one_click_unlock_by_sorg_v2.zip)to adb folder (in my case C:\adb)
1- reboot in fastboot mode
2 - insert the following commands
fastboot oem start_partitioning
fastboot flash /tmp/start.sh unlock1 
fastboot flash /tmp/recovery.launcher unlock2
fastboot flash /system/bin/logcat unlock3 
fastboot flash /tmp/unlock unlock4 
fastboot oem stop_partitioning
3- reboot and check if splash screen become inverted

in my case worked :good: tested on ze551ml (deluxe edition) with android 5.0 fw pre-rooted (i've follow this step for root system http://forum.xda-developers.com/zenfone2/general/asus-zenfone-2-flashing-recovery-mode-t3096596)

just for clarity my problem was this:
start unlock_one_click_v2.bat
in fastboot mode
Starting unlock...

Bootloader should do the rest unlocking actions
and then will reboot and become unlocked
if boot screen become inverted.

Press any key to continue . . 
But bootloader was still locked

I hope it is helpful ;)
Last edited:


Dec 16, 2016
Can't unlock bootloader

I can't unlock my boot loader by the unlockerapp and all by this method,after completing the unlocking one click unlocker shows press any key to continue and it closed by pressing any key.but phone still asking the bootmenu asking start fast boot,when I using the apk it closed automatically,my version is marshmallow 21.40


Mar 7, 2011
Linux Instructions

Thanks, Sorg! Worked great on linux with Just unzip the tool in a new directory and cd to it. Here's the important bits from the .bat:

$ adb reboot bootloader

Wait for bootloader and verify fastboot sees it:
$ fastboot devices

Start oem partitioning, flash the files, and stop partitioning. The device will restart after the stop_partitioning command.

$ fastboot oem start_partitioning
$ fastboot flash /tmp/start.sh tools/unlock1
$ fastboot flash /tmp/recovery.launcher tools/unlock2
$ fastboot flash /system/bin/logcat tools/unlock3
$ fastboot flash /tmp/unlock tools/unlock4
$ fastboot oem stop_partitioning

Thx for the tips ;)
(I know it's been a while but i just decided to go forward)


New member
Dec 19, 2015
Hello guys,

I need your help with my Asus Memopad 7 tablet. I need to root them but I cannot unlock bootloader.
I have been searching and trying for 2weeks how to unlock the bootloader, nothing works.

According to the K01a model, I found countless tutorials (here, youtube, other forums that led again to xda...) and everywhere the bootloader for the K01a model ME170...,173,.... was described. But nothing worked, even though a few methods had some cooperation with the tablet, but without results.
I'm glad I locked the tablet.
I only found out from ASUS support that my K01a model is the ME70C version based on the serial number.
I'm looking for how to unlock the bootloader for the ME70C, but the instructions are nowhere to be found.
And if I find this one, it is listed here in the procedure for "downgrade" with android 5 installed.
On the contrary, I need an upgrade from Android 4.3. to 5 or 6 ( :-D ) so that I can use apps whose support ended for android 4.
How did you manage to unlock the bootloader to install android 5 on your tablet?
I was trying update to UL-K01A-WW- but the upgrade will not complete ( i'm guessing because i still have build 10.32.1.....)

Asus Memopad7 for Europe distribution: Model K01A (ME70C), Android 4.3, Kernel version: 3.4.43 android@Scorpio #1 Tue Jul 22 14:38:47 CST 2014
Build number: JSS15Q.WW_MeMo_Pad-

My bootloader has only menu:
Reboot droidboot
Factory recovery
SD Download
Power Off
SD Update

Thanks for the help.

Top Liked Posts

  • There are no posts matching your filters.
  • 121
    I've made simplier way to unlock the bootloader of ZE551ML/ZE550ML.

    Version 2.
    Now it's not required to flash/downgrade droidboot.img. But you still need to flash one of compatible ROM.
    Currently compatible versions are:
    For ZE551ML: v2.19.40.18, v2.19.40.20, v2.19.40.22 and future newer versions unless opposite mentioned.
    For ZE550ML: v2.19.40.12, v2.19.40.13, v2.19.40.23 and future newer versions unless opposite mentioned.

    For example, you can flash full ROM v2.19.40.22 and then use unlocker v2.

    Just unzip everything from attached archive and then start unlock_one_click_v2.bat
    If you've enable USB debugging then phone will automatically reboot to bootloader and will unlock the bootloader. If you didn't enable USB debugging, then you need to reboot to bootloader manually (Turn the phone off and disconnect USB, then press Power+VolumeUp keys at the same time and keep it pressed till you see ASUS logo, then you may connect USB cable).
    Either way, unlock_one_click_v2.bat will proceed to unlock in fully automated way.
    If initial boot splash screen become inverted, then bootloader has been unlocked!

    If you don't like white boot screen, then you can flash original black one:

    Originally, it's developed for WW firmware but should work on any region.
    Works on CN firmware. Confirmed by @corrsea

    Based on unlock method discovered by
    Based on fastboot hack by @social-design-concepts
    Important note for Stock ROM lovers:
    Although, unlocker v2 works with v2.19.40.22, there is no warranty, it will continue to work on future versions. It is up to ASUS decision. Unlocking process still requires several files from /system partition including special version of if.bin (/system/etc/firmware/if.bin). These files are still supplied with v2.19.40.22, but in the future they can be removed by ASUS together with disable of downgrade ability for if.bin.
    So, if you will flash future stock ROM through official update procedure (which includes bootloader update - from ifwi.zip) then you may loose unlocked bootloader! And of course, ASUS may completely block unlocking procedure (at least unofficial way).
    So, if unlocked bootloader is important for you, then
    1) unlock it ASAP while current firmware allows.
    2) don't use official updates. You need to remove all lines from update script containing ifwi.zip references and then flash through TWRP (you need to remove lines checking recovery version as well).
    Version 1 (old)

    To use this version, you need to flash ROM not older than v2.19.40.18 for ZE551ML, and v2.19.40.12 for ZE550ML. And then downgrade (if required) droidboot to compatible droidboot.img
    fastboot flash fastboot droidboot.img
    For ZE551ML, known compatible droidboot.img versions are,
    For ZE550ML, known compatible droidboot.img versions are
    so we have asus flash tool?.....can u post link pls....and in case I end up soft bricking can I use flash tool to get the sock rom on my device again?
    AFT: https://mega.nz/#!LcwhXDLZ!PN1jzQ0hDotKotC5ckIP_GHVvh4qAQyvMzN8VK4fVBU
    RAW: https://mega.nz/#!7cA3nTZC!NiHOzVoVPdXAOVsQkjQT6umMMpfIeaxpE2es7lrwGpI
    I've updated the OP, wrote compatible (as of today) versions. If even this is not clear enough, then i give up.