[TOOL] rkDumper (utility for backup firmware of RockChip's devices)

Search This thread

zeroprobe

Senior Member
Apr 20, 2010
1,387
1,431
What the name of device?

rkDumper 1.09d test

Note that the latest versions of devices give fake data instead of firmware after a certain address.

I think you are right. I dumped using rkdeveloptool and a lot of the partitions were just filled with hex CC.
Probably no solution then.

Your program I had an issue with any command.

Android\RockChip\rkDumper_109d_test>rkdumper /log /debug /test

rkDumper (version 1.09d_test)
Utility for Rockchip's firmware backup

(c) RedScorpio, Moscow, 2014-2021

==========================[ START ]==========================

Detected OS: Windows 8 Pro [build 9200] x64
Real OS: Windows 10 Pro [build 19042] x64
-- Devices enumerating --

USB devices table (found 12 devices):
1 Device #0: USB Root Hub (ports: 8)
2 Device #1: USB Root Hub (ports: 8)
3 Device #2: USB Root Hub (ports: 8)
3.5 Device #3: Genesys Logic USB2.0 Card Reader
VID = 0x05e3, PID = 0x0745, REV = 0x0903 (USB 2.0)
Driver version = 4.5.4.2 (7-15-2019)
3.8 Device #4: USB Composite Device
VID = 0x046d, PID = 0xc52b, REV = 0x1203 (USB 2.0)
Driver version = 10.0.19041.488 (6-21-2006)
4 Device #5: USB Root Hub (ports: 4)
4.3 Device #6: USB Hub (ports: 2)
VID = 0x0424, PID = 0x2532, REV = 0x0182 (USB 2.0)
4.4 Device #7: USB Composite Device
VID = 0x046a, PID = 0x0023, REV = 0x0220 (USB 2.0 Low Speed)
Driver version = 10.0.19041.488 (6-21-2006)
5 Device #8: USB Root Hub (ports: 22)
5.11 Device #9: Rockusb Device
VID = 0x2207, PID = 0x350a, REV = 0x0223 (USB 2.0)
Driver version = 5.0.0.0 (9-1-2020)
5.12 Device #10: USB Composite Device
VID = 0x062a, PID = 0x5918, REV = 0x0102 (USB 1.1)
Driver version = 10.0.19041.488 (6-21-2006)
5.22 Device #11: ASUS USB-BT400
VID = 0x0b05, PID = 0x17cb, REV = 0x0112 (USB 2.0)
Driver version = 12.0.0.7820 (8-30-2013)

Found: LOADER device (RK3566 2207:350a) #9
Unknown command

==========================[ STOP ]==========================

==========================[ STOP ]==========================
 

mitchell4you

Senior Member
Aug 3, 2016
143
32
Utrecht
Rkdumper /log /debug /test dump
Found Loader device ( rk3566 2207:350a) #13
Command to read failed
Command to reset failed

Unit: rk3566 h96max 8/64 version / using rkdumper 109d
Trying to backup units firmware
 

mitchell4you

Senior Member
Aug 3, 2016
143
32
Utrecht
Hmm.. Problem solved by user xmannv In the "imgRepackRK" thread
Hey thankfully upload a full backup image
- that I unpacked and boot patched with magic and flashed
All worked fine

Thanks for great support and amazing tools
Cheers
 
Sep 1, 2019
10
8
Hey buddy, from what i can tell, you are the most talented rockchip developer around.
I have a 7 inch rockchip device that i would love to be able to "unlock" the bootloader. I have full root access to the device (ANDROID 4.2.2) . i can pull and flash the stock images (mtdblock) with dd. but if i modify the boot.img at all it will not boot. (I tested by flashing to recovery) . I have bricked several of these trying to figure this thing out. It definitely is not normal rk firmware. I have several of these particular tablets that i would like to be able to upgrade to Android 5.1.1. i can pay you for the job and i can send you a device
 
Sep 1, 2019
10
8
Alas, I'm not a developer at all. It's just a small Uility

you are a developer my friend.... and i need you. Please take a look at my boot.img? this was pulled from mtdblock2 with dd. if you can help me recreate the signature block at 00000400 i would be willing to pay you substantially. Hell id pay you just to try. please take a look bro and let me know if you need to see anything else
 

Razorj76

New member
Dec 17, 2020
1
0
I am trying to learn how to root a jp5 tablet, if you have any information I would be grateful, I will gladly compensate for step by step instructions, all I have is a broke tablet myself and a data cable with USB otg file manager nexus. Thank you.
 

Top Liked Posts