[Tool] SP Flash Tool New Version v5.1352.01

Search This thread

aabidhashmi

Senior Member
Feb 19, 2012
89
213
Paonta Sahib
www.facebook.com
Friends,

Sp Tool updated to new version with whole new revamped interface
New SP Flash Tool 3.1352.01 (5.1352.01)

2hga6g1.jpg


Smart Phone Flash Tool is a cross platform application that could download built images and binary data to MediaTek smart phone chips. Now it supports Win XP 32bit and Ubuntu 10.4.

Tool Version:1.1352

New Features/Enhancement:
- Intial Pre-Release for Linux platform

Bug Fixes:
- New int.

Limitations:
- Not support storage size larger than 4GB

Download
This feature is used to download built image or binary data to target.

Memory Test
Smart phone Flash tool offers this feature for Users to test and verify the external memory Device RAM and NAND flash

Format
This feature allows users to format phone NAND, EMMC or SDMMC flash.

Parameter Setting
This feature allows user to set some parameter of phone, such as OTP parameter and so on.

Readback
This feature allows customer to read a length of Memory from phone.

Option
Flash Tool also provides option function for user to customize their tool and set some parameters for download, and so on.

Console
This feature allows customer to run Flash Tool in console mode.

Other Information
For users who want to more features, smart phone Flash Tool also provides below advanced features:

FAQ
The FAQ provides some help for customer when they meet some problem using flash tool.

You can download it from here :-

mod edit - link removed
Mediafire : http://www.mediafire.com/download/aix6jxmcbxmmc2b/SP+Flash+Tool+3.1352.01+(5.1352.01).rar.html
 
Last edited by a moderator:

Rafael Cardoso

Senior Member
Jul 23, 2013
86
12
São Paulo
Xiaomi Poco X3 NFC
Need some help

Development team! I really need some help. I have a blu life PURE (Rebrand Gionee Elife e6 - Mediatek 6589T). My last rom was COLOR OS Rom for QMobile Z4 (also rebrand Elife Gionee e6) , everything great, but I wanted to try another rom, so I flashed via CWM the rom z4Amigo for Qmobile, but it gave error status 7 on CWM, and I couldn't Install it. I already had wiped data and factory reset, now my phone is stuck on boot logo. I tried to flash other rom with SP Flash Tools, I use windows 8.1, my blu is recognized normally, but SP always gives error 8037, even if the scatters are with the same values! Now, I do not know what to do, maybe the problem is with my SP FLASH TOOLS, maybe with my Windows, I don't know, I can't mount USB storage with CWM recovery, what would save me! So, I see no solution, I would be thankfully if someone could help! Thanks in advance =)

Regards from Brazil :laugh::good:
 

Satyam Sp

New member
Jun 2, 2014
3
0
Not Working

When i flash mobile using sp flash tools it shows BROM errors and then my mobile showing black screen and mobile does not start it shows only black screen.I tried many times to start the mobile but it does not start.
 

jamiljorge

New member
Jul 23, 2014
2
0
BROM_s_error_not_enough_storage_space

http: //tinypic.com /view.php?pic=1g0jcz&s=8
Prevent me to post outside link so i made a spaces
after formatting without bootloader i always get that when im downgrading my Alcatel One Touch 4033D so please need help :confused:
 

Sagar_Patel

Senior Member
Jan 10, 2014
95
32
Bhavnagar
i have micromax a46 bolt having MTK 6572 Dual Core Processor...i had rooted it first...then i searched for its cwm but i could not get...however i wanted to modify it so i had installed link2sd and root explorer...i had successfully mounted ext2 and linux swap partition on it...i linked user apps...then i went to change bootanimation and shutanimation....so i did it with the help of root explorer...then i went to check the modified animations...and my phone got stuck into bootloop....i googled and XDAed and found that using SP flash tool i can re-install the stock rom so followed all the instructions about using sp flash tool step by step but when i tried to connect my phone with pc through data cable, there is no response from pc as well as SP flash tool...note that i had installed micromax a46 drivers but though this problem is existed.............
 
  • Like
Reactions: Markosfit.

Degenerate76

Member
Jul 28, 2013
9
2
Where can i find that linux version ?

Indeed, I am scouring the internet for that mythical linux version. Where is the original source of SP flash Tool? Is there a website, or does it just get distributed by forum posts and download links that mention a linux version but offer no way to obtain it?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 182
    Friends,

    Sp Tool updated to new version with whole new revamped interface
    New SP Flash Tool 3.1352.01 (5.1352.01)

    2hga6g1.jpg


    Smart Phone Flash Tool is a cross platform application that could download built images and binary data to MediaTek smart phone chips. Now it supports Win XP 32bit and Ubuntu 10.4.

    Tool Version:1.1352

    New Features/Enhancement:
    - Intial Pre-Release for Linux platform

    Bug Fixes:
    - New int.

    Limitations:
    - Not support storage size larger than 4GB

    Download
    This feature is used to download built image or binary data to target.

    Memory Test
    Smart phone Flash tool offers this feature for Users to test and verify the external memory Device RAM and NAND flash

    Format
    This feature allows users to format phone NAND, EMMC or SDMMC flash.

    Parameter Setting
    This feature allows user to set some parameter of phone, such as OTP parameter and so on.

    Readback
    This feature allows customer to read a length of Memory from phone.

    Option
    Flash Tool also provides option function for user to customize their tool and set some parameters for download, and so on.

    Console
    This feature allows customer to run Flash Tool in console mode.

    Other Information
    For users who want to more features, smart phone Flash Tool also provides below advanced features:

    FAQ
    The FAQ provides some help for customer when they meet some problem using flash tool.

    You can download it from here :-

    mod edit - link removed
    Mediafire : http://www.mediafire.com/download/aix6jxmcbxmmc2b/SP+Flash+Tool+3.1352.01+(5.1352.01).rar.html
    4
    Where to find Linux version?

    SP lash Tool Linux 64Bit v5.1520.00.100
    i found this and working. You can find latest windows version too.

    SP Flash Tool 5.1524

    Thanks for the developers :good:
    2
    Linux version

    Intial Pre-Release for Linux platform

    Where can i find that linux version ?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone