[TOOL]TF201 NVFLash [Updated 21. July]

Search This thread


Jun 10, 2010
Somehow, I messed up while attempting to flash CM11 and have gotten stuck on the Asus logo screen and cannot re-enter recovery. It doesn't show the "Device is UnLocked" as it normally did- it just hangs forever.

I can get into the APX mode, have the latest Naked Drivers loaded (tried on x64 and x32 Windows) and the device shows up in device manager. I have also tried using Linux and the device in AXP mode is shown in the lsusb output. I've tried this with multiple USB dock cables.

No matter what configuration I try, I have been unable to get wheelie to communicate - it always dumps out with an "Error 3" as below:

C:\nvflash>wheelie --blob blob.bin
Wheelie 0.1 - Preflight for nvflash.
Copyright (c) 2011-2012 androidroot.mobi

Waiting for device in APX mode...
[=] Chip UID: 0x15d0787bc641408
[=] RCM Version: 0x30001

[-] Error 3 receiving response from command

I found several mention of a Linux version of wheelie 0.2 that is supposed to solve this for some, but the androidroot.mobi site is a bit of a mess and all the older links are broken.

OK, got it working again. I left the tablet on the Asus logo screen until the battery died, then plugged it in and charged it for a couple hours.

Attached it to a linux machine and followed this guide: http://rootzwiki.com/topic/35086-guide-nvflash-general-users-guide-unbrickrecoverdowngradeupgrade-tf201/

Just using wheelie and flashing the images wasn't enough - I had to use the "semi-automated recovery" script, which also rebuilds the partitons and sends over additional configuration.

On the linux side, the NVFlash is 32 bit, so I had to install the i686 version of libstdc++, YMMV.
Last edited:


Senior Member
Jan 28, 2009
Lenovo P11
I'm having exactly the same problem. Coming from HairyBean tried to install CM11 and the same as above.
Does anyone know how to fix it with a Windows PC. ... By the way I'm not having the Error 3 with my "old" wheelie ... just getting it when installing a newer wheelie. But at the end it doesn't matter the result is the same. Prime freezes at the Logo cannot access recovery or fastboot just wheelie "old" is working installing all the blobs doesn't fix.
Help would be highly appreciated.



Senior Member
Oct 16, 2009
North Carolina
I get all the way to nvflash --resume --read 14 factory-config.img and then I get an error "file create failed NvError 0x30010".

I've rebooted and still get the same error. If I close out the command prompt and try again it just hangs.

Any help appreciated.


  • ScreenShot004.jpg
    43.9 KB · Views: 588


Senior Member
Sep 14, 2007

I bricked my TF201...

Cannot boot into Android and cannot acces to the Bootloader.
My devices is unlocked, but i don't activate nvflash so i don't have my proper Blob file.

Is my device dead ?
Today, is there a hack in order to generate a goog blob form antoher blob's device ?

I Will pay if anyone really help me with success to unbrick my TF201, really !

Thanks a lot,

You are my last hope....
Last edited:


Jun 7, 2013
I cannot speak for the others but I personally would not be impressed with this outcome. It is not like other rooting methods and other tweaks, this carries a high brick risk. One-clicks and all those types of installers trivialize the risk that we are trying to make users aware of. Making someone read the instructions gives us the opportunity to really reinforce the risk that you are undertaking.

So great community developers like wugresh, chainfire cfrooter, unified android tool developer etc that creates adb GUI devices to semi automate processors are doing the android Dev community a disservice? These are the best devs in the community and they develop programs and apps to help others for free, and are usually very happy to offer help and clear concise how to's to newer people in this community. Its called progress, that's what developers do, write computer programs to simplify tasks ( jobs) for the wider community, you wouldn't have a PC or even a mobile phone if nobody helped anybody by not developing software tools... I agree the tf 201 is a *****, I had one for years, it unlocked via Asus method, rooted for all intensive purposes, su and busybox ran, all rooted apps ran, but it could not install Roms from twrp or cwm, it would stall halfway through, I had to reboot to recovery then reboot.? This went on for months on end, I'd leave it a box somewhere and pull it out again months later when I was ready for the challenge, or bored!. Untill eventually in frustration I totally bricked it, by that time I already had a nexus 10 & 7 so it was outdated and retired anyway. It was also the ist android I learnt these methods on.
Point is if some good talented Dev who can actually write programs ( as against those knowing how to enter a bit of code in adb, and think they are the ducks nuts because of it and anyone who hasn't grasped it yet are morons ) then maybe I wouldn't have gone through all that frustration and could have had an updated tf201, as Asus only did one update in the three years I had it., it was a great concept android device and I believe the first detachable, great build quality but the 1gb ram basically outdated itself too soon.
Anyway I get sick of reading these replies like just google it,or if you can't use code in adb shell then you shouldn't be custom romming your phone.
Everyone starts somewhere and usually asks for a bit of guidance when they do, even you criticalis I bet, so I would say if you can't add something constructive or positive to the conversation then why bother answering at all? Forums are communities, which mean all members are part of that community, so show some respect and try and help people and if you can't, or just an angry young dude on a negativity troll trip, try and curtail your incessant need to put down others, when your feeling that way just walk away from your computer and go breathe some fresh air, take a walk, have a break, you will feel so much better asfterwards

Sent from my Nexus 10 using XDA Free mobile app
Last edited:
  • Like
Reactions: taddyjason


Senior Member
Aug 9, 2014
Hard brick although a working blob.bin file has been created?

First of all, I would like to express my thanks to all developers who made nvflash working on the TF201! Your support is really appreciated and I can confirm that it already saved me from hard bricking my Prime in at least two cases. :fingers-crossed:

However, the best preparation is not always a absolute guaranty to avoid hard bricking as I have faced now: Although, I created a working blob.bin file by flatline recovery, I can't get into apx mode anymore. Maybe, I made some stupid mistakes, I don't exactly know :crying:. I tried to flash multirom on my TF201 device by using an unofficial version for the Asus TF300t tablet. At first it was working, but I noticed that the device recognition got mixed (the TF201 turned into an TF300t) and I experienced some problems during installing some custom roms for the TF201. I tried to undo the changes to get cm11 working again. However, the flashing process was not sucessful. Then I lost control over my tablet. I couldn't enter bootloader anymore including fastboot or recovery mode. However, while trying to press the hardware keys to enter apx mode, I recognized that the display of my TF201 remained black (which is actually a good sign because it should be like that during first stage of this mode).

However, as mentioned above my tablet is not recognized as apx device on my PC anymore after connecting it via USB cable. I was not successful, neither under Linux nor under Windows. Under linux I could not find any entry for the device by checking the lsusb output.

Is there any idea, what I still can do? Any constructive advices are very appreciated!

Many thanks


Senior Member
Jan 25, 2012
Rio de Janeiro
Hi Guys My Prime is with unlockedBootloader In the Stock room , i have To Root to be able to Usa NVFlash and Save the Blobs files ,someone can provide me the link how to save my blobs step by steps ? Pls and Thank you all

Top Liked Posts

  • There are no posts matching your filters.
  • 108
    After much hard work and scary semi-bricks, we are proud to finally provide nvflash to the masses!

    This release allows unlocked devices to create a set of device-specific files that lets you access nvflash.

    Once the procedure is done, you will always be able to recover any software brick (even bootloader!) as long as you keep your files safe!


    More details at http://androidroot.mobi/?p=452

    Important note: We kind of forgot to clarify what the license for wheelie was so here goes. Due to the nature of wheelie and the importance of people always using the latest version, Wheelie is NOT redistributable! You are allowed to download it and use it, but you are not allowed to redistribute it in any way - this means no GUI's including it, no reposting zips/tar.gz's and similar! At a later date, we will be releasing our source code and relicense it as GPL.

    Update log:
    1. 18. July: Added windows version!
    2. 21. July: Clarify License

    - AndroidRoot.Mobi Team

    NOTE: If anyone wishes to donate, http://androidroot.mobi/donations/ is place to do it! DO NOT DONATE DIRECTLY TO ME.
    nvflash binary package for tegra 3 ICS for win32-x86/x64

    attached is a working tested nvflash binary package for tegra 3 ICS win32.
    included is also fastboot and adb executables.

    extract this zip and all wheelie win32 executables in the same directory and follow the directions on http://androidroot.mobi/?p=452 as rayman has stated.

    a couple things to note:

    entering apx mode was not very clear.
    hold power + vol up until you feel the tablet vibrate
    release power and volume up and immediately press volume up for about 3 seconds
    then release volume up.

    the screen will remain blank but will be in nvidia apx mode.
    you will then need to install the apx driver from the universal driver package here on xda.

    edit: fyi I have nothing to do with androidroot.mobi team.
    I have a prime and spent the last two days trying to find the nvflash binaries on the hacked nvidia site and thought I would share.
    Here's your Windows How To

    Ok, took me a while to find everything I needed and make sure everything was setup just right for this to work, but finally got all my backups made. So, I figured I'd make a how to a save a few people some time.

    **Note** This is for windows, windows 7 (x64) spicifically, but may also work on (x86).

    1) Plug in you tablet to your PC.

    2) Download the most recent version of Universal Naked Drivers here:

    3) Go to Device Manager (Control Panel -> Device Manager), select any instance of Asus or TF201, and uninstall the current driver, and also choose "delete the driver software for this device." If you were already using a older version of Naked Drivers, then you places to delete drivers are under Android Device -> Asus Transformer Prime ADB Interface, and Portable Devices -> Transformer Prime TF201.

    4) Unplug your tablet, and turn off internet, just so windows doesn't go and try to download anything when you plug it back in. Plug you tablet back in and if you see it trying to install a driver, hit the X on the notification in the system tray.

    5) Go back to Device Manager, select your device (should have a ? or ! by it now, since it doesn't have drivers). Right click on it & choose Update Driver Software. Browse Computer for Driver Software, Navigate to the folder where you unzipped the driver package you downloaded earlier (make sure that the include all sub-folders is checked), select Next. A Warning may come up about security, choose to install anyway.

    6) Download the attached .zip, which includes blob & wheelie files provided by androidroot.mobi and the NV Flash files provided by joe ferreira. Make sure to thank both. Deleted upon developer request... Use the OP to find the proper tools. :)

    7) Unzip the attached file, and open a command prompt in the folder (Shift+Right Click). Follow the instructions here: http://androidroot.mobi/t3_nvflash/
    You do not need to issue the "$" in front of the commands.

    8) After you reboot & before moving on to the "Accessing nvflash" part of the guide linked above, grab the files that were made @ /sdcard/AndroidRoot and copy them to the same folder on your PC as all the other NVFlash files... Continue with the linked guide.

    9) Once you put your device in APX mode for the first time and connect it to your PC, go to Device manager and you should see a APX device with a ! symbol. Just like before, right click on it and choose update driver, navigate to your drivers folder you downloaded earlier, and update the driver. You should now be able to successfully issue the "wheelie --blob blob.bin" command and be able to move onto the next step. If your device is still showing up as Unknown device, you didn't install the drivers right, and you need to uninstall them again, and re-install them as stated.

    10) I issued the NVFlash Commands in this order:
    - wheelie --blob blob.bin
    - nvflash --resume --rawdeviceread 0 2944 bricksafe.img
    - nvflash --resume --read 14 factory-config.img
    - nvflash --resume --read 7 unlock-token.img
    - nvflash --resume --go <---- This reboots your device, so issue it last.

    11) You should be all set to go, with all your files in one folder.... go get your brick on!!! :laugh:
    fastboot/blobs after the nvflash fix

    flashing a recovery like twrp:
    say you get a copy of twrp from http://teamw.in/project/twrp2/93

    it comes for the tf201 in a .blob format (openrecovery-twrp-2.2.0-tf201.blob)

    at a commandline type
    blobunpack openrecovery-twrp-2.2.0-tf201.blob

    this will give you a file called openrecovery-twrp-2.2.0-tf201.blob.sos
    this is the recovery.img file

    in nvflash
    nvflash -r --download 5 openrecovery-twrp-2.2.0-tf201.blob.sos

    in fastboot
    fastboot -i 0x0b05 flash recovery openrecovery-twrp-2.2.0-tf201.blob.SOS
    So, now that I have created all of the backup files, is there a guide somewhere which explains how to restore my device if it does get bricked? Windows 7 X64......

    No, no guide yet.

    We purposedly left out the procedure for doing a full restore until it is explicitly required.
    Our experience is that if we give the instructions for this, people will do it for every little brick that could easily be fixed in other ways and it's just not a good idea ;)

    For 99% of cases, you can restore by simply flashing the partitions that have been broken, e.g.
    1. Bootloader having issues => nvflash -r --download 4 bootloader.bin
    2. Broken or stock recovery => nvflash -r --download 5 recovery.img
    3. Broken or stock boot partition => nvflash -r --download 6 boot.img
    4. Broken system partition => nvflash -r --download 10 system.img

    stock system.img, boot.img etc can be retrieving by using the blobunpack tool on the blob file (different blob :() inside official ASUS images (downloaded from support.asus.com). When unpacked, blob.APP => system, blob.LNX => boot.img, blob.SOS => blob.LNX.

    There are very few cases where you will brick further than this and when/if that happens, we'll be happy to help people through it, assuming they have ALL the backups we mention on androidroot.mobi! In everyday usage, you won't need those backups, but when/if something really bad happens, they could mean the difference between a brick and a recoverable tablet.