[TOOL][Updated 5.9.12]viperMOD PrimeTime v4.6 | Auto Root/Unroot/Busybox/CMW Flash!

Search This thread


Senior Member
May 13, 2007
This tool is very outdated anyway

Sent from my Full Android on PrimoC using xda app-developers app

All the threads regarding rooting the TF201 all seem to be outdated. How the hell does one root this tablet (running JB 4.2.1) currently?? Motochopper method was the last working method I knew about but I think even that is outdated.


Senior Member
Sep 12, 2012
All the threads regarding rooting the TF201 all seem to be outdated. How the hell does one root this tablet (running JB 4.2.1) currently?? Motochopper method was the last working method I knew about but I think even that is outdated.

MotoChopper still works. Asus never released a 4.2 update for the Prime so you can't be running that unless you're already running a custom ROM

Sent from my TF300T using xda app-developers app


Senior Member
May 13, 2007
MotoChopper still works. Asus never released a 4.2 update for the Prime so you can't be running that unless you're already running a custom ROM

Sent from my TF300T using xda app-developers app

Durrr.... you are 100% correct. Been so long since I fired this thing up I totally thought it was running a newer version of JB. I will proceed with Motochopper then, thanks. Trying to go from 100% unrooted stock to the latest version of AndroWook HairyBean. Hopefully I don't brick this thing trying to get root, then two different TWRP recoveries, then flashing HairyBean.


Nov 8, 2009
transformer prime problems

ok I was just given a transformer prime eee tab TF201 build-170 and have not been able to root it I have tried so many things and nothing has worked I would like to try the viper mod but no downloads that work or that aren't infected with viruses if somone could help me out please I need this project to keep me busy since I just had heart surgery and cant do much at all .

thanks much:D

Top Liked Posts

  • There are no posts matching your filters.
  • 394



    PrimeTime Reviews

    Tried the other two methods without any success...but this one is the only one that works!!

    You have done great work here. Top notch, the crazy thing is, even after trying to root about 6 times and being unsuccessful, I wasn't at all worried when I started PrimeTime.

    Everything went great I had lost root during the ICS ota and this fixed everything. Thanks -viperboy-

    currentuserjade said:
    Asus should send you a commission check, PrimeTime is the only reason I didn't return the TFP today!!! Thanks again!!!

    I do not have a TF101 anymore, but it has been reported that you can root the latest ICS update via option 1. Do so at your own risk! And PLEASE don't flash recovery if you're not on a Prime. That option is ONLY for TF201's!!


    Introducing viperMOD PrimeTime! An automated rooting program for your Asus Transformer Prime TF201 (ICS or HC supported) and the Asus Transformer TF101. It is very simple and easy to use with extra features that other root methods don't have. Works on Prime's that lost root with the ICS OTA! Now, here is how it works...

    • Download the .zip
    • Plug in your Transformer and make sure to install the drivers located in the included .zip (unless you can already adb into your device, then no need for drivers)
    • Kill Asus Sync and Splashtop! - very important!!
    • Make sure you have NO OTHER ANDROID DEVICES connected via USB!
    • If on Linux, you may need to do "chmod a+x /path/to/primetime/primetime.sh" (no quotes)
    • Run the viperMOD PrimeTime.exe and choose an option.
    • After rooting, download OTA Root Keeper from the Market!
    • ???
    • Profit?

    It's as simple as that! I have tested this about 30 times (both rooting and unrooting) and it works just fine! I would HIGHLY recommend downloading Voodoo Root Keeper!! Any issues or questions, please feel free to post here! Enjoy your rooted Prime :D

    Things you should NOT do!
    • Try to root with the Transformer in the dock
    • Use a USB extension cable
    • Not download OTA Root Keeper
    • Not follow directions

    Updated 5.9.12 - v4.6
    • Replaced OLD CWM recovery with latest TWRP 2.1
    • Fixed sparkym3's donate link

    HC root based on NachoRoot by jcase and TeamAndIRC.

    ICS root based on TPSparkyRoot by sparkym3.

    Latest ICS root based on https://github.com/saurik/mempodroid by Saurik.

    Windows (v4.6): Main Link, Mirror 1, Mirror 2
    Linux/Unix (v4.1 - update coming soon!): http://bit.ly/PrimeTime_v4_1_Linux
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 2.22 - v4.5[/COLOR][/SIZE][/U][/I][/B]
    [*][*]Added Asus Unlock Tool install and automated CWM flash
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.25 - v4.1[/COLOR][/SIZE][/U][/I][/B]
    [*]Fixed an issue where people couldn't root, even on latest OTA. The problem was a copy of su in /system/bin (or in some cases /system/xbin) that had the wrong permissions. The fix is to remove it, repush, and set correct permissions on it.
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.24 - v4[/COLOR][/SIZE][/U][/I][/B]
    [*]Support latest OTA (.11) and up! This should (hopefully) stick around a while because of the exploit used!
    [*]Code clean up
    [*][B]TIP:[/B] I would recommend just updating to .11.1 from [URL="http://forum.xda-developers.com/showthread.php?t=1452933"]here[/URL] (make sure you download the large 300+MB file) and follow those directions and then try rooting. That is what I did and v4 worked on that just fine :)
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.22[/COLOR][/SIZE][/U][/I][/B]
    [*]Added Linux/Unix version
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.12 - v3.1[/COLOR][/SIZE][/U][/I][/B]
    [*]Added a line of code to (hopefully) fix failed rooting. This was likely caused by root failing and not undoing the code (my script has always done that on a failed root, I assume most people who are having problems now did it by hand before?)
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.12 - v3[/COLOR][/SIZE][/U][/I][/B]
    [*]Supports ICS root method (as well as alt. root method, used on TF101 and Prime's on HC)
    [*]Better busybox install
    [*]Better su binary and Superuser app removal (checks /data for Superuser if you updated it in Market)
    [*]More code enhancements and cleanup
    [*]Added donate menu [because you guys love us :D]
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.10 - v2[/COLOR][/SIZE][/U][/I][/B]
    [*]Name changed to PrimeTime (thanks xda user whose name I need to find!)
    [*]Installs busybox upon rooting
    [*]Fix bug where superuser and binary weren't removed
    [*]Removes superuser.apk from /data/app if updated from Market
    [*]Gives you sysro and sysrw (type that into a terminal/adb shell for quick rw/ro /system)
    [*]Code enhancements and cleanup
    [B][I][U][SIZE="4"][COLOR="Red"]Updated 1.4 - v1[/COLOR][/SIZE][/U][/I][/B]
    [*]Initial Release


    Q. Do I need ADB?
    A. Yes, but you don't need to set it up or anything. I have packaged it as part of the .exe and it should work just fine.

    Q. Will I not be able to OTA?
    A. No, rooting doesn't affect OTA whatsoever. It's actually reverse - OTA affects root. You will still get update notifications when updates drops, but you WILL loose root if you update. Download Voodoo Root Keeper to keep root if you take the next OTA! The only way rooting would possibly affect an OTA is if, once rooted, you delete the certificates and modify the build.prop (and other things) that don't allow the OTAs to come through.

    Q. Will this work on ICS and/or HC?
    A. Yes, it now supports both. The ICS root method may work on HC Prime's and TF101's but I haven't gotten reports on that yet.

    Q. The program doesn't do anything! WTF?!
    A. Did you enable USB Debugging like the program told you too? [Settings > Developer Options] I hope you also installed the drivers, since the program told you to do that too. Once that is all set, the program will continue. If you're still having issues, please try this:

    Originally Posted by Swiftks
    Here's what I did to resolve the auto driver install by Windows 7, which does not allow for adb interface:

    1) Turn USB Debugging ON (Settings -> Developer Options)
    2) Allow installation of non-market apps (Settings -> Security -> Unknown Sources)
    3) Uncheck Launch ASUS Sync (Settings -> Accounts & sync)

    PC (Windows 7 x64):
    4) Connect Prime to PC via USB & drivers automatically installed. *Note: Prime is only visible under "Portable Devices" in Device Manager.
    5) Download the ViperMod .zip for Windows from the OP.
    6) In Device Manager, right click on Transformer Prime TF201 (under portable devices), and choose Update Driver Software.
    7) Choose Browse My Computer for Driver Software.
    8) Choose Let Me Pick A List of Device Drivers on My Computer
    9) If you see MTP USB Device on the next screen under ASUS Android MTP Device, choose it and click next. If you don't see this, then maybe try selecting "Have Disk" and pointing to the drivers folder in ViperMod (MTP file perhaps??).
    10) Windows will install driver and and you should now also see a separate tier under Device Manager labeled, ASUS Android Devices -> ASUS Android Composite ADB Interface. If you see this you are good to go and can run the adb vipermod root process.

    If you still need help with the driver install, this video tutorial might help.

    Q. Why add busybox and Superuser.apk to /system? I don't want that ****!
    A. Sorry I can't please you. Busybox is important because it adds many commands to the device that it doesn't have (it doesn't have basic commands like 'copy' or 'grep' [a type of find]). When you install ROMs on other devices, you have busybox. It will be necessary to things I have coming down the pipe ;) As far as Superuser getting installed to /system, you'd have to go out of your way to uninstall it. In /data, it's easy to uninstall and if you master reset, root wouldn't work because there is no app, upon reboot, that would manage apps requesting root access.
    Updated to v4.5! Installs the Asus Unlock Tool (you will get an error if you already have it installed, ignore it) and automatically flashes CWM! I've had 3 reports of this working, you guys should have no issues!

    I do intend to update to v5 and overhaul the entire program. Do things a little bit better and more efficiently. But that won't be for a little bit, as everything is working. I just want to do it since it's a little bit messy as it is right now.

    Enjoy :)
    Updated to v3! Get your automated ICS root on!! :D Please post feedback so that I know how it's working and PLEASE let me know if you're on ICS or HC (build number, please!). If someone has a good write-up or post with driver install info, that would be great. I would like to put it in the 2nd post for users who need help!
    Can you share step by step instructions as to how you did it. It will be greatly appreciated.

    Thank you

    Firts I downloaded the unlock tool here.


    Than you have to set up ADB.
    See here.


    After that you install CWM with method one from this thread.


    and than flah root files from this thread


    And than you are finished and rooted. :D