[toolbox] OnePlus One Toolbox

Search This thread

Babyhustle

Senior Member
Nov 13, 2013
218
21
V1 Link doesn't work

I'm sorry that I'm new here, the V1 link doesn't seem to be working, is it only me experiencing this? :confused:

Problem solved
 
Last edited:

Jamesr1292

Senior Member
Jan 29, 2013
88
8
Cork
having an issue with this today, seems to revert the recovery and root access when i update to cm12s. hoping this will be fixed quick as i want to get the most out of my oneplus one
 

areavip

Member
Jan 8, 2009
12
3
I tried this to update to oxygen but now I have no acess to the local storage. I cant even get the files into the phone by using adb push it just says "failed to copy....Read-only file system. Oxygen is running but nothing can write to the storage like games and whatsapp downloads. What can I do?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 166
    How to use by TK


    Capture2.png


    Whats new in V6
    • Updated TWRP to 2.8.6.0
    • Updated SuperSu to 2.46
    • Easily copy SuperSu to your Device with “Prepare”
    • This version don’t come with CM. You can download CM12S and flash with Recovery. Click here for more details

    Features
    • Lock/Unlock Bootloader
    • Install Custom Recovery (CWM, TWRP & Philz)
    • Install Stock Recovery
    • Root Device (Manual)

    Note
    Please download V6 if you are going to Unlock bootloader, Root, Change Recovery. Because others include CM11S installation files which is huge.

    Download Link:
    Click Here

    Hints (Manual)
    Enter fastboot mode: Turn the phone off. Hold volume up + power until the "fastboot" screen appears.
    Make sure you have drivers installed.
    9
    I mean full stock rom cm11s no matter which version, i think only XNPH22Q. Is available for flash using fastboot commands.
    http://forum.xda-developers.com/showthread.php?t=2765455

    Now you can install CM11S. v2 is up.
    5
    Updated to v6
    • Updated TWRP to 2.8.6.0
    • Updated SuperSu to 2.46
    • Easily copy SuperSu to your Device with “Prepare”
    3
    Hello,

    is it possibel to update the TWRP.img to the newest version from: teamw.in/project/twrp2/231

    If it is possible, is it enough to rename the new file with the original filename ?
    Also the same process for root\Super SU and CM?

    regards
    Neodym

    Just download the latest image file and rename it TWRP.img and put it in the Recovery folder of the tool. I've done that with no issues.

    ---------- Post added at 09:12 AM ---------- Previous post was at 09:09 AM ----------

    Hello!

    Excuse me for posting this in here but I hope anyone can help:

    -I am running currently TWRP recovery
    -CM12 unofficial builds
    -OPO alpha modem (for lollipop i suppose)
    -Of course rooted and everything
    -Unlocked bootloader also

    Now I am getting really tired of all the flashing and issues, wiping etc... I want to live like a normal guy without my ORD issues! (see signature)

    I can't believe I'm saying this, but I want to return to completely stock!

    All I need is root! Locked bootloader, stock recovery, stock modem, I don't care!

    All I want it stock rooted to be able to take OTA updates!

    (((IF I can do it without wiping my device it would be a huge benefit!)))

    How can I do that?
    I remember this tool that I downloaded to root/unlock bootloader etc... included such option but I don't know if that's safe to do now on lollipop!
    Besides there's this app that allows locking/unlocking bootloaders on the go without need for wipe etc...
    xda link for the app above!

    Copy over everything you want to keep from your phone to a flash drive or your computer (flashing back to stock wipes EVERYTHING), put your phone in Fastboot mode, plug it into your computer, open the tool then click the Flash CM XNPH44S button. That will flash your phone back to stock like it is brand new. Then flash a custom recovery so that you'll have TWRP or CWM then if you have a back up of 44S do a restore with it. I've done it twice like this and have not had any issues.
    2
    Do I have to unlock the device with this Toolkit before I am able to root?
    Yes
    Unlock the bootloader
    Flash recovery
    Flash super su zip
    Done.