[ToolKit] Nexus 7 one click root tool !

Search This thread

joe2262

Senior Member
Jan 30, 2011
196
10
I used this tool a while back and thought it went well, titanium backup and root explorer both ran as expected. But now I'm not so sure. Stick mount doesn't work and Lock Screen Policy will remove the widgets it won't remove the bold hour. It asks if I have root. Is it safe to use the tool again?


Just found and used Root Checker, it reports I don't have proper root?


Sent from my Nexus 7 using xda premium
 
Last edited:

vikashhero

Senior Member
Feb 17, 2011
486
177
London
Oh dear...

I've tried this on my 4.21 N7. It didn't work properly, just reset everything, I don't mind that, it's just that I can't factory reset anymore as it appears the tablet cant boot into recovery mode...

I've tried to launch recovery from the bootloader, but when I try to, it just boots into android.
 

treIII

Senior Member
Jul 10, 2012
3,177
583
Thank you r this tool kit. I'm a noob and used a super wipe script that totally erased everything from my tablet other than boot loader and recovery. I reinstalled 4.2.1 and rooted it then used voodoo ota root keeper. Accepted the update and now im back to 4.2.2 rooted. Thanks a million.

Sent from my Galaxy Nexus using xda app-developers app
 
Mar 26, 2011
48
0
I just got a Nexus 7 tablet. I used this method to unlock the bootloader, root, and install SuperSU and TWRP. It worked like a champ, and I thought I was good to go for installing all my apps/data from my previous tablet using the update.zip files I created with TiBu. I have the zip files in place on my Nexus 7, but I can't boot into recovery to install them.

Using both the manual boot method (Power + Vol down) and from inside apps (TiBu, ROM Toolbox, Quickboot) I can get into the bootloader menu just fine, but when I choose to go into Recovery Mode from there it simply goes to the white "Google" screen and then back into the normal boot process. I never get to the dead-looking Android guy with the exclamation mark.

How do I boot into recovery so I can install the update.zip files?
 
Last edited:

graydiggy

Senior Member
Sep 26, 2011
4,980
2,724
33
Bryan, TX
Tried that, didn't work.

If you have root go grab goo manager from the play store. Run it and give it root permission. Then hit your menu button when it comes up and hit install openrecoveryscript. You should be good to go once it finishes.

Sent from my Nexus 7 using xda premium
 

Attachments

  • uploadfromtaptalk1367772954342.jpg
    uploadfromtaptalk1367772954342.jpg
    59.8 KB · Views: 914
  • Like
Reactions: thecarlsoncrew
Mar 26, 2011
48
0
If you have root go grab goo manager from the play store. Run it and give it root permission. Then hit your menu button when it comes up and hit install openrecoveryscript. You should be good to go once it finishes.

Sent from my Nexus 7 using xda premium

Success! Looks like the recovery didn't take the first time - I actually flashed TWRP again through ROM Toolbox and everything worked perfectly. Same problem, different solution, but ultimately...thanks for your help!
 

fateit

New member
Aug 1, 2009
2
1
Hey gang, I had used this when I first got my Nexus 7 and it installed Flawlessly. Anyhow
I sent my N7 in for repairs with Asus as it was no longer charging, and they did a factory reset.
and now the root installer doesn't work and my N7 can't connect to PDANet, Yes I used
the drivers provided and debug is enabled, any clue what up?

Running 4.3, ADB just doesn't seem to work with this version, I'm tired of looking for versions that work
anyone have a version that DOES work?
 
Last edited:
  • Like
Reactions: xROID-RAGEx

Top Liked Posts

  • There are no posts matching your filters.
  • 132
    This tool will root you nexus 7 install su or super su and ClockWorkMod recovery!!
    i already developed a similar tool for the nexus s and galaxy nexus,this tool is based on the same code with few modifications.it should root your device in few minutes,so give it a spin and tell me how it goes :D

    Disclaimer!
    Your warranty is now void.
    I am not responsible for bricked or damaged devices
    YOU are choosing to make these modifications.


    Current v1.5:http://d-h.st/xMX

    Mirror:http://www.mediafire.com/?c29tr726xpejad7

    (old versions)
    v1.1: http://d-h.st/8I4
    Extract the downloaded zip file on your pc,install the drivers available in the "drivers" folder if you don't have them already installed,after installing the drivers run the file called "root.exe" to root your device.

    and here is a video that explains it all (big thank to SladeNoctics) : http://www.youtube.com/watch?v=2Q6uBd38hm0&feature=youtu.be

    Changelog
    v1.5
    -updated superuser and supersu
    -new recovery (all cwm bugs should be fixed)
    -new menu that
    4
    Hrm...there are a lot of ways you could improve this.
    3
    Worked right out of the box, thank you.

    1. Install driver accordingly, for 32bit or 64bit OS.
    2. Watch the question on Nexus 7 screen to let it unlock, use volume and power buttons to choose it.
    3. Remember to turn USB Debugging back on again after first boot, it wiped out everything.
    4. Go apps drawer, go Super User and update the bin coed twice.
    5. Install Busybox Free to create busybox.

    Done, and I install TB after this to restore my apps from other android, everything worked like a chime.
    3
    Well I am impressed. I thought for sure I would be seeing it AFTER it was shipped.

    Good job!

    This is Xda!!!!!!! (said in the Sparta scream voice)
    2
    also do i need android sdk installed for this toolkit to work?