• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Tried everything? Bluetooth trobleshooting - no sound in calls

Search This thread

SardaoVoador

Member
May 20, 2014
5
2
Hi everyone,
I can't make any calls through a bluetooth connected device, on my P20 Lite ANE-LX1. I've tried connecting to a car FM adapter and with my Xiaomi Mi TW Lite earbuds.
Symptoms are:
- devices successfully pair with P20L
- devices successfully conneted, with connection sound issued from the devices
- devices set to enable on calls and music
- devices play music with no problem
- I can chitchat with google assistant through the devices
- when I make a call google assistant uses the paired device to announce "callin person xxxx", there is no calling tone, can't hear or be heard.

Steps taken:
- devices tested with other phones, no problem there
- checked sound volume in calls
- restarted devices multiple times
- disconnected and reconnected devices
- tried every combination of calls/music/contact sharing on BT device properties
- deleted devices, re-paired and re-connected devices
- cache and data deleted for bluetooth backgound process
- reset network connections
- after reseting network, did all the above, several times
- wiped system cache/dalvik
- searched this forum, sorry if I'm missing the answer, I HONESTLY tried to find one
- boot into safe mode, no joy for bluetooth calls
- downgraded with HiSuite, updated, paired devices before restoring apps, no luck
- did most of the above again :)
- disabled google assistant

I've been searching everywhere for a solution and got nowhere. I think I'm down to either factory restore, which I don't think will solve the issue as I already downgraded, or maybe this could be permission related in the scense that another app could be taking controll over BT. I've been looking at permissions, but can't make an educated guess.
I've been seriously considering risking bricking my phone to unlock the bootloader and flash a different OS as I've only flashed an Android once, 10 years ago (and it was easy back then).

Please advise! ;)
 
Last edited:

blackhawk

Senior Member
Jun 23, 2020
6,421
2,084
Clear system cache
And this... toggle it on.
 

Attachments

  • Screenshot_20211007-092222_Settings.jpg
    Screenshot_20211007-092222_Settings.jpg
    361.2 KB · Views: 14

SardaoVoador

Member
May 20, 2014
5
2
Clear system cache
And this... toggle it on.
@blackhawk Thanks for the quick reply.
I forgot to mention I already tried wiping cache/dalvik, added to the original post.
As for disabling A2DP I can't find it on my developer options (Android 9/MIUI 9.1.0.381). I'll try to find why and if there's an alternative way to do the switching.
Will wipe cahe/dalvik again, should I find a way to deactivate A2DP.
Android shouldn't be this complicated :cry:
 
  • Like
Reactions: blackhawk

blackhawk

Senior Member
Jun 23, 2020
6,421
2,084
@blackhawk Thanks for the quick reply.
I forgot to mention I already tried wiping cache/dalvik, added to the original post.
As for disabling A2DP I can't find it on my developer options (Android 9/MIUI 9.1.0.381). I'll try to find why and if there's an alternative way to do the switching.
Will wipe cahe/dalvik again, should I find a way to deactivate A2DP.
Android shouldn't be this complicated :cry:
That's odd. I don't know if that's normal or not for that device.
Androids can be quit the terror sometimes.
 
  • Like
Reactions: SardaoVoador

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Clear system cache
    And this... toggle it on.
    @blackhawk Thanks for the quick reply.
    I forgot to mention I already tried wiping cache/dalvik, added to the original post.
    As for disabling A2DP I can't find it on my developer options (Android 9/MIUI 9.1.0.381). I'll try to find why and if there's an alternative way to do the switching.
    Will wipe cahe/dalvik again, should I find a way to deactivate A2DP.
    Android shouldn't be this complicated :cry:
    1
    @blackhawk Thanks for the quick reply.
    I forgot to mention I already tried wiping cache/dalvik, added to the original post.
    As for disabling A2DP I can't find it on my developer options (Android 9/MIUI 9.1.0.381). I'll try to find why and if there's an alternative way to do the switching.
    Will wipe cahe/dalvik again, should I find a way to deactivate A2DP.
    Android shouldn't be this complicated :cry:
    That's odd. I don't know if that's normal or not for that device.
    Androids can be quit the terror sometimes.
    1
    Hi @blackhawk, no such option. Any advanced options are those accessed via developer settings.
    Thanks for replying ;)