Tried To Install Factory ROM: Z5 Bricked

Search This thread


New member
Jul 5, 2022
Greetings -

A couple of years ago I purchased my Xperia Z5. A friend installed /e/ Foundation's custom ROM. It worked well until this year when 3G became obsolete. I figured I would try using it as a wifi phone without a SIM card. I would need to use my Google Voice number if I wanted to receive calls so I tried installing the factory Sony ROM so I could use the Google Voice app.

Sony Xperia Companion wouldn't recognize the phone because it had been unlocked to install a custom ROM. I then tried using the androidmtk's XperiFirm and Sony Flashtool apps to install the original ROM on the phone. Unfortunately Flashtool prompted me to select lock or unlock before proceeding and I unfortunately selected 'lock' because Xperia Companion wouldn't function with it unlocked. So that's all it took to brick my phone.

I can no longer power it on. If I press the power and volume up buttons at the same time it'll vibrate 3 times but won't power on. Sony Xperia Companion and Windows Device manager won't detect it. I hate to throw away a phone that still has a good battery. If anyone has any suggestions I'm all ears!