• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Trouble getting ROM onto my Note 4 (TWRP)

Search This thread


New member
Sep 17, 2021
United States
Hi. I've been trying to flash a ROM onto my Note 4 using TWRP, but I've been struggling to get it on there.

In the past I've been able to use something like ADB sideload to flash and it worked perfectly. However, when I try to use ADB sideload, it sits there forever saying "Starting ADB sideload feature...". I also tried mounting and using the "Install" feature, but I couldn't get it to mount either. I have the Samsung USB drivers installed and I have the android platform tools on my computer.

The phone is not bootable, there is no ROM installed, I formatted the device.

TWRP v3.4.0-0

From ADB:
Android Debug Bridge v1.0.41
Version 31.0.2-7242960

Any help would be appreciated.
Last edited:


Senior Member
Jul 17, 2017
why do you want to sideload a rom? a custom ROM is in zip format which you flash by installing it from twrp
you don't need to mount anything
what n4 model do you have? if it's the Snapdragon, maybe it's the emmc issue
also, try to flash stock with Odin to see if you can use it normally
then reflash twrp