• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Troubleshooting wifi problems on S2 exynos5433 tablet ONLY discussion for users running any version of Android 10

Search This thread

retiredtab

Senior Member
Nov 16, 2017
770
320
Please take 10 minutes to read all of post #1 and #2. lpedia and I have spent 5 days troubleshooting this together and want to present our wifi findings. DO NOT USE this thread to report any other problems, it's only for exynos5433 S2 tablet wifi. If this is unreasonable, then stop reading. Thank you.

If your device's wifi is not connecting after a restart and/or wake from sleep, and/or dropping out at random, this could be because the 17.1 code is using Samsung Galaxy S6 wifi blobs instead of its stock S2 wifi blobs. This commit was made in 17.1 at

gts2: Import Galaxy S6 BCM4358 firmware · universal5433/[email protected]

@lpedia has confirmed that LineageOS 17.1 on his T710 has the wifi problems when using S6 blobs, but not after the S6 blobs have been replaced with stock S2 blobs. This appears to fix both non-connection at boot and not reconnecting on wake from sleep. Random dropouts are less common and were not seen during the limited testing, so it's not certain that they're gone.

FAQ

Q1. Will changing from S6 wifi blobs solve all my wifi no reconnect or disconnect problems?
A1. This has only been tested on the T710, and there's no guarantee it will help the other devices. If you want to try, follow the instructions below. Before you try, make sure to back up all your data. The following should write the stock S2 blobs to the /system partition only, but if you make a mistake you could lose your data! Back up first.

It's an easy test to see if the stock S2 blobs will help or not. If your current rom does not connect to wifi after a restart, try our proposed solution. Before you do, reboot your current rom 5 times in a row. After each reboot, see if your wifi connects. After you install stock S2 blobs, reboot your device again 5 times in a row and see if wifi connects. This will easily tell you if the S2 stock blobs have solved this one particular problem or not.

As for wifi not connecting after long/deep sleep, you should notice over 2 or 3 days if wifi connects or not after deep sleep.

Q2. Will this work on SM-T710, SM-T810, etc?
A2. Same answer as A1. It should work on any S2 tablet exynos5433 device that uses the S6 wifi blobs that are the default in 17.1 or Android 10. These instructions are only for exynos5433 devices.

As the thread grows bigger, you can see who is responding back with either positive or negative feedback and what model they have.

Q3. Will this work on RR, Havoc or LineageOS (Android 10 or 17.1)?
A3. The instructions below replace the S6 blobs with the original stock S2 blobs. The instructions provided should work regardless if it's Havoc, RR or LineageOS. All these variant OSes share the same repo (i.e. code and blobs) on github.

Q4. Is this post relevant to Android 9 or LineageOS 16.0?
A4. NO. The github repos show that Android 9 or LineageOS 16.0 used the stock S2 wifi blobs. This was changed to S6 wifi blobs in Android 10 or LineageOS 17.1. I don't know why it was changed to S6 blobs as I'm not involved with that change.

Q5. Why do I need my model and code name?
A5. In order to follow the instructions below, you need to know your model number and it's code name. The model number or device name is settings, about tablet.

You can find the code name at (scroll almost all the way down to the bottom)


For example, SM-T710 is gts28wifi.

Q6. Does it matter if my wifi is 2.4Ghz or 5Ghz or a mix of both?
A6. When reporting back to us, please state whether your network is 2.4Ghz only, 5Ghz only, or a mix of 2.4Ghz and 5Ghz. In addition, if its a mix, please let us know if it's one wifi network (same ssid) or two separate wifi networks. That is, 2.4Ghz is one ssid and 5Ghz is another ssid.

Q7. If this works, how will this be fixed for the next release of code and the future?
A7. If enough people say it fixes their wifi problems, I can submit a git pull request to Anan to revert the S6 wifi blobs back to S2 wifi blobs.

Instructions

1. Make sure adb debugging is enabled in developer options. To enable developer options, tap settings, about tablet, build number 7 times until it says developer options unlocked. Go back to settings, system, advanced, developer options, enable android debugging and rooted debugging.

Note if you are running Magisk, see posts regarding Magisk if you cannot see rooted debugging.

2. You will need git. There are instructions and download links for installing git on Windows, MacOS, and Linux at Git Guides - install git | GitHub.
3. After you install git, follow the instructions exactly below.
Bash:
# make temporary vendor directory
mkdir temp
# cd to that directory
cd temp
# git the 16.0 stock drivers
git clone https://github.com/universal5433/proprietary_vendor_samsung -b lineage-16.0
# change directory to proprietary_vendor_samsung/<your device>/proprietary/system/vendor/etc
# or if Windows, to proprietary_vendor_samsung\<your device>\proprietary\system\vendor\etc
# where "<your device>" is your device's code, for example gts28wifi for the T710:
cd proprietary_vendor_samsung/gts28wifi/proprietary/system/vendor/etc
# start adb root
adb root
# remount /system as rw (it's read only by default)
adb remount
# start adb shell
adb shell
# delete S6 blobs from wifi directory
cd /system/vendor/etc/wifi
rm bcm*
rm nvr*
# There should be only .conf files left now
ls -al
exit
# you should be back at your desktop terminal prompt now
# now push all stock drivers to /system/vendor/etc/wifi
adb push wifi /system/vendor/etc
# check to make sure it got pushed okay
adb shell ls -al /system/vendor/etc/wifi
# now reboot Android
adb reboot

If the above does not work for you, or if it causes other problems, just reflash the last rom. That will overwrite the /system partition and everything will be restored.

If you do try this, please report back to this thread about whatever happened and include your device and what wifi network you are running.
 
Last edited:

Yogi555

Member
Jul 21, 2021
16
5
Thanks for the instructions!
I had to boot my T810 (gts210wifi) into TWRP and mount /system from there before adb root and adb remount was possible. Everything else worked as described.
Observations after 5 reboots: WiFi available after reboot each time! Much better than before!
I will observe it now for a while regarding wifi-off after sleep or sporadical wifi-off.
Btw. for the random reboots of the unmodified linageos17.1 (ripee) I'm pinging my DNS-server all 2mins using Tasker. Fixed reboots since 2 month at least on my system.
 
  • Like
Reactions: lpedia

Yogi555

Member
Jul 21, 2021
16
5
Strangely the setting seems not there in my system. But I remember that in some system its available. Can the installed Magisk be the reason?
 

retiredtab

Senior Member
Nov 16, 2017
770
320

Attachments

  • Screenshot_20210721-141159_Settings.png
    Screenshot_20210721-141159_Settings.png
    173.1 KB · Views: 28

Yogi555

Member
Jul 21, 2021
16
5
Short update: The S2 wifi blobs are a huge improvement. With S6 blobs I had reliable dropoffs at medium router-signal combined with heavy wifi-load (no dropoffs with full router signal). With the S2 blobs no single dropoff even at weak router-signal and heavy wifi-load for several hours now.
 
  • Like
Reactions: lpedia

retiredtab

Senior Member
Nov 16, 2017
770
320
Again, to enable developer options, tap settings, about tablet, build number 7 times until it says developer options unlocked. Go back to settings, system, advanced, developer options, enable android debugging and rooted debugging.
 

Yogi555

Member
Jul 21, 2021
16
5
As I said earlier, the routed debugging option is missing in my developer-options (with installed Magisk). Everything else is looking identical to the attachement of post 6. But maybe we should not cover this thread with the different ways to adb root. The really important thing is that the proposed fix works really great! At least for me and hopefully for everybody else who is willing to try it
 

lpedia

Senior Member
Sep 18, 2020
142
67
As I said earlier, the routed debugging option is missing in my developer-options (with installed Magisk). Everything else is looking identical to the attachement of post 6. But maybe we should not cover this thread with the different ways to adb root. The really important thing is that the proposed fix works really great! At least for me and hopefully for everybody else who is willing to try it
Thanks, @Yogi555! It's great to know that replacing the blobs works on one of the other S2 models! We could only test it on gts28wifi (T710).
 

lpedia

Senior Member
Sep 18, 2020
142
67
@Yogi555, about the Rooted debugging option: my T710 doesn't show that option, either, and I think it's because I have Magisk installed (@retiredtab doesn't).

If the device is not rooted, "adb root" temporarily restarts the adbd daemon on the device as root (there's a timeout period after which it will remove root access again).

I'm guessing that if the device is rooted, that isn't necessary - because adbd is probably already running as root . The Rooted debugging option is therefore unnecessary, and isn't shown.

In either case, when you do "adb root" on the PC, there should be a prompt on the device asking you if you want to allow access. Did you see the prompt? If you don't explicitly allow it, root access won't be given.

Also, "adb root" works on Windows (for an account that's in the Administrators group) without needing to be Run As Administrator, but I think Linux requires the command to be run as root (eg, sudo adb root).
 

Yogi555

Member
Jul 21, 2021
16
5
Update2: after the night the T810 with S2 blobs was immediately connected to wifi this morning. Great!
Regarding "adb root" with Magisk: I'm running it from Win10 PC. Independent if normal commandline or commandline as administrator - after "adb root" there is no output at all, but a sound like connecting or disconnecting a device. After "adb remount" next, an error is displayed:
Not running as root. Try "adb root" first.
remount failed
Maybe my adb is too old (version 1.0.40)
However "adb reboot recovery" works and "adb root" then in TWRP as well. So strange, but no problem :)
 

lpedia

Senior Member
Sep 18, 2020
142
67
Update2: after the night the T810 with S2 blobs was immediately connected to wifi this morning. Great!
Regarding "adb root" with Magisk: I'm running it from Win10 PC. Independent if normal commandline or commandline as administrator - after "adb root" there is no output at all, but a sound like connecting or disconnecting a device.
Did you check the device to see if it's prompting you to allow this access? The prompt times out fairly quickly, so you might not see it if you don't check straight away. It does give a notification sound.

1626930219581.png
 

Yogi555

Member
Jul 21, 2021
16
5
The prompting came yesterday at the very beginning of the activity and I allowed it (including the always checkbox). "adb device" shows the device id.
 

lpedia

Senior Member
Sep 18, 2020
142
67
I don't understand why you'd see anything different from what I see. I use a Windows PC, I have Magisk (version 23.0) installed on the T710, and have previously allowed adb root access "always".

What I see is this:
Code:
> adb version
Android Debug Bridge version 1.0.41 
Version 31.0.2-7242960

> adb root
adbd is already running as root

> adb remount
remount succeeded

> adb root
gts28wifi:/ #

I think there could be something wrong with your Magisk configuration. What version is it?
 

Yogi555

Member
Jul 21, 2021
16
5
Downloaded adb version 1.0.41. Now I get "ADB Root access is disabled by system setting - enable in Settings -> System -> Developer options"
Updated Magisk from 20.4 to 22.1. and App to 23.0 => No difference :-(
In Magisk App adb is not listed in Superuser-tab. Can I add it somehow?
 

lpedia

Senior Member
Sep 18, 2020
142
67
Downloaded adb version 1.0.41. Now I get "ADB Root access is disabled by system setting - enable in Settings -> System -> Developer options"
Updated Magisk from 20.4 to 22.1. and App to 23.0 => No difference :-(
In Magisk App adb is not listed in Superuser-tab. Can I add it somehow?
I think I know what's going on now.

I've just uninstalled Magisk, and (after the enforced reboot) I can now see the "Rooted debugging" setting in Settings > System > Developer Options > Debugging.

Mine was ON, but had been hidden by Magisk's presence, as I suspected.

If you uninstall Magisk, I think you will find that your "Rooted debugging" is OFF. If so, turn it on, then try "adb root" etc. You don't need to root the device in order to use adb root functions. If you want the device to be rooted, by all means re-install Magisk - but with that setting still ON.

I'll be very interested to hear what happens. :)
 
  • Like
Reactions: Yogi555

lpedia

Senior Member
Sep 18, 2020
142
67
The simplest way to check that adb root has actually given you root access is to "adb shell". The prompt will end in a "#" if the shell's running as root. As mentioned in an earlier post.
 

lpedia

Senior Member
Sep 18, 2020
142
67
I think I know what's going on now.

I've just uninstalled Magisk, and (after the enforced reboot) I can now see the "Rooted debugging" setting in Settings > System > Developer Options > Debugging.

Mine was ON, but had been hidden by Magisk's presence, as I suspected.
I've just re-installed Magisk and proved to myself that Magisk 23 is hiding the setting. I found that Magisk 22 didn't hide it - I re-installed using a version 22 zip that I had on hand, checked the "Rooted debugging" setting, which was still visible, then updated to Magisk 23 via the app. After the reboot, the setting had disappeared again.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Please take 10 minutes to read all of post #1 and #2. lpedia and I have spent 5 days troubleshooting this together and want to present our wifi findings. DO NOT USE this thread to report any other problems, it's only for exynos5433 S2 tablet wifi. If this is unreasonable, then stop reading. Thank you.

    If your device's wifi is not connecting after a restart and/or wake from sleep, and/or dropping out at random, this could be because the 17.1 code is using Samsung Galaxy S6 wifi blobs instead of its stock S2 wifi blobs. This commit was made in 17.1 at

    gts2: Import Galaxy S6 BCM4358 firmware · universal5433/[email protected]

    @lpedia has confirmed that LineageOS 17.1 on his T710 has the wifi problems when using S6 blobs, but not after the S6 blobs have been replaced with stock S2 blobs. This appears to fix both non-connection at boot and not reconnecting on wake from sleep. Random dropouts are less common and were not seen during the limited testing, so it's not certain that they're gone.

    FAQ

    Q1. Will changing from S6 wifi blobs solve all my wifi no reconnect or disconnect problems?
    A1. This has only been tested on the T710, and there's no guarantee it will help the other devices. If you want to try, follow the instructions below. Before you try, make sure to back up all your data. The following should write the stock S2 blobs to the /system partition only, but if you make a mistake you could lose your data! Back up first.

    It's an easy test to see if the stock S2 blobs will help or not. If your current rom does not connect to wifi after a restart, try our proposed solution. Before you do, reboot your current rom 5 times in a row. After each reboot, see if your wifi connects. After you install stock S2 blobs, reboot your device again 5 times in a row and see if wifi connects. This will easily tell you if the S2 stock blobs have solved this one particular problem or not.

    As for wifi not connecting after long/deep sleep, you should notice over 2 or 3 days if wifi connects or not after deep sleep.

    Q2. Will this work on SM-T710, SM-T810, etc?
    A2. Same answer as A1. It should work on any S2 tablet exynos5433 device that uses the S6 wifi blobs that are the default in 17.1 or Android 10. These instructions are only for exynos5433 devices.

    As the thread grows bigger, you can see who is responding back with either positive or negative feedback and what model they have.

    Q3. Will this work on RR, Havoc or LineageOS (Android 10 or 17.1)?
    A3. The instructions below replace the S6 blobs with the original stock S2 blobs. The instructions provided should work regardless if it's Havoc, RR or LineageOS. All these variant OSes share the same repo (i.e. code and blobs) on github.

    Q4. Is this post relevant to Android 9 or LineageOS 16.0?
    A4. NO. The github repos show that Android 9 or LineageOS 16.0 used the stock S2 wifi blobs. This was changed to S6 wifi blobs in Android 10 or LineageOS 17.1. I don't know why it was changed to S6 blobs as I'm not involved with that change.

    Q5. Why do I need my model and code name?
    A5. In order to follow the instructions below, you need to know your model number and it's code name. The model number or device name is settings, about tablet.

    You can find the code name at (scroll almost all the way down to the bottom)


    For example, SM-T710 is gts28wifi.

    Q6. Does it matter if my wifi is 2.4Ghz or 5Ghz or a mix of both?
    A6. When reporting back to us, please state whether your network is 2.4Ghz only, 5Ghz only, or a mix of 2.4Ghz and 5Ghz. In addition, if its a mix, please let us know if it's one wifi network (same ssid) or two separate wifi networks. That is, 2.4Ghz is one ssid and 5Ghz is another ssid.

    Q7. If this works, how will this be fixed for the next release of code and the future?
    A7. If enough people say it fixes their wifi problems, I can submit a git pull request to Anan to revert the S6 wifi blobs back to S2 wifi blobs.

    Instructions

    1. Make sure adb debugging is enabled in developer options. To enable developer options, tap settings, about tablet, build number 7 times until it says developer options unlocked. Go back to settings, system, advanced, developer options, enable android debugging and rooted debugging.

    Note if you are running Magisk, see posts regarding Magisk if you cannot see rooted debugging.

    2. You will need git. There are instructions and download links for installing git on Windows, MacOS, and Linux at Git Guides - install git | GitHub.
    3. After you install git, follow the instructions exactly below.
    Bash:
    # make temporary vendor directory
    mkdir temp
    # cd to that directory
    cd temp
    # git the 16.0 stock drivers
    git clone https://github.com/universal5433/proprietary_vendor_samsung -b lineage-16.0
    # change directory to proprietary_vendor_samsung/<your device>/proprietary/system/vendor/etc
    # or if Windows, to proprietary_vendor_samsung\<your device>\proprietary\system\vendor\etc
    # where "<your device>" is your device's code, for example gts28wifi for the T710:
    cd proprietary_vendor_samsung/gts28wifi/proprietary/system/vendor/etc
    # start adb root
    adb root
    # remount /system as rw (it's read only by default)
    adb remount
    # start adb shell
    adb shell
    # delete S6 blobs from wifi directory
    cd /system/vendor/etc/wifi
    rm bcm*
    rm nvr*
    # There should be only .conf files left now
    ls -al
    exit
    # you should be back at your desktop terminal prompt now
    # now push all stock drivers to /system/vendor/etc/wifi
    adb push wifi /system/vendor/etc
    # check to make sure it got pushed okay
    adb shell ls -al /system/vendor/etc/wifi
    # now reboot Android
    adb reboot

    If the above does not work for you, or if it causes other problems, just reflash the last rom. That will overwrite the /system partition and everything will be restored.

    If you do try this, please report back to this thread about whatever happened and include your device and what wifi network you are running.
    1
    Thanks for the instructions!
    I had to boot my T810 (gts210wifi) into TWRP and mount /system from there before adb root and adb remount was possible. Everything else worked as described.
    Observations after 5 reboots: WiFi available after reboot each time! Much better than before!
    I will observe it now for a while regarding wifi-off after sleep or sporadical wifi-off.
    Btw. for the random reboots of the unmodified linageos17.1 (ripee) I'm pinging my DNS-server all 2mins using Tasker. Fixed reboots since 2 month at least on my system.
    1
    Short update: The S2 wifi blobs are a huge improvement. With S6 blobs I had reliable dropoffs at medium router-signal combined with heavy wifi-load (no dropoffs with full router signal). With the S2 blobs no single dropoff even at weak router-signal and heavy wifi-load for several hours now.
    1
    Downloaded adb version 1.0.41. Now I get "ADB Root access is disabled by system setting - enable in Settings -> System -> Developer options"
    Updated Magisk from 20.4 to 22.1. and App to 23.0 => No difference :-(
    In Magisk App adb is not listed in Superuser-tab. Can I add it somehow?
    I think I know what's going on now.

    I've just uninstalled Magisk, and (after the enforced reboot) I can now see the "Rooted debugging" setting in Settings > System > Developer Options > Debugging.

    Mine was ON, but had been hidden by Magisk's presence, as I suspected.

    If you uninstall Magisk, I think you will find that your "Rooted debugging" is OFF. If so, turn it on, then try "adb root" etc. You don't need to root the device in order to use adb root functions. If you want the device to be rooted, by all means re-install Magisk - but with that setting still ON.

    I'll be very interested to hear what happens. :)
    1
    Want to also quickly confirm in here that the S2 Blobs are working real fine for me as well.