• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[TUR]Disable Home key or change to Power key

Search This thread

sanixk

Member
Sep 29, 2011
22
18
first backup /system/usr/keylayout/gpio-keys.kl
edit /system/usr/keylayout/gpio-keys.kl,
key 136 SEARCH WAKE_DROPPED
key 139 MENU WAKE
key 102 UNKNOWN
key 158 BACK WAKE_DROPPED
key 116 POWER WAKE
key 115 VOLUME_UP WAKE_DROPPED
key 114 VOLUME_DOWN WAKE_DROPPED

change 3td line to "key 102 UNKNOWN " to disable Home key.
u can change to "key 102 POWER", so u can screen on/off by pressing Home key
Edit/Delete Message
 

jschall

Senior Member
Dec 30, 2009
148
27
79
Mont Saint-Hilaire, Québec
So, I followed the instructions above, the home button is 'unknown ", but it still keeps flashing - to indicate notifications, I guess. Is there any way to stop notifications from flashing the home (and Power) buttons?

---------- Post added at 06:42 AM ---------- Previous post was at 06:27 AM ----------

I am wondering - would it be possible to turn the HOME button into a second BACK button rather than a POWER button? I find the bottom-left locationof the BACK button quite inconvenient.
 

Kung-Fu-Panda

Member
Oct 15, 2011
6
0
Hi, I have HP IPAQ 514 (Voice Messenger) :D and my red button is broken :(. It isn't actually broken, but when I click it, it doesn't respond :eek:. Instead, it responds whenever it wants :p. Is there a way to disable the button :confused: because it's really getting on my nerves :mad:. Please help, thanks :p!
 

painter_

Senior Member
Dec 10, 2006
729
166
North Eastern Ohio
Hi, I have HP IPAQ 514 (Voice Messenger) :D and my red button is broken :(. It isn't actually broken, but when I click it, it doesn't respond :eek:. Instead, it responds whenever it wants :p. Is there a way to disable the button :confused: because it's really getting on my nerves :mad:. Please help, thanks :p!

Thank you for the morning laugh. This post fails on many levels. The Ipaq is Windows Mobile, not Android.
 

FloatingFatMan

Senior Member
Apr 20, 2005
2,708
539
51
Hi, I have HP IPAQ 514 (Voice Messenger) :D and my red button is broken :(. It isn't actually broken, but when I click it, it doesn't respond :eek:. Instead, it responds whenever it wants :p. Is there a way to disable the button :confused: because it's really getting on my nerves :mad:. Please help, thanks :p!

Until you learn to both post in the right section AND stop using so many goddam smilies, I think we should just disable your posting button instead. :p
 

goofball2k

Senior Member
Oct 5, 2010
1,569
457
Ottawa
first backup /system/usr/keylayout/gpio-keys.kl
edit /system/usr/keylayout/gpio-keys.kl,
key 136 SEARCH WAKE_DROPPED
key 139 MENU WAKE
key 102 UNKNOWN
key 158 BACK WAKE_DROPPED
key 116 POWER WAKE
key 115 VOLUME_UP WAKE_DROPPED
key 114 VOLUME_DOWN WAKE_DROPPED

change 3td line to "key 102 UNKNOWN " to disable Home key.
u can change to "key 102 POWER", so u can screen on/off by pressing Home key
Edit/Delete Message

Sorry for the noob questions I'm about to ask.
I need to have the A100 rooted before I do this?
What am I using to edit the .kl file?
 

goofball2k

Senior Member
Oct 5, 2010
1,569
457
Ottawa
Yes. You do need to be rooted. You can't access the file without root.
You don't need anything to edit the file.
Simply open as - text - text editor and modify the file. Save it afterwards.

Great, thanks! Got it working now (or rather, not working). Now my 2yr old son won't be pressing it each time he holds it to watch his videos. I've hit it enough times to annoy me as well, wish they would have used a real button but then I'm sure Apple would have sued them for using a real button :rolleyes:
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    first backup /system/usr/keylayout/gpio-keys.kl
    edit /system/usr/keylayout/gpio-keys.kl,
    key 136 SEARCH WAKE_DROPPED
    key 139 MENU WAKE
    key 102 UNKNOWN
    key 158 BACK WAKE_DROPPED
    key 116 POWER WAKE
    key 115 VOLUME_UP WAKE_DROPPED
    key 114 VOLUME_DOWN WAKE_DROPPED

    change 3td line to "key 102 UNKNOWN " to disable Home key.
    u can change to "key 102 POWER", so u can screen on/off by pressing Home key
    Edit/Delete Message
    2
    Hi, I have HP IPAQ 514 (Voice Messenger) :D and my red button is broken :(. It isn't actually broken, but when I click it, it doesn't respond :eek:. Instead, it responds whenever it wants :p. Is there a way to disable the button :confused: because it's really getting on my nerves :mad:. Please help, thanks :p!

    Thank you for the morning laugh. This post fails on many levels. The Ipaq is Windows Mobile, not Android.
    1
    We can change the behaviour of the physical keys of A100 from changing the file:/system/usr/keylayout/gpio-keys.kl
    1
    sure!!!!!!!!!!!!!!!!!!!!!!!!!1
    1
    It works!

    Just want to make sure this works before I attempt it...thanks
    I just tried it, and it works!

    Thanks, @sanixk!