• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[TUR]Disable Home key or change to Power key

Search This thread

xxdababyonexx

Senior Member
Apr 13, 2010
65
1
Help

I have a different issue, I want to move to home when I push the home button but stopped working after I installed the new leak of ICS, now I can't figure out a way to get it working properly again.
 

jeromel

Senior Member
Jul 19, 2008
119
14
Winnipeg
I have a different issue, I want to move to home when I push the home button but stopped working after I installed the new leak of ICS, now I can't figure out a way to get it working properly again.

Not sure if this is what you meant... But do you mean that when you press the Home button, now, you don't get back to the Home screen?

Sent from my A100 using Tapatalk
 
Oct 4, 2012
7
1
That's correct

Sent from my ADR6425LVW using xda premium

Did you ever get it working again? I am having a similar problem.

Can anyone help?

I wanted to disable the home button at the lockscreen I did this:

1) Made backup of /system/usr/keylayout/gpio-keys.kl
2) edited it to make the power button not work at the lockscreen.

It worked.. but then I wanted to change back as I didnt like it.

deleted the file, and pasted the backup one in the same location.

rebooted but I still cant use the button :(
 

pio_masaki

Senior Member
May 7, 2012
4,587
3,653
Surprise, Az
Did you ever get it working again? I am having a similar problem.

Can anyone help?

I wanted to disable the home button at the lockscreen I did this:

1) Made backup of /system/usr/keylayout/gpio-keys.kl
2) edited it to make the power button not work at the lockscreen.

It worked.. but then I wanted to change back as I didnt like it.

deleted the file, and pasted the backup one in the same location.

rebooted but I still cant use the button :(

Try clearing cache and dalvik and see if that helps it reset

Sent from my Galaxy Nexus using Tapatalk 2
 

Maverynthia

Member
Jun 9, 2012
10
0
I'm having a similar problem with mine. I messed up trying to install a build.prop then went and installed ICS 1.0.0.14 WW GEN1 something again and now the Home button both the software and the tablet button don't work. :c

I saw a fix for installing "latest gapps" but I can't find those for the a100 unless it's for some CM mod.
 

Romman0

Senior Member
May 7, 2012
996
468

jtcressy

Senior Member
Nov 26, 2012
61
15
Grand Junction, CO
fully disable home key

Ichanged Key 102 to UNKNOWN, and it now functions as a "Scroll To Top" button in Dolphin HD!

Has anybody else seen that behavior?
:::See edit2 first:::
Go to /system/usr/keylayout/Generic.kl
Scroll down to find "key 102 MOVE_HOME"
Delete "MOVE_HOME
" to make it say "key 102"
Leaving it blank at the end removes any function from the key.

Sorry to dig up this thread, but that needed an answer.

Edit: prior to editing that line, the button acted as a "page up" function. So if you had a page on the screen(web,email,PDF,etc), it would scroll to the top whenever you touched the button.

Edit2: DO NOT EDIT general.Kl. it disables the volume buttons if it is erased. Instead, use "BREAK ", not "UNKNOWN ". Break has no function, so when you press the key nothing will happen. Sorry about the extra edits, I had to correct myself.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    first backup /system/usr/keylayout/gpio-keys.kl
    edit /system/usr/keylayout/gpio-keys.kl,
    key 136 SEARCH WAKE_DROPPED
    key 139 MENU WAKE
    key 102 UNKNOWN
    key 158 BACK WAKE_DROPPED
    key 116 POWER WAKE
    key 115 VOLUME_UP WAKE_DROPPED
    key 114 VOLUME_DOWN WAKE_DROPPED

    change 3td line to "key 102 UNKNOWN " to disable Home key.
    u can change to "key 102 POWER", so u can screen on/off by pressing Home key
    Edit/Delete Message
    2
    Hi, I have HP IPAQ 514 (Voice Messenger) :D and my red button is broken :(. It isn't actually broken, but when I click it, it doesn't respond :eek:. Instead, it responds whenever it wants :p. Is there a way to disable the button :confused: because it's really getting on my nerves :mad:. Please help, thanks :p!

    Thank you for the morning laugh. This post fails on many levels. The Ipaq is Windows Mobile, not Android.
    1
    We can change the behaviour of the physical keys of A100 from changing the file:/system/usr/keylayout/gpio-keys.kl
    1
    sure!!!!!!!!!!!!!!!!!!!!!!!!!1
    1
    It works!

    Just want to make sure this works before I attempt it...thanks
    I just tried it, and it works!

    Thanks, @sanixk!