[TUT][OUTDATED] How to Root your G9, Enable SDE, and Optimize

Search This thread

briandang98

Member
Oct 12, 2011
46
0
I tried the new guide for firmware 4.0.26 but it did not work : update failed 221. So I tried this old way but I have
encountered problem in step 1 pre-root/temp-root:

In command I put
C:\User\Nam\anroid\android-sdk\platform-tools\ adb device
It shows:
*daemon not ..........
*daemon started ..........
list of device attached
A80S6kf92jf5096ff4 device

It means I have ADB installed in my computer
but when I tried to run rootdevice.cmd it shows ( in command window )

'adb' is not recognized as an internal or external command

What did i do wrong?
Note:
1) When I run command it run default as c:\user\Nam
2) My Sdk is in c:\user\Nam\Android.
 

julle131

Senior Member
Mar 24, 2011
1,476
606
I tried the new guide for firmware 4.0.26 but it did not work : update failed 221. So I tried this old way but I have
encountered problem in step 1 pre-root/temp-root:

In command I put
C:\User\Nam\anroid\android-sdk\platform-tools\ adb device
It shows:
*daemon not ..........
*daemon started ..........
list of device attached
A80S6kf92jf5096ff4 device

It means I have ADB installed in my computer
but when I tried to run rootdevice.cmd it shows ( in command window )

'adb' is not recognized as an internal or external command

What did i do wrong?
Note:
1) When I run command it run default as c:\user\Nam
2) My Sdk is in c:\user\Nam\Android.

You must add adb to your path. Follow this guide, but change the locations from this guide to where you have your sdk:

You will have to enter the path (cd C:\android-sdk-windows\platform-tools) and (adb.exe) everytime you want to use adb. You can go to Environmental Variables to set add the path.

1. Right click My Computer
2. Advanced system settings
3. Environmental Variables
4. System Variables -> Path
5. ;C:\android-sdk-windows\platform-tools
OR if ADB is in tools
;C:\android-sdk-windows\tools

Source:
http://www.xoomforums.com/forum/mot...windows-7-64-bit-other-windows-platforms.html

Sent from my GT-I9100 using xda app-developers app
 

h8train

Member
Feb 6, 2010
10
3
Faq boot loop, step 1, file did not work for me, error 221.
But I downloaded the official from the archos website and it worked and fixed my boot loop.

Just thought I would share that.

Also.

Does anyone know the details about "update failed: error (221) ?
That's what I get when trying to update the official SDE from archos, hence why I'm here trying this method. Of course this method didn't work either, ended up with the above boot loop.

Thanks,
Rich
 

Shano56

Senior Member
Oct 21, 2011
1,432
556
null
Official sde doesn't install if you are on the latest archos firmware. Not sure why. I need to update my guides to make this more clear, but i have been really busy with work lately. Sorry guys

Sent from my ADR6300 using Tapatalk 2
 

Urbangt19

Member
Oct 4, 2021
11
0
Bro do you still have
Concerning multiple users, I would suggest you Switch Me, it allows users to have their own sessions on the tablet.

As for the uncompatible apps, it's mostly games that haven't been certified as compatible but they actually run flawlessly! (9mm, Asphalt 6 HD...). I tried to modify build.prop and init.Archos.80S (in my case) but it didn't work on ICS (see topic http://forum.xda-developers.com/showthread.php?t=1528899)

Sent from my Archos 80G9 using XDA Premium HD app
Bro do you still have asphalt 6 on archos g9?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 29
    archos.png


    NEW GUIDE SEE HERE: http://forum.xda-developers.com/showthread.php?t=1653566


    Hi everyone! The following guide I put together is a simple, easy to follow guide, for all G9 users. If you own an ARCHOS G8, this guide will not work for you. This guide will help you easily root your tablet. If you have found anything helpful, please click "thanks" on my post, and visit the original threads of our amazing developers and leave thanks there too! Before you go on, please BACKUP ALL IMPORTANT FILES YOU DO NOT WANT TO LOSE TO A SAFE LOCATION.

    If you have rooted other android devices before..rooting your Archos G9 may be a little difference. Instead of rooting stock firmware, we first temp root, then enable SDE (special developer edition) menu. Once SDE menu is enabled, it adds an option in recovery to install developer firmware. This is when we install a modified firmware that has busybox and super user included. We do this because the exploit in the temp root causes some issues that doesn't make sense to keep in the long term. Hence the name "temp" root. This guide is very safe to follow. Chances are most problems you run into are very easy to recovery. Please view the FAQ at the bottom of this post if you have questions or run into problems. Because we don't have to flash recoveries or mess with the bootloader like some Android devices require, and because all methods are universal to G9s, this rooting process is very safe and easy to follow.

    Please if you have any issues following this guide, reply with the stock firmware you have (be it honeycomb, ICS, firmware 4.0.6 etc) and the G9 model (flash or HDD 250gb). Board version and processor (OMAP 4430 and 4460 should not be a problem with anything, so probably don't include this when you ask your problem.)

    STEP 1: Pre-root/Temp-root
    1. Install the ADB drivers, using Quinny's thread here (WINDOWS ONLY)
    2. Make sure you have the Android SDK installed and have access to adb
    3. Open up a command window (Windows key + R, type cmd and hit enter)
    4. Type, with your tablet plugged in:
    Code:
    adb devices
    Your device should appear. If not, repeat steps 1-4 until it does. You may need to restart your computer
    5. Download root_hack and extract. Note: Don't open these links in a browser, not tapatalk or the xda app
    Download them to your desktop (or wherever your ADB installation is if you cannot access ADB from your desktop)
    6. Double click rootdevice.cmd to open, press any key after reading the prompt.
    (Note: Device will reboot a couple times)
    7. Restart your tablet (important do not skip this step)

    THANKS TO PAUL FROM MoDaCo for this root
    THANKS TO QUINNY and LETAMA for the original guide


    STEP 2: Enable SDE
    1. Make sure you have done the temp root method. Please turn off your tablet. Your tablet should now be off.
    2. Download this zip and extract to your desktop
    3. Turn on your tablet. Once your tablet is on, plug it into your computer via usb cable.
    4. double click enable_sde.bat
    5. Once that is finished, type the following: (press enter after each line)
    Code:
    adb shell 
    rm /data/local.prop
    6. (If the above code doesn't work or doesn't do anything, it is okay, move on with the rest of the guide). SDE should now be enabled, make sure buy turning off your device, then once it's off:
    7. Hold power + volume down until the archos logo appears and a recovery menu appears
    8. Use Volume Up + Down and power to select Recovery Menu > Developer Edition menu
    9. If you can get to Developer Edition menu, you have correctly enabled SDE.


    STEP 3: (optional, but recommended from honeycomb). Format your device, and then install/re-install ICS. No worries: You will not lose SDE menu doing this.

    It is recommended to do a full device format when upgrading to ICS. If your device is acting up or feels "laggy" after updating to ICS, this usually helps. Before you begin, please note: You will lose all apps, media files, pictures, etc. Please backup any important files. Consider Titanium Backup (root users only to backup any apps with personal data you want to keep (game scores, etc).

    AGAIN: YOU WILL LOSE *ANYTHING* NOT BACKED UP!

    Note: You WILL need a PC connected to the internet, and the USB cable that came with your device. Before you being, please download Archos 80/101 G9 OS v 4.0.6 (190668Kb, for 80/101 G9 devices only) to your PC, copy to your desktop or wherever you will remember, then do the following:

    Step 1: Power off your device
    Step 2: Boot into recovery by holding the volume rocker down and pressing the power button simultaneously
    Step 3: Once in recovery, select "Format System", then "Reformat Device..." (use the volume up/down to change selection, power button to select)
    Step 4: Once formatted, return to recovery using the same method above, this time select "Update Firmware"
    Step 5: Plug your device into your computer using the USB cable that came with your device
    Step 6: A new drive should appear in "My Computer", copy firmware_archos_it4.aos to this device
    Step 7: Ensure the transfer is completed, then press the power button on your device, keep it plugged in while it is updating
    Step 8: Your device should boot, and be updated to the latest firmware 4.0.6


    STEP 4: Install rooted firmware. YES! This will work after installing the official ICS OTA update or official AOS.

    Before you begin, you will need SDE enabled. Please follow steps 1 & 2 in my first post. If you have SDE enabled, you can continue. Any downloaded applications and personal media should remain untouched. You have some options for which ROM you want. Please download files to your PC hard drive.

    For stock ROM w/ root (busybox and superuser), download and extract the following:


    BE SURE to extract, Archos recovery does not recognize zip files

    Step 1: Power your device on
    Step 2: Once your device is on, and your home screen is visible, plug your device into your PC
    Step 3: Open a command prompt on your PC and type
    Code:
    adb devices
    Step 4: Ensure your device shows up so you know it's connected properly and adb is active
    Step 5: Type
    Code:
    cd desktop
    This is to change the directory to where you download the two files

    Step 6: If you have flash NAND model (8gb or 16gb): Type
    Code:
    adb push archos.ext4.update /data/media

    If you have HDD model (250gb): Type
    Code:
    adb push archos.ext4.update /mnt/storage
    Give it some time to transfer, it is a large file and will take several minutes, you will be presented with transfer info once the transfer is complete
    Step 7: Power off your device
    Step 8: Boot into recovery by holding the volume rocker down and pressing the power button simultaneously
    Step 9: You should now be in Recovery mode with the following options "No" "Reboot" "Update Firmware" "Repair System" "Format System" "Developer Edition Menu". Select "Developer Edition Menu"
    Step 10: Select "Remove Android Kernel" (if the option is present, if not, skip)
    Step 11: Select Flash Kernel and Initramfs
    Step 12: Copy zImage and initramfs.cpio.lzo to the drive that appears
    Step 13: Reboot your device. Your device should now be rooted.


    Frequently Asked Questions! (FAQ)
    Will this guide work for my Archos 80 G9? For my 101 G9? I have Archos 101 G9 OMAP 4430. I have 250GB hdd model! I have turbo edition!
    Yes this guide will work for ALL Archos G9 users. This includes 80 G9s and 101 G9s. This includes all 8gb G9s and 16gb G9s and 250GB G9s and 1.0 GHz G9s and 1.2 GHz G9s and 1.5 GHz G9s and OMAP 4430 G9s and OMAP 4460 G9s and board version V5 etc etc. ALL G9s!


    Can I just drag the .zip file to the RAMDISK that appears when I flash zImage and initramfs?
    No! Archos recovery cannot read ZIP files. You must first EXTRACT, then copy the contents of the extracted folder. NOT the folder itself. This means you will have two files on the RAMDISK, and no additional folders. If you don't know what a RAMDISK is, try Google or Wikipedia. If you get stuck in a boot loop because you forgot to extract archos.update.ext4 or drive.zip, you must follow the instructions below.

    Help! I am stuck in a bootloop! Archos splash screen appears and keeps rebooting. I messed up when I was rooting, and now android will not boot! I accidentally formatted my device, and now I cannot boot into android.
    This is a simple mistake and in 99% of cases it is easy to fix. Follow these steps:

    Step 1: Download official Archos G9 firmware for ALL G9 tablets (aos file) HERE
    Step 2: Boot into recovery turning your device off and then holding volume down + power at the same time
    Step 3: Choose "Update Firmware"
    Step 4: Connect USB cable to computer and tablet
    Step 5: A removable device should appear (RAMDISK), copy the file you just download straight to that drive
    Step 6: Press the power button once the file is done copying. DO NOT UNPLUG your device until it has finished updating and has booted back into android.

    If you did not format your tablet or delete any personal media, your files should be uneffected.

    Will I lose SDE menu if I update my tablet with official AOS or OTA update
    As of the latest update (4.0.6) no official update from Archos has removed SDE menu. You should be fine, and your SDE menu should remain untouched.
    4
    Useful tips

    Overclock
    How to overclock your device. For SDE only.
    First please download and extract https://hotfile.com/dl/152251241/ef27ecd/fast_ics_oc.zip.html
    Then follow the instructions in my second post to push to your device then copy zImage and initramfs.
    After you have successfully booted download SetCPU or No-Frills CPU Control and overclock to your desire. Thanks to surdu for making this happen! Visit his original thread HERE to view all warnings.

    Howto take a screenshot
    ICS has a built-in screenshot feature. No need to download any app!

    Step 1: On the screen you wish to capture, press and hold the power button and volume down button simultaneously for a few seconds until the screen flashes and you hear a shutter. Be sure to press them at the same time
    Step 2: You can find the saved screenshots in storage > Pictures > Screenshots
    Step 3: Alternately, you can simply find them in the folder labeled "Screenshots" in the gallery.

    Touchscreen issues
    If you have touch related issues/errors, try the following:

    Step 1: Turn your device off
    Step 2: Carefully wipe down the screen with a dry or lightly damp rag. If you use a lightly damp rag, be sure to dry it with a dry one quickly.
    Step 3: Power on your device
    Step 4: Go to Settings > Repair & formatting > Touch screen calibration > *Put your device down on a flat, hard surface like a table, tap Calibrate the Touch Screen ONCE, then DO NOT TOUCH.
    Step 5: Once finished, you can return to your launcher or wherever you wish

    Multiple Users
    More than one person uses your Archos?
    Either designate home screens using a contact widget, or use a note widget in launchers like GO Launcher. There are also apps that support multiple profiles for root users like SwitchMe Root Profile Manager, however I can not guarantee this will work.

    Multi-boot!

    Removeable System apps
    System apps you can safely disable (new ICS feature) or delete via Titanium Backup or other root app: (only remove the ones you don't use)
    Archos Connect
    Archos Remote Control
    Media Center
    Media Server
    Movie Studio
    Online Registration
    Photo Frame
    Talk Back
    User Manual


    If you have any tips I should add, or if any part of this guide is inaccurate or outdated, please let me know!

    BIG THANKS:
    Android Development Team for giving us awesome Honeycomb and Ice Cream Sandwich OS!
    Archos for their hardware and awesome customer support!
    serdu_petru for full root and all his hard work putting together these rooted firmwares so quickly!
    letama for his original work on this device and work with kernels for overclock!
    gen_scheisskopf for his work on allowing root access for HDD models!
    Quinny899 for putting together his easy root guide for noobs like me!
    Any other wonderful people involved in the development and advancement of this wonderful device!

    GUIDE TBC
    2
    Okay, I'm ****ed.

    I edited Build.prop and /system/etc/init/A80S.rc to fake a Galaxy Tab. Unfortunately (I don't know why) the tab doesn't boot anymore (the archos thing just keeps on moving).
    Is it safe to hit "Repair System" to get it fixed? Or won't that change a thing...

    Please, I can't reflash the files because I can't get to the internal storage (and not into ADB either so I can't push the files)... :(

    HI!

    If you can access SDE menu ....go to Format System-> Reformat Device -> I Understand , and copy here firmware _archos_it4.aos 4.0.5 !
    2
    I followed the guide, really great work. To make it an easier read for everyone else, here at all the step in sequence, which needs to be taken:

    1. Make sure you already did the Archos system update to get ICS directly from Archos
    2. Install JDK
    a. http://www.oracle.com/technetwork/java/javase/downloads/index.html
    3. Install ADB SDK
    a. http://developer.android.com/sdk/index.html
    b. When the SDK Manager opens at the end of the installation, remember to download and install the 4.0.4 packages
    4. Add ADB Path to Windows Environment Variables (follow step 3)
    a. http://www.addictivetips.com/mobile/what-is-adb-and-how-to-install-it-android/
    5. Install ADB Driver
    a. http://forum.xda-developers.com/showthread.php?t=1413293
    6. Temp Root
    a. http://forum.xda-developers.com/showpost.php?p=21646973&postcount=2
    7. Install SDE (stop at point 6)
    a. http://forum.xda-developers.com/showpost.php?p=21646983&postcount=3
    8. Permanent Root (follow step 2)
    a. http://forum.xda-developers.com/showthread.php?t=1542058
    b. Don't use the files from the above post, use the files archos.ext4.update, zImage and initramfs.cpio.lzo from http://forum.xda-developers.com/showthread.php?t=1551682
    c. Under Step 2, when reaching step 7, and your device may not turn off of react as it should, just hold the power switch on the Archos in until it power off (press it and count to 20, that should do it)
    d. Under Step 2, when reaching step 9, the initial menu after booting into Recovery may reach « Reboot », « Android something-something » and « Developer Menu ». Choose Developer Menu using the volume rocker and press the power button to select it. If it does not boot up correctly or show the correct menu afterwards (my Archos 80 G9 showed the boot splash and kept flashing) don’t freak out. Just hold the power button down and count to 20 to do a hard power off, now boot into recovery (power button+volume down) and you should see the correct menu.

    Virtually all my root and busybox apps worked fine after following step 2 and all the needed things which were required.

    [ISSUE RESOLVED]Although, I have not been able to get DataSync (check Google Play, since I cannot add the URL, sorry) to update apps on my Archos correctly. Such as taking data files from Angry Birds on my HTC Desire and pushing them to my Archos 80 G9. This has been working fine in the past when I pushed to a Nook Color running CM7. If I backup the app in Titanium and send the files to my Archos and restore it from there, it does work fine.

    EDIT: I noticed that when I install Busybox Installer (Jrummy) it says that the busybox version is 1.7.2 in the rom from Step 2 and not the latest version 1.19.4. Could this be the reason? If so, my assumption would be that I need to follow http://forum.xda-developers.com/showpost.php?p=21646995&postcount=4

    EDIT 2: Followed the instructions to install BusyBox, this broke my Archos and now it say's no BusyBox is installed and will not connect to any WiFi. Gonna reinstall 4.0.4 (from http://forum.xda-developers.com/showthread.php?t=1551682). Should be noted that when I followed the instructions here: http://forum.xda-developers.com/showpost.php?p=21646995&postcount=4 at step 12 (http://forum.xda-developers.com/showpost.php?p=21646995&postcount=4) I was told there was no such file, but continued anyway.

    EDIT 3: I redid the update but using the files from http://forum.xda-developers.com/showthread.php?t=1551682 and this resulted in BusyBox being version 1.19.3 and now everything is working fine. Basically I followed Step 2 from http://forum.xda-developers.com/showthread.php?t=1542058, but used the files archos.ext4.update, zImage and initramfs.cpio.lzo from http://forum.xda-developers.com/showthread.php?t=1551682. I have updated the instructions above to reflect this.
    1
    Got it gents, not sure what was going on....

    1 thing I must add, I was rooted before all this, maybe it kept the root and everytime I was trying to re root I was rooting an already rooted device even after a format???

    My steps were:

    Reformat, installing 4.06 Stock

    DO NOT run Step 1 for the temp root.

    Go straight to enable SDE.

    Flash Kernel in recovery etc (follow step 4 onwards).

    now rooted....

    Darned if I know what was happening, glad to see the GPS is now working, I have tested it in XCSoar so will try it out on a flight, see how it goes.

    See how the stability goes or if I now have a messed up system, Superuser was installed after the reboot, busybox was not, ran everything and now seems sorted.

    maybe you did not reboot after temp root. I will add that to instructions. I thought the root script did it automatically but maybe not