[TUTO] Enable Adoptable Storage on MM

Search This thread

ozelarf

New member
Oct 28, 2013
2
0
Me too

Hey Guys
please help
i'm running Rooted Stock ROM Marshmallow .570 on my Xperia Z2 D6503
i got this message



when i changed to mixed, it showed same message
can anyone solve this problem ???

same problem in here, fella. any news on this yet? I guess my sd is corrupted, since other sd cards are correctly shown.
 

nicoX

Senior Member
Jan 31, 2011
138
11
With adaptable storage I experience my XA to run much faster and smoother, might be of my fast SD card, apps open very fast, specially games that needed some time to load.

Is it because the app data is now saved on the SD card, and not just the app itself? Because the internal card is encrypted by stock and encryption makes things go slower.
 
Sep 3, 2015
31
2
You can't move all apps, same problem on almost all phones. Use integrated app2sd to move your apps to get better results. Tried with big games like Real Racing 3 and no problem, with Firefox the app disappear after phone reboot :eek:

@Virtual anomaly, yes you can, no problem reported.

How? System updates check if there's any change in the system partition and if there is they don't work.
 

rrvuhpg

Senior Member
Jan 2, 2009
713
659
No,im talking about adb commands.

Also what's integrated app2sd? You mean in the app section,apps that allows you to move them to sd?

Do like this: go to Settings, Storage and Memory, Advanced, Storage, Internal Storage and Migrate Data. You should have same screen as my screenshot. I hope it can help you.

Edit: Sorry for the mistake but it will move app to internal memory, do it will not help you... :(
 

Attachments

  • Screenshot_20160918-153223.png
    Screenshot_20160918-153223.png
    129.3 KB · Views: 544
Last edited:

rrvuhpg

Senior Member
Jan 2, 2009
713
659
Do like this: go to Settings, Storage and Memory, Advanced, Storage, Internal Storage and Migrate Data. You should have same screen as my screenshot. I hope it can help you.

Edit: Sorry for the mistake but it will move app to internal memory, do it will not help you... :(

Edit2: The good way is: Settings, Storage and Memory, Advanced, Storage, SD Card and Migrate data.
 

Attachments

  • Screenshot_20160918-160120.png
    Screenshot_20160918-160120.png
    52.9 KB · Views: 447
  • Screenshot_20160918-160134.png
    Screenshot_20160918-160134.png
    131.8 KB · Views: 441
Z5c xpower4 rom.
I tried easy adoptable storage, as the method above showed some java error
I don't remember if with two partitions I could get stock camera to work.. I think it did not accept any
I wish anyone could modify the Sony camera to use adoptable storage, or... Maybe someone could"port" the concept Rom of Sony z3c to a z5c....
On my z3c with concept Rom, there was official adoptable storage, and the camera did work... Too bad that phone broke...
Or maybe someone with experience could lookinto that software and see what changes could be made to z5c MM.
Maybe only port camera concept Rom z3c to z5c...

Oh, and i could not use foldermount app when with 2 partitions...
 
Last edited:

nicoX

Senior Member
Jan 31, 2011
138
11
The latest update OTP fails installing, has this anything to do with this tweak?

I have plenty of storage on internal and external.
 

KevinPedrick

New member
Dec 20, 2016
1
0
I've an Xperia Z3 Compact tablet. Now Netflix allow downloads but only to internal storage I gave this a try with a 128GB EVO Plus SD card. All seemed to go well but I do have the settings reporting my total used storage as being -92182675456.00B of 16.00GB. Camera doesn't work but I don't care, may look for a third party camera app. EDIT: Went for Open Camera, that seems to work.

When I downloaded from Netflix, sure enough the app settings reports that the data has gone to the SD card. Though strangely, Netflix sometimes reports that I have insufficient storage. I think this may be when I set a stack of downloads that would exceed my spare true internal storage.

Is this something that may be fixed in the future? Would rooting my tablet potential offer a better solution?
 
Last edited:

andross77

Senior Member
May 5, 2009
61
9
Is this posible for Android 7.0 ?

I just tried this on Sony Xperia X Compact US version with the UK firmware (to enable fingerprint scanner) which means I'm on Androis 7.0 and I keep getting this error:

Error: java.lang.IllegalStateException: command '301 volume partition disk:179,64 private' failed with 'null'

Not sure if it's because of 7.0 or b/c of the UK firmware. Got this little hack to work on my previous Galaxy S7 which was nice b/c then I never worried about space. Already filled up this little bugger with games so was hoping I could get this to work as well on the x compact. Guess not...

I just ended up having to format the card because it got corrupted I think because it kept looping into "eject mode." Thankfully a format worked and I just had to reload some game apps. Guess I will just have to use the SD card for photos and videos and be more selective in what games i have loaded on my phone....not the worst but damn is it annoying when we have so much space on these cards and can't use them fully on our phones :(
 
Last edited:
  • Like
Reactions: floripi

story

Senior Member
Mar 27, 2006
447
24
On a Z3 Plus / Z4
It works fine but OP put a colon after "mixed"

<DISK> needs to be replaced with the output of the previous command. For example sm partition disk:179,64 private.
If you don't want to convert the whole disk, then use this command instead: sm partition <DISK> mixed <VALUE>, where <VALUE> is the percentage (0-100) to keep as external storage. For example sm partition disk:179,64 mixed 50 for 50%.
Reboot is optional, but recommend, so all apps detect the external storage.
 
Last edited:

Ali hamoud

New member
Feb 19, 2016
1
0
Does it work in xperia z with resurrection remix mm??

---------- Post added at 10:49 PM ---------- Previous post was at 10:45 PM ----------

Does it work in xperia z c6603 with resurrection remix mm??:confused:
 

AlexFR38

Member
Feb 18, 2013
7
0
Hi all,

Thank you for this tip. I follow the process and it is working almost well on my Xperia E5.
Unfortunately I regularly got corrupted SD card on a regular basis (every 2 months) and I have no idea why. So it is quite annoying to redo this process and reinstall all my apps.

My SD card is a Samsung one, with 128 Gb capacity and I allocate only 16 Go to the Adoptable storage.

Did anyone got this problem as well and know how to fix it ?

Thank you very much !
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    MM bring the ability to devices which support it to share SD card with system to install apps on SD card. But Sony disabled this on MM. Here is to Enable this functionality ;)
    (Be aware that your shared partition will be hidden on other devices)

    You will need adb installed on your computer
    If you doesn't have it :
    http://lifehacker.com/the-easiest-way-to-install-androids-adb-and-fastboot-to-1586992378

    Then connect your phone with adb debugging enabled.

    Type "adb shell"
    Once you're connected to your device : "sm list-disks"
    This will return the ID of your sd card.
    Now, if you want the whole sd card to be shared type "sm partition disk:ID private"

    If you want your sd to be partitionned type "sm partition disk:ID mixed:%"
    (replace ID with your own card ID and % with the STANDARD stockage percent you want on your sd card)

    You're done !
    (Sizes of partitions are not reported as they should but it seems to work)

    Before/After
    Before :
    wGU4U21.png
    After :
    2wsS6S9.png



    Source :
    mocado.com
    This is Mocado's work, not mine !
    1
    @roland101 @fqj1994 Yes the partition created for apps cannot be use to store files. Mixed will create 1 partition for apps and 1 for files :)
    About the Google Photos app I guess it store photos in app data and if we cannot write that partition it doesn't allow us to delete these files but should work using Google photo app since it's is own files. If Gphoto was baked with your rom maybe it have arlready the permision needed. You can also check in per apps permissions in settings ;) Check if it delete the cloud backup when you delete local photo. :)
    1
    Tested on Z3 tablet compact and MM 23.4.A.0.575

    Works quite well. Camera do not recognize internal memory anymore so format SD Card "Mixed" is mandatory to use Camera (with regular external SD partition)

    Move data to adoptable SD move some data that cannot be moved on regular external SD. on a clean phone (cleaned by sd maid) with everything possible moved to regular external SD, I saved 3GB more. nice.

    Move app give no gain. only app can be moved on regular external SD can be moved on adoptable SD. nothing more. I kept it on regular external SD to avoid the hassle to move them one by one. move directly app from external SD to adoptable SD crash and reboot tablet. Need to process in 2 steps via normal Internal memory.

    Some memory count in setting / storage show crazy negative number. Sony clearly do not update their "written with the foot" code. Just a cosmetic issue.

    The only application degraded is Sony Camera. What a shame for Sony.

    Envoyé depuis mon SGP621 avec Tapatalk
    1
    Once you shared the SD card would removing it pose any system error or the phone will revert to its stock stated partition?
    1
    Z3 Compact now has 2 SD Cards?

    So, I applied this to my Z2 Compact using a new Samsung Pro Plus 128gb card and now I have 2 x 64Gb SD Cards listed, not quite what I was expecting...

    When I look at apps say Clash Of Clans, it still says it's in internal, but I can change it, that gives me 3 options,
    1) Internal
    2) SD Card (I've renamed it adaptive)
    3) SD Card

    If I select 2, it moves the entire app to SD Cards, where as before it'd only move part of the app, so I see that as an improvement. However that's not what I was expecting to see and some apps still can't be moved (No change option)

    p.s. when I did sm list-disks I saw disk:179,64 is that the correct format for the id?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone