• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Tutorial] How to Disable S Planner (correctly)

Search This thread

mastawindu

Senior Member
Sep 4, 2009
307
111
Dear fellow xda members,

You might have noticed, it is impossible to use the "turn off" option for S planner, therefore one has to find a way to instal another calendar app without the annoying double reminders/ double notifications effect. I came across this problem and found a simple workaround that doesn't require root.

Here's how :

1- Open S planner
2- Hit the upper right corner (options) and go to calendars
3- Un-tick all the calendars
4- Hit setting and disable all reminders and notifications
5- Go to Settings/app settings/all and find the 2 "S Planner" entries
6- For first S Planner entry hit "force close", "turn off" and "clear data"
7- For the second entry hit "force close" and "clear data" (unfortunately there is no possibility to turn this one off)
8- Instal Google Calendar from the Maket or any other calendar app and voila !

I like S planner but I had to stop using it because there is no way to activate an auto reminder setting. So if you forget to set it manual when you create your event, it won't be reminded to you in advance. I know Google Calendar and MIUI calendar have this option.
This issue was related in the following threads :
http://forum.xda-developers.com/galaxy-s3/help/s-planner-dont-notification-stock-t1908516/page3
http://forum.xda-developers.com/galaxy-s3/help/auto-default-reminder-s-planner-adding-t2001705

Hope this helped
 
Last edited:

josephkarthic

Member
Jul 26, 2013
49
4
There is a problem with your step 7.

If you hit "clear data" then all the settings for the app will be reset, which means the "untick all calendars" in step 3 and notifications setting in step 4...everything will be back to normal ...so its useless to do "clear data"..

Even if you do just force stop in step 7, and when you install google calendar the splanner will trigger and continue to run in background(and will import all the calendars again) but will not disturb you if you disabled the notifications in the app...So technically its still running in the background as google calendar....only thing is its not notifying you if you have disabled that setting.....
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Dear fellow xda members,

    You might have noticed, it is impossible to use the "turn off" option for S planner, therefore one has to find a way to instal another calendar app without the annoying double reminders/ double notifications effect. I came across this problem and found a simple workaround that doesn't require root.

    Here's how :

    1- Open S planner
    2- Hit the upper right corner (options) and go to calendars
    3- Un-tick all the calendars
    4- Hit setting and disable all reminders and notifications
    5- Go to Settings/app settings/all and find the 2 "S Planner" entries
    6- For first S Planner entry hit "force close", "turn off" and "clear data"
    7- For the second entry hit "force close" and "clear data" (unfortunately there is no possibility to turn this one off)
    8- Instal Google Calendar from the Maket or any other calendar app and voila !

    I like S planner but I had to stop using it because there is no way to activate an auto reminder setting. So if you forget to set it manual when you create your event, it won't be reminded to you in advance. I know Google Calendar and MIUI calendar have this option.
    This issue was related in the following threads :
    http://forum.xda-developers.com/galaxy-s3/help/s-planner-dont-notification-stock-t1908516/page3
    http://forum.xda-developers.com/galaxy-s3/help/auto-default-reminder-s-planner-adding-t2001705

    Hope this helped