How To Guide [TUTORIAL] How To Unlock & Root Tab A7 Lite T220/T225, & Install LSPosed, Magisk, Mods

Search This thread


Senior Member
Feb 18, 2012
Bay Area
LG V20
Samsung Galaxy Watch 4
FYI, some of the steps in this guide can be streamlined if you're running Linux or Windows Subsystem for Linux. For example, to uncompress an lz4 archive just install the 'lz4' package and use 'unlz4 <file>' to uncompress it. Similarly, when you need to repack boot.img into a tar archive, just run 'tar -cf boot.tar boot.img'

You also don't need to install termux. Simply install ADB driver and ADB and Fastboot from here, then after you've enabled Developer Mode and USB Debugging on the tablet, from a Windows Powershell just run 'adb shell' to open a shell on the tablet. Then type 'su' and on the tablet Magisk will prompt for superuser access, and you can run any commands now as root.


Senior Member
Oct 15, 2010
Warning: Step V. Remove Bootloader Warning causes bootlop on SM-T220 running T220XXU1CVL7_T220OXM1CVL7_XAR. Had to reflash entire system via Odin to recover.
Well yeah, because that file was designed for an Android 11-based bootloader and not the Android 13 you're running. To recover, you only had to reflash the BL (bootloader) Odin file for your firmware. There's another thread with the right up_param file for A13.
  • Like
Reactions: Aethera


Senior Member
Feb 18, 2012
Bay Area
LG V20
Samsung Galaxy Watch 4
Well yeah, because that file was designed for an Android 11-based bootloader and not the Android 13 you're running. To recover, you only had to reflash the BL (bootloader) Odin file for your firmware. There's another thread with the right up_param file for A13.
Can you please put a warning in Step V or a link to the Android 13-compatible up_param? Thanks!


Senior Member
Feb 7, 2017
7. DISCONNECT from internet after a few seconds. You'll see it trying to update things in the pull down menu, disconnect from internet, you don't want it to update anything. It just needs to be connected long enough to update the day and time to the correct day and time, and register your device. If it didn't work, it didn't register your device yet.
Thanks for the guide in getting the OEM Unlock working.

#7 tripped me up. I disconnected from wifi too fast so the device wasn't registered. Had to use the other guide, specifically these points:

5. Go to developer options and turn it off (click on the right top corner toggle)
6. Now go to software update and check for a manual update, after result is shown restart your device. IMPORTANT: After the phone has rebooted, your date and time should be reset to the current time automatically
After checking for a manual update under Software Update and getting a result, I disconnected wifi and proceeded with xbt-'s guide I believe. Then I was able to unlock the bootloader.

Thanks again! Now to decide to use stock Android 13 or a GSI build!


Dec 12, 2006
This was a real good (and pretty successful) guide to the root process. The fact that Magisk worked consistently and that I did prepare some emergency recovery and boot tar files to restart the device each of the 10 to 15 times I bricked it, was just lucky. I would not try removing the Samsung "bootload warning" though! That was the first big "brick" and pretty much erased 5 days of work! But, it did force me to do the entire process again, and again, and again... each time learning what does not work. I have patched not just the boot.img file, but the whole AP image for Magisk. Going through the subsequent entire 25 pages of this thread outlining a kind of evolution of the process of attempting to flash TWRP, I found that any attempts at using Fastboot were useless - the Samsung SM-T225 simply reacted by messages that the commands were not understood. I did not know that Fastboot would be a dead end each time until roughly page 18, or so, Johx22 / Patch-Recovery , Clearly time has passed since the posting of that fix which may or may not have helped - in any event, the system does not offer the ability under the Actions dropdown to run the workflow. I am assuming it was discontinued.
Having tried literally everything, in different orders, except trying to patch the Unofficial TWRP itself,. Between pages 12 and 20, it seemed that recovery from the TWRP tar could be extracted the TWRP tar and patched by Magisk, etc., etc. Indeed, every "patch" that I did, and undid, and did again, worked flawlessly. TWRP never once came even close to loading. Out of desperation, I even tried flashing the various files (and I even understood their purpose and that flashing them out of order would not work) advised by Scorpian96 through Magisk or Fastboot, but, no luck. I have reached the end of the thread - it does not appear that a TWRP is forthcoming - indeed, on page 25, the drumbeat of Magisks not working was the last sentence as a final inflection point! Magisk does indeed work - very well. It was the saving grace of this entire exercise.

It does seem that people like me who need root only make certain minor adjustments for legal purposes, probably don't need all the benefits of a TWRP. I loved it because it created such clean and complete total backups - it was a comfort to know one could always restore the device to EXACTLY the way it was if anything ever happened.

A lot of work goes into this stuff - I see it is amazing. I actually learned a lot and nothing one learns is ever wasted. But, as long as I use Samsung devices (which is coming to an end), I will just have to settle for a workaround to back up the device.

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Is there anyway to get this to work for T-227? I had no luck on my attempts following these instructions - can't unlock OEM.
    Were you ever able to unlock the bootloader? Recently picked one up and trying to root it
  • 20
    While some of these instructions are copied from other sources, I combined all the different things I learned, because no one guide was sufficient, and all needed additional info, so I expanded it all to one place. Part I is partly from @nevertechdose. Parts II & III are mostly copied from @thatha's guide. Part V is mostly @razs.originals guide. Parts IV, VI, VII, VIII, IX, X, XI, etc are my guides.

    Special thanks to @thatha for their guide & T225 files, @Talich52 for their post & T220 file, @realbbb for their post & odin files, & @nevertechdose for their OEM Unlock guide. Also to @razs.originals for their bootloader warning removal guide.

    I. Get OEM Unlock to show up (If it doesn't show already. If it shows, skip to Part II.)
    1. Factory Reset Device (Sorry but this will happen when you unlock & root anyway, and has to be done first.)
    2. Skip everything on the first boot setup including WiFi settings (you'll connect to the Internet later). (You can still during setup decline to provide sensitive info - just select the first two bubbles and accept - and you can also still turn off the three privacy sharing buttons.)
    3. I did not change any settings when I booted in, just proceeded to step 4.
    4. Enable developer options and disable automatic system updates from there.
    5. Disable automatic software update. Settings > Software Update > turn off.
    6. Connect to a WiFi network.
    7. DISCONNECT from internet after a few seconds. You'll see it trying to update things in the pull down menu, disconnect from internet, you don't want it to update anything. It just needs to be connected long enough to update the day and time to the correct day and time, and register your device. If it didn't work, it didn't register your device yet.
    8. For me, it did get to the point where there was a notification that said, "Finish setting up your Tab A7 Lite." DO NOT finish setting anything up, but do make sure internet is disconnected. Ignore notification, but you should see that.
    9. Go to General > Date and Time settings and select for the time to be set manually (don't touch time zone). Set the date to be EXACTLY 10 days BEHIND from your current date.
    10. Go to Developer Options, and OEM Unlock should be there!

      If it still doesn't work, you may have to go to extreme measures, but I didn't have to. But first just make sure you did the above steps EXACTLY.

      Go here for extreme measures if you did EXACTLY like above and still didn't work (my instructions above were a bit different)

    II. Unlock bootloader (Thanks @thatha)
    1. Enable developer options by going to Settings > About Tablet > Software information > and tap "build number" 7 times
    2. Go to Developer options, turn on OEM Unlock (If it doesn't show up, skip to Part III and then come
    3. Turn off Tab A7 Lite, connect it to the computer while holding Volume Up and Volume Down keys until you see the bootloader screen
    4. Long-press Volume Up key to enter Device Unlock mode
    5. Press Volume Up key to confirm and unlock the bootloader

    III. Create your device's patched boot (You can skip this if you have one of the 3 devices with the files in part IV.1 below.)
    1. Download your firmware from samfirm or other source (I didn't have to do this, so I can't instruct on it)
    2. (On PC) Extract boot.img.lz4 from Stock AP...tar file, then copy it to Tab
    3. (On Tab) Install ZArchiver to extract boot.img from boot.img.lz4
    4. (On Tab) Install Magisk and patch the boot.img that you have just extracted from step 3
    5. (On PC) Copy magisk_patched.img (in Tab\download) to pc, rename it to boot.img
    6. (On PC) Use 7zip to pack boot.img from step 5 into boot.img.tar

    IV. Root Tab A7 Lite
    1. Download correct boot.img.tar for your device (For T220XXU1AUJ1 it's magisk_patched-23000_acKsR.tar), it will probably be a zip, if so you'll need to unpack it to a tar (you can use 7zip for that). The two T225 files were pulled from here. The T220 file (my device) was pulled from here. I inserted and attached them for future proofing and to make it easier for you.

      You can find your device under Settings > About Tablet > Software information > Build Number. Mine is a Wifi model Tab A7 Lite, model T220 4GB/64GB, my build is T220XXU1AUJ1.

      The files below are direct links to the attachments in this thread (take CAREFUL note of the T220 or T225 in the name - they are different).

      For T220XXU1AUJ1:

      For T225XXU1AUJ1:

      For T225XXU1AUL1:

      For T220XXU1AUL2:

      If you don't have one of the above 3 devices, then follow the Part III guide above to create the correct boot.img.tar file. DON'T FLASH THE ABOVE IF IT IS NOT YOUR DEVICE!

    2. Get Odin 3.14.1. (All 3.14.4 are FAKE!) The exact one I used was Odin3 v3.14.1_3B_PatcheD. Get it from here ONLY!
      I also attached the same file to this post. Download from the other page if you don't trust me.

    3. Boot into Download Mode
      (If you're stuck at SetupConnection in Odin, it's because you have to run it from Download Mode, it won't run while device is on.)
      - Power off device
      - Hold Volume Up & Volume Down buttons at the same time, connect USB cable, keep holding until you see the screen.
      - Press Volume Up to go to Download Mode

      Here's a video for this device on how to do it and what it looks like (credit goes to the maker of the video, not me):

    4. Open Odin as Administrator (Right-click > Run as Administrator)

    5. Click AP and find the file magisk_patched-23000_acKsR.tar (for T220XXU1AUJ1). NOT THE ZIP. And not the raw boot file(s). Has to be the tar.

      If successful, it wlil say this:
      • <ID:0/008> Added!!
      • <ID:0/008> Odin engine v(ID:3.1401)..
      • <ID:0/008> File analysis..
      • <ID:0/008> Total Binary size: 32 M
      • <ID:0/008> SetupConnection..
      • <ID:0/008> Initialzation..
      • <ID:0/008> Get PIT for mapping..
      • <ID:0/008> Firmware update start..
      • <ID:0/008> NAND Write Start!!
      • <ID:0/008> SingleDownload.
      • <ID:0/008> vbmeta.img
      • <ID:0/008> boot.img
      • <ID:0/008> RQT_CLOSE !!
      • <ID:0/008> RES OK !!
      • <ID:0/008> Removed!!
      • <ID:0/008> Remain Port .... 0
      • <OSM> All threads completed. (succeed 1 / failed 0)
    6. Device will reboot. It will say bootloader unlocked continue, so press Power button like it asks. You will see a screen with red text warning you it's been altered.

    7. It will not boot. Don't worry it will reboot again, same thing as step 6. Now it fails and asks you to Factory Data Reset. Ignore the errors it's telling you, and Yes, go ahead and click Factory Data Reset (you have to).

    8. It will go through step 6 again, this time, after a few minutes it will boot up into Android and prompt you to setup device. Success!

    V. Remove Bootloader Warning ⚠ (thanks to @razs.originals for their guide & file)

    @razs.originals provided a guide and the needed file, but their guide was slightly lacking for those less experienced, so I'll expand it slightly to be more precise what to do. This removes all the bootloader unlock warnings on boot.
    1. Get the free app Termux.
    2. Download the up_param.tar file and move it to download folder (internal storage) - it might be the default location, if not then it should be here:
    3. Open Termux, and then type the next series of lines of code (press enter in between each line):
      cd /
      dd if=/storage/emulated/0/Download/up_param.tar of=/dev/block/platform/bootdevice/by-name/up_param
    4. Now reboot, and the bootloader warning screens should be gone!

    VI. Install/Update Magisk on Tab A7 Lite

    Magisk will exist in apps, but clicking on it asked me to update but nothing happened. If that's the case for you too, then:
    1. Download Magisk latest version from their official Github. (DO NOT DOWNLOAD FROM ANY OTHER SOURCES!) I included the apk from the github page here for future proofing and reference, I am using Magisk 24.1 which worked.
    2. Install the APK. Open file manager if you need to and then find it in Downloads or wherever you downloaded it.
    3. Open Magisk, it will ask you to update. Choose "Direct Install (Recommended)" and then click Let's Go in the top right.
    4. It will flash the image and then say All Done!, then you can click the Reboot button in the bottom right.
    5. You can now check root by installing any app that needs root, for example Titanium Backup which is an essential one for me. There's also OandBackupX, which is a free and open source fork of Titanium backup.
    6. You will be greeted with a Superuser popup if you are rooted, so grant permissions and you can see you are rooted! Congratulations!
    7. Nothing special is needed on reboot, if you ever reboot your device, it just reboots as normal and stays rooted. Congratulations on completing the guide! Please remember to like this if you liked the guide (only if you liked it), so I know I am helping.

    VII: Install LSPosed (Successor to Xposed) on Tab A7 Lite
    1. Download LSPosed latest version from the official Github.
      - Make sure to choose the Zygisk version (e.g
      - Why Zygisk? Because Riru is retired. You don't need it anymore.
      - Don't worry about downloading any Zygisk or Riru. Riru is retired and Zygisk is now integrated in Magisk.
    2. Copy the zip file to your device.
    3. Open Magisk, go to Modules, click Install from Storage, and find the zip you just copied for lsposed zygisk version.
    4. Click Reboot button in the bottom right when it's finished.

    VIII: Activate Zygisk (Successor to Riru) on Tab A7 Lite
    1. You're not done yet. Now go into Magisk, click Settings button in the top right.
    2. Scroll down and enable Zygisk (Beta).
    3. Below that, enable Enforce DenyList.
    4. Below that, click Configure DenyList.
    5. In the top right, click the 3 dots menu and check the box Show System Apps.
    6. Select Google Play Services by checking the box.
    7. Tap on Google Play Services to open all the items for it, and enable all the items for Google Play Service.
    8. For anything else you deny in the DenyList that you configure, Zygisk will not work for it, because you denied it. So in the future if you want to disable Zygisk for anything else, this is how. But if you don't konw what this means, don't worry about it.
    9. That's it! Now go ahead and reboot your device by holding the Power button for a couple seconds and clicking Reboot (If you choose Power Off by accident then it won't reboot without you turning it back on ;))
    10. On reboot, it will ask if you want to add a home page shortcut. Choose YES, because it won't show in your apps, so you want an easy way to access LSPosed.
    11. Open Magisk and click on Modules to see that LSPosed is active! Congratulations you now have LSPosed installed and working!

    IX: Xposed Modules for LSPosed

    I recommend a couple mods for LSPosed. There aren't a ton yet for Android 11 and less for Android 12.
    1. Browse the Xposed Repository, because you apparently can't from within LSPosed.
      - Note - Don't use any modules you don't know what they do.
    2. Recommended Module: GravityBox [R] (For Android 11) - Allows you to do lots of customizations. (Enable dark theme for GravityBox under the About at the bottom, after you activate it using steps 5 and 6.)
    3. Recommended Module: DarkTricks (For Android 11) - More customizations and tricks. Nothing "dark" about it, just the user's name.
    4. Recommended Module: FireFds Kit [R] (For Android 11) - Activate Advanced Power Menu, Disable restart confirmation, Date in Status Bar, etc.
    5. Recommended Module: App Settings Reborn (For Android 11)
      - Allows you to set custom DPI per-app. I used it to put Swype into tablet mode using these settings: DP: 175, Screen (dp): 1080x1920)
    6. To install, just copy to your device, and browse to the apk through file manager, and install it.
    7. When you install, you will get a notification, "Module is installed but not activated". Either click on the notification and Enable, or open LSPosed, go to Modules, click on the greyed-out modules, and click Enable on each module you want to activate.
    8. Then reboot to activate the module. If you don't reboot, then the module isn't going to work when you click on it, but it will after you restart.

    X: Install Shamiko (Magisk Hide Alternative) & Momo [Both In Development ALPHA (Pre-Beta)]

    Magisk Hide was permanently removed from the latest versions of Magisk. The alternative is Shamiko, although it's still in development. Install at your own risk.

    Momo simply checks your environment for your knowledge. It can help detect if you successfully hid Magisk.
    1. Shamiko Development Version:
    2. Momo Development Version:
    3. Install Shamiko using Magisk like you did in Part VI: Go to Modules, Install from Storage, Find the Shamiko .zip file, Install, Reboot.
    4. Install the Momo APK. You can open it right away.
    Official Telegram: (Find latest versions here on the Telegram page. I had to use actual Telegram to download them. So I attached the apks above.)

    More details on Shamiko & Momo:

    XI: Tweaks
    • Disable tablet mode in apps universally:
      • Go to:
        Settings > Developer Options > Drawing > Minimum width
      • Set to 598 (Default 600)
    - This will disable the annoying tablet mode, browsers and other apps look weird. Yandex had search bar at top, no extension support, and no dark theme. This hack brought everything back.​
    - Will not affect size or resolution at all. It will just trick apps into displaying in normal phone mode.​
    - You can also disable on a per-app basis using xposed module in the above section.​
    • Turn off animations (Optional):
      • Go to:
        Settings > Developer Options > Drawing >
        • Window animation scale: 0.5
        • Transform animation scale: 0.5
        • Animator duration scale: None

    I will add more later if I find anything else major, and also if a working TWRP is released and I find it, I will post it in a new section here.

    I leave the boot.img patched with magisk

    ROM this XXU1AVB2 and device is SM-T225
    how did you find T220XXU1AUL2 stock firmware region code OXM
    it's really hard to find
    Don't worry found it it's because its in Urkraine

    I got a 4GB/64GB (top model) T220 on sale from the Best Buy ebay page for only $150!

    Sams Club and Costco have the 3GB/32GB model on sale right now for only $130!
    Picked up the 3GB/32GB model on Amazon for $119 this week.
    It worked for me