[Tutorial] Installing adb/fastboot drivers in Windows 8

Search This thread

Nburnes

Senior Member
Sep 4, 2010
1,330
977
Google Pixel 5a
So after going through this headache of not being able to fastboot either of my Nexus devices (GNex and N7) I have found the solution to my problems and I am sharing it with you guys.

Windows 8 forces drivers to be digitally signed and checks that signature with it's known driver signatures at home. This is a problem if you are trying to install and use something like fastboot/adb which Redmond may not have drivers for.

I was personally trying to install this as I did before on Windows 7: http://forum.xda-developers.com/showthread.php?t=1379875 and in order to install this we need to "Disable driver signature enforcement"

Steps to be taken:

1.) Bring up Charms by mousing over to the right of the screen
2.) Go to Settings
3.) Change PC Settings
4.) General
5.) Scroll down to Advanced Startup > Restart Now
6.) Trouble shoot
7.) Advanced options
8.) Windows startup options
9.) Restart
10.) Choose F7 (I believe) or click on "Disable driver signature enforcement"
11.) Reboot

Install the relevant driver (In my case Universal driver) under Device Management

This allowed me to install the Universal driver for both my Nexus devices. Anyway, hope it helps ya'll.

(Mods if posted before feel free to delete/merge/whatever.)
 

efrant

Retired Senior Moderator & Developers Relations
Feb 12, 2009
11,466
10,956
Montreal
Samsung Galaxy S20
efrant, if you use the official drivers and not ones that someone patched together, there is no need for that step.
Yup, if you use the Verizon_Wireless_I515_Galaxy_Nexus_USB_Driver_v1.4.6.0.exe from Samsung's website, I believe it is signed, so it probably would work.

The issue was that some users (myself included), had problems installing the driver using Samsung's .exe package. 1wayjonny's repack worked flawlessly, and doesn't install anything else...
 

Alucardi

Member
Jan 12, 2011
35
2
I am able to isntall just fine BUT i cannot get the drivers to work and its ****ing iritating. I just get something like This unit cannot start (error 10), A request for the USB device descriptor failed.
 
  • Like
Reactions: Neo3D

Utkarsh-ezzo

Senior Member
Sep 16, 2012
848
497
Pune- India
So after going through this headache of not being able to fastboot either of my Nexus devices (GNex and N7) I have found the solution to my problems and I am sharing it with you guys.

Windows 8 forces drivers to be digitally signed and checks that signature with it's known driver signatures at home. This is a problem if you are trying to install and use something like fastboot/adb which Redmond may not have drivers for.

I was personally trying to install this as I did before on Windows 7: http://forum.xda-developers.com/showthread.php?t=1379875 and in order to install this we need to "Disable driver signature enforcement"

Steps to be taken:

1.) Bring up Charms by mousing over to the right of the screen
2.) Go to Settings
3.) Change PC Settings
4.) General
5.) Scroll down to Advanced Startup > Restart Now
6.) Trouble shoot
7.) Advanced options
8.) Windows startup options
9.) Restart
10.) Choose F7 (I believe) or click on "Disable driver signature enforcement"
11.) Reboot

Install the relevant driver (In my case Universal driver) under Device Management

This allowed me to install the Universal driver for both my Nexus devices. Anyway, hope it helps ya'll.

(Mods if posted before feel free to delete/merge/whatever.)

Thanks,, Solved the problem...
 

AndrewMPhoto

Member
Dec 20, 2012
18
0
I tried this method and another method. I still can't get the drivers to work correctly. I installed the drivers and now when i connect my phone it is now coming up on device manager as "Andriod bootloader interface" I have a sony xperia S and after about 5 seconds it reboots. Any thoughts?
 

t1.8matt

Senior Member
Jan 22, 2012
1,922
419
Pittsburgh, PA.
when i upgraded to windows 8, all i did was plug my phone in, go into device manager and find my phone and uninstall drivers since it wouldn't let me use fastboot even though it recognized my phone. i then installed pdanet and let it install the drivers and rebooted and it worked great.
 

AndrewMPhoto

Member
Dec 20, 2012
18
0
when i upgraded to windows 8, all i did was plug my phone in, go into device manager and find my phone and uninstall drivers since it wouldn't let me use fastboot even though it recognized my phone. i then installed pdanet and let it install the drivers and rebooted and it worked great.

I looked up pdanet and its a program to tether my phone. Why would that help with fastboot?
 

t1.8matt

Senior Member
Jan 22, 2012
1,922
419
Pittsburgh, PA.
it installs the correct drivers needed to use fastboot for your phone. you can just uninstall the app when it's done, i kept it because sometimes i use the cable to tether my phone to my laptop.

---------- Post added at 02:47 PM ---------- Previous post was at 02:47 PM ----------

i'm just telling how i did it, it's up to you how you do it.
 

AndrewMPhoto

Member
Dec 20, 2012
18
0
when i upgraded to windows 8, all i did was plug my phone in, go into device manager and find my phone and uninstall drivers since it wouldn't let me use fastboot even though it recognized my phone. i then installed pdanet and let it install the drivers and rebooted and it worked great.

I did what you said it installed the drivers but when i connect my phone in fastboot its still doing the same thing, rebooting after 5 seconds. On device manager the phone comes up as "boot S1 download" I will try installing the fastboot drivers again and report back
 

EddyOS

Senior Member
Jan 2, 2010
15,281
4,030
London
I'm having an absolute mare with Windows 8, fastboot drivers won't install (with the Samsung package or the naked drivers - just says 'no drivers found') and now the SDK won't install as it doesn't think I've got the Java SDK on my computer (which I have). This is a ballache!

Windows 7 was so much easier...

EDIT: SDK seems to be done following this:

http://forum.xda-developers.com/showthread.php?t=1758817

I did do it but think I set the path wrong so need to check it later on!
 
Last edited:

h3ck

Senior Member
Oct 7, 2007
471
127
Otizzle
So after going through this headache of not being able to fastboot either of my Nexus devices (GNex and N7) I have found the solution to my problems and I am sharing it with you guys.

Windows 8 forces drivers to be digitally signed and checks that signature with it's known driver signatures at home. This is a problem if you are trying to install and use something like fastboot/adb which Redmond may not have drivers for.

I was personally trying to install this as I did before on Windows 7: http://forum.xda-developers.com/showthread.php?t=1379875 and in order to install this we need to "Disable driver signature enforcement"

Steps to be taken:

1.) Bring up Charms by mousing over to the right of the screen
2.) Go to Settings
3.) Change PC Settings
4.) General
5.) Scroll down to Advanced Startup > Restart Now
6.) Trouble shoot
7.) Advanced options
8.) Windows startup options
9.) Restart
10.) Choose F7 (I believe) or click on "Disable driver signature enforcement"
11.) Reboot

Install the relevant driver (In my case Universal driver) under Device Management

This allowed me to install the Universal driver for both my Nexus devices. Anyway, hope it helps ya'll.

(Mods if posted before feel free to delete/merge/whatever.)


You seriously saved the day. Awesome! Gave thanks!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 26
    So after going through this headache of not being able to fastboot either of my Nexus devices (GNex and N7) I have found the solution to my problems and I am sharing it with you guys.

    Windows 8 forces drivers to be digitally signed and checks that signature with it's known driver signatures at home. This is a problem if you are trying to install and use something like fastboot/adb which Redmond may not have drivers for.

    I was personally trying to install this as I did before on Windows 7: http://forum.xda-developers.com/showthread.php?t=1379875 and in order to install this we need to "Disable driver signature enforcement"

    Steps to be taken:

    1.) Bring up Charms by mousing over to the right of the screen
    2.) Go to Settings
    3.) Change PC Settings
    4.) General
    5.) Scroll down to Advanced Startup > Restart Now
    6.) Trouble shoot
    7.) Advanced options
    8.) Windows startup options
    9.) Restart
    10.) Choose F7 (I believe) or click on "Disable driver signature enforcement"
    11.) Reboot

    Install the relevant driver (In my case Universal driver) under Device Management

    This allowed me to install the Universal driver for both my Nexus devices. Anyway, hope it helps ya'll.

    (Mods if posted before feel free to delete/merge/whatever.)
    4
    Or avoid all that by installing drivers from here:
    http://www.samsung.com/us/support/owners/product/SCH-I515MSAVZW#

    Then you can install the N7 ones as well.

    http://support.asus.com/Download.aspx?SLanguage=en&m=Nexus+7&p=28&s=2

    That way you don't have to deal with a Test Mode watermark and have the latest drivers.
    1
    I am able to isntall just fine BUT i cannot get the drivers to work and its ****ing iritating. I just get something like This unit cannot start (error 10), A request for the USB device descriptor failed.