• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[TUTORIAL] [ROOT] Light Flow - Enable LED For Notifications

Search This thread

hutzdani

Senior Member
May 9, 2010
1,222
357
London
Light%2BFlow%2B-%2BLED%2BControl%2Bv3.1.1%2BApk%2BApp.png



Okay so we all know by now that you can enable the "Charging LED" to use as a Notification light.
A lot of people have been having issues with getting it up and running, so here is a in depth look at whats needed to get it going.

Sections :

  • Kernels
  • Pre-Requisites
  • General Settings
  • Root Settings
  • Per-Notification Settings
  • SuperUser Settings



*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
Purchase from the playstore : Light Flow PAID APP
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*




Custom Kernels

After Flashing a new kernel you may find that Light Flow will no longer work with the previous settings, you can either clear its cache and data and start again or uninstall and re install.


Kernels tested :

  • Elemental X - Needs Mixer Mode (? 1 Report of working without needing mixer enabled)
  • Franco's - Does not need mixer mode
  • Stock CM - Needs Mixer Mode
  • Stock - Needs Mixer Mode

*If you have used Light Flow with another kernel please PM me and I'll add it to the list*



--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Pre-Requisites

1. You MUST be Rooted for this to work

2. The PAID / Donate Version of Light Flow, if yours says LIGHT FLOW LIGHT it is not officially supported by the dev !

3. Make Sure you have a fresh install of light flow so everything is set to default values to make this easy to follow.


--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

General Settings

1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

2. Hit the Three horizontal lines in the top left corner of the screens and head for settings

3. Go into General Settings and make sure all the following Settings are Ticked :
  • Enable Light Flow
  • Show LED in Priority Mode
  • Enable Clear All
  • Accessibility check
  • Version Upgrade Reminder ( you don't need this one but i keep it on regardless )

N6_GENERAL_SETTINGS_LIGHT_FLOW.png


You may find that Lightflow will run in the foreground and leave a persistent notification, this is done to solve issues with the app from stopping running in some cases.
So far I have not had this issue with the N6 so you can go ahead and untick that in Settings -> Persistent Icon.
Persistant_notification_LF.png


--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Root Settings

Back in the settings menu go into Device Settings and Root

You need to enable the following options if your system is set to SELinux - Enforcing

  • Direct Mode
  • Root Mode
  • Run Every Command as Root
  • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )

N6_LIGHT_FLOW_ROOT_SETTINGS.png


If your system is set to Permissive you can Untick :

  • Run Every command as root
  • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )

--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Per-Notification Settings

This is all the settings you need to let light flow have control of the LED, now you need to configure Notifications to use the light.

Head into the Notification settings and select one of the Default Profiles ( Im using charging battery )

You need to scroll across the screen to the tab called "LIGHT", on this page scroll down until you see Enable Mixer Mode make sure this is ticked.

Depending on your kernel you may find you don't need to enable Mixer mode, however its more than likely you will need mixer mode enabled !

Now you have control over the 3 Primary colors R/G/B and their brightness ( 1-20 ) - I have played with the brightness settings here and it seems to not affect the LED as of Version 3.51.1

If you are using the LED without mixer mode, you will find that it can't display any colors that are not Red or Green or Blue it.

For example picking Orange from the color picker resulted in a Green LED.

  • You have the same settings for each color however the SOLID option is the only one that seems to work !
  • You can select 1 LED on or all 3 on and mix them together to make other colors but because of the led it does not work as well as the Nexus 5's LED.

PER_NOTIFICATION_SETTINGS.png



--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

Red / Blue / Green LEDs
LEDS_n6.png


SUPERSU Settings

You may find that Flightflow appears to show SU notifications constantly, this is because Show notifications is enable in your SU app.
Dive into settings and un-tick the option.
SUPERSULIGHTFLOW.png
 
Last edited:

jawmail

Senior Member
Nov 14, 2011
531
98
Finally seems to work better. This morning w/ slightly different settings it was unusable. Any way to make them flash? A flashing sms light would be perfect.
 

zephiK

Inactive Recognized Developer
Aug 23, 2009
21,656
37,705
New York, NY
1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

use the one in Settings > Sounds & Notifications > App Notifications > Light Flow (Enable) not the one in Accessibility.

The one in accessibility has a warning, "this option is not recommended to be used in android 4.3 upwards and the new notification access method should be used instead"[b/]
I use the one in Sounds & Notifications and LED works fine.

Other than that, great guide. Should help people get it to work :) Hopefully the LED can be worked on and we won't need Light Flow in the future.
 

jawmail

Senior Member
Nov 14, 2011
531
98
It's weird so picking the color from the circle drop down doesn't choose the color. You have to tweak/create the color yourself in the mixer options. Either way I like it because it works. Now we just need flashing.
 

NICEGYPT

Senior Member
Dec 31, 2007
1,179
133
Grovetown
How can I get this massage to go away. It's keep poping up every 30 sec. It's driving me crazy
 

Attachments

  • Screenshot_2014-12-31-00-18-11.png
    Screenshot_2014-12-31-00-18-11.png
    175.3 KB · Views: 2,801

stumpy352

Senior Member
Sep 20, 2011
2,000
1,267
Lightflow is working perfectly for me with elementalx kernel without mixer. I have the charging led enabled by the kernel. Also you need permissive selinux for this to work.
 
Last edited:

occtec

Senior Member
Dec 9, 2012
2,818
924
South Australia
use the one in Settings > Sounds & Notifications > App Notifications > Light Flow (Enable) not the one in Accessibility.

The one in accessibility has a warning, "this option is not recommended to be used in android 4.3 upwards and the new notification access method should be used instead"[b/]
I use the one in Sounds & Notifications and LED works fine.

Other than that, great guide. Should help people get it to work :) Hopefully the LED can be worked on and we won't need Light Flow in the future.


Great to see you took my advice ? 'Happy New Year' ?2?0?1?5?
 
Last edited:

hutzdani

Senior Member
May 9, 2010
1,222
357
London
Yes but if you do you miss out on some led notifications.

That's weird it must be for some notifications dependent on the app, which notifications are you using ?

Im using ( All set to dismiss on Battery or when notification is cleared ) :

Charged Battery
Charging
Missed Call
SMS ( Google Messenger ) Recived

Also having "Reduce wake" seems to make no difference to how the app effects the battery for me ( might make it use 1 or 2% more but its not a massive impact that would be the difference between 1 days usage and not )
 

hutzdani

Senior Member
May 9, 2010
1,222
357
London
use the one in Settings > Sounds & Notifications > App Notifications > Light Flow (Enable) not the one in Accessibility.

The one in accessibility has a warning, "this option is not recommended to be used in android 4.3 upwards and the new notification access method should be used instead"[b/]
I use the one in Sounds & Notifications and LED works fine.

Other than that, great guide. Should help people get it to work :) Hopefully the LED can be worked on and we won't need Light Flow in the future.


Yeah i saw that message, however i have had it enabled in one or the other or both and had no issues YET so i decided to leave this one out as the app seems to function correctly if you just follow what it asks for so people can get set up as easy as possible.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 43
    Light%2BFlow%2B-%2BLED%2BControl%2Bv3.1.1%2BApk%2BApp.png



    Okay so we all know by now that you can enable the "Charging LED" to use as a Notification light.
    A lot of people have been having issues with getting it up and running, so here is a in depth look at whats needed to get it going.

    Sections :

    • Kernels
    • Pre-Requisites
    • General Settings
    • Root Settings
    • Per-Notification Settings
    • SuperUser Settings



    *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
    Purchase from the playstore : Light Flow PAID APP
    *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*




    Custom Kernels

    After Flashing a new kernel you may find that Light Flow will no longer work with the previous settings, you can either clear its cache and data and start again or uninstall and re install.


    Kernels tested :

    • Elemental X - Needs Mixer Mode (? 1 Report of working without needing mixer enabled)
    • Franco's - Does not need mixer mode
    • Stock CM - Needs Mixer Mode
    • Stock - Needs Mixer Mode

    *If you have used Light Flow with another kernel please PM me and I'll add it to the list*



    --/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

    Pre-Requisites

    1. You MUST be Rooted for this to work

    2. The PAID / Donate Version of Light Flow, if yours says LIGHT FLOW LIGHT it is not officially supported by the dev !

    3. Make Sure you have a fresh install of light flow so everything is set to default values to make this easy to follow.


    --/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

    General Settings

    1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

    2. Hit the Three horizontal lines in the top left corner of the screens and head for settings

    3. Go into General Settings and make sure all the following Settings are Ticked :
    • Enable Light Flow
    • Show LED in Priority Mode
    • Enable Clear All
    • Accessibility check
    • Version Upgrade Reminder ( you don't need this one but i keep it on regardless )

    N6_GENERAL_SETTINGS_LIGHT_FLOW.png


    You may find that Lightflow will run in the foreground and leave a persistent notification, this is done to solve issues with the app from stopping running in some cases.
    So far I have not had this issue with the N6 so you can go ahead and untick that in Settings -> Persistent Icon.
    Persistant_notification_LF.png


    --/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

    Root Settings

    Back in the settings menu go into Device Settings and Root

    You need to enable the following options if your system is set to SELinux - Enforcing

    • Direct Mode
    • Root Mode
    • Run Every Command as Root
    • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )

    N6_LIGHT_FLOW_ROOT_SETTINGS.png


    If your system is set to Permissive you can Untick :

    • Run Every command as root
    • Nexus 5 force LED Reset ( this mode does not have to be enabled unless you have issues with your LED messing up )

    --/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

    Per-Notification Settings

    This is all the settings you need to let light flow have control of the LED, now you need to configure Notifications to use the light.

    Head into the Notification settings and select one of the Default Profiles ( Im using charging battery )

    You need to scroll across the screen to the tab called "LIGHT", on this page scroll down until you see Enable Mixer Mode make sure this is ticked.

    Depending on your kernel you may find you don't need to enable Mixer mode, however its more than likely you will need mixer mode enabled !

    Now you have control over the 3 Primary colors R/G/B and their brightness ( 1-20 ) - I have played with the brightness settings here and it seems to not affect the LED as of Version 3.51.1

    If you are using the LED without mixer mode, you will find that it can't display any colors that are not Red or Green or Blue it.

    For example picking Orange from the color picker resulted in a Green LED.

    • You have the same settings for each color however the SOLID option is the only one that seems to work !
    • You can select 1 LED on or all 3 on and mix them together to make other colors but because of the led it does not work as well as the Nexus 5's LED.

    PER_NOTIFICATION_SETTINGS.png



    --/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--/--

    Red / Blue / Green LEDs
    LEDS_n6.png


    SUPERSU Settings

    You may find that Flightflow appears to show SU notifications constantly, this is because Show notifications is enable in your SU app.
    Dive into settings and un-tick the option.
    SUPERSULIGHTFLOW.png
    9
    For those not enthused by the random blinking rate, I sent a mail to the dev asking about that. It seems changes in Lollipop are responsible, and he has started working on correcting the problem ;)
    4
    I have just updated LightFlow (paid app) and in the change log it mentions flashing LEDs for Nexus 6.

    Has anyone managed to get this working since the update? What options do i need to enable?

    Choose a notification > settings > light > scroll down to led mixer and enable it. Check app controlled flash then choose your color and brightness. Make sure you set them as solid. Test them and they should flash.
    3
    1. Once your in Light Flow allow it Root Access if Superuser asks and allow it accessibility access to notifications ( YOU MUST ALLOW THIS ! )

    use the one in Settings > Sounds & Notifications > App Notifications > Light Flow (Enable) not the one in Accessibility.

    The one in accessibility has a warning, "this option is not recommended to be used in android 4.3 upwards and the new notification access method should be used instead"[b/]
    I use the one in Sounds & Notifications and LED works fine.

    Other than that, great guide. Should help people get it to work :) Hopefully the LED can be worked on and we won't need Light Flow in the future.
    2
    Not to hijack a thread, but Validus ROM has notification lights active.

    Sent from my Nexus 6 using XDA Premium 4 mobile app