[TWRP][64 bit][3.2.1_r12][UNOFFICIAL]Moto Z2 Play[Albus]

Search This thread


Senior Member
Last edited:


Senior Member
Dec 2, 2012
Thanks for all your work on this, fyi download link is 404

Until that's updated, in case it helps others, managed to dig up this one which appears to be a few revs newer than what's listed in the OP

for the Motorola Moto Z2 Play(XT1710), by rahulsnair

I successfully used this to install the LOS 15.1 linked in these forums, and it's working fine with os encryption (haven't tested backup encryption), still has the power button bug mentioned in the OP, and ran into a few of the other issues mentioned (maybe only mentioned in 32 bit thread) such as the Image not signed or corrupt
error/warning, but as he says beta.

I've tested usb otg, works, backups work though i haven't tried restores



Senior Member
May 14, 2020
Punto Fijo
lol 404 64twrp not found

̶T̶h̶e̶ ̶o̶t̶h̶e̶r̶ ̶l̶i̶n̶k̶s̶/̶c̶o̶n̶t̶r̶i̶b̶u̶t̶o̶r̶s̶ ̶f̶o̶r̶ ̶6̶4̶-̶b̶i̶t̶ ̶T̶W̶R̶P̶ ̶a̶r̶e̶ ̶e̶i̶t̶h̶e̶r̶ ̶d̶e̶a̶d̶ ̶o̶r̶ ̶i̶n̶a̶c̶t̶i̶v̶e̶ ̶s̶o̶ ̶t̶h̶i̶s̶ ̶i̶s̶ ̶y̶o̶u̶r̶ ̶o̶n̶l̶y̶ ̶s̶h̶o̶t̶ ̶a̶t̶ ̶g̶e̶t̶t̶i̶n̶g̶ ̶o̶n̶e̶ ̶o̶n̶ ̶y̶o̶u̶r̶ ̶Z̶2̶P̶.̶
̶L̶i̶n̶k̶ ̶a̶l̶s̶o̶ ̶c̶o̶n̶t̶a̶i̶n̶s̶ ̶3̶2̶ ̶b̶i̶t̶ ̶T̶W̶R̶P̶ ̶j̶u̶s̶t̶ ̶i̶n̶ ̶c̶a̶s̶e̶.̶.̶.̶
̶A̶l̶s̶o̶ ̶i̶f̶ ̶s̶o̶m̶e̶o̶n̶e̶ ̶i̶s̶ ̶s̶t̶i̶l̶l̶ ̶a̶l̶i̶v̶e̶ ̶h̶e̶r̶e̶ ̶c̶a̶n̶ ̶s̶o̶m̶e̶o̶n̶e̶ ̶c̶o̶n̶t̶a̶c̶t̶ ̶O̶P̶ ̶t̶o̶ ̶o̶r̶ ̶s̶o̶m̶e̶ ̶m̶o̶d̶/̶a̶d̶m̶i̶n̶ ̶w̶i̶t̶h̶ ̶e̶n̶o̶u̶g̶h̶ ̶p̶r̶i̶v̶i̶l̶e̶g̶e̶s̶ ̶t̶o̶ ̶u̶p̶d̶a̶t̶e̶ ̶l̶i̶n̶k̶ ̶i̶n̶ ̶t̶h̶e̶ ̶m̶a̶i̶n̶ ̶t̶h̶r̶e̶a̶d̶?̶ ̶I̶t̶ ̶i̶s̶ ̶a̶n̶n̶o̶y̶i̶n̶g̶ ̶t̶h̶a̶t̶ ̶t̶h̶e̶ ̶s̶a̶m̶e̶ ̶d̶e̶a̶d̶ ̶l̶i̶n̶k̶s̶ ̶a̶r̶e̶ ̶o̶n̶ ̶e̶v̶e̶r̶y̶ ̶o̶t̶h̶e̶r̶ ̶p̶o̶s̶t̶ ̶r̶e̶g̶a̶r̶d̶i̶n̶g̶ ̶6̶4̶-̶b̶i̶t̶ ̶R̶O̶M̶/̶T̶W̶R̶P̶
̶I̶ ̶k̶n̶o̶w̶ ̶I̶'̶m̶ ̶j̶u̶s̶t̶ ̶a̶ ̶n̶e̶w̶ ̶m̶e̶m̶b̶e̶r̶ ̶b̶u̶t̶ ̶i̶t̶ ̶i̶s̶ ̶k̶i̶n̶d̶a̶ ̶i̶r̶o̶n̶i̶c̶ ̶t̶h̶a̶t̶ ̶s̶o̶m̶e̶ ̶c̶u̶s̶t̶o̶m̶ ̶R̶O̶M̶s̶ ̶a̶r̶e̶ ̶u̶p̶ ̶t̶o̶ ̶d̶a̶t̶e̶ ̶f̶r̶o̶m̶ ̶t̶h̶i̶s̶ ̶y̶e̶a̶r̶ ̶a̶n̶d̶ ̶t̶h̶e̶ ̶r̶e̶s̶p̶e̶c̶t̶i̶v̶e̶ ̶6̶4̶ ̶b̶i̶t̶ ̶T̶W̶R̶P̶ ̶i̶s̶ ̶n̶o̶w̶h̶e̶r̶e̶ ̶t̶o̶ ̶b̶e̶ ̶f̶o̶u̶n̶d̶,̶ ̶j̶u̶s̶t̶ ̶w̶a̶n̶t̶e̶d̶ ̶t̶o̶ ̶p̶o̶i̶n̶t̶ ̶t̶h̶a̶t̶ ̶o̶u̶t̶.̶
̶F̶o̶r̶ ̶*̶*̶*̶*̶ ̶s̶a̶k̶e̶ ̶t̶h̶i̶s̶ ̶s̶p̶a̶m̶ ̶f̶i̶l̶t̶e̶r̶ ̶i̶s̶ ̶s̶o̶ ̶d̶u̶m̶b̶,̶ ̶p̶a̶r̶d̶o̶n̶ ̶m̶e̶ ̶b̶u̶t̶ ̶t̶h̶a̶t̶'̶s̶ ̶a̶ ̶l̶i̶n̶k̶ ̶f̶o̶r̶ ̶a̶ ̶6̶4̶-̶b̶i̶t̶ ̶T̶W̶R̶P̶ ̶t̶h̶a̶t̶ ̶s̶t̶i̶l̶l̶ ̶w̶o̶r̶k̶s̶ ̶a̶n̶d̶ ̶p̶e̶o̶p̶l̶e̶ ̶n̶e̶e̶d̶ ̶t̶o̶ ̶b̶e̶ ̶a̶w̶a̶r̶e̶ ̶o̶f̶ ̶i̶t̶ ̶s̶o̶ ̶t̶h̶e̶y̶ ̶d̶o̶n̶'̶t̶ ̶l̶o̶s̶e̶ ̶9̶1̶8̶3̶7̶4̶9̶1̶4̶9̶0̶1̶8̶4̶ ̶h̶o̶u̶r̶s̶ ̶s̶e̶a̶r̶c̶h̶i̶n̶g̶ ̶1̶9̶2̶4̶7̶9̶0̶2̶4̶7̶0̶1̶ ̶t̶h̶r̶e̶a̶d̶s̶,̶ ̶m̶a̶n̶ ̶i̶t̶ ̶i̶s̶ ̶a̶l̶r̶e̶a̶d̶y̶ ̶h̶e̶r̶e̶
̶i̶f̶ ̶y̶o̶u̶ ̶n̶e̶e̶d̶ ̶6̶4̶ ̶b̶i̶t̶ ̶t̶w̶r̶p̶ ̶s̶e̶a̶r̶c̶h̶ ̶o̶n̶ ̶p̶a̶g̶e̶ ̶6̶ ̶o̶n̶ ̶s̶e̶k̶k̶'̶s̶ ̶a̶n̶s̶w̶e̶r̶
̶h̶t̶t̶p̶s̶ ̶d̶o̶t̶s̶ ̶s̶l̶a̶s̶h̶ ̶s̶l̶a̶s̶h̶ ̶d̶r̶i̶v̶e̶ ̶d̶o̶t̶ ̶g̶o̶o̶g̶l̶e̶ ̶d̶o̶t̶ ̶c̶o̶m̶ ̶s̶l̶a̶s̶h̶ ̶f̶i̶l̶e̶ ̶s̶l̶a̶s̶h̶ ̶d̶ ̶s̶l̶a̶s̶h̶ ̶1̶g̶8̶S̶Y̶K̶I̶l̶6̶w̶7̶G̶q̶K̶m̶k̶9̶9̶H̶u̶C̶g̶0̶z̶b̶f̶7̶w̶j̶Q̶U̶i̶E̶ ̶s̶l̶a̶s̶h̶ ̶v̶i̶e̶w̶
̶i̶f̶ ̶I̶ ̶g̶e̶t̶ ̶b̶a̶n̶n̶e̶d̶ ̶o̶r̶ ̶w̶h̶a̶t̶e̶v̶e̶r̶ ̶i̶t̶'̶s̶ ̶w̶o̶r̶t̶h̶ ̶i̶t̶ ̶a̶n̶y̶w̶a̶y̶s̶
if you need 64 bit twrp search is this very thread on page 6 in sekk's answer, it contains the latest 64-bit twrp treble
Last edited:


Senior Member
May 14, 2020
Punto Fijo
links updated

It seems some developer heard us and updated the 64-bit TWRP links.
They are now fully functional.
Latest 64-bit TWRP is twrp_albus_treble_3.2.2_r23_64.img
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    TWRP 3.2.1_r12 Moto Z2 Play (albus)


    TWRP changelog : Here

    Working/Bugs : Need to press power button two times for touch to work

    Please do read the installation guide note !

    1. At first boot twrp will ask for "Swipe to allow modifications for /system" and if you choose to allow it system partition will get modified. So if you choose to reboot back to OS without performing anything in twrp, the OS won't boot (as verity check is enabled in stock OS/kernel) . To avoid this you have to flash either SuperSU or flash any of the verity disabler zips there in xda

    2. Encryption is enabled by default

    3. If in case decryption doesn't go fine, twrp will popup a dialog box asking for password and that means decryption went wrong and you would need to wipe data once via twrp wipe options and reboot back to twrp for functioning of /data

    Installation Guide :
    1. Make sure you have unlocked bootloader
    2. Reboot to bootloader
    3. fastboot flash recovery twrp-xxxx.img (if you want permanent flash) or
    fastboot boot twrp-xxxx.img (if you want temporary boot)

    Download Link :Here

    Tree : Here

    XDA:DevDB Information
    TWRP-ALBUS, Tool/Utility for the Moto Z2 Play

    Source Code: https://github.com/TeamWin

    Version Information
    Status: Beta

    Created 2018-01-03
    Last Updated 2018-02-03
    3.1.2_r18 version released. Check download link in OP
    Hi, I'm facing the same issue, could you share what you did in order to fix it?
    Or link to some resources you used?


    I should have already wrote the instruction for others, I couldn't find the time. Here are all the steps from stock:

    • Unlock bootloader.
    • Flash TWRP from fastboot screen and reboot to recovery.
    • Dont swipe to allow modification on first prompt. Keep read only.
    • Take twrp backup of system, boot, recovery, efs and anything else you want and copy it to your computer to be safe.
    • Flash magisk (stable preferred) but dont reboot.
    • Run the following echo commands while in twrp > Advanced > Terminal:
      echo KEEPVERITY=true>>/data/.magisk
      echo KEEPFORCEENCRYPT=true>>/data/.magisk
    • Reboot to system.

    Excuse me, but why don't you update the post with the latest version of your TWRP?

    I should have already wrote the instruction for others, I couldn't find the time. Here are all the steps from stock:

    Thank you for taking the time now!

    That looks very clean compared to what I went through. I found these instructions on reddit.

    Should this link ever die, here is the digest:
    • Flash stock image
    • Backup system and boot partitions
    • Restore these backups (!)
    • Flash Magisk
    • Reboot

    Strangely enough, that worked just as well for me…
    I wouldn't recommend that to anyone, though, since it seems like a giant hack and telling Magisk directly what to do makes a lot more sense and is also a lot less time-consuming.